setup-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393
  1. Summary: A set of system configuration and setup files.
  2. Summary(ja): システム設定およびセットアップファイル一式
  3. Name: setup
  4. Version: 2.9.0
  5. Release: 1%{?_dist_release}
  6. License: Public Domain
  7. Group: System Environment/Base
  8. URL: https://fedorahosted.org/setup/
  9. # use our forked version
  10. Source: setup-vine-%{version}.tar.bz2
  11. Buildroot: %{_tmppath}/%{name}-%{version}-root
  12. BuildArch: noarch
  13. Conflicts: initscripts < 4.26, bash <= 2.0.4-21
  14. %description
  15. The setup package contains a set of important system configuration and
  16. setup files, such as passwd, group, and profile.
  17. %description -l ja
  18. このsetupパッケージには、passwd, group, profile などの、
  19. 重要なシステム設定ファイルが含まれてます。
  20. %prep
  21. %setup -q -n %{name}-vine-%{version}
  22. ./shadowconvert.sh
  23. %install
  24. rm -rf %{buildroot}
  25. mkdir -p %{buildroot}/etc/profile.d
  26. cp -ar * %{buildroot}/etc
  27. rm -f %{buildroot}/etc/uidgid
  28. rm -f %{buildroot}/etc/COPYING
  29. mkdir -p %{buildroot}/var/log
  30. touch %{buildroot}/etc/{shadow,gshadow}
  31. touch %{buildroot}/var/log/lastlog
  32. touch %{buildroot}/etc/environment
  33. chmod 0644 %{buildroot}/etc/environment
  34. chmod 0400 %{buildroot}/etc/{shadow,gshadow}
  35. chmod 0644 %{buildroot}/var/log/lastlog
  36. touch %{buildroot}/etc/fstab
  37. # remove unpackaged files
  38. rm -f %{buildroot}/etc/Makefile
  39. rm -f %{buildroot}/etc/services.orig
  40. rm -f %{buildroot}/etc/serviceslint
  41. rm -f %{buildroot}/etc/uidgidlint
  42. rm -f %{buildroot}/etc/shadowconvert.sh
  43. rm -f %{buildroot}/etc/setup.spec
  44. rm -f $RPM_BUILD_ROOT/etc/{bashrc,aliases}
  45. %clean
  46. rm -rf %{buildroot}
  47. #throw away useless and dangerous update stuff until rpm will be able to
  48. #handle it ( http://rpm.org/ticket/6 )
  49. %post -p <lua>
  50. for i, name in ipairs({"passwd", "shadow", "group", "gshadow"}) do
  51. os.remove("/etc/"..name..".rpmnew")
  52. end
  53. %files
  54. %defattr(-,root,root)
  55. %doc uidgid COPYING
  56. %verify(not md5 size mtime) %config(noreplace) /etc/passwd
  57. %verify(not md5 size mtime) %config(noreplace) /etc/group
  58. %verify(not md5 size mtime) %config(noreplace,missingok) /etc/shadow
  59. %verify(not md5 size mtime) %config(noreplace,missingok) /etc/gshadow
  60. %verify(not md5 size mtime) %config(noreplace) /etc/services
  61. %verify(not md5 size mtime) %config(noreplace) /etc/exports
  62. %config(noreplace) /etc/environment
  63. %config(noreplace) /etc/filesystems
  64. %config(noreplace) /etc/host.conf
  65. %verify(not md5 size mtime) %config(noreplace) /etc/hosts
  66. %verify(not md5 size mtime) %config(noreplace) /etc/hosts.allow
  67. %verify(not md5 size mtime) %config(noreplace) /etc/hosts.deny
  68. %verify(not md5 size mtime) %config(noreplace) /etc/motd
  69. %config(noreplace) /etc/printcap
  70. %verify(not md5 size mtime) %config(noreplace) /etc/inputrc
  71. # config(noreplace) /etc/bashrc
  72. %config(noreplace) /etc/profile
  73. %verify(not md5 size mtime) %config(noreplace) /etc/protocols
  74. %attr(0600,root,root) %config(noreplace,missingok) /etc/securetty
  75. %config(noreplace) /etc/csh.login
  76. %config(noreplace) /etc/csh.cshrc
  77. %dir /etc/profile.d
  78. %config(noreplace) %verify(not md5 size mtime) /etc/shells
  79. %ghost %attr(0644,root,root) %verify(not md5 size mtime) /var/log/lastlog
  80. %ghost %verify(not md5 size mtime) %config(noreplace,missingok) /etc/fstab
  81. %changelog
  82. * Wed Jul 02 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.9.0-1
  83. - rebase to 2.9.0
  84. * Thu Apr 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.31-1
  85. - update to 2.8.31
  86. - use <lua> for post scriptlet
  87. * Sat Mar 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-1
  88. - update to 2.8.1
  89. - spec in utf-8
  90. - new versioning policy
  91. - add %%postun to remove dangerous .rpmnew files
  92. * Sat May 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.7-2vl5
  93. - add /etc/environment
  94. - add /etc/{fstab,mtab} as %%ghost
  95. - add console to /etc/securetty
  96. - import /etc/services from FC
  97. - set mark-symlinked-directories in /etc/inputrc
  98. - add /sbin/nologin to /etc/shells
  99. * Fri Mar 04 2005 Satoshi MACHINO <machino@vinelinux.org> 2.5.7-2vl4
  100. - updated setup-2.5.7-vine.patch
  101. -- changed /etc/printcap for using cups
  102. * Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.5.7-2vl3
  103. - source /etc/profile.d/*.sh in /etc/profile
  104. * Sun Feb 24 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.7-2vl1
  105. - merge with new upstream version
  106. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  107. - automated rebuild
  108. * Mon Aug 27 2001 Preston Brown <pbrown@redhat.com>
  109. - add ext3 to /etc/filesystems
  110. * Mon Aug 20 2001 Bill Nottingham <notting@redhat.com>
  111. - change FTP user's home dir to /var/ftp (#52091)
  112. - %%ghost /etc/shadow, /etc/gshadow
  113. * Fri Aug 17 2001 Bill Nottingham <notting@redhat.com>
  114. - add /etc/shells to filelist (#51813)
  115. * Mon Aug 13 2001 Bill Nottingham <notting@redhat.com>
  116. - put lock in /etc/group (#51654)
  117. * Wed Aug 8 2001 Bill Nottingham <notting@redhat.com>
  118. - lock only needs to be a gid
  119. - don't set dspmbyte=euc here; do it in lang.csh, and only if necessary (#50318)
  120. * Mon Aug 6 2001 Jeff Johnson <jbj@redhat.com>
  121. - add lock.lock uid/gid 54 to own /var/lock directory.
  122. * Thu Jul 19 2001 Bill Nottingham <notting@redhat.com>
  123. - add forward/backward-word mappings (#48783)
  124. - add pgpkeyserver port to /etc/services (#49407)
  125. * Thu Jul 19 2001 Preston Brown <pbrown@redhat.com>
  126. - core files disabled by default. Developers can enable them.
  127. * Fri Jul 13 2001 Bill Nottingham <notting@redhat.com> 2.5.1-1
  128. - revert news user back to no shell (#48701)
  129. * Tue Jul 10 2001 Bill Nottingham <notting@redhat.com> 2.5.0-1
  130. - move profile.d parsing from csh.cshrc to csh.login (#47417)
  131. * Sat Jul 7 2001 Nalin Dahyabhai <nalin@redhat.com> 2.4.15-1
  132. - reorder /etc/services to match comments again
  133. - protocol 118 is stp, not st
  134. - update URLs in /etc/protocols and /etc/services
  135. * Thu Jul 5 2001 Preston Brown <pbrown@redhat.com> 2.4.14-1
  136. - put */sbin in path if user ID is 0.
  137. * Mon Jun 25 2001 Bill Nottingham <notting@redhat.com>
  138. - add an entry to /etc/services for ssh X11 forwarding (#44944)
  139. * Wed Jun 13 2001 Bill Nottingham <notting@redhat.com>
  140. - take ttyS0 out of securetty on main tree
  141. * Tue Jun 12 2001 Philip Copeland <bryce@redhat.com>
  142. - added ttyS0 to securetty for serial console usage
  143. * Tue Jun 12 2001 Bill Nottingham <notting@redhat.com>
  144. - add rndc to /etc/services (#40265)
  145. - test for read bit, not execute bit, for profile.d (#35714)
  146. * Sun Jun 03 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  147. - add "canna" entry to /etc/services
  148. * Mon May 21 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.4.10-1
  149. - Fix bugs #24159 and #30634 again; whoever moved bashrc from bash
  150. to setup used an old version. :((
  151. * Wed May 2 2001 Preston Brown <pbrown@redhat.com> 2.4.9-1
  152. - bashrc moved here from bash package
  153. - set umask in bashrc, so it applies for ALL shells.
  154. * Fri Apr 27 2001 Preston Brown <pbrown@redhat.com> 2.4.8-1
  155. - /sbin/nologin for accounts that aren't "real."
  156. * Sat Apr 7 2001 Preston Brown <pbrown@redhat.com>
  157. - revert control-arrow forward/backward word (broken)
  158. * Tue Mar 27 2001 Preston Brown <pbrown@redhat.com>
  159. - fix japanese input with tcsh (#33211)
  160. * Tue Mar 6 2001 Bill Nottingham <notting@redhat.com>
  161. - fix some weirdness with rxvt (#30799)
  162. * Wed Feb 28 2001 Bill Nottingham <notting@redhat.com>
  163. - add SKK input method (#29759)
  164. * Fri Feb 23 2001 Preston Brown <pbrown@redhat.com>
  165. * Wed Feb 21 2001 Bill Nottingham <notting@redhat.com>
  166. - fix inputrc, Yet Again. (#28617)
  167. * Thu Feb 15 2001 Bill Nottingham <notting@redhat.com>
  168. - add in uidgid file, put it in %doc
  169. * Wed Feb 7 2001 Adrian Havill <havill@redhat.com>
  170. - bindkey for delete in the case of tcsh
  171. * Wed Feb 7 2001 Bill Nottingham <notting@redhat.com>
  172. - add some more stuff to /etc/services (#25396, patch from
  173. <pekkas@netcore.fi>)
  174. * Tue Feb 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  175. - add gii/tcp = 616 for gated
  176. * Tue Jan 30 2001 Bill Nottingham <notting@redhat.com>
  177. - wrap some inputrc settings with tests for mode, term (#24117)
  178. * Mon Jan 29 2001 Bill Nottingham <notting@redhat.com>
  179. - overhaul /etc/protocols (#18530)
  180. - add port 587 to /etc/services (#25001)
  181. - add corbaloc (#19581)
  182. - don't set /usr/X11R6/bin in $PATH if it's already set (#19968)
  183. * Fri Dec 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  184. - Clean up /etc/services, separating registered numbers from unregistered
  185. ("squatted") numbers, and adding some.
  186. * Mon Nov 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  187. - Add smtps (465/tcp) and submission (587/tcp) to /etc/services for TLS
  188. support (postfix >= 20001030-2)
  189. * Mon Nov 6 2000 Kazuhisa TAKEI <takei@vinelinux.org>
  190. - rebuild in rpm 3.0.6
  191. * Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
  192. - remove reading profile.d process from /etc/profile
  193. the process moved to /etc/bashrc...
  194. * Thu Sep 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  195. - 2.2.1-1vl2
  196. - removed /etc/filesystems in %files section
  197. * Sun Aug 6 2000 Bill Nottingham <notting@redhat.com>
  198. - /var/log/lastlog is %config(noreplace) (#15412)
  199. - some of the various %verify changes (#14819)
  200. * Thu Aug 3 2000 Nalin Dahyabhai <nalin@redhat.com>
  201. - linuxconf should be 98, not 99
  202. * Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
  203. - fix some of the csh stuff (#14622)
  204. * Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  205. - stop setting "multi on" in /etc/host.conf
  206. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  207. - automatic rebuild
  208. * Tue Jun 27 2000 Bill Nottingham <notting@redhat.com>
  209. - add hfs filesystem
  210. * Wed Jun 21 2000 Preston Brown <pbrown@redhat.com>
  211. - printcap is a noreplace file now
  212. * Sun Jun 18 2000 Bill Nottingham <notting@redhat.com>
  213. - fix typo
  214. * Tue Jun 13 2000 Lisa Sagami <czs14350@nifty.ne.jp>
  215. - merged RH 2.2.1-1 and Vine 2.0.5-1vl3
  216. * Tue Jun 13 2000 Nalin Dahyabhai <nalin@redhat.com>
  217. - add linuxconf/tcp = 99 to /etc/services
  218. * Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
  219. - add some stuff to /etc/services
  220. - tweak ulimit call again
  221. * Tue Jun 6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  222. - homedir of ftp is now /var/ftp
  223. * Sun May 14 2000 Nalin Dahyabhai <nalin@redhat.com>
  224. - move profile.d logic in csh.login to csh.cshrc
  225. * Tue Apr 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  226. - redirect ulimit -S -c to /dev/null to avoid clutter
  227. * Thu Apr 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  228. - s/ulimit -c/ulimit -S -c/ - bash 2.x adaption
  229. * Mon Apr 03 2000 Nalin Dahyabhai <nalin@redhat.com>
  230. - Add more of the kerberos-related services from IANA's registry and krb5
  231. * Wed Mar 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  232. - Add 2.4'ish vc/* devices to securetty
  233. * Thu Feb 17 2000 Preston Brown <pbrown@redhat.com>
  234. - add /etc/filesystems with sane defaults
  235. * Wed Feb 16 2000 Bill Nottingham <notting@redhat.com>
  236. - don't set prompt in /etc/profile (it's done in /etc/bashrc)
  237. * Sat Feb 5 2000 Bill Nottingham <notting@redhat.com>
  238. - yet more inputrc tweaks from Hans de Goede (hans@highrise.nl)
  239. * Sun Jan 30 2000 Bill Nottingham <notting@redhat.com>
  240. - yet more inputrc tweaks from Hans de Goede (hans@highrise.nl)
  241. * Sun Jan 23 2000 Bill Nottingham <notting@redhat.com>
  242. - fix mailq line. (#7140)
  243. * Fri Jan 21 2000 Bill Nottingham <notting@redhat.com>
  244. - add ldap to /etc/services
  245. * Tue Jan 18 2000 Bill Nottingham <notting@redhat.com>
  246. - kill HISTFILESIZE, it's broken
  247. * Tue Jan 18 2000 Preston Brown <pbrown@redhat.com>
  248. - some inputrc tweaks
  249. * Wed Jan 12 2000 Bill Nottingham <notting@redhat.com>
  250. - make some more stuff noreplace
  251. * Fri Nov 19 1999 Bill Nottingham <notting@redhat.com>
  252. - fix mailq line. (#7140)
  253. * Fri Oct 29 1999 Bill Nottingham <notting@redhat.com>
  254. - split csh.login into csh.login and csh.cshrc (#various)
  255. - fix pop service names (#6206)
  256. - fix ipv6 protocols entries (#6219)
  257. * Thu Sep 2 1999 Jeff Johnson <jbj@redhat.com>
  258. - rename /etc/csh.cshrc to /etc/csh.login (#2931).
  259. - (note: modified /etc/csh.cshrc should end up in /etc/csh.cshrc.rpmsave)
  260. * Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
  261. - add defattr.
  262. - fix limit command in /etc/csh.cshrc (#4582).
  263. * Thu Jul 8 1999 Bill Nottingham <notting@redhat.com>
  264. - move /etc/inputrc here.
  265. * Mon Apr 19 1999 Bill Nottingham <notting@redhat.com>
  266. - always use /etc/inputrc
  267. * Wed Mar 31 1999 Preston Brown <pbrown@redhat.com>
  268. - added alias pointing to imap from imap2
  269. * Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
  270. - updated protocols/services from debian to comply with more modern
  271. - IETF/RFC standards
  272. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  273. - auto rebuild in the new build environment (release 4)
  274. * Thu Feb 18 1999 Jeff Johnson <jbj@redhat.com>
  275. - unset variables used in /etc/csh.cshrc (#1212)
  276. * Mon Jan 18 1999 Jeff Johnson <jbj@redhat.com>
  277. - compile for Raw Hide.
  278. * Tue Oct 13 1998 Cristian Gafton <gafton@redhat.com>
  279. - fix the csh.cshrc re: ${PATH} undefined
  280. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  281. - translations modified for de, fr, tr
  282. * Fri Dec 05 1997 Erik Troan <ewt@redhat.com>
  283. - /etc/profile uses $i, which needs to be unset
  284. * Mon Nov 03 1997 Donnie Barnes <djb@redhat.com>
  285. - made /etc/passwd and /etc/group %config(noreplace)
  286. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  287. - removed /etc/inetd.conf, /etc/rpc
  288. - flagged /etc/securetty as missingok
  289. - fixed buildroot stuff in spec file
  290. * Thu Jul 31 1997 Erik Troan <ewt@redhat.com>
  291. - made a noarch package
  292. * Wed Apr 16 1997 Erik Troan <ewt@redhat.com>
  293. - Don't verify md5sum, size, or timestamp of /var/log/lastlog, /etc/passwd,
  294. or /etc/group.