screen-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258
  1. Summary: A screen manager that supports multiple logins on one terminal.
  2. Summary(ja): スクリーンマネージャ - 一つの端末で多重ログイン
  3. Name: screen
  4. Version: 4.6.2
  5. Release: 1%{?_dist_release}
  6. License: GPLv2+
  7. Group: Applications/System
  8. Source0: ftp://ftp.uni-erlangen.de/pub/utilities/screen/screen-%{version}.tar.gz
  9. Source1: screen.pam
  10. Patch1: screen-4.3.1-libs.patch
  11. Patch2: screen-4.3.1-screenrc.patch
  12. Patch3: screen-E3.patch
  13. Patch4: screen-4.3.1-suppress_remap.patch
  14. Patch5: screen-4.3.1-crypt.patch
  15. Requires: ncurses
  16. Requires(post,preun): /sbin/install-info
  17. BuildRequires: ncurses-devel, texinfo, perl
  18. BuildRequires: pam-devel
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. %description
  23. The screen utility allows you to have multiple logins on just one
  24. terminal. Screen is useful for users who telnet into a machine or
  25. are connected via a dumb terminal, but want to use more than just
  26. one login.
  27. Install the screen package if you need a screen manager that can
  28. support multiple logins on one terminal.
  29. %description -l ja
  30. 一つの端末プログラムだけで多重のログインを可能にするスクリーン管理
  31. ユーティリティです。telnetで操作しているユーザやダムターミナルから
  32. 接続しているユーザでもっと多くの端末画面を使いたい場合にはとても
  33. 便利なプログラムです。
  34. %prep
  35. %setup -q
  36. %autosetup -p1
  37. %build
  38. autoconf
  39. %configure \
  40. --enable-pam \
  41. --enable-locate \
  42. --enable-telnet \
  43. --enable-colors256 \
  44. --with-sys-screenrc=%{_sysconfdir}/screenrc
  45. # configure can figure out these values.
  46. #perl -pi -e 's|.*#.*PTYMODE.*|#define PTYMODE 0620|' config.h
  47. #perl -pi -e 's|.*#.*PTYGROUP.*|#define PTYGROUP 5|' config.h
  48. perl -pi -e 's|.*#undef HAVE_BRAILLE.*|#define HAVE_BRAILLE 1|' config.h
  49. perl -pi -e 's|/usr/local/etc/screenrc|/etc/screenrc|' etc/etcscreenrc doc/*
  50. perl -pi -e 's|/local/etc/screenrc|/etc/screenrc|' doc/*
  51. rm -f doc/screen.info*
  52. # fails with %{?_smp_mflags}
  53. make CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
  54. %install
  55. rm -rf $RPM_BUILD_ROOT
  56. mkdir -p $RPM_BUILD_ROOT/etc/skel
  57. perl -pi -e 's,/usr/local/etc/screenrc,/etc/screenrc,' etc/etcscreenrc
  58. %makeinstall DDESTDIR=$RPM_BUILD_ROOT
  59. ( cd $RPM_BUILD_ROOT
  60. # gzip -9nf .%{_infodir}/screen.info*
  61. # strip .%{_bindir}/screen-%{version}
  62. rm -f .%{_bindir}/screen.old .%{_bindir}/screen
  63. mv .%{_bindir}/screen-%{version} .%{_bindir}/screen
  64. )
  65. install -c -m 0444 etc/etcscreenrc $RPM_BUILD_ROOT/etc/screenrc
  66. install -c -m 0644 etc/screenrc $RPM_BUILD_ROOT/etc/skel/.screenrc
  67. # Better not forget to copy the pam file around
  68. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
  69. install -p -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/screen
  70. # Remove files from the buildroot which we don't want packaged
  71. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  72. %clean
  73. rm -rf $RPM_BUILD_ROOT
  74. %post
  75. /sbin/install-info %{_infodir}/screen.info.* %{_infodir}/dir --entry="* screen: (screen). Terminal multiplexer."
  76. if [ -d /tmp/screens ]; then
  77. # we're not setuid root anymore
  78. chmod 777 /tmp/screens
  79. fi
  80. %preun
  81. if [ $1 = 0 ]; then
  82. /sbin/install-info --delete %{_infodir}/screen.info.* %{_infodir}/dir --entry="* screen: (screen). Terminal multiplexer."
  83. fi
  84. %files
  85. %defattr(-,root,root)
  86. %doc COPYING NEWS* README doc/FAQ TODO doc/README.DOTSCREEN terminfo
  87. #%attr(755,root,root) %{_bindir}/screen
  88. %{_bindir}/screen
  89. %{_mandir}/man1/screen.*
  90. %{_infodir}/screen.info*
  91. %{_datadir}/screen
  92. %config(noreplace) %{_sysconfdir}/screenrc
  93. %config(noreplace) %{_sysconfdir}/pam.d/screen
  94. %config /etc/skel/.screenrc
  95. %changelog
  96. * Fri Apr 20 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.6.2-1
  97. - update to 4.6.2
  98. - change License
  99. - sync fc28 package
  100. * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.3-4
  101. - rebuild with VineSeed environment
  102. * Tue Apr 5 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.3-3vl6
  103. - build on current VineSeed
  104. - add execvpe patch (Patch0) based upstream git
  105. * Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.0.3-2
  106. - spec in UTF-8
  107. - add Patch12 to build against glibc-2.8
  108. - fix typo (from --enable-color256 to --enable-colors256)
  109. thanks Minematsu Hiroki-san for pointing this out
  110. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.3-1vl5
  111. - used %%{?_dist_release}
  112. * Mon Nov 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.3-0vl4
  113. - rebuild for VineSeed
  114. * Mon Nov 20 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.3-0vl3
  115. - rebuilt without libelf-devel (ppc.rpm linked with libelf.so.0)
  116. * Thu Nov 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.3-0vl2
  117. - add BuildRequires: texinfo, perl
  118. * Tue Oct 31 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-0vl1
  119. - upstream release with security fix (build for Vine 4.0)
  120. * Sat Jul 01 2006 NAKAMURA Kenta <kenta@vinelinux.org> 4.0.2-0vl2
  121. - use License instead of Copyright
  122. * Sat Jun 5 2004 IWAI, Masaharu <iwai@alib.jp> 4.0.2-0vl1
  123. - new upstream release
  124. - add %%{_datadir}/screen in %%files
  125. - no replace configuration file: /etc/screenrc
  126. * Mon Mar 17 2003 IWAI Masaharu <iwai@alib.jp> 3.9.13-0vl2
  127. - eliminate %%{_bindir} from %%files section
  128. * Thu Sep 12 2002 Yoshihiro Ota <ota@j.email.ne.jp> 3.9.13-0vl1
  129. - update to 3.9.13
  130. - add FAQ instead of a symbolic link to FAQ
  131. - remove unnecessary patches
  132. * Thu Nov 1 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.10-0vl1
  133. - update to 3.9.10 (security update)
  134. * Mon Aug 27 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.9-0vl1
  135. - update to 3.9.9
  136. - rebuild by current Seed
  137. - remove makeinfo patch, jbj patch
  138. * Sat Mar 10 2001 sagami@vinelinux.org
  139. - made minor spec fixes
  140. * Fri Mar 2 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.8-0vl1
  141. - update to 3.9.8
  142. - update 3.9.5-jbj.patch for 3.9.8
  143. - add hascrypt patch
  144. * Sat Dec 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  145. - 3.9.5-1vl3
  146. - built with gcc-2.95.3
  147. - partially used rpmmacros
  148. * Tue Oct 24 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
  149. - 3.9.5-1vl2
  150. - fixed %files section to handle compressed man page
  151. * Fri Mar 3 2000 Taro FUNAKI <taro@KU3G.org>
  152. - updated to 3.9.5
  153. * Sun Feb 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  154. - 3.9.4-5vl1
  155. - merged missing patches from screen-3.9.4-3 on Red Hat 6.1
  156. * Wed Oct 20 1999 Bill Nottingham <notting@redhat.com>
  157. - you know, we weren't just patching in Unix98 pty support for fun.
  158. * Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
  159. - put screendir in ~
  160. * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
  161. - update to 3.9.4.
  162. * Wed Jun 16 1999 Bill Nottingham <notting@redhat.com>
  163. - force tty permissions/group
  164. * Sat Jun 5 1999 Dale Lovelace <dale@redhat.com>
  165. - permissions on /etc/skel/.screenrc to 644
  166. * Mon Apr 26 1999 Bill Nottingham <notting@redhat.com>
  167. - take out warning of directory permissions so root can still use screen
  168. * Wed Apr 07 1999 Bill Nottingham <notting@redhat.com>
  169. - take out warning of directory ownership so root can still use screen
  170. * Wed Apr 07 1999 Erik Troan <ewt@redhat.com>
  171. - patched in utempter support, turned off setuid bit
  172. * Fri Mar 26 1999 Erik Troan <ewt@redhat.com>
  173. - fixed unix98 pty support
  174. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  175. - auto rebuild in the new build environment (release 3)
  176. * Thu Mar 11 1999 Bill Nottingham <notting@redhat.com>
  177. - add patch for Unix98 pty support
  178. * Mon Dec 28 1998 Jeff Johnson <jbj@redhat.com>
  179. - update to 3.7.6.
  180. * Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
  181. - build root
  182. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  183. - translations modified for de, fr, tr
  184. * Tue Oct 21 1997 Cristian Gafton <gafton@redhat.com>
  185. - upgraded to 3.7.4
  186. * Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
  187. - removed glibc 1.99 specific patch
  188. * Tue Sep 23 1997 Erik Troan <ewt@redhat.com>
  189. - added install-info support
  190. * Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
  191. - built against glibc