nmap-vl.spec 9.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307
  1. %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  2. Summary: Network exploration tool and security scanner
  3. Summary(ja): 多機能なポートスキャナー
  4. Name: nmap
  5. Version: 7.70
  6. Release: 1%{?_dist_release}
  7. License: GPL
  8. Group: Applications/System
  9. URL: http://www.insecure.org/nmap/
  10. Source0: http://www.insecure.org/nmap/dist/%{name}-%{version}.tar.bz2
  11. #Source1: zenmap.desktop
  12. # Patches from Fedora rawhide
  13. #prevent possible race condition for shtool, rhbz#158996
  14. Patch1: nmap-4.03-mktemp.patch
  15. #don't suggest to scan microsoft
  16. Patch2: nmap-4.52-noms.patch
  17. # upstream provided patch for rhbz#845005, not yet in upstream repository
  18. Patch5: ncat_reg_stdin.diff
  19. Patch6: nmap-6.25-displayerror.patch
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildRequires: libpcap-devel
  22. BuildRequires: pcre-devel
  23. BuildRequires: python-devel
  24. BuildRequires: pygtk2-devel
  25. BuildRequires: openssl-devel
  26. BuildRequires: lua-devel
  27. %description
  28. Nmap is a utility for network exploration or security auditing. It
  29. supports ping scanning (determine which hosts are up), many port
  30. scanning techniques (determine what services the hosts are offering),
  31. and TCP/IP fingerprinting (remote host operating system
  32. identification). Nmap also offers flexible target and port
  33. specification, decoy scanning, determination of TCP sequence
  34. predictability characteristics, sunRPC scanning, reverse-identd
  35. scanning, and more.
  36. %description -l ja
  37. Nmap はネットワークの調査やセキュリティ診断を行うユーティリティです。
  38. ping によるスキャン(どのホストが稼働中かの調査)、様々なポートスキャン
  39. 技術(そのホストがどのサービスを提供しているかの調査)や、TCP/IP 指紋
  40. の検査(そのホストの OS を特定)をサポートしています。Nmap は調査対象や
  41. ポートを柔軟に設計することもでき、おとりスキャン、TCP シーケンスの
  42. 予測可能な性質の測定、Sun RPC スキャン、逆 identd スキャンなどの
  43. 機能も提供します。
  44. %package frontend
  45. Summary: Gtk+ frontend for nmap
  46. Summary(ja): Nmap の GTK+ フロントエンド
  47. Group: Applications/System
  48. Requires: nmap = %{version}-%{release}
  49. Requires: python pygtk2 pysqlite
  50. Provides: zenmap = %{version}-%{release}
  51. %description frontend
  52. This package includes zenmap, a GTK+ frontend for nmap. The nmap package must
  53. be installed before installing nmap-frontend.
  54. %description frontend -l ja
  55. Nmap の GTK+ ベースのフロントエンド(zenmap)です。このパッケージをインストール
  56. する前に、nmap パッケージをインストールする必要があります。
  57. %prep
  58. %setup -q
  59. %patch1 -p1 -b .mktemp
  60. %patch2 -p1 -b .noms
  61. %patch5 -p1 -b .ncat_reg_stdin
  62. %patch6 -p1 -b .displayerror
  63. %build
  64. export CPPFLAGS="-I%{_includedir}/pcap -I%{_includedir}/pcre"
  65. %configure
  66. make
  67. %install
  68. rm -rf $RPM_BUILD_ROOT
  69. make install DESTDIR=$RPM_BUILD_ROOT
  70. rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_zenmap
  71. rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_ndiff
  72. cp docs/zenmap.1 $RPM_BUILD_ROOT%{_mandir}/man1/
  73. gzip $RPM_BUILD_ROOT%{_mandir}/man1/* || :
  74. pushd $RPM_BUILD_ROOT%{_mandir}/man1
  75. ln -s zenmap.1.gz nmapfe.1.gz
  76. ln -s zenmap.1.gz xnmap.1.gz
  77. popd
  78. #pushd $RPM_BUILD_ROOT%{_datadir}/pixmaps
  79. #mkdir zenmap
  80. #mv *.svg zenmap
  81. #mv *.png zenmap
  82. #popd
  83. #desktop-file-install --vendor= \
  84. # --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  85. # %{SOURCE1};
  86. rm -f $RPM_BUILD_ROOT%{_datadir}/applications/zenmap-root.desktop
  87. %find_lang %{name} --with-man
  88. %clean
  89. rm -rf %{buildroot}
  90. %files -f %{name}.lang
  91. %defattr(-,root,root)
  92. %doc COPYING CHANGELOG
  93. %doc docs/README docs/nmap.usage.txt docs/nmap.dtd
  94. %{_bindir}/nmap
  95. %{_bindir}/ncat
  96. %{_bindir}/ndiff
  97. %{_bindir}/nping
  98. %{_datadir}/nmap
  99. %{_datadir}/ncat
  100. #%{_libexecdir}/nmap
  101. %{_mandir}/man1/nmap.1*
  102. %{_mandir}/man1/ncat.1*
  103. %{_mandir}/man1/ndiff.1*
  104. %{_mandir}/man1/nping.1*
  105. %files frontend
  106. %defattr(-,root,root)
  107. %{_bindir}/nmapfe
  108. %{_bindir}/xnmap
  109. %{_bindir}/zenmap
  110. %{python_sitelib}/*
  111. %{_datadir}/applications/*.desktop
  112. #%{_datadir}/icons/*
  113. #%{_datadir}/pixmaps/zenmap
  114. %{_datadir}/zenmap
  115. %{_mandir}/man1/zenmap.1*
  116. %{_mandir}/man1/nmapfe.1*
  117. %{_mandir}/man1/xnmap.1*
  118. %changelog
  119. * Sat Nov 17 2018 Toshiaki Ara <ara_t@384.jp> 7.70-1
  120. - update to 7.70
  121. - add Patches from Fedora rawhide
  122. * Sat Jul 02 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.12-2
  123. - rebuild with gcc-5.4.0
  124. * Thu Mar 31 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.12-1
  125. - new upstream release
  126. * Tue Mar 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11-1
  127. - new upstream release
  128. * Thu Dec 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.01-1
  129. - new upstream release
  130. * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.47-1
  131. - new upstream release
  132. * Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.25-1
  133. - new upstream release
  134. * Wed Oct 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.01-2
  135. - rebuild with pcre-8.31
  136. * Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.01-1
  137. - new upstream release
  138. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-2
  139. - new upstream release
  140. * Mon Feb 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-1
  141. - new upstream release
  142. * Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.50-1
  143. - new upstream release
  144. - fix %files to add nping
  145. * Fri Jun 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.21-1
  146. - new upstream release
  147. - add BuildRequires: openssl-devel, lua-devel
  148. - fix %files to add ncat and ndiff
  149. * Fri Apr 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.76-1
  150. - new upstream release
  151. - spec in UTF-8
  152. - added BuildRequires: libpcap-devel instead of libpcap
  153. - removed BuildRequires: desktop-file-utils
  154. * Sat Nov 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.60-4
  155. - rebuilt with libpcap 1.0.0
  156. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 4.60-3
  157. - rebuilt with python-2.5.2
  158. * Mon Apr 28 2008 NAKAMURA Kenta <kenta@vinelinux.org> 4.60-2
  159. - updated python sitelib files path
  160. * Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.60-1vl5
  161. - new upstream release
  162. * Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.20-0vl1
  163. - new upstream release
  164. - rebuild with new environment/toolchain
  165. * Sat Jun 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10-0vl1
  166. - new upstream release
  167. - added BuildRequires: desktop-file-utils
  168. * Sat Feb 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.01-0vl1
  169. - new upstream release
  170. * Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl2
  171. - rebuild for VineSeed Plus
  172. * Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl1
  173. - new upstream release
  174. * Fri Feb 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-0vl1
  175. - new upstream release
  176. * Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.75-0vl1
  177. - new upstream release
  178. - added Japanese summary to nmap-frontend
  179. * Thu Sep 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.70-0vl1
  180. - new upstream release
  181. * Sat Mar 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl2
  182. - rebuild with new openssl
  183. * Tue Mar 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl1
  184. - new upstream release
  185. * Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.48-0vl1
  186. - new upstream release
  187. * Thu Sep 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.45-0vl1
  188. - new upstream release
  189. * Sun Jul 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.30-0vl1
  190. - new upstream release
  191. * Tue May 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl2
  192. - merged Vine Plus specfile and VineSeed Plus specfile (sorry...)
  193. * Sat May 3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl1
  194. - new upstream release
  195. - rebuild with new toolchains
  196. * Sun Sep 22 2002 Masaru Sato <masachan@mediaship.ne.jp> 3.00-0vl1
  197. - new upstream release
  198. - delete Version Tag from nmap-frontend package
  199. - fix BuildRoot
  200. * Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.54BETA34-0vl1
  201. - new upstream release
  202. - 2.54BETA is developpment release, but it is more stable than 2.53.
  203. * Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 2.53-1vl2
  204. - unfortunately increase release: 1vl2 from 0vl2
  205. ( 2.53-1vl1 is found in VinePlus/2.1, also breaking our packaging rule)
  206. - patch to build on current glibc22 system
  207. * Thu Sep 06 2001 Toru Sagami <sagami@vinelinux.org>
  208. - 2.53-0vl2: use better macros
  209. * Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
  210. - rebuild for VineSeed based on the original site's srpm
  211. - add Japanese summary and description
  212. * Thu Dec 30 1999 Fyodor <fyodor@insecure.org>
  213. - Updated description
  214. - Eliminated source1 (nmapfe.desktop) directive and simply packaged it with Nmap
  215. - Fixed nmap distribution URL (source0)
  216. - Added this .rpm to base Nmap distribution
  217. * Mon Dec 13 1999 Tim Powers <timp@redhat.com>
  218. - based on origional spec file from
  219. http://www.insecure.org/nmap/index.html#download
  220. - general cleanups, removed lots of commenrts since it made the spec hard to
  221. read
  222. - changed group to Applications/System
  223. - quiet setup
  224. - no need to create dirs in the install section, "make
  225. prefix=$RPM_BUILD_ROOT&{prefix} install" does this.
  226. - using defined %{prefix}, %{version} etc. for easier/quicker maint.
  227. - added docs
  228. - gzip man pages
  229. - strip after files have been installed into buildroot
  230. - created separate package for the frontend so that Gtk+ isn't needed for the
  231. CLI nmap
  232. - not using -f in files section anymore, no need for it since there aren't that
  233. many files/dirs
  234. - added desktop entry for gnome
  235. * Sun Jan 10 1999 Fyodor <fyodor@dhp.com>
  236. - Merged in spec file sent in by Ian Macdonald <ianmacd@xs4all.nl>
  237. * Tue Dec 29 1998 Fyodor <fyodor@dhp.com>
  238. - Made some changes, and merged in another .spec file sent in
  239. by Oren Tirosh <oren@hishome.net>
  240. * Mon Dec 21 1998 Riku Meskanen <mesrik@cc.jyu.fi>
  241. - initial build for RH 5.x