libxcrypt-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626
  1. %bcond_with fipstest
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. # Build with new api?
  4. %if 0%{?fedora} >= 30 || 0%{?rhel} >= 9
  5. %bcond_without new_api
  6. %else
  7. %bcond_with new_api
  8. %endif
  9. # Build the compat package?
  10. %if 0%{?fedora} >= 999 || 0%{?rhel} >= 99
  11. %bcond_with compat_pkg
  12. %else
  13. %bcond_without compat_pkg
  14. %endif
  15. # Run memcheck?
  16. # Valgrind does not work well on %%{power64} arches.
  17. %ifnarch %{power64}
  18. %bcond_without memcheck
  19. %else
  20. %bcond_with memcheck
  21. %endif
  22. # Shared object version of libcrypt.
  23. %if %{with new_api}
  24. %global soc 2
  25. %global sol 0
  26. %global sof 0
  27. %global sov %{soc}.%{sol}.%{sof}
  28. %if %{with compat_pkg}
  29. %global csoc 1
  30. %global csol 1
  31. %global csof 0
  32. %global csov %{csoc}.%{csol}.%{csof}
  33. %endif
  34. %else
  35. %global soc 1
  36. %global sol 1
  37. %global sof 0
  38. %global sov %{soc}.%{sol}.%{sof}
  39. %endif
  40. # Hash methods and API supported by libcrypt.
  41. # NEVER EVER touch this, if you do NOT know what you are doing!
  42. %if %{with new_api}
  43. %global hash_methods fedora,glibc,strong
  44. %global obsolete_api no
  45. %if %{with compat_pkg}
  46. %global compat_methods glibc
  47. %global compat_api glibc
  48. %endif
  49. %else
  50. %global hash_methods all
  51. %global obsolete_api glibc
  52. %endif
  53. # Needed for the distribution README file.
  54. %if 0%{?fedora}
  55. %global distname .fedora
  56. %else
  57. %if 0%{?rhel}
  58. %global distname .rhel
  59. %else
  60. %global distname .distribution
  61. %endif
  62. %endif
  63. # Needed for out-of-tree builds.
  64. %global _configure ../"configure"
  65. # Common configure options.
  66. %global common_configure_options \\\
  67. --libdir=/%{_lib} \\\
  68. --disable-failure-tokens \\\
  69. --disable-silent-rules \\\
  70. --enable-shared \\\
  71. --enable-static \\\
  72. %if %{with memcheck} \
  73. --enable-valgrind \\\
  74. %else \
  75. --disable-valgrind \\\
  76. %endif \
  77. --srcdir=.. \\\
  78. --with-pkgconfigdir=%{_libdir}/pkgconfig
  79. %if %{with fipstest}
  80. # Add generation of HMAC checksums of the final stripped
  81. # binaries. %%define with lazy globbing is used here
  82. # intentionally, because using %%global does not work.
  83. BuildRequires: fipscheck
  84. %define __spec_install_post \
  85. %{?__debug_package:%{__debug_install_post}} \
  86. %{__arch_install_post} \
  87. %{__os_install_post} \
  88. %{_bindir}/fipshmac %{buildroot}/%{_lib}/libcrypt.a \
  89. %{__ln_s} .libcrypt.a.hmac \\\
  90. %{buildroot}/%{_lib}/.libxcrypt.a.hmac \
  91. %{_bindir}/fipshmac %{buildroot}/%{_lib}/libcrypt.so.%{sov} \
  92. %{__ln_s} .libcrypt.so.%{sov}.hmac \\\
  93. %{buildroot}/%{_lib}/.libcrypt.so.%{soc}.hmac \
  94. if [[ %{with new_api} == 1 && %{with compat_pkg} == 1 ]]; then \
  95. %{_bindir}/fipshmac %{buildroot}/%{_lib}/libcrypt.so.%{csov} \
  96. %{__ln_s} .libcrypt.so.%{csov}.hmac \\\
  97. %{buildroot}/%{_lib}/.libcrypt.so.%{csoc}.hmac \
  98. fi \
  99. %{nil}
  100. %endif
  101. Name: libxcrypt
  102. Version: 4.4.2
  103. Release: 6%{?_dist_release}
  104. Summary: Extended crypt library for descrypt, md5crypt, bcrypt, and others
  105. Group: System Environment/Libraries
  106. Vendor: Project Vine
  107. Distribution: Vine Linux
  108. # For explicit license breakdown, see the
  109. # LICENSING file in the source tarball.
  110. License: LGPLv2+ and BSD and Public Domain
  111. URL: https://github.com/besser82/%{name}
  112. Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
  113. # Patch 0000 - 2999: Backported patches from upstream.
  114. # Patch 3000 - 5999: Backported patches from pull requests.
  115. # Patch 6000 - 9999: Downstream patches.
  116. BuildRequires: libtool
  117. %if %{with memcheck}
  118. BuildRequires: valgrind
  119. %endif
  120. # We do not need to keep this forever.
  121. # We need a version of glibc, that doesn't build libcrypt anymore.
  122. Requires: glibc%{?_isa} >= 2.26.9000-46
  123. %if 0%{?fedora} >= 30
  124. Recommends: mkpasswd
  125. %endif
  126. %description
  127. libxcrypt is a modern library for one-way hashing of passwords. It
  128. supports a wide variety of both modern and historical hashing methods:
  129. yescrypt, gost-yescrypt, scrypt, bcrypt, sha512crypt, sha256crypt,
  130. %if %{with new_api}
  131. md5crypt, and descrypt.
  132. %else
  133. md5crypt, SunMD5, sha1crypt, NT, bsdicrypt, bigcrypt, and descrypt.
  134. %endif
  135. It provides the traditional Unix crypt and crypt_r interfaces, as well
  136. as a set of extended interfaces pioneered by Openwall Linux, crypt_rn,
  137. crypt_ra, crypt_gensalt, crypt_gensalt_rn, and crypt_gensalt_ra.
  138. libxcrypt is intended to be used by login(1), passwd(1), and other
  139. similar programs; that is, to hash a small number of passwords during
  140. an interactive authentication dialogue with a human. It is not suitable
  141. for use in bulk password-cracking applications, or in any other situation
  142. where speed is more important than careful handling of sensitive data.
  143. However, it is intended to be fast and lightweight enough for use in
  144. servers that must field thousands of login attempts per minute.
  145. %if %{with new_api}
  146. This version of the library does not provide the legacy API functions
  147. that have been provided by glibc's libcrypt.so.1.
  148. %endif
  149. %if %{with new_api} && %{with compat_pkg}
  150. %package compat
  151. Summary: Compatibility library providing legacy API functions
  152. Requires: %{name}%{?_isa} == %{version}-%{release}
  153. %description compat
  154. This package contains the library providing the compatibility API
  155. for applications that are linked against glibc's libxcrypt, or that
  156. are still using the unsafe and deprecated, encrypt, encrypt_r,
  157. setkey, setkey_r, and fcrypt functions, which are still required by
  158. recent versions of POSIX, the Single UNIX Specification, and various
  159. other standards.
  160. All existing binary executables linked against glibc's libcrypt should
  161. work unmodified with the library supplied by this package.
  162. %endif
  163. %package devel
  164. Summary: Development files for %{name}
  165. Group: Development/Libraries
  166. Conflicts: man-pages < 4.15-3
  167. Requires: %{name}%{?_isa} == %{version}-%{release}
  168. Requires: glibc-devel%{?_isa}
  169. %description devel
  170. The %{name}-devel package contains libraries and header files for
  171. developing applications that use %{name}.
  172. %package static
  173. Summary: Static library for -static linking with %{name}
  174. Group: Development/Libraries
  175. Requires: %{name}-devel%{?_isa} == %{version}-%{release}
  176. Requires: glibc-static%{?_isa}
  177. %description static
  178. This package contains the libxcrypt static library for -static
  179. linking.
  180. You don't need this, unless you link statically, which is highly
  181. discouraged.
  182. %package -n compat32-%{name}
  183. Summary: Extended crypt library for descrypt, md5crypt, bcrypt, and others
  184. Group: System Environment/Libraries
  185. %description -n compat32-%{name}
  186. libxcrypt is a modern library for one-way hashing of passwords. It
  187. supports a wide variety of both modern and historical hashing methods:
  188. yescrypt, gost-yescrypt, scrypt, bcrypt, sha512crypt, sha256crypt,
  189. %if %{with new_api}
  190. md5crypt, and descrypt.
  191. %else
  192. md5crypt, SunMD5, sha1crypt, NT, bsdicrypt, bigcrypt, and descrypt.
  193. %endif
  194. It provides the traditional Unix crypt and crypt_r interfaces, as well
  195. as a set of extended interfaces pioneered by Openwall Linux, crypt_rn,
  196. crypt_ra, crypt_gensalt, crypt_gensalt_rn, and crypt_gensalt_ra.
  197. libxcrypt is intended to be used by login(1), passwd(1), and other
  198. similar programs; that is, to hash a small number of passwords during
  199. an interactive authentication dialogue with a human. It is not suitable
  200. for use in bulk password-cracking applications, or in any other situation
  201. where speed is more important than careful handling of sensitive data.
  202. However, it is intended to be fast and lightweight enough for use in
  203. servers that must field thousands of login attempts per minute.
  204. %if %{with new_api}
  205. This version of the library does not provide the legacy API functions
  206. that have been provided by glibc's libcrypt.so.1.
  207. %endif
  208. %package -n compat32-%{name}-devel
  209. Summary: Development files for cpmpat32-%{name}
  210. Group: Development/Libraries
  211. Requires: %{name}-devel == %{version}-%{release}
  212. Requires: compat32-glibc-devel
  213. %description -n compat32-%{name}-devel
  214. The compat32-%{name}-devel package contains libraries and header files for
  215. developing applications that use compat32-%{name}.
  216. %prep
  217. %autosetup -p 1
  218. ./bootstrap
  219. %if %{with new_api}
  220. %{__cat} << EOF >> README%{distname}
  221. This version of the %{name} package ships the libcrypt.so2
  222. library and does not provide the legacy API functions that have
  223. been provided by glibc's libcrypt.so.1. The removed functions
  224. by name are encrypt, encrypt_r, setkey, setkey_r, and fcrypt.
  225. %if %{with compat_pkg}
  226. If you are using a third-party application that links against
  227. those functions, or that is linked against glibc's libcrypt,
  228. you may need to install the %{name}-compat package manually.
  229. All existing binary executables linked against glibc's libcrypt
  230. should work unmodified with the libcrypt.so.1 library supplied
  231. by the %{name}-compat package.
  232. %endif
  233. EOF
  234. %endif
  235. %{__mkdir_p} %{_vpath_builddir}{,-compat}
  236. %build
  237. # Build the default system library.
  238. pushd %{_vpath_builddir}
  239. %configure \
  240. %{common_configure_options} \
  241. --enable-hashes=%{hash_methods} \
  242. --enable-obsolete-api=%{obsolete_api}
  243. %make_build
  244. popd
  245. %if %{with new_api} && %{with compat_pkg}
  246. # Build the compatibility library.
  247. pushd %{_vpath_builddir}-compat
  248. %configure \
  249. %{common_configure_options} \
  250. --enable-hashes=%{compat_methods} \
  251. --enable-obsolete-api=%{compat_api}
  252. %make_build
  253. popd
  254. %endif
  255. %install
  256. rm -rf %{buildroot}
  257. %if %{with new_api} && %{with compat_pkg}
  258. # Install the compatibility library.
  259. %make_install -C %{_vpath_builddir}-compat
  260. # Cleanup everything we do not need from the compatibility library.
  261. %{__rm} -fr %{buildroot}%{_bindir} \
  262. %{buildroot}%{_includedir} \
  263. %{buildroot}/%{_lib}/lib{,x}crypt.{a,so} \
  264. %{buildroot}%{_libdir}/pkgconfig \
  265. %{buildroot}%{_mandir} \
  266. %{buildroot}%{_sbindir}
  267. %endif
  268. # Install the default system library.
  269. %make_install -C %{_vpath_builddir}
  270. # Get rid of libtool crap.
  271. %{_bindir}/find %{buildroot} -name '*.la' -print -delete
  272. %check
  273. %if %{with new_api} && %{with compat_pkg}
  274. for dir in %{_vpath_builddir} %{_vpath_builddir}-compat; do
  275. %else
  276. for dir in %{_vpath_builddir}; do
  277. %endif
  278. %make_build -C ${dir} check || \
  279. {
  280. rc=$?;
  281. echo "-----BEGIN TESTLOG: ${dir}-----";
  282. %{__cat} ${dir}/test-suite.log;
  283. echo "-----END TESTLOG: ${dir}-----";
  284. exit $rc;
  285. }
  286. %if %{with memcheck}
  287. %make_build -C ${dir} check-valgrind-memcheck || \
  288. {
  289. rc=$?;
  290. echo "-----BEGIN TESTLOG: ${dir}-----";
  291. %{__cat} ${dir}/test-suite-memcheck.log;
  292. echo "-----END TESTLOG: ${dir}-----";
  293. exit $rc;
  294. }
  295. %endif
  296. done
  297. %post -p /sbin/ldconfig
  298. %postun -p /sbin/ldconfig
  299. %if %{with new_api} && %{with compat_pkg}
  300. %post compat -p /sbin/ldconfig
  301. %postun compat -p /sbin/ldconfig
  302. %endif
  303. %if 0%{?build_compat32}
  304. %post -n compat32-%{name} -p /sbin/ldconfig
  305. %postun -n compat32-%{name} -p /sbin/ldconfig
  306. %endif
  307. %files
  308. %doc NEWS README* THANKS
  309. %license AUTHORS COPYING.LIB LICENSING
  310. %if %{with fipstest}
  311. /%{_lib}/.libcrypt.so.%{soc}.hmac
  312. /%{_lib}/.libcrypt.so.%{sov}.hmac
  313. %endif
  314. /%{_lib}/libcrypt.so.%{soc}
  315. /%{_lib}/libcrypt.so.%{sov}
  316. %{_mandir}/man5/crypt.5.*
  317. %if %{with new_api} && %{with compat_pkg}
  318. %files compat
  319. %if %{with fipstest}
  320. /%{_lib}/.libcrypt.so.%{csoc}.hmac
  321. /%{_lib}/.libcrypt.so.%{csov}.hmac
  322. %endif
  323. /%{_lib}/libcrypt.so.%{csoc}
  324. /%{_lib}/libcrypt.so.%{csov}
  325. %endif
  326. %files devel
  327. %doc ChangeLog TODO
  328. /%{_lib}/lib*crypt.so
  329. %{_includedir}/*crypt.h
  330. %{_libdir}/pkgconfig/libcrypt.pc
  331. %{_libdir}/pkgconfig/%{name}.pc
  332. %{_mandir}/man3/crypt*.3*
  333. %files static
  334. %if %{with fipstest}
  335. /%{_lib}/.lib*crypt.a.hmac
  336. %endif
  337. /%{_lib}/lib*crypt.a
  338. %if 0%{?build_compat32}
  339. %files -n compat32-%{name}
  340. %if %{with fipstest}
  341. /%{_lib}/.libcrypt.so.%{soc}.hmac
  342. /%{_lib}/.libcrypt.so.%{sov}.hmac
  343. %endif
  344. /%{_lib}/libcrypt.so.%{soc}
  345. /%{_lib}/libcrypt.so.%{sov}
  346. %files -n compat32-%{name}-devel
  347. /%{_lib}/lib*crypt.so
  348. %{_libdir}/pkgconfig/libcrypt.pc
  349. %{_libdir}/pkgconfig/%{name}.pc
  350. %endif
  351. %changelog
  352. * Sat Jan 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.2-6
  353. - initial build for Vine Linux.
  354. * Mon Jan 14 2019 Björn Esser <besser82@fedoraproject.org> - 4.4.2-5
  355. - Build the compat package with glibc hashing methods only
  356. - Add an option to disable the compat-package for future use
  357. * Mon Jan 14 2019 Björn Esser <besser82@fedoraproject.org> - 4.4.2-4
  358. - Bump SO-name for Fedora >= 30 and enable compat package (#1666033)
  359. - Add distribution README file
  360. - Update description of the compat package
  361. - Conditionally remove non-built hashing methods from description
  362. * Sun Dec 23 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.2-3
  363. - Remove architecture bits from Recommends
  364. * Sun Dec 23 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.2-2
  365. - Update summary
  366. * Sat Dec 22 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.2-1
  367. - New upstream release
  368. * Thu Dec 06 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.1-1
  369. - New upstream release
  370. * Tue Dec 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-5
  371. - Sync -fno-plt patch with upstream commit
  372. * Tue Dec 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-4
  373. - Backport upstream commit to fix a memory leak from a static pointer
  374. * Tue Dec 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-3
  375. - Backport upstream PR to build with -fno-plt optimization
  376. * Mon Nov 26 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-2
  377. - Backport upstream commit to use a safer strcpy for the NT method
  378. - Backport upstream generating base64 encoded output for NT gensalt
  379. - Backport upstream commit to require less rbytes for NT gensalt
  380. - Backport upstream commit to test incremental hmac-sha256 computation
  381. - Add Recommends: mkpasswd for Fedora >= 30
  382. * Tue Nov 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-1
  383. - New upstream release
  384. * Wed Nov 14 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.4-1
  385. - New upstream release
  386. * Wed Nov 14 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-4
  387. - Bump release for proper obsoletion of former common sub-package
  388. * Wed Nov 14 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-3
  389. - Add two upstream patches with minor fixes
  390. - Add HMAC checksum file for the static library
  391. - Drop the common sub-package
  392. - Some spec-file optimizations
  393. * Tue Nov 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-2
  394. - Add a patch to define crypt_gensalt_r as macro, so applications
  395. link the identical crypt_gensalt_rn directly
  396. * Sun Nov 11 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-1
  397. - New upstream release
  398. * Sun Nov 11 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.2-1
  399. - New upstream release
  400. * Sun Nov 11 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.1-2
  401. - Backport two patches from upstream fixing the gensalt function for
  402. NT to properly terminate its returned output
  403. * Sat Nov 10 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.1-1
  404. - New upstream release
  405. * Sat Nov 10 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.0-1
  406. - New upstream release
  407. * Fri Oct 26 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.3-1
  408. - New upstream release
  409. * Thu Oct 25 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.2-2
  410. - Add patch updating to recent development version
  411. - Run valgrind-memcheck
  412. - Use bootstrap script
  413. * Thu Oct 18 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.2-1
  414. - New upstream release
  415. * Mon Oct 01 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.1-3
  416. - Drop compat-devel package
  417. - Set configure options from globals
  418. * Sun Sep 30 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.1-2
  419. - Build out-of-tree
  420. - Split off noarch-bits into common sub-package
  421. - Update %%description
  422. - Prepare to remove legacy API from library and to provide a compatibilty
  423. package for the legacy API
  424. * Sat Sep 29 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.1-1
  425. - New upstream release
  426. - Add new manpages
  427. * Sat Sep 29 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.0-1
  428. - New upstream release
  429. * Fri Aug 24 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.2-1
  430. - New upstream release
  431. * Wed Aug 08 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-4
  432. - Move *.3 manpages to devel subpackage (#1613762)
  433. - Add needed Conflicts: man-pages < 4.15-3
  434. * Wed Aug 08 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-3
  435. - Make crypt{,_r} return NULL on failure (#1611784)
  436. * Sat Aug 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-2
  437. - Add manpages for crypt{,_r,_ra}.3 (#1610307)
  438. * Wed Aug 01 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-1
  439. - New upstream release
  440. * Fri Jul 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.0-1
  441. - New upstream release
  442. * Fri Jul 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.1-6
  443. - Make testsuite fail on error again
  444. - Update patch0 with more upstream fixes
  445. * Fri Jul 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.1-5
  446. - Add patch to update to recent development branch
  447. - Re-enable SUNMD5 support as it is BSD licensed now
  448. - Build compatibility symbols for glibc only
  449. - Skip failing testsuite once
  450. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.1-4
  451. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  452. * Fri Jun 29 2018 Florian Weimer <fweimer@redhat.com> - 4.0.1-3
  453. - Remove CDDL from license list (#1592445)
  454. * Fri Jun 29 2018 Florian Weimer <fweimer@redhat.com> - 4.0.1-2
  455. - Remove SUNMD5 support (#1592445)
  456. * Wed May 16 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.1-1
  457. - New upstream release
  458. * Sat Feb 17 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-5
  459. - Switch to %%ldconfig_scriptlets
  460. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.0-4
  461. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  462. * Thu Feb 01 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-3
  463. - Add patch to fix unintialize value in badsalt test
  464. * Wed Jan 31 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-2
  465. - Add patch to fix bcrypt test with GCC8
  466. * Sat Jan 27 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-1
  467. - New upstream release
  468. * Mon Jan 22 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 4.0.0-0.204.20180120git3436e7b
  469. - Fix Obsoletes
  470. * Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.203.20180120git3436e7b
  471. - Update to new snapshot fixing cast-align
  472. * Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.202.20180120gitde99d27
  473. - Update to new snapshot (rhbz#1536752)
  474. * Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.201.20171109git15447aa
  475. - Use archful Obsoletes for libcrypt
  476. - Add versioned Requires on glibc packages not shipping libcrypt
  477. - Add comments about the packaging logic for replacing former libcrypt
  478. * Fri Jan 12 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.200.20171109git15447aa
  479. - Initial import (rhbz#1532794)
  480. - Add Obsoletes/Provides for libcrypt
  481. * Wed Jan 10 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.101.20171109git15447aa
  482. - Fix style of %%git_{rel,ver}
  483. * Tue Jan 09 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.100.git20171109.15447aa
  484. - Initial rpm release (rhbz#1532794)
  485. - Start revision at 0.100 to superseed builds from COPR