libssh2-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A library implementing the SSH2 protocol
  3. Summary(ja): SSH2 プロトコルを実装するためのライブラリ
  4. Name: libssh2
  5. Version: 1.9.0
  6. Release: 1%{?_dist_release}
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. Group: System Environment/Libraries
  10. License: BSD
  11. URL: https://www.libssh2.org/
  12. Source0: https://www.libssh2.org/download/%{name}-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: openssl-devel
  15. BuildRequires: zlib-devel
  16. %description
  17. libssh2 is a library implementing the SSH2 protocol as defined by
  18. Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
  19. SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
  20. SECSH-DHGEX(04), and SECSH-NUMBERS(10).
  21. %package devel
  22. Summary: Development files for %{name}
  23. Summary(ja): %{name} の開発ファイル
  24. Group: Development/Libraries
  25. Requires: %{name} = %{version}-%{release}
  26. %description devel
  27. The %{name}-devel package contains libraries and header files for
  28. developing applications that use %{name}.
  29. %package docs
  30. Summary: Documentation for %{name}
  31. Summary(ja): %{name} のドキュメント
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. %description docs
  35. The %{name}-docs package contains man pages and examples for
  36. developing applications that use %{name}.
  37. ## to build compat32 for x86_64 architecture support
  38. %package -n compat32-%{name}
  39. Summary: A library implementing the SSH2 protocol
  40. Summary(ja): SSH2 プロトコルを実装するためのライブラリ
  41. Group: System Environment/Libraries
  42. %description -n compat32-%{name}
  43. libssh2 is a library implementing the SSH2 protocol as defined by
  44. Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
  45. SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
  46. SECSH-DHGEX(04), and SECSH-NUMBERS(10).
  47. %prep
  48. %setup -q
  49. # Replace hard wired port number in the test suite to avoid collisions
  50. # between 32-bit and 64-bit builds running on a single build-host
  51. sed -i s/4711/47%{__isa_bits}/ tests/ssh2.{c,sh}
  52. # make sure things are UTF-8...
  53. for i in ChangeLog NEWS ; do
  54. iconv --from=ISO-8859-1 --to=UTF-8 $i > new
  55. mv new $i
  56. done
  57. %build
  58. %configure --disable-static --enable-shared
  59. make %{?_smp_mflags}
  60. %install
  61. rm -rf %{buildroot}
  62. make install DESTDIR=%{buildroot} INSTALL="install -p"
  63. find %{buildroot} -name '*.la' -exec rm -f {} +
  64. # clean things up a bit for packaging
  65. ( cd example && make clean )
  66. rm -rf example/simple/.deps
  67. find example/ -type f '(' -name '*.am' -o -name '*.in' ')' -exec rm -v {} +
  68. %check
  69. (cd tests && make check)
  70. %clean
  71. rm -rf %{buildroot}
  72. %post -p /sbin/ldconfig
  73. %postun -p /sbin/ldconfig
  74. %post -n compat32-%{name} -p /sbin/ldconfig
  75. %postun -n compat32-%{name} -p /sbin/ldconfig
  76. %files
  77. %defattr(-,root,root,-)
  78. %license COPYING
  79. %doc NEWS README* RELEASE-NOTES
  80. %{_libdir}/*.so.*
  81. %files docs
  82. %defattr(-,root,root,-)
  83. %license COPYING
  84. %doc example/ docs/HACKING
  85. %{_mandir}/man?/*
  86. %files devel
  87. %defattr(-,root,root,-)
  88. %license COPYING
  89. %{_includedir}/*
  90. %{_libdir}/*.so
  91. %{_libdir}/pkgconfig/libssh2.pc
  92. %if %{build_compat32}
  93. %files -n compat32-%{name}
  94. %defattr(-,root,root,-)
  95. %{_libdir}/*.so.*
  96. %endif
  97. %changelog
  98. * Thu Oct 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.0-1
  99. - new upstream release.
  100. * Thu Mar 28 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.2-1
  101. - new upstream release.
  102. * Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.0-1
  103. - new upstream release.
  104. - built with openssl-1.1.1.
  105. * Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.0-2
  106. - rebuilt with openssl 1.0.2g
  107. * Fri Feb 26 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.0-1
  108. - new upstream release with security fixes
  109. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-1
  110. - new upstream reelase
  111. - add compat32 package
  112. * Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-1
  113. - new upstream release
  114. - fix %%files
  115. * Tue Sep 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-1
  116. - initial build for Vine Linux
  117. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0-4
  118. - rebuilt with new openssl
  119. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-3
  120. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  121. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-2
  122. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  123. * Mon Feb 16 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.0-1
  124. - update to 1.0
  125. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.18-8
  126. - rebuild with new openssl
  127. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.18-7
  128. - Autorebuild for GCC 4.3
  129. * Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-6
  130. - rebuild for new openssl...
  131. * Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-5
  132. - bump
  133. * Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-4
  134. - add INSTALL arg to make install vs env. var
  135. * Mon Nov 26 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-3
  136. - run tests; don't package test
  137. * Sun Nov 18 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-2
  138. - split docs into -docs (they seemed... large.)
  139. * Tue Nov 13 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-1
  140. - update to 0.18
  141. * Sun Oct 14 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.17-1
  142. - update to 0.17
  143. - many spec file changes
  144. * Wed May 23 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.2.20070506
  145. - Fix release tag
  146. - Move manpages to -devel package
  147. - Add Examples dir to -devel package
  148. * Sun May 06 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.20070506.1
  149. - Initial build