libldb-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define _unpackaged_files_terminate_build 1
  3. %define talloc_version 2.1.14
  4. %define tdb_version 1.3.16
  5. %define tevent_version 0.9.37
  6. Name: libldb
  7. Summary: A schema-less, ldap like, API and database
  8. Version: 1.4.3
  9. Release: 1%{?_dist_release}
  10. Group: System Environment/Libraries
  11. License: LGPLv3+
  12. URL: http://ldb.samba.org/
  13. Source: http://samba.org/ftp/ldb/ldb-%{version}.tar.gz
  14. # Patches
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: libtalloc-devel >= %{talloc_version}
  17. BuildRequires: libtdb-devel >= %{tdb_version}
  18. BuildRequires: libtevent-devel >= %{tevent_version}
  19. BuildRequires: popt-devel
  20. BuildRequires: autoconf
  21. BuildRequires: libxslt
  22. BuildRequires: docbook-style-xsl
  23. BuildRequires: python-devel
  24. BuildRequires: python-rpm-macros
  25. BuildRequires: python-tdb
  26. BuildRequires: python-talloc-devel
  27. BuildRequires: python-tevent
  28. BuildRequires: python3-devel
  29. BuildRequires: python3-rpm-macros
  30. BuildRequires: python3-tdb
  31. BuildRequires: python3-talloc-devel
  32. BuildRequires: python3-tevent
  33. BuildRequires: doxygen
  34. Requires: libtalloc >= %{talloc_version}
  35. Requires: libtdb >= %{tdb_version}
  36. Requires: libtevent >= %{tevent_version}
  37. Provides: bundled(libreplace)
  38. Vendor: Project Vine
  39. Distribution: Vine Linux
  40. Packager: tomop
  41. %description
  42. An extensible library that implements an LDAP like API to access remote LDAP
  43. servers, or use local tdb databases.
  44. %package -n ldb-tools
  45. Group: Applications/System
  46. Summary: Tools to manage LDB files
  47. Requires: libldb = %{version}-%{release}
  48. %description -n ldb-tools
  49. Tools to manage LDB files
  50. %package devel
  51. Group: Development/Libraries
  52. Summary: Developer tools for the LDB library
  53. Requires: libldb = %{version}-%{release}
  54. Requires: libtdb-devel >= %{tdb_version}
  55. Requires: libtalloc-devel >= %{talloc_version}
  56. Requires: libtevent-devel >= %{tevent_version}
  57. Requires: pkgconfig
  58. %description devel
  59. Header files needed to develop programs that link against the LDB library.
  60. %package -n python-ldb
  61. Group: System Environment/Libraries
  62. Summary: Python bindings for the LDB library
  63. Requires: libldb = %{version}-%{release}
  64. Requires: python-tdb >= %{tdb_version}
  65. Provides: pyldb = %{version}-%{release}
  66. Obsoletes: pyldb < 1.1.31-2
  67. %description -n python-ldb
  68. Python bindings for the LDB library
  69. %package -n python-ldb-devel
  70. Group: Development/Libraries
  71. Summary: Development files for the Python bindings for the LDB library
  72. Requires: python-ldb = %{version}-%{release}
  73. Requires: python-ldb-devel-common = %{version}-%{release}
  74. Provides: pyldb-devel = %{version}-%{release}
  75. Obsoletes: pyldb-devel <= 1.1.31-2
  76. %description -n python-ldb-devel
  77. Development files for the Python bindings for the LDB library
  78. %package -n python-ldb-devel-common
  79. Summary: Common development files for the Python bindings for the LDB library
  80. %description -n python-ldb-devel-common
  81. Development files for the Python bindings for the LDB library.
  82. This package includes files that aren't specific to a Python version.
  83. %package -n python3-ldb
  84. Group: System Environment/Libraries
  85. Summary: Python3 bindings for the LDB library
  86. Requires: libldb = %{version}-%{release}
  87. Requires: python3-tdb >= %{tdb_version}
  88. %description -n python3-ldb
  89. Python3 bindings for the LDB library
  90. %package -n python3-ldb-devel
  91. Group: Development/Libraries
  92. Summary: Development files for the Python3 bindings for the LDB library
  93. Requires: python3-ldb = %{version}-%{release}
  94. Requires: python-ldb-devel-common = %{version}-%{release}
  95. %description -n python3-ldb-devel
  96. Development files for the Python3 bindings for the LDB library
  97. %if %{build_compat32}
  98. %package -n compat32-%{name}
  99. Summary: A schema-less, ldap like, API and database
  100. Group: System Environment/Libraries
  101. %description -n compat32-%{name}
  102. An extensible library that implements an LDAP like API to access remote LDAP
  103. servers, or use local tdb databases.
  104. %endif
  105. %prep
  106. %setup -q -n ldb-%{version}
  107. %build
  108. # tdb_compat and ccan have no upstream releases to link against yet and their
  109. # API is in flux. It is unsafe to make them public and shared at this time.
  110. %configure \
  111. --disable-rpath \
  112. --disable-rpath-install \
  113. --bundled-libraries=cmocka \
  114. --builtin-libraries=replace \
  115. --with-modulesdir=%{_libdir}/ldb/modules \
  116. --with-privatelibdir=%{_libdir}/ldb \
  117. --without-ldb-lmdb \
  118. --extra-python=%{__python3}
  119. make V=1 %{?_smp_mflags}
  120. doxygen Doxyfile
  121. %install
  122. make install DESTDIR=%{buildroot}
  123. rm -f %{buildroot}%{_libdir}/libldb.a
  124. # Shared libraries need to be marked executable for
  125. # rpmbuild to strip them and include them in debuginfo
  126. find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
  127. # Install API docs
  128. cp -a apidocs/man/* $RPM_BUILD_ROOT/%{_mandir}
  129. # LDB 1.1.8+ bug: remove manpage named after full
  130. # file path
  131. rm -f $RPM_BUILD_ROOT/%{_mandir}/man3/_*
  132. %clean
  133. rm -rf %{buildroot}
  134. %post
  135. /sbin/ldconfig
  136. %postun
  137. /sbin/ldconfig
  138. %post -n python-ldb
  139. /sbin/ldconfig
  140. %postun -n python-ldb
  141. /sbin/ldconfig
  142. %post -n python3-ldb
  143. /sbin/ldconfig
  144. %postun -n python3-ldb
  145. /sbin/ldconfig
  146. %if %{build_compat32}
  147. %post -n compat32-%{name}
  148. /sbin/ldconfig
  149. %postun -n compat32-%{name}
  150. /sbin/ldconfig
  151. %endif
  152. %files
  153. %defattr(-,root,root,-)
  154. %dir %{_libdir}/ldb
  155. %{_libdir}/ldb/libcmocka-ldb.so
  156. %{_libdir}/ldb/libldb-key-value.so
  157. %{_libdir}/libldb.so.*
  158. %dir %{_libdir}/ldb/modules
  159. %dir %{_libdir}/ldb/modules/ldb
  160. %{_libdir}/ldb/modules/ldb/*.so
  161. %files -n ldb-tools
  162. %defattr(-,root,root,-)
  163. %{_bindir}/ldbadd
  164. %{_bindir}/ldbdel
  165. %{_bindir}/ldbedit
  166. %{_bindir}/ldbmodify
  167. %{_bindir}/ldbrename
  168. %{_bindir}/ldbsearch
  169. %{_libdir}/ldb/libldb-cmdline.so
  170. %{_mandir}/man1/ldbadd.1.*
  171. %{_mandir}/man1/ldbdel.1.*
  172. %{_mandir}/man1/ldbedit.1.*
  173. %{_mandir}/man1/ldbmodify.1.*
  174. %{_mandir}/man1/ldbrename.1.*
  175. %{_mandir}/man1/ldbsearch.1.*
  176. %files devel
  177. %defattr(-,root,root,-)
  178. %{_includedir}/ldb_module.h
  179. %{_includedir}/ldb_handlers.h
  180. %{_includedir}/ldb_errors.h
  181. %{_includedir}/ldb_version.h
  182. %{_includedir}/ldb.h
  183. %{_libdir}/libldb.so
  184. %{_libdir}/pkgconfig/ldb.pc
  185. %{_mandir}/man3/ldb*.gz
  186. %{_mandir}/man3/ldif*.gz
  187. %files -n python-ldb
  188. %defattr(-,root,root,-)
  189. %{python_sitearch}/ldb.so
  190. %{python_sitearch}/_ldb_text.*
  191. %{_libdir}/libpyldb-util.so.1*
  192. %files -n python-ldb-devel
  193. %defattr(-,root,root,-)
  194. %{_libdir}/libpyldb-util.so
  195. %{_libdir}/pkgconfig/pyldb-util.pc
  196. %files -n python-ldb-devel-common
  197. %{_includedir}/pyldb.h
  198. %{_mandir}/man*/Py*.gz
  199. %files -n python3-ldb
  200. %{python3_sitearch}/ldb.cpython-*.so
  201. %{_libdir}/libpyldb-util.cpython-*.so.1*
  202. %{python3_sitearch}/_ldb_text.py
  203. %files -n python3-ldb-devel
  204. %{_libdir}/libpyldb-util.cpython-*.so
  205. %{_libdir}/pkgconfig/pyldb-util.cpython-*.pc
  206. %if %{build_compat32}
  207. %files -n compat32-%{name}
  208. %defattr(-,root,root,-)
  209. %dir %{_libdir}/ldb
  210. %{_libdir}/libldb.so.*
  211. %dir %{_libdir}/ldb/modules
  212. %dir %{_libdir}/ldb/modules/ldb
  213. %{_libdir}/ldb/libcmocka-ldb.so
  214. %{_libdir}/ldb/libldb-cmdline.so
  215. %{_libdir}/ldb/libldb-key-value.so
  216. %{_libdir}/ldb/modules/ldb/*.so
  217. %endif
  218. %changelog
  219. * Fri Nov 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.3-1
  220. - new upstream release.
  221. - dropped Patch1.
  222. * Thu Mar 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.2-1
  223. - new upstream release.
  224. * Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-1
  225. - new upstream release.
  226. - dropped Patch1001.
  227. - imported Patch1 from rawhide.
  228. - enabled python3 modules.
  229. - renamed python packages.
  230. * Sat Jul 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.31-1
  231. - new upstream release.
  232. * Sun Dec 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.29-1
  233. - new upstream release.
  234. * Wed Feb 24 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.26-1
  235. - new upstream release.
  236. * Fri Dec 18 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.25-1
  237. - new upstream release.
  238. * Thu Dec 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.24-1
  239. - new upstream release.
  240. * Wed Dec 2 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.23-1
  241. - new upstream release.
  242. * Fri Jul 24 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.21-1
  243. - new upstream release.
  244. * Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.20-2
  245. - added compat32 package.
  246. * Fri Mar 6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.20-1
  247. - new upstream release.
  248. * Mon Jan 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.19-1
  249. - new upstream release.
  250. * Wed Dec 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.18-1
  251. - new upstream release.
  252. * Fri Oct 3 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.17-2
  253. - moved libldb and pyldb to System Environment/Libraries Group
  254. - moved ldb-tool to Applications/System Group
  255. * Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.17-1
  256. - new upstream release.
  257. * Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-2
  258. - rebuilt with current environment.
  259. * Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-1
  260. - new upstream release.
  261. * Sun Mar 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-1
  262. - new upstream release.
  263. * Thu Dec 20 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-3
  264. - moved libldb-cmdline.so to main package.
  265. * Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-2
  266. - fixed dependency.
  267. * Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-1
  268. - new upstream release.
  269. - initial build for Vine Linux.
  270. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-2
  271. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  272. * Tue Dec 06 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.4-1
  273. - New upstream release
  274. - Add ldb_module_error() routine
  275. - Fedora: work around unreliable configure check for pytevent
  276. - Drop patch to ignore --disable-silent-rules (included in tarball)
  277. * Thu Dec 01 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-4
  278. - Add patch to ignore --disable-silent-rules
  279. * Wed Nov 23 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-3
  280. - Add explicit mention of the bundled libreplace
  281. - https://fedorahosted.org/fpc/ticket/120
  282. - Add explicit mention of bundled libtdb_compat and libccan
  283. - https://fedorahosted.org/fpc/ticket/119
  284. * Mon Nov 21 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-2
  285. - Build and install API documentation
  286. - Build tdb_compat and ccan statically. They have no upstream releases to
  287. link against yet and their API is in flux. It is unsafe to make them
  288. public and shared at this time.
  289. * Wed Nov 09 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-1
  290. - New upstream release
  291. - Required for building newer samba4 packages
  292. * Tue Aug 2 2011 Simo Sorce <ssorce@redhat.com> - 1.1.0-1
  293. - Update to 1.1.0
  294. (dependency for samba4 alpha16 snapshot)
  295. * Tue Feb 22 2011 Simo Sorce <ssorce@redhat.com> - 1.0.2-1
  296. - Update to 1.0.2
  297. (dependency for samba4 alpha15 snapshot)
  298. * Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-2
  299. - Disable rpath
  300. * Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-1
  301. - New upstream release 1.0.0
  302. - SOname bump to account for module loading changes
  303. - Rename libldb-tools to ldb-tools to make upgrades easier
  304. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.22-9
  305. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  306. * Fri Feb 04 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-8
  307. - Fixes from package review
  308. - Change Requires: on tools subpackage to be the exact version/release
  309. - Remove unnecessary BuildRoot directive
  310. * Mon Jan 17 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-7
  311. - Update to 0.9.22 (first independent release of libldb upstream)