keepalived-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169
  1. Summary: HA monitor built upon LVS, VRRP and services poller
  2. Name: keepalived
  3. Version: 2.0.18
  4. Release: 1%{?_dist_release}
  5. License: GPL
  6. Group: Applications/System
  7. URL: http://www.keepalived.org/
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Source0: https://www.keepalived.org/software/keepalived-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildRequires: openssl-devel
  13. BuildRequires: libnl3-devel
  14. BuildRequires: ipset-devel
  15. BuildRequires: iptables-devel
  16. BuildRequires: libnfnetlink-devel
  17. BuildRequires: net-snmp-devel
  18. Requires(post): /sbin/chkconfig
  19. Requires(preun): /sbin/service, /sbin/chkconfig
  20. Requires(postun): /sbin/service
  21. %description
  22. The main goal of the keepalived project is to add a strong & robust keepalive
  23. facility to the Linux Virtual Server project. This project is written in C with
  24. multilayer TCP/IP stack checks. Keepalived implements a framework based on
  25. three family checks : Layer3, Layer4 & Layer5/7. This framework gives the
  26. daemon the ability to check the state of an LVS server pool. When one of the
  27. servers of the LVS server pool is down, keepalived informs the linux kernel via
  28. a setsockopt call to remove this server entry from the LVS topology. In
  29. addition keepalived implements an independent VRRPv2 stack to handle director
  30. failover. So in short keepalived is a userspace daemon for LVS cluster nodes
  31. healthchecks and LVS directors failover.
  32. %prep
  33. %setup
  34. %build
  35. %configure \
  36. --with-init=SYSV \
  37. --enable-snmp --enable-snmp-rfc \
  38. --enable-sha1
  39. %{__make} %{?_smp_mflags} STRIP=/bin/true
  40. %install
  41. %{__rm} -rf %{buildroot}
  42. %{__make} install DESTDIR=%{buildroot}
  43. # Remove "samples", as we include them in %%doc
  44. %{__rm} -rf %{buildroot}%{_sysconfdir}/keepalived/samples/
  45. %{__rm} -rf %{buildroot}%{_docdir}/keepalived
  46. mkdir -p %{buildroot}%{_libexecdir}/keepalived
  47. %clean
  48. %{__rm} -rf %{buildroot}
  49. %post
  50. /sbin/chkconfig --add keepalived
  51. %preun
  52. if [ $1 -eq 0 ]; then
  53. /sbin/service keepalived stop &>/dev/null || :
  54. /sbin/chkconfig --del keepalived
  55. fi
  56. %postun
  57. if [ $1 -ge 1 ]; then
  58. /sbin/service keepalived condrestart &>/dev/null || :
  59. fi
  60. %files
  61. %defattr(-, root, root, -)
  62. %license COPYING
  63. %doc AUTHOR ChangeLog CONTRIBUTORS README TODO
  64. %doc doc/keepalived.conf.SYNOPSIS doc/samples/keepalived.conf.*
  65. %attr(0755,root,root) %{_bindir}/genhash
  66. %attr(0755,root,root) %{_sbindir}/keepalived
  67. %attr(0644, root, root) %config(noreplace) %{_sysconfdir}/keepalived/keepalived.conf
  68. %attr(0644, root, root) %config(noreplace) %{_sysconfdir}/sysconfig/keepalived
  69. %{_sysconfdir}/rc.d/init.d/keepalived
  70. %dir %{_sysconfdir}/keepalived/
  71. %dir %{_libexecdir}/keepalived/
  72. %{_datadir}/snmp/mibs/*
  73. %{_mandir}/man1/genhash.1*
  74. %{_mandir}/man5/keepalived.conf.5*
  75. %{_mandir}/man8/keepalived.8*
  76. %changelog
  77. * Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.18-1
  78. - new upstream release.
  79. * Thu Nov 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.8-1
  80. - new upstream release.
  81. * Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.19-1
  82. - new upstream release.
  83. * Mon Apr 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
  84. - initial build for Vine Linux
  85. * Thu Sep 13 2007 Alexandre Cassen <acassen@linux-vs.org> 1.1.14
  86. - Merge work done by freshrpms.net... Thanks guys !!! ;)
  87. * Wed Feb 14 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-5
  88. - Add missing scriplet requirements.
  89. * Tue Feb 13 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-4
  90. - Add missing \n to the kernel define, for when multiple kernels are installed.
  91. - Pass STRIP=/bin/true to "make" in order to get a useful debuginfo package.
  92. * Tue Feb 13 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-3
  93. - Add %%check section to make sure any build without LVS support will fail.
  94. * Mon Feb 5 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-2
  95. - Use our own init script, include a sysconfig entry used by it for options.
  96. * Thu Jan 25 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-1
  97. - Update to 1.1.13.
  98. - Change mode of configuration file to 0600.
  99. - Don't include all of "doc" since it meant re-including all man pages.
  100. - Don't include samples in the main configuration path, they're in %%doc.
  101. - Include patch to add an optional label to interfaces.
  102. * Sat Apr 08 2006 Dries Verachtert <dries@ulyssis.org> - 1.1.12-1.2
  103. - Rebuild for Fedora Core 5.
  104. * Sun Mar 12 2006 Dag Wieers <dag@wieers.com> - 1.1.12-1
  105. - Updated to release 1.1.12.
  106. * Fri Mar 04 2005 Dag Wieers <dag@wieers.com> - 1.1.11-1
  107. - Updated to release 1.1.11.
  108. * Wed Feb 23 2005 Dag Wieers <dag@wieers.com> - 1.1.10-2
  109. - Fixed IPVS/LVS support. (Joe Sauer)
  110. * Tue Feb 15 2005 Dag Wieers <dag@wieers.com> - 1.1.10-1
  111. - Updated to release 1.1.10.
  112. * Mon Feb 07 2005 Dag Wieers <dag@wieers.com> - 1.1.9-1
  113. - Updated to release 1.1.9.
  114. * Sun Oct 17 2004 Dag Wieers <dag@wieers.com> - 1.1.7-2
  115. - Fixes to build with kernel IPVS support. (Tim Verhoeven)
  116. * Fri Sep 24 2004 Dag Wieers <dag@wieers.com> - 1.1.7-1
  117. - Updated to release 1.1.7. (Mathieu Lubrano)
  118. * Mon Feb 23 2004 Dag Wieers <dag@wieers.com> - 1.1.6-0
  119. - Updated to release 1.1.6.
  120. * Mon Jan 26 2004 Dag Wieers <dag@wieers.com> - 1.1.5-0
  121. - Updated to release 1.1.5.
  122. * Mon Dec 29 2003 Dag Wieers <dag@wieers.com> - 1.1.4-0
  123. - Updated to release 1.1.4.
  124. * Fri Jun 06 2003 Dag Wieers <dag@wieers.com> - 1.0.3-0
  125. - Initial package. (using DAR)