rust-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861
  1. %bcond_with bootstrap
  2. %bcond_with test
  3. %bcond_without clang
  4. %bcond_without bundled_libgit2
  5. %bcond_without bundled_libssh2
  6. # Some sub-packages are versioned independently of the rust compiler and runtime itself.
  7. # Also beware that if any of these are not changed in a version bump, then the release
  8. # number should still increase, not be reset to 1!
  9. %global rustc_version 1.46.0
  10. %global cargo_version %{rustc_version}
  11. %global rustfmt_version %{rustc_version}
  12. %global rls_version %{rustc_version}
  13. %global clippy_version %{rustc_version}
  14. %global llvm_major 10
  15. # The channel can be stable, beta, or nightly
  16. %{!?channel: %global channel stable}
  17. # Only x86_64 and i686 are Tier 1 platforms at this time.
  18. # https://forge.rust-lang.org/platform-support.html
  19. %global rust_arches x86_64 i686
  20. # To bootstrap from scratch, set the channel and date from src/stage0.txt
  21. # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
  22. # or nightly wants some beta-YYYY-MM-DD
  23. %global bootstrap_rust 1.46.0
  24. %global bootstrap_cargo 1.46.0
  25. %global bootstrap_channel %{bootstrap_rust}
  26. # Only the specified arches will use bootstrap binaries.
  27. %if %{with bootstrap}
  28. %global bootstrap_arches %%{rust_arches}
  29. %endif
  30. # We generally don't want llvm-static present at all, since llvm-config will
  31. # make us link statically. But we can opt in, e.g. to aid LLVM rebases.
  32. # FIXME: LLVM 3.9 prefers shared linking now! Which is good, but next time we
  33. # *want* static we'll have to force it with "llvm-config --link-static".
  34. # See also https://github.com/rust-lang/rust/issues/36854
  35. # The new rustbuild accepts `--enable-llvm-link-shared`, else links static.
  36. %bcond_with llvm_static
  37. # We can also choose to just use Rust's bundled LLVM, in case the system LLVM
  38. # is insufficient. Rust currently requires LLVM 3.7+.
  39. %bcond_with bundled_llvm
  40. # LLDB only works on some architectures
  41. %ifarch %{arm} aarch64 %{ix86} x86_64
  42. # LLDB isn't available everywhere...
  43. %bcond_without lldb
  44. %else
  45. %bcond_with lldb
  46. %endif
  47. Summary: The Rust Programming Language
  48. Name: rust
  49. Version: %{rustc_version}
  50. Release: 1%{?_dist_release}
  51. Group: programming
  52. Vendor: Project Vine
  53. Distribution: Vine Linux
  54. License: (ASL 2.0 or MIT) and (BSD and ISC and MIT)
  55. # ^ written as: (rust itself) and (bundled libraries)
  56. URL: https://www.rust-lang.org
  57. ExclusiveArch: %{rust_arches}
  58. %if "%{channel}" == "stable"
  59. %global rustc_package rustc-%{version}-src
  60. %else
  61. %global rustc_package rustc-%{channel}-src
  62. %endif
  63. Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.gz
  64. # Get the Rust triple for any arch.
  65. %{lua: function rust_triple(arch)
  66. local abi = "gnu"
  67. if arch == "armv7hl" then
  68. arch = "armv7"
  69. abi = "gnueabihf"
  70. elseif arch == "ppc64" then
  71. arch = "powerpc64"
  72. elseif arch == "ppc64le" then
  73. arch = "powerpc64le"
  74. end
  75. return arch.."-unknown-linux-"..abi
  76. end}
  77. %global rust_triple %{lua: print(rust_triple(rpm.expand("%{_target_cpu}")))}
  78. %if %defined bootstrap_arches
  79. # For each bootstrap arch, add an additional binary Source.
  80. # Also define bootstrap_source just for the current target.
  81. %{lua: do
  82. local bootstrap_arches = {}
  83. for arch in string.gmatch(rpm.expand("%{bootstrap_arches}"), "%S+") do
  84. table.insert(bootstrap_arches, arch)
  85. end
  86. local base = rpm.expand("https://static.rust-lang.org/dist"
  87. .."/rust-%{bootstrap_channel}")
  88. local target_arch = rpm.expand("%{_target_cpu}")
  89. for i, arch in ipairs(bootstrap_arches) do
  90. print(string.format("Source%d: %s-%s.tar.gz\n",
  91. i, base, rust_triple(arch)))
  92. if arch == target_arch then
  93. rpm.define("bootstrap_source "..i)
  94. end
  95. end
  96. end}
  97. %endif
  98. %ifarch %{bootstrap_arches}
  99. %global bootstrap_root rust-%{bootstrap_channel}-%{rust_triple}
  100. %global local_rust_root %{_builddir}/%{bootstrap_root}/usr
  101. Provides: bundled(%{name}-bootstrap) = %{bootstrap_rust}
  102. %else
  103. BuildRequires: cargo >= %{bootstrap_cargo}
  104. BuildRequires: %{name} >= %{bootstrap_rust}
  105. BuildConflicts: %{name} > %{version}
  106. %global local_rust_root %{_prefix}
  107. %endif
  108. BuildRequires: cmake
  109. BuildRequires: make
  110. %if %{with clang}
  111. BuildRequires: clang
  112. BuildRequires: lld
  113. %else
  114. BuildRequires: gcc
  115. BuildRequires: gcc-c++
  116. %endif
  117. %if %{without bundled_libgit2}
  118. BuildRequires: libgit2-devel
  119. %endif
  120. %if %{without bundled_libssh2}
  121. BuildRequires: libssh2-devel
  122. %endif
  123. BuildRequires: ncurses-devel
  124. BuildRequires: openssl-devel
  125. BuildRequires: zlib-devel
  126. BuildRequires: python3
  127. BuildRequires: python3-rpm-macros
  128. BuildRequires: curl
  129. BuildRequires: curl-devel
  130. BuildRequires: xz-devel
  131. %if %{with bundled_llvm}
  132. BuildRequires: cmake
  133. BuildRequires: git
  134. Provides: bundled(llvm) = 6.0
  135. %else
  136. %if %defined llvm
  137. %global llvm_root %{_libdir}/%{llvm}
  138. %else
  139. %global llvm llvm
  140. %global llvm_root %{_prefix}
  141. %endif
  142. BuildRequires: %{llvm}-devel >= 7.0.0
  143. %if %{with llvm_static}
  144. BuildRequires: %{llvm}-static
  145. BuildRequires: libffi-devel
  146. %else
  147. # Make sure llvm-config doesn't see it.
  148. Requires: %{llvm}%{llvm_major}-libs
  149. BuildConflicts: %{llvm}-static
  150. %endif
  151. %endif
  152. # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
  153. BuildRequires: procps
  154. # debuginfo-gdb tests need gdb
  155. BuildRequires: gdb
  156. # TODO: work on unbundling these!
  157. Provides: bundled(jquery) = 2.1.4
  158. Provides: bundled(miniz) = 1.14
  159. # Virtual provides for folks who attempt "dnf install rustc"
  160. Provides: rustc = %{version}-%{release}
  161. Provides: rustc%{?_isa} = %{version}-%{release}
  162. # Always require our exact standard library
  163. Requires: %{name}-std-static%{?_isa} = %{version}-%{release}
  164. # The C compiler is needed at runtime just for linking. Someday rustc might
  165. # invoke the linker directly, and then we'll only need binutils.
  166. # https://github.com/rust-lang/rust/issues/11937
  167. Requires: /usr/bin/cc
  168. # ALL Rust libraries are private, because they don't keep an ABI.
  169. %global _privatelibs lib.*-[[:xdigit:]]*[.]so.*
  170. %global __provides_exclude ^(%{_privatelibs})$
  171. %global __requires_exclude ^(%{_privatelibs})$
  172. %global __provides_exclude_from ^%{_docdir}/.*$
  173. %global __requires_exclude_from ^%{_docdir}/.*$
  174. # While we don't want to encourage dynamic linking to Rust shared libraries, as
  175. # there's no stable ABI, we still need the unallocated metadata (.rustc) to
  176. # support custom-derive plugins like #[proc_macro_derive(Foo)]. But eu-strip is
  177. # very eager by default, so we have to limit it to -g, only debugging symbols.
  178. %if 0%{?fedora} >= 27
  179. # Newer find-debuginfo.sh supports --keep-section, which is preferable. rhbz1465997
  180. %global _find_debuginfo_opts --keep-section .rustc
  181. %else
  182. %global _find_debuginfo_opts -g
  183. %undefine _include_minidebuginfo
  184. %endif
  185. # Use hardening ldflags.
  186. %global rustflags -Clink-arg=-Wl,-z,relro,-z,now
  187. %if %{without bundled_llvm} && "%{llvm_root}" != "%{_prefix}"
  188. # https://github.com/rust-lang/rust/issues/40717
  189. %global library_path $(%{llvm_root}/bin/llvm-config --libdir)
  190. %endif
  191. %description
  192. Rust is a systems programming language that runs blazingly fast, prevents
  193. segfaults, and guarantees thread safety.
  194. This package includes the Rust compiler and documentation generator.
  195. %package std-static
  196. Summary: Standard library for Rust
  197. Group: programming
  198. %description std-static
  199. This package includes the standard libraries for building applications
  200. written in Rust.
  201. %package debugger-common
  202. Summary: Common debugger pretty printers for Rust
  203. Group: programming
  204. BuildArch: noarch
  205. %description debugger-common
  206. This package includes the common functionality for %{name}-gdb and %{name}-lldb.
  207. %package gdb
  208. Summary: GDB pretty printers for Rust
  209. Group: programming
  210. BuildArch: noarch
  211. Requires: gdb
  212. Requires: %{name}-debugger-common = %{version}-%{release}
  213. %description gdb
  214. This package includes the rust-gdb script, which allows easier debugging of Rust
  215. programs.
  216. %if %{with lldb}
  217. %package lldb
  218. Summary: LLDB pretty printers for Rust
  219. Group: programming
  220. # It could be noarch, but lldb has limited availability
  221. #BuildArch: noarch
  222. Requires: lldb
  223. Requires: python3-lldb
  224. Requires: %{name}-debugger-common = %{version}-%{release}
  225. %description lldb
  226. This package includes the rust-lldb script, which allows easier debugging of Rust
  227. programs.
  228. %endif
  229. %package doc
  230. Summary: Documentation for Rust
  231. Group: documentation
  232. # NOT BuildArch: noarch
  233. # Note, while docs are mostly noarch, some things do vary by target_arch.
  234. # Koji will fail the build in rpmdiff if two architectures build a noarch
  235. # subpackage differently, so instead we have to keep its arch.
  236. %description doc
  237. This package includes HTML documentation for the Rust programming language and
  238. its standard library.
  239. %package -n cargo
  240. Summary: Rust's package manager and build tool
  241. Version: %{cargo_version}
  242. Group: programming
  243. # For tests:
  244. BuildRequires: git
  245. # Cargo is not much use without Rust
  246. Requires: rust
  247. %description -n cargo
  248. Cargo is a tool that allows Rust projects to declare their various dependencies
  249. and ensure that you'll always get a repeatable build.
  250. %package -n cargo-doc
  251. Summary: Documentation for Cargo
  252. Version: %{cargo_version}
  253. Group: programming
  254. BuildArch: noarch
  255. # Cargo no longer builds its own documentation
  256. # https://github.com/rust-lang/cargo/pull/4904
  257. Requires: rust-doc = %{rustc_version}-%{release}
  258. %description -n cargo-doc
  259. This package includes HTML documentation for Cargo.
  260. %package -n rustfmt
  261. Summary: Tool to find and fix Rust formatting issues
  262. Version: %{rustfmt_version}
  263. Group: programming
  264. Requires: cargo
  265. Obsoletes: rustfmt-preview < 1.0.0
  266. %description -n rustfmt
  267. A tool for formatting Rust code according to style guidelines.
  268. %package -n rls
  269. Summary: Rust Language Server for IDE integration
  270. Version: %{rls_version}
  271. Group: programming
  272. Requires: rust-analysis
  273. # /usr/bin/rls is dynamically linked against internal rustc libs
  274. Requires: %{name} = %{rustc_version}-%{release}
  275. Obsoletes: rls-preview < 1.0.0
  276. %description -n rls
  277. The Rust Language Server provides a server that runs in the background,
  278. providing IDEs, editors, and other tools with information about Rust programs.
  279. It supports functionality such as 'goto definition', symbol search,
  280. reformatting, and code completion, and enables renaming and refactorings.
  281. %package -n clippy
  282. Summary: Lints to catch common mistakes and improve your Rust code
  283. Version: %{clippy_version}
  284. Group: programming
  285. License: MPLv2.0
  286. Requires: cargo
  287. # /usr/bin/clippy-driver is dynamically linked against internal rustc libs
  288. Requires: %{name} = %{rustc_version}-%{release}
  289. Obsoletes: clippy-preview < 1.0.0
  290. %description -n clippy
  291. A collection of lints to catch common mistakes and improve your Rust code.
  292. %package src
  293. Summary: Sources for the Rust standard library
  294. Group: programming
  295. BuildArch: noarch
  296. %description src
  297. This package includes source files for the Rust standard library. It may be
  298. useful as a reference for code completion tools in various editors.
  299. %package analysis
  300. Summary: Compiler analysis data for the Rust standard library
  301. Group: programming
  302. Requires: rust-std-static = %{rustc_version}-%{release}
  303. %description analysis
  304. This package contains analysis data files produced with rustc's -Zsave-analysis
  305. feature for the Rust standard library. The RLS (Rust Language Server) uses this
  306. data to provide information about the Rust standard library.
  307. %debug_package
  308. %prep
  309. %ifarch %{bootstrap_arches}
  310. %setup -q -n %{bootstrap_root} -T -b %{bootstrap_source}
  311. ./install.sh --components=cargo,rustc,rust-std-%{rust_triple} \
  312. --prefix=%{local_rust_root} --disable-ldconfig
  313. test -f '%{local_rust_root}/bin/cargo'
  314. test -f '%{local_rust_root}/bin/rustc'
  315. %endif
  316. %setup -q -n %{rustc_package}
  317. sed -i.try-py3 -e '/try python2.7/i try python3 "$@"' ./configure
  318. %if %without bundled_llvm
  319. rm -rf src/llvm-project/
  320. %endif
  321. # We never enable emscripten.
  322. rm -rf src/llvm-emscripten/
  323. # Remove other unused vendored libraries
  324. #rm -rf vendor/curl-sys/curl/
  325. rm -rf vendor/jemalloc-sys/jemalloc/
  326. rm -rf vendor/libz-sys/src/zlib/
  327. rm -rf vendor/lzma-sys/xz-*/
  328. rm -rf vendor/openssl-src/openssl/
  329. %if %{without bundled_libgit2}
  330. rm -rf vendor/libgit2-sys/libgit2/
  331. %endif
  332. %if %{without bundled_libssh2}
  333. rm -rf vendor/libssh2-sys/libssh2/
  334. %endif
  335. # This only affects the transient rust-installer, but let it use our dynamic xz-libs
  336. sed -i.lzma -e '/LZMA_API_STATIC/d' src/bootstrap/tool.rs
  337. # rename bundled license for packaging
  338. if [ -e vendor/backtrace-sys/src/libbacktrace/LICENSE ]; then
  339. cp -a vendor/backtrace-sys/src/libbacktrace/LICENSE{,-libbacktrace}
  340. fi
  341. %if %{with bundled_llvm} && 0%{?epel}
  342. mkdir -p cmake-bin
  343. ln -s /usr/bin/cmake cmake-bin/cmake
  344. %global cmake_path $PWD/cmake-bin
  345. %endif
  346. %if %{without bundled_llvm} && %{with llvm_static}
  347. # Static linking to distro LLVM needs to add -lffi
  348. # https://github.com/rust-lang/rust/issues/34486
  349. sed -i.ffi -e '$a #[link(name = "ffi")] extern {}' \
  350. src/librustc_llvm/lib.rs
  351. %endif
  352. # The configure macro will modify some autoconf-related files, which upsets
  353. # cargo when it tries to verify checksums in those files. If we just truncate
  354. # that file list, cargo won't have anything to complain about.
  355. find vendor -name .cargo-checksum.json \
  356. -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
  357. %build
  358. %if %{without bundled_libgit2}
  359. export LIBGIT2_SYS_USE_PKG_CONFIG=1
  360. %endif
  361. %if %{without bundled_libssh2}
  362. export LIBSSH2_SYS_USE_PKG_CONFIG=1
  363. %endif
  364. %{?cmake_path:export PATH=%{cmake_path}:$PATH}
  365. %{?library_path:export LIBRARY_PATH="%{library_path}"}
  366. %{?rustflags:export RUSTFLAGS="%{rustflags}"}
  367. # We're going to override --libdir when configuring to get rustlib into a
  368. # common path, but we'll fix the shared libraries during install.
  369. %global common_libdir %{_prefix}/lib
  370. %global rustlibdir %{common_libdir}/rustlib
  371. %ifarch x86_64
  372. %define enable_debuginfo --debuginfo-level=0 --debuginfo-level-std=2
  373. %else
  374. %define enable_debuginfo --debuginfo-level=0
  375. %endif
  376. %if %{with clang}
  377. export CC=clang
  378. export CXX=clang++
  379. export LDFLAGS="$LDFLAGS -fuse-ld=lld"
  380. export RUSTFLAGS="$RUSTFLAGS -C linker=clang -C link-arg=-fuse-ld=lld"
  381. %endif
  382. # workaround for https://github.com/rust-lang/rust/issues/69953
  383. # --set rust.deny-warnings=false
  384. %configure \
  385. --disable-option-checking \
  386. --libdir=%{common_libdir} \
  387. --build=%{rust_triple} --host=%{rust_triple} --target=%{rust_triple} \
  388. --enable-local-rust --local-rust-root=%{local_rust_root} \
  389. %{!?with_bundled_llvm: --llvm-root=%{llvm_root} --disable-codegen-tests \
  390. %{!?with_llvm_static: --enable-llvm-link-shared } } \
  391. --disable-rpath \
  392. %{enable_debuginfo} \
  393. --enable-extended \
  394. --enable-vendor \
  395. --enable-verbose-tests \
  396. --set rust.codegen-units-std=1 \
  397. --release-channel=%{channel} \
  398. --set rust.deny-warnings=false \
  399. %{nil}
  400. RUST_BACKTRACE=1 %{__python3} ./x.py build
  401. %{__python3} ./x.py doc
  402. %install
  403. rm -rf %{buildroot}
  404. %{?cmake_path:export PATH=%{cmake_path}:$PATH}
  405. %{?library_path:export LIBRARY_PATH="%{library_path}"}
  406. %{?rustflags:export RUSTFLAGS="%{rustflags}"}
  407. %if %{with clang}
  408. export CC=clang
  409. export CXX=clang++
  410. export RUSTFLAGS="$RUSTFLAGS -C linker=clang -C link-arg=-fuse-ld=lld"
  411. %endif
  412. DESTDIR=%{buildroot} ./x.py install
  413. #DESTDIR=%{buildroot} ./x.py install src
  414. # Make sure the shared libraries are in the proper libdir
  415. %if "%{_libdir}" != "%{common_libdir}"
  416. mkdir -p %{buildroot}%{_libdir}
  417. find %{buildroot}%{common_libdir} -maxdepth 1 -type f -name '*.so' \
  418. -exec mv -v -t %{buildroot}%{_libdir} '{}' '+'
  419. %endif
  420. # The shared libraries should be executable for debuginfo extraction.
  421. find %{buildroot}%{_libdir} -maxdepth 1 -type f -name '*.so' \
  422. -exec chmod -v +x '{}' '+'
  423. # The libdir libraries are identical to those under rustlib/. It's easier on
  424. # library loading if we keep them in libdir, but we do need them in rustlib/
  425. # to support dynamic linking for compiler plugins, so we'll symlink.
  426. (cd "%{buildroot}%{rustlibdir}/%{rust_triple}/lib" &&
  427. find ../../../../%{_lib} -maxdepth 1 -name '*.so' |
  428. while read lib; do
  429. if [ -f "${lib##*/}" ]; then
  430. # make sure they're actually identical!
  431. cmp "$lib" "${lib##*/}"
  432. ln -v -f -s -t . "$lib"
  433. fi
  434. done)
  435. # Remove installer artifacts (manifests, uninstall scripts, etc.)
  436. find %{buildroot}%{rustlibdir} -maxdepth 1 -type f -exec rm -v '{}' '+'
  437. # Remove backup files from %%configure munging
  438. find %{buildroot}%{rustlibdir} -type f -name '*.orig' -exec rm -v '{}' '+'
  439. # https://fedoraproject.org/wiki/Changes/Make_ambiguous_python_shebangs_error
  440. # We don't actually need to ship any of those python scripts in rust-src anyway.
  441. find %{buildroot}%{rustlibdir}/src -type f -name '*.py' -exec rm -v '{}' '+'
  442. # FIXME: __os_install_post will strip the rlibs
  443. # -- should we find a way to preserve debuginfo?
  444. # Remove unwanted documentation files (we already package them)
  445. # Remove unwanted documentation files (we already package them)
  446. rm -f %{buildroot}%{_docdir}/%{name}/README.md
  447. rm -f %{buildroot}%{_docdir}/%{name}/COPYRIGHT
  448. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE
  449. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-APACHE
  450. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-MIT
  451. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-THIRD-PARTY
  452. rm -f %{buildroot}%{_docdir}/%{name}/*.old
  453. # Sanitize the HTML documentation
  454. find %{buildroot}%{_docdir}/%{name}/html -empty -delete
  455. find %{buildroot}%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
  456. # Create the path for crate-devel packages
  457. mkdir -p %{buildroot}%{_datadir}/cargo/registry
  458. # Cargo no longer builds its own documentation
  459. # https://github.com/rust-lang/cargo/pull/4904
  460. mkdir -p %{buildroot}%{_docdir}/cargo
  461. ln -sT ../rust/html/cargo/ %{buildroot}%{_docdir}/cargo/html
  462. %if %{without lldb}
  463. rm -f %{buildroot}%{_bindir}/rust-lldb
  464. rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
  465. %endif
  466. %if %{with bundled_llvm}
  467. rm -rf %{buildroot}/home
  468. %endif
  469. %check
  470. %if %{with test}
  471. %{?cmake_path:export PATH=%{cmake_path}:$PATH}
  472. %{?library_path:export LIBRARY_PATH="%{library_path}"}
  473. %{?rustflags:export RUSTFLAGS="%{rustflags}"}
  474. %if %{with clang}
  475. export CC=clang
  476. export CXX=clang++
  477. export LD=ld.lld
  478. export RUSTFLAGS="$RUSTFLAGS -C linker=ld.lld -C link-arg=-fuse-ld=lld"
  479. %endif
  480. # The results are not stable on koji, so mask errors and just log it.
  481. %{__python3} ./x.py test --no-fail-fast || :
  482. %{__python3} ./x.py test --no-fail-fast cargo || :
  483. %{__python3} ./x.py test --no-fail-fast clippy || :
  484. %{__python3} ./x.py test --no-fail-fast rls || :
  485. %{__python3} ./x.py test --no-fail-fast rustfmt || :
  486. %endif
  487. %post -p /sbin/ldconfig
  488. %postun -p /sbin/ldconfig
  489. %files
  490. %license COPYRIGHT LICENSE-APACHE LICENSE-MIT
  491. #license src/libbacktrace/LICENSE-libbacktrace
  492. %doc README.md
  493. %{_bindir}/rustc
  494. %{_bindir}/rustdoc
  495. %{_libdir}/*.so
  496. %{_mandir}/man1/rustc.1*
  497. %{_mandir}/man1/rustdoc.1*
  498. %dir %{rustlibdir}
  499. %dir %{rustlibdir}/%{rust_triple}
  500. %dir %{rustlibdir}/%{rust_triple}/lib
  501. %{rustlibdir}/%{rust_triple}/lib/*.so
  502. %exclude %{_bindir}/*miri
  503. %files std-static
  504. %dir %{rustlibdir}
  505. %dir %{rustlibdir}/%{rust_triple}
  506. %dir %{rustlibdir}/%{rust_triple}/lib
  507. %{rustlibdir}/%{rust_triple}/lib/*.rlib
  508. %files debugger-common
  509. %dir %{rustlibdir}
  510. %dir %{rustlibdir}/etc
  511. %{rustlibdir}/etc/rust_types.py*
  512. %files gdb
  513. %{_bindir}/rust-gdb
  514. %{rustlibdir}/etc/gdb_*.py*
  515. %exclude %{_bindir}/rust-gdbgui
  516. %if %with lldb
  517. %files lldb
  518. %{_bindir}/rust-lldb
  519. %{rustlibdir}/etc/lldb_*.py*
  520. %endif
  521. %files doc
  522. %docdir %{_docdir}/%{name}
  523. %dir %{_docdir}/%{name}
  524. %dir %{_docdir}/%{name}/html
  525. %{_docdir}/%{name}/html/*/
  526. %{_docdir}/%{name}/html/*.html
  527. %{_docdir}/%{name}/html/*.css
  528. %{_docdir}/%{name}/html/*.ico
  529. %{_docdir}/%{name}/html/*.js
  530. %{_docdir}/%{name}/html/*.png
  531. %{_docdir}/%{name}/html/*.svg
  532. %{_docdir}/%{name}/html/*.woff
  533. %license %{_docdir}/%{name}/html/*.txt
  534. %license %{_docdir}/%{name}/html/*.md
  535. %files -n cargo
  536. %license src/tools/cargo/LICENSE-APACHE src/tools/cargo/LICENSE-MIT src/tools/cargo/LICENSE-THIRD-PARTY
  537. %doc src/tools/cargo/README.md
  538. %{_bindir}/cargo
  539. %{_mandir}/man1/cargo*.1*
  540. %dir %{_sysconfdir}/bash_completion.d
  541. %{_sysconfdir}/bash_completion.d/cargo
  542. %dir %{_datadir}/zsh
  543. %dir %{_datadir}/zsh/site-functions
  544. %{_datadir}/zsh/site-functions/_cargo
  545. %dir %{_datadir}/cargo
  546. %dir %{_datadir}/cargo/registry
  547. %files -n cargo-doc
  548. %docdir %{_docdir}/cargo
  549. %dir %{_docdir}/cargo
  550. %{_docdir}/cargo/html
  551. %files -n rustfmt
  552. %{_bindir}/rustfmt
  553. %{_bindir}/cargo-fmt
  554. %doc src/tools/rustfmt/{README,CHANGELOG,Configurations}.md
  555. %license src/tools/rustfmt/LICENSE-{APACHE,MIT}
  556. %files -n rls
  557. %{_bindir}/rls
  558. %doc src/tools/rls/{README.md,COPYRIGHT,debugging.md}
  559. %license src/tools/rls/LICENSE-{APACHE,MIT}
  560. %files -n clippy
  561. %{_bindir}/cargo-clippy
  562. %{_bindir}/clippy-driver
  563. %doc src/tools/clippy/{README.md,CHANGELOG.md}
  564. %license src/tools/clippy/LICENSE*
  565. %files src
  566. %dir %{rustlibdir}
  567. %{rustlibdir}/src
  568. %files analysis
  569. %{_bindir}/rust-analyzer
  570. %{rustlibdir}/%{rust_triple}/analysis/
  571. %changelog
  572. * Thu Sep 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.46.0-1
  573. - new upstream release.
  574. * Thu Mar 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.42.0-1
  575. - new upstream release.
  576. - separated debuginfo.
  577. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.40.0-1
  578. - new upstream release.
  579. * Sat Sep 28 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.38.0-1
  580. - new upstream release.
  581. - erased "-preview" from the name of subpackages.
  582. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.30.1-1
  583. - new upstream release.
  584. - dropped Patch1.
  585. - added subpackages cargo, cargo-doc, rustformat-preview, rls-preview, clippy-preview and rust-analysis.
  586. * Fri Jan 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.23.0-1
  587. - Update to 1.23.0 (stable).
  588. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.23.0-0.beta1
  589. - initial build for Vine Linux.
  590. - Update to 1.23.0-beta.
  591. - built a bootstrap rpm.
  592. * Thu Nov 23 2017 Josh Stone <jistone@redhat.com> - 1.22.1-1
  593. - Update to 1.22.1.
  594. * Thu Oct 12 2017 Josh Stone <jistone@redhat.com> - 1.21.0-1
  595. - Update to 1.21.0.
  596. * Mon Sep 11 2017 Josh Stone <jistone@redhat.com> - 1.20.0-2
  597. - ABI fixes for ppc64 and s390x.
  598. * Thu Aug 31 2017 Josh Stone <jistone@redhat.com> - 1.20.0-1
  599. - Update to 1.20.0.
  600. - Add a rust-src subpackage.
  601. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.0-4
  602. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  603. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.0-3
  604. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  605. * Mon Jul 24 2017 Josh Stone <jistone@redhat.com> - 1.19.0-2
  606. - Use find-debuginfo.sh --keep-section .rustc
  607. * Thu Jul 20 2017 Josh Stone <jistone@redhat.com> - 1.19.0-1
  608. - Update to 1.19.0.
  609. * Thu Jun 08 2017 Josh Stone <jistone@redhat.com> - 1.18.0-1
  610. - Update to 1.18.0.
  611. * Mon May 08 2017 Josh Stone <jistone@redhat.com> - 1.17.0-2
  612. - Move shared libraries back to libdir and symlink in rustlib
  613. * Thu Apr 27 2017 Josh Stone <jistone@redhat.com> - 1.17.0-1
  614. - Update to 1.17.0.
  615. * Mon Mar 20 2017 Josh Stone <jistone@redhat.com> - 1.16.0-3
  616. - Make rust-lldb arch-specific to deal with lldb deps
  617. * Fri Mar 17 2017 Josh Stone <jistone@redhat.com> - 1.16.0-2
  618. - Limit rust-lldb arches
  619. * Thu Mar 16 2017 Josh Stone <jistone@redhat.com> - 1.16.0-1
  620. - Update to 1.16.0.
  621. - Use rustbuild instead of the old makefiles.
  622. - Update bootstrapping to include rust-std and cargo.
  623. - Add a rust-lldb subpackage.
  624. * Thu Feb 09 2017 Josh Stone <jistone@redhat.com> - 1.15.1-1
  625. - Update to 1.15.1.
  626. - Require rust-rpm-macros for new crate packaging.
  627. - Keep shared libraries under rustlib/, only debug-stripped.
  628. - Merge and clean up conditionals for epel7.
  629. * Fri Dec 23 2016 Josh Stone <jistone@redhat.com> - 1.14.0-2
  630. - Rebuild without bootstrap binaries.
  631. * Thu Dec 22 2016 Josh Stone <jistone@redhat.com> - 1.14.0-1
  632. - Update to 1.14.0.
  633. - Rewrite bootstrap logic to target specific arches.
  634. - Bootstrap ppc64, ppc64le, s390x. (thanks to Sinny Kumari for testing!)
  635. * Thu Nov 10 2016 Josh Stone <jistone@redhat.com> - 1.13.0-1
  636. - Update to 1.13.0.
  637. - Use hardening flags for linking.
  638. - Split the standard library into its own package
  639. - Centralize rustlib/ under /usr/lib/ for multilib integration.
  640. * Thu Oct 20 2016 Josh Stone <jistone@redhat.com> - 1.12.1-1
  641. - Update to 1.12.1.
  642. * Fri Oct 14 2016 Josh Stone <jistone@redhat.com> - 1.12.0-7
  643. - Rebuild with LLVM 3.9.
  644. - Add ncurses-devel for llvm-config's -ltinfo.
  645. * Thu Oct 13 2016 Josh Stone <jistone@redhat.com> - 1.12.0-6
  646. - Rebuild with llvm-static, preparing for 3.9
  647. * Fri Oct 07 2016 Josh Stone <jistone@redhat.com> - 1.12.0-5
  648. - Rebuild with fixed eu-strip (rhbz1380961)
  649. * Fri Oct 07 2016 Josh Stone <jistone@redhat.com> - 1.12.0-4
  650. - Rebuild without bootstrap binaries.
  651. * Thu Oct 06 2016 Josh Stone <jistone@redhat.com> - 1.12.0-3
  652. - Bootstrap aarch64.
  653. - Use jemalloc's MALLOC_CONF to work around #36944.
  654. - Apply pr36933 to really disable armv7hl NEON.
  655. * Sat Oct 01 2016 Josh Stone <jistone@redhat.com> - 1.12.0-2
  656. - Protect .rustc from rpm stripping.
  657. * Fri Sep 30 2016 Josh Stone <jistone@redhat.com> - 1.12.0-1
  658. - Update to 1.12.0.
  659. - Always use --local-rust-root, even for bootstrap binaries.
  660. - Remove the rebuild conditional - the build system now figures it out.
  661. - Let minidebuginfo do its thing, since metadata is no longer a note.
  662. - Let rust build its own compiler-rt builtins again.
  663. * Sat Sep 03 2016 Josh Stone <jistone@redhat.com> - 1.11.0-3
  664. - Rebuild without bootstrap binaries.
  665. * Fri Sep 02 2016 Josh Stone <jistone@redhat.com> - 1.11.0-2
  666. - Bootstrap armv7hl, with backported no-neon patch.
  667. * Wed Aug 24 2016 Josh Stone <jistone@redhat.com> - 1.11.0-1
  668. - Update to 1.11.0.
  669. - Drop the backported patches.
  670. - Patch get-stage0.py to trust existing bootstrap binaries.
  671. - Use libclang_rt.builtins from compiler-rt, dodging llvm-static issues.
  672. - Use --local-rust-root to make sure the right bootstrap is used.
  673. * Sat Aug 13 2016 Josh Stone <jistone@redhat.com> 1.10.0-4
  674. - Rebuild without bootstrap binaries.
  675. * Fri Aug 12 2016 Josh Stone <jistone@redhat.com> - 1.10.0-3
  676. - Initial import into Fedora (#1356907), bootstrapped
  677. - Format license text as suggested in review.
  678. - Note how the tests already run in parallel.
  679. - Undefine _include_minidebuginfo, because it duplicates ".note.rustc".
  680. - Don't let checks fail the whole build.
  681. - Note that -doc can't be noarch, as rpmdiff doesn't allow variations.
  682. * Tue Jul 26 2016 Josh Stone <jistone@redhat.com> - 1.10.0-2
  683. - Update -doc directory ownership, and mark its licenses.
  684. - Package and declare licenses for libbacktrace and hoedown.
  685. - Set bootstrap_base as a global.
  686. - Explicitly require python2.
  687. * Thu Jul 14 2016 Josh Stone <jistone@fedoraproject.org> - 1.10.0-1
  688. - Initial package, bootstrapped