libjpeg-turbo-vl.spec 8.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A MMX/SSE2/SIMD accelerated library for manipulating JPEG image files
  3. Summary(ja): MMX/SSE2/SIMD でアクセラレーションされた libjpeg ライブラリ
  4. Name: libjpeg-turbo
  5. Version: 2.0.5
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. License: IJG
  9. URL: http://sourceforge.net/projects/libjpeg-turbo
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  13. Patch0: libjpeg-turbo-cmake.patch
  14. Patch1: libjpeg-turbo-CET.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: cmake
  17. %ifarch %{ix86} x86_64
  18. BuildRequires: nasm
  19. %endif
  20. Obsoletes: libjpeg < 6b-50vl6
  21. Provides: libjpeg = 6b-50vl6
  22. %description
  23. The libjpeg-turbo package contains a library of functions for manipulating
  24. JPEG images
  25. %package devel
  26. Summary: Headers for the libjpeg-turbo library
  27. Summary(ja): libjpeg-turbo ライブラリのヘッダファイル
  28. Group: programming
  29. Obsoletes: libjpeg-devel < 6b-50vl6
  30. Obsoletes: libjpeg-static < 6b-50vl6
  31. Provides: libjpeg-devel = 6b-50vl6
  32. Requires: libjpeg-turbo = %{version}-%{release}
  33. %description devel
  34. This package contains header files necessary for developing programs which
  35. will manipulate JPEG files using the libjpeg-turbo library
  36. %package utils
  37. Summary: Utilities for manipulating JPEG images
  38. Summary(ja): JPEG イメージを操作するためのユーティリティ
  39. Group: graphics
  40. Requires: libjpeg-turbo = %{version}-%{release}
  41. %description utils
  42. The libjpeg-turbo-utils package contains simple client programs for
  43. accessing the libjpeg functions. It contains cjpeg, djpeg, jpegtran,
  44. rdjpgcom and wrjpgcom. Cjpeg compresses an image file into JPEG format.
  45. Djpeg decompresses a JPEG file into a regular image file. Jpegtran
  46. can perform various useful transformations on JPEG files. Rdjpgcom
  47. displays any text comments included in a JPEG file. Wrjpgcom inserts
  48. text comments into a JPEG file.
  49. ## to build compat32 for x86_64 architecture support
  50. %package -n compat32-%{name}
  51. Summary: A MMX/SSE2 accelerated library for manipulating JPEG image files
  52. Summary(ja): MMX/SSE2 でアクセラレーションされた libjpeg ライブラリ
  53. Group: system
  54. Obsoletes: compat32-libjpeg < 6b-50vl6
  55. Provides: compat32-libjpeg = 6b-50vl6
  56. %description -n compat32-%{name}
  57. The libjpeg-turbo package contains a library of functions for manipulating
  58. JPEG images
  59. %package -n compat32-%{name}-devel
  60. Summary: Headers for the libjpeg-turbo library
  61. Summary(ja): libjpeg-turbo ライブラリのヘッダファイル
  62. Group: programming
  63. Obsoletes: compat32-libjpeg-devel < 6b-50vl6
  64. Provides: compat32-libjpeg-devel = 6b-50vl6
  65. Requires: libjpeg-turbo = %{version}-%{release}
  66. %description -n compat32-%{name}-devel
  67. This package contains header files necessary for developing programs which
  68. will manipulate JPEG files using the libjpeg-turbo library
  69. %debug_package
  70. %prep
  71. %setup -q
  72. %patch0 -p1
  73. %patch1 -p1
  74. %build
  75. %ifarch %{ix86} x86_64
  76. export LDFLAGS="$RPM_LD_FLAGS -Wl,-z,ibt -Wl,-z,shstk"
  77. %endif
  78. mkdir jpeg6
  79. pushd jpeg6
  80. %{cmake} \
  81. -DCMAKE_SKIP_RPATH:BOOL=YES \
  82. -DCMAKE_SKIP_INSTALL_RPATH:BOOL=YES \
  83. -DENABLE_STATIC:BOOL=NO \
  84. ..
  85. make %{?_smp_mflags} V=1
  86. popd
  87. mkdir jpeg8
  88. pushd jpeg8
  89. %{cmake} \
  90. -DWITH_JPEG8=YES \
  91. -DCMAKE_SKIP_RPATH:BOOL=YES \
  92. -DCMAKE_SKIP_INSTALL_RPATH:BOOL=YES \
  93. -DENABLE_STATIC:BOOL=NO \
  94. ..
  95. make %{?_smp_mflags} V=1
  96. popd
  97. # Fix perms
  98. chmod -x README.md
  99. %install
  100. rm -rf %{buildroot}
  101. pushd jpeg6
  102. make install DESTDIR=%{buildroot}
  103. popd
  104. rm -rf %{buildroot}%{_mandir}/*
  105. rm -f %{buildroot}%{_includedir}/*
  106. rm -f %{buildroot}%{_bindir}/*
  107. rm -f %{buildroot}%{_libdir}/pkgconfig/*
  108. rm -f %{buildroot}%{_libdir}/lib*.so
  109. pushd jpeg8
  110. make install DESTDIR=%{buildroot}
  111. popd
  112. # Remove unwanted files
  113. rm -f %{buildroot}/%{_libdir}/lib{,turbo}jpeg.la
  114. %check
  115. pushd jpeg6
  116. LD_LIBRARY_PATH=%{buildroot}%{_libdir} make test %{?_smp_mflags}
  117. popd
  118. pushd jpeg8
  119. LD_LIBRARY_PATH=%{buildroot}%{_libdir} make test %{?_smp_mflags}
  120. popd
  121. %clean
  122. rm -rf %{buildroot}
  123. %post -p /sbin/ldconfig
  124. %postun -p /sbin/ldconfig
  125. %post -n compat32-%{name} -p /sbin/ldconfig
  126. %postun -n compat32-%{name} -p /sbin/ldconfig
  127. %files
  128. %defattr(-,root,root,-)
  129. %license LICENSE.md
  130. %doc README.md README.ijg ChangeLog.md
  131. %{_libdir}/libjpeg.so.*
  132. %{_libdir}/libturbojpeg.so.*
  133. %files devel
  134. %defattr(-,root,root,-)
  135. %doc coderules.txt jconfig.txt libjpeg.txt structure.txt example.c
  136. %{_includedir}/jconfig.h
  137. %{_includedir}/jerror.h
  138. %{_includedir}/jmorecfg.h
  139. %{_includedir}/jpegint.h
  140. %{_includedir}/jpeglib.h
  141. %{_includedir}/turbojpeg.h
  142. %{_libdir}/libjpeg.so
  143. %{_libdir}/libturbojpeg.so
  144. %{_libdir}/pkgconfig/libjpeg.pc
  145. %{_libdir}/pkgconfig/libturbojpeg.pc
  146. %files utils
  147. %defattr(-,root,root,-)
  148. %doc usage.txt wizard.txt
  149. %{_bindir}/cjpeg
  150. %{_bindir}/djpeg
  151. %{_bindir}/jpegtran
  152. %{_bindir}/rdjpgcom
  153. %{_bindir}/wrjpgcom
  154. %{_mandir}/man1/cjpeg.1*
  155. %{_mandir}/man1/djpeg.1*
  156. %{_mandir}/man1/jpegtran.1*
  157. %{_mandir}/man1/rdjpgcom.1*
  158. %{_mandir}/man1/wrjpgcom.1*
  159. ## to build compat32 for x86_64 architecture support
  160. %if %{build_compat32}
  161. %files -n compat32-%{name}
  162. %defattr(-,root,root)
  163. %{_libdir}/libjpeg.so.*
  164. %{_libdir}/libturbojpeg.so.*
  165. %files -n compat32-%{name}-devel
  166. %defattr(-,root,root)
  167. %{_libdir}/*.so
  168. %endif
  169. %changelog
  170. * Wed Sep 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.5-1
  171. - new upstream release.
  172. - dropped Patch1000: fixed in upstream.
  173. * Mon Jun 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-2
  174. - added Patch1000 to fix CVE-2020-13790.
  175. * Mon Feb 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-1
  176. - new upstream release.
  177. * Sat Oct 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.3-2
  178. - built both of libjpeg.so.62 and libjpeg.so.8.
  179. * Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.3-1
  180. - new upstream release.
  181. - dropped all patches.
  182. - imported Patch0 and 1 from rawhide.
  183. * Tue Dec 19 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.5.3-1
  184. - update to 1.5.3
  185. - update Patch0,doc
  186. * Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  187. - update to 1.4.2
  188. - update Patch0
  189. * Sun Sep 07 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.3.1-1
  190. - update to 1.3.1
  191. - ship turbojpeg library and headers
  192. * Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-2
  193. - rebuild with VineSeed environment
  194. * Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  195. - new upstream release
  196. * Tue Mar 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
  197. - new upstream release
  198. * Tue Sep 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  199. - initial build for Vine Linux
  200. * Wed Aug 04 2010 Adam Tkac <atkac redhat com> 1.0.0-3
  201. - fix huffman decoder to handle broken JPEGs well (#617469)
  202. * Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-2
  203. - add libjpeg-devel%%{_isa} provides to -devel subpkg to satisfy imlib-devel
  204. deps
  205. * Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-1
  206. - update to 1.0.0
  207. - patches merged
  208. - libjpeg-turbo-programs.patch
  209. - libjpeg-turbo-nosimd.patch
  210. - add libjpeg provides to the main package to workaround problems with broken
  211. java-1.6.0-openjdk package
  212. * Fri Jul 02 2010 Adam Tkac <atkac redhat com> 0.0.93-13
  213. - remove libjpeg provides from -utils subpkg
  214. * Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-12
  215. - move Obsoletes: libjpeg to main pkg
  216. * Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-11
  217. - -utils: Requires: %%name ...
  218. * Wed Jun 30 2010 Adam Tkac <atkac redhat com> 0.0.93-10
  219. - add Provides = libjpeg to -utils subpackage
  220. * Mon Jun 28 2010 Adam Tkac <atkac redhat com> 0.0.93-9
  221. - merge review related fixes (#600243)
  222. * Wed Jun 16 2010 Adam Tkac <atkac redhat com> 0.0.93-8
  223. - merge review related fixes (#600243)
  224. * Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-7
  225. - obsolete -static libjpeg subpackage (#600243)
  226. * Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-6
  227. - improve package description a little (#600243)
  228. - include example.c as %%doc in the -devel subpackage
  229. * Fri Jun 11 2010 Adam Tkac <atkac redhat com> 0.0.93-5
  230. - don't use "fc12" disttag in obsoletes/provides (#600243)
  231. * Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-4
  232. - fix compilation on platforms without MMX/SSE (#600243)
  233. * Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-3
  234. - package review related fixes (#600243)
  235. * Wed Jun 09 2010 Adam Tkac <atkac redhat com> 0.0.93-2
  236. - package review related fixes (#600243)
  237. * Fri Jun 04 2010 Adam Tkac <atkac redhat com> 0.0.93-1
  238. - initial package