jasper-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: jasper
  3. Summary: implementation of the JPEG-2000 standard, Part 1
  4. Version: 2.0.19
  5. Release: 1%{?_dist_release}
  6. Group: graphics
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: Modified BSD (see LICENSE)
  10. URL: https://www.ece.uvic.ca/~frodo/jasper/
  11. Source: https://github.com/mdadams/jasper/archive/version-%{version}.tar.gz#/%{name}-version-%{version}.tar.gz
  12. # skip hard-coded prefix/lib rpath
  13. Patch1: jasper-2.0.14-rpath.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: autoconf automake libtool
  16. BuildRequires: freeglut-devel
  17. BuildRequires: libGLU-devel
  18. BuildRequires: libjpeg-devel
  19. BuildRequires: pkgconfig
  20. BuildRequires: cmake
  21. Requires: %{name}-libs = %{version}-%{release}
  22. %description
  23. JasPer is a collection of software (i.e., a library and application
  24. programs) for the coding and manipulation of images. This software
  25. can handle image data in a variety of formats. One such format
  26. supported by JasPer is the JPEG-2000 format defined in ISO/IEC 15444-1.
  27. %package devel
  28. Summary: Include Files and Documentation for jasper
  29. Group: programming
  30. Requires: %{name}-libs = %{version}-%{release}
  31. Requires: libjpeg-devel
  32. %description devel
  33. This package contains libjasper, a library implementing the JPEG-2000
  34. image compression standard Part 1.
  35. %package libs
  36. Summary: Runtime libraries for %{name}
  37. Group: system
  38. %description libs
  39. This package contains runtime libraries for JasPer.
  40. # compat32
  41. %package -n compat32-%{name}-devel
  42. Summary: Include Files and Documentation for jasper
  43. Group: programming
  44. Requires: %{name}-libs = %{version}-%{release}
  45. Requires: compat32-libjpeg-devel
  46. %description -n compat32-%{name}-devel
  47. This package contains libjasper, a library implementing the JPEG-2000
  48. image compression standard Part 1.
  49. %package -n compat32-%{name}-libs
  50. Summary: Runtime libraries for %{name}
  51. Group: system
  52. %description -n compat32-%{name}-libs
  53. This package contains runtime libraries for JasPer.
  54. %prep
  55. %setup -q -n %{name}-version-%{version}
  56. %patch1 -p1 -b .rpath
  57. %build
  58. mkdir -p builder
  59. pushd builder
  60. %cmake -DJAS_ENABLE_DOC:BOOL=OFF ..
  61. popd
  62. %make_build -C builder
  63. %install
  64. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  65. make install/fast DESTDIR=%{buildroot} -C builder
  66. # Unpackaged files
  67. rm -f doc/README
  68. rm -f %{buildroot}%{_libdir}/lib*.la
  69. rm -rf %{buildroot}%{_docdir}/JasPer
  70. %check
  71. make test -C builder
  72. %clean
  73. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  74. %post libs -p /sbin/ldconfig
  75. %postun libs -p /sbin/ldconfig
  76. %post -n compat32-%{name}-libs -p /sbin/ldconfig
  77. %postun -n compat32-%{name}-libs -p /sbin/ldconfig
  78. %files
  79. %defattr(-,root,root)
  80. %{!?_licensedir:%global license %%doc}
  81. %{_bindir}/*
  82. %{_mandir}/man1/*
  83. %files libs
  84. %license COPYRIGHT LICENSE
  85. %doc INSTALL README doc/README doc/jasper.pdf doc/jpeg2000.pdf
  86. %defattr(-,root,root)
  87. %{_libdir}/libjasper*.so.*
  88. %files devel
  89. %defattr(-,root,root)
  90. %{_includedir}/jasper
  91. %{_libdir}/libjasper*.so
  92. %{_libdir}/pkgconfig/jasper.pc
  93. # compat32
  94. %if %{build_compat32}
  95. %files -n compat32-%{name}-libs
  96. %defattr(-,root,root)
  97. %{_libdir}/libjasper*.so.*
  98. %files -n compat32-%{name}-devel
  99. %defattr(-,root,root)
  100. %{_libdir}/libjasper*.so
  101. %{_libdir}/pkgconfig/jasper.pc
  102. %endif
  103. %changelog
  104. * Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.19-1
  105. - new upstream release.
  106. * Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.16-1
  107. - new upstream release.
  108. - dropped Patch1: fixed in upstream.
  109. - imported Patch1 from rawhide.
  110. * Mon Mar 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.12-1
  111. - new upstream release.
  112. - dropped all patches.
  113. - imported patch1 from rawhide.
  114. * Tue Jul 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-11
  115. - added Patch1000-1002 to fix CVE-2016-{1577,2089,2116}.
  116. * Wed Dec 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-10
  117. - imported all patches from RawHide.
  118. * Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.900.1-9
  119. - rebuild with libpng-1.6.12
  120. * Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-8
  121. - rebuilt with current VineSeed
  122. * Sat May 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.900.1-7
  123. - added compat32 subpackage for x86_64 arch support.
  124. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.900.1-6
  125. - splited out runtime library to sub package
  126. - enable opengl again, add BuildRequires: freeglut-devel
  127. * Wed Jun 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-5
  128. - remove .la
  129. - add --disable-static to configure option
  130. * Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl4
  131. - added Patch0 from VinePlus/4.0
  132. * Thu Jun 21 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.900.1-0vl2.1
  133. - add patch100 for fix CVE-2007-2721
  134. - add Vendor/Distributin Tag
  135. * Fri May 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-0vl3
  136. - remove BuildPrereq: freeglut-devel and Requires freeglut
  137. - add --disable-opengl to configure option
  138. * Fri Mar 16 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.900.1-0vl2
  139. - add BuildPreReq: unzip (used in the %%pre section)
  140. * Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl1
  141. - new upstream release
  142. * Tue Jan 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.0-0vl1
  143. - new upstream release
  144. - changed Group to System Environment/Libraries
  145. - added --mandir=%{_mandir}
  146. - added %post and %postun section
  147. * Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.701.0-0vl3
  148. - added --libdir=%{_libdir} configure option
  149. * Tue Sep 5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.701.0-0vl2
  150. - build with freeglut
  151. - change BuildPrereq and Requires
  152. * Tue Dec 14 2004 Satoshi MACHINO <machino@vinelinux.org> 1.701.0-0vl1
  153. - new upstream version (jasper-1.701.0)
  154. * Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl2
  155. - rebuild for VineSeedPlus
  156. * Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl1
  157. - source upgrade
  158. - change spec to build for VineLinux
  159. * Fri Oct 25 2002 Alexander D. Karaivanov <adk@medical-insight.com>
  160. - spec file created