exiv2-vl.spec 6.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222
  1. %define _unpackaged_files_terminate_build 1
  2. Name: exiv2
  3. Summary: Exif and IPTC metadata manipulation library
  4. Summary(ja): Exif, IPTC メタデータ操作ライブラリ
  5. Version: 0.27.3
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPLv2
  11. URL: https://www.exiv2.org/
  12. Source0: https://www.exiv2.org/builds/exiv2-%{version}-Source.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: cmake
  15. BuildRequires: expat-devel
  16. BuildRequires: gettext
  17. BuildRequires: pkgconfig
  18. BuildRequires: curl-devel
  19. BuildRequires: libssh-devel
  20. BuildRequires: zlib-devel
  21. Obsoletes: libexiv2 <= 0.13
  22. Provides: libexiv2 = %{version}-%{release}
  23. %description
  24. Exiv2 comprises of a C++ library and a command line utility to access image metadata. Exiv2 supports full read and write access to the Exif and Iptc metadata, Exif MakerNote support, extract and delete methods for Exif thumbnails, classes to access Ifd and so on.
  25. The command line utility allows you to:
  26. * print the Exif metadata of Jpeg images as summary info, interpreted values,
  27. or the plain data for each tag (here is a sample)
  28. * print the IPTC metadata of Jpeg images
  29. * print the Jpeg comment of Jpeg images
  30. * set, add and delete Exif and Iptc metadata of Jpeg images
  31. * adjust the Exif timestamp (that's how it all started...)
  32. * rename Exif image files according to the Exif timestamp
  33. * extract, insert and delete Exif metadata, IPTC metadata and Jpeg comments
  34. * extract, insert and delete the thumbnail image embedded in the Exif metadata
  35. %description -l ja
  36. Exiv2 は、イメージメタデータにアクセスするための C++ ライブラリと
  37. コマンドラインユーティリティにより構成されています.Exiv2 は Exif,
  38. IPTC メタデータの完全な読込み及び書込みアクセス,Exif MakerNote,
  39. Exif サムネイルを抽出/削除するためのメソッド,Ifd 等にアクセスする
  40. ためのクラス等をサポートします.
  41. コマンドラインユーティリティにより、次のようなことができます:
  42. * JPEG イメージの EXIF メタデータを各タグごとに表示する
  43. * JPEG イメージの IPTC メタデータを表示する
  44. * JPEG イメージのコメントを表示する
  45. * JPEG イメージに EXIF 情報や IPTC メタデータを設定/追加/削除する
  46. * EXIF タイムスタンプを調整する
  47. * EXIF タイムスタンプに基づいて EXIF イメージファイルをリネームする
  48. * EXIF メタデータ,IPTC メタデータ,JPEG コメントを抽出/挿入/削除する
  49. * EXIF メタデータ中のサムネイルイメージを抽出/挿入/削除する
  50. #'
  51. %package devel
  52. Summary: Header files, libraries and development documentation for exiv2
  53. Summary(ja): exiv2 の開発用ファイル
  54. Group: programming
  55. Requires: %{name} = %{version}-%{release}
  56. Obsoletes: libexiv2-devel <= 0.13
  57. Provides: libexiv2-devel = %{version}-%{release}
  58. %description devel
  59. Header files, libraries and development documentation for exiv2
  60. %description -l ja devel
  61. exiv2 用ヘッダファイル,ライブラリ,開発用ドキュメントです.
  62. %debug_package
  63. %prep
  64. %setup -q -n %{name}-%{version}-Source
  65. %build
  66. %cmake \
  67. -DEXIV2_ENABLE_NLS:BOOL=ON \
  68. -DEXIV2_BUILD_PO:BOOL=ON \
  69. -DEXIV2_BUILD_SAMPLES:BOOL=OFF \
  70. -DEXIV2_ENABLE_LIBXMP:BOOL=ON \
  71. .
  72. make %{?_smp_mflags}
  73. %install
  74. rm -rf $RPM_BUILD_ROOT
  75. make install/fast DESTDIR=%{buildroot}
  76. %find_lang exiv2 --with-man
  77. ## unpackaged files
  78. rm -fv %{buildroot}%{_libdir}/libexiv2.la
  79. rm -fv %{buildroot}%{_libdir}/libxmp.a
  80. rm -fv %{buildroot}%{_libdir}/pkgconfig//exiv2.lsm
  81. # set eXecute bit on installed lib
  82. chmod a+x $RPM_BUILD_ROOT%{_libdir}/lib*.so.*
  83. ## FIXME/TODO: patch installed exiv2-config to instead pull values from pkgconfig
  84. %clean
  85. rm -rf $RPM_BUILD_ROOT
  86. %post -p /sbin/ldconfig
  87. %postun -p /sbin/ldconfig
  88. %files -f %{name}.lang
  89. %defattr(-,root,root,-)
  90. %license COPYING*
  91. %doc README*
  92. %{_bindir}/exiv2
  93. %{_libdir}/lib*.so.*
  94. %{_mandir}/man1/*
  95. %files devel
  96. %defattr(-,root,root,-)
  97. #doc doc/index.html doc/include
  98. #{_bindir}/exiv2-config
  99. %{_includedir}/exiv2/*
  100. %{_libdir}/libexiv2.so
  101. %{_libdir}/*.a
  102. %{_libdir}/pkgconfig/exiv2.pc
  103. %dir %{_libdir}/cmake
  104. %{_libdir}/cmake/*
  105. #{_datadir}/exiv2
  106. %changelog
  107. * Sat Sep 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.27.3-1
  108. - new upstream release.
  109. * Fri Nov 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.27.2-1
  110. - new upstream release.
  111. * Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.27-1
  112. - new upstream release.
  113. - dropprd all patches.
  114. * Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.25-2
  115. - rebuilt with new toolchain.
  116. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.25-1
  117. - new upstream release
  118. * Tue Dec 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.24-1
  119. - new upstream release
  120. - add Patch3 (exiv2-0.24-visibility.patch)
  121. * Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.23-1
  122. - new upstream release
  123. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22-1
  124. - new upstream release
  125. * Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.21.1-1
  126. - new upstream release
  127. - updated Patch3
  128. * Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.19-2
  129. - rebuilt with rpm-4.8.1 for pkg-config
  130. * Wed May 5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.19-1
  131. - new upstream release
  132. - updated Patch3
  133. * Mon Oct 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.18.2-1
  134. - new upstream release
  135. - updated Japanese description
  136. * Fri May 1 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.18.1-2
  137. - add Patch3 not to use -fvisibility-inlines-hidden
  138. (this will also fix build failure on ppc)
  139. http://dev.exiv2.org/issues/show/627
  140. * Sun Apr 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.18.1-1
  141. - new upstream release
  142. * Tue Sep 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17.1-1vl5
  143. - new upstream release
  144. * Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 0.15-1vl5
  145. - applied new versioning policy, spec in utf-8
  146. * Wed Dec 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.15-0vl4
  147. - add patch100 for fix CVE-2007-6353 ("setDataArea()" Integer OF)
  148. * Sat Aug 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15-0vl3
  149. - add Obsoletes: libexiv2 <= 0.13 , libexiv2-devel <= 0.13
  150. to upgrade from 0.13-0vl[12]
  151. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.13-0vl2
  152. - rebuild with new environment/toolchain
  153. * Fri Mar 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.13-0vl1
  154. - initial build for Vine Linux
  155. * Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.15-0vl2
  156. - rebuilt for VineSeed
  157. * Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.15-0vl1
  158. - new upstream release
  159. - remove Requires: kdelibs-devel at devel package
  160. * Fri Jan 5 2007 TOSHI <vine-jp@mail.goo.ne.jp> 0.12-0vl1
  161. - build for vine 4.0
  162. * Tue Nov 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.12-1
  163. - exiv2-0.12
  164. # end of file