clisp-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187
  1. %define year 2002
  2. %define month 07
  3. %define day 25
  4. %define name clisp
  5. %define version 2.49
  6. %define release 2%{?_dist_release}
  7. %define clisp_build vine
  8. Summary: Common Lisp (ANSI CL) implementation
  9. Summary(ja): 関数型言語 Common Lisp (ANSI CL) の実装
  10. Name: clisp
  11. Version: %{version}
  12. Release: %{release}
  13. Icon: clisp.gif
  14. License: GPL
  15. Group: Development/Languages
  16. Source: ftp://ftp.gnu.org/pub/gnu/clisp/release/%{version}/%{name}-%{version}.tar.bz2
  17. Patch0: clisp-2.47-cpp.patch
  18. #Patch: %{name}-2.32-hfs.patch
  19. #Patch1: %{name}-2.27-dvi.patch
  20. URL: http://www.clisp.org/
  21. Provides: clisp, ansi-cl
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildRequires: imake
  24. BuildRequires: libsigsegv-devel
  25. BuildRequires: readline-devel
  26. BuildRequires: dbus-devel
  27. BuildRequires: diffutils
  28. BuildRequires: fcgi-devel
  29. BuildRequires: ffcall
  30. BuildRequires: gdbm-devel
  31. BuildRequires: gettext
  32. BuildRequires: gtk2-devel
  33. BuildRequires: libICE-devel
  34. BuildRequires: libSM-devel
  35. BuildRequires: libX11-devel
  36. BuildRequires: libXaw-devel
  37. BuildRequires: libXext-devel
  38. BuildRequires: libXft-devel
  39. BuildRequires: libXmu-devel
  40. BuildRequires: libXrender-devel
  41. BuildRequires: libXt-devel
  42. BuildRequires: libglade2-devel
  43. BuildRequires: pcre-devel
  44. BuildRequires: postgresql-devel
  45. BuildRequires: zlib-devel
  46. %description
  47. Common Lisp is a high-level, general-purpose, object-oriented, dynamic,
  48. functional programming language.
  49. CLISP is a Common Lisp implementation by Bruno Haible, then of Karlsruhe
  50. University, and Michael Stoll, then of Munich University, both in Germany.
  51. It supports the Lisp described in the ANSI Common Lisp standard plus many
  52. extensions.
  53. CLISP includes an interpreter, a compiler, a debugger, CLOS, MOP, a foreign
  54. language interface, i18n, regular expressions, a socket interface, and more.
  55. An X11 interface is available through CLX, Garnet and CLUE/CLIO. Command line
  56. editing is provided by readline. CLISP runs Maxima, ACL2 and many other
  57. Common Lisp packages.
  58. CLISP runs on most GNU and Unix systems (Linux, FreeBSD, NetBSD, OpenBSD,
  59. Solaris, Tru64, HP-UX, BeOS, NeXTstep, IRIX, AIX and others) and on other
  60. systems (Windows NT/2000/XP, Windows 95/98/ME) and needs only 4 MB of RAM.
  61. CLISP is Free Software and may be distributed under the terms of GNU GPL.
  62. You may distribute commercial proprietary applications compiled with CLISP,
  63. see file COPYRIGHT in the CLISP distribution.
  64. The user interface comes in English, German, French, Spanish, Dutch, Russian
  65. and Danish, and can be changed at run time.
  66. %prep
  67. %setup -q
  68. sed -i 's|http://www.lisp.org/HyperSpec/|http://www.lispworks.com/documentation/HyperSpec/|g' \
  69. doc/* src/*.d src/*.lisp
  70. %build
  71. %ifarch ppc ppc64
  72. %define opt_flags "%{optflags} -DNO_GENERATIONAL_GC -DNO_MULTIMAP_FILE -DNO_SINGLEMAP"
  73. ulimit -s unlimited
  74. %else
  75. %define opt_flags "%{optflags}"
  76. %endif
  77. ./configure --prefix=%{_prefix} \
  78. --libdir=%{_libdir} \
  79. --mandir=%{_mandir} \
  80. --docdir=%{_docdir}/clisp-%{version} \
  81. --fsstnd=redhat \
  82. --hyperspec=http://www.lispworks.com/documentation/HyperSpec/ \
  83. --with-module=bindings/glibc \
  84. --with-module=clx/new-clx \
  85. --with-module=dbus \
  86. --with-module=fastcgi \
  87. --with-module=gdbm \
  88. --with-module=gtk2 \
  89. --with-module=i18n \
  90. --with-module=pcre \
  91. --with-module=postgresql \
  92. --with-module=rawsock \
  93. --with-module=regexp \
  94. --with-module=syscalls \
  95. --with-module=wildcard \
  96. --with-module=zlib \
  97. --with-readline \
  98. --cbc \
  99. build CFLAGS=%opt_flags
  100. %install
  101. rm -rf %{buildroot}
  102. make -C build DESTDIR=%{buildroot} install
  103. rm -f %{buildroot}%{_docdir}/clisp-%{version}/doc/clisp.{dvi,1,ps}
  104. cp -p doc/mop-spec.pdf %{buildroot}%{_docdir}/clisp-%{version}/doc
  105. cp -p doc/*.png %{buildroot}%{_docdir}/clisp-%{version}/doc
  106. cp -p doc/Why-CLISP* %{buildroot}%{_docdir}/clisp-%{version}/doc
  107. cp -p doc/regexp.html %{buildroot}%{_docdir}/clisp-%{version}/doc
  108. find %{buildroot}%{_libdir} -name '*.dvi' | xargs rm -f
  109. %find_lang %{name}
  110. %find_lang %{name}low
  111. cat %{name}low.lang >> %{name}.lang
  112. ## ad-hoc fix <BTS:VineLinux:825>: '--vimdir' option is broken...
  113. %__mkdir_p %{buildroot}%{_sysconfdir}/vim
  114. %__mv %{buildroot}%{_datadir}/vim/vimfiles/after %{buildroot}%{_sysconfdir}/vim
  115. %clean
  116. rm -rf %{buildroot}
  117. %files -f %{name}.lang
  118. %defattr(-,root,root,-)
  119. %{_bindir}/%{name}
  120. %{_mandir}/man1/*
  121. %{_libdir}/%{name}-%{version}
  122. %{_datadir}/aclocal/*.m4
  123. %{_datadir}/emacs/site-lisp/*
  124. %{_sysconfdir}/vim
  125. %doc %{_docdir}/clisp-%{version}
  126. %changelog
  127. * Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.49-2
  128. - rebuild with current ffcall
  129. * Tue Apr 19 2011 IWAI, Masaharu <iwai@alib.jp> 2.49-1
  130. - new upstream release
  131. - ad-hoc fix <BTS:VineLinux:825>: but '--vimdir' option is broken...
  132. * Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 2.48-2
  133. - rebuilt with postgresql-9.0.3
  134. * Sat Mar 6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.48-1
  135. - new upstream release
  136. - built with new toolchain, libsigsegv-2.8
  137. - updated build dependencies
  138. * Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 2.43-1vl5
  139. - applied new versioning policy, spec in utf-8
  140. * Mon Nov 26 2007 Shu KONNO <owa@bg.wakwak.ne.jp> 2.43-0vl1
  141. - version up to 2.43
  142. - updated source url
  143. - changed %%{_libdir}/clisp to %%{_libdir}/clisp-%%{version}
  144. - added option "--libdir=%%{_libdir}" to configure for lib64
  145. * Sun Mar 18 2007 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 2.41-0vl1
  146. - version up to 2.41
  147. - add BuildRequires : readline-devel, gettext, libsigsegv-devel
  148. - update %%description, %%files, configure options
  149. - drop hfs patch
  150. * Tue Jan 6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.32-0vl1
  151. - version up to 2.32
  152. - rebuild with new toolchains
  153. - updated hfs patch
  154. * Sat Aug 25 2002 Yoshihiro Ota <ota@j.email.ne.jp>
  155. - version up to 2.29
  156. * Sat Mar 9 2002 Yoshihiro Ota <ota@j.email.ne.jp>
  157. - version up to 2.28
  158. - added BuildRequires : ncurses-devel and removed groff patch
  159. * Fri Jan 18 2002 Yoshihiro Ota <ota@j.email.ne.jp>
  160. - create rpm for release 2.27