gnucash-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276
  1. %define ver 2.6.6
  2. %define rel 1%{?_dist_release}
  3. %define __libtoolize /bin/true
  4. Name: gnucash
  5. Summary: GnuCash is an application to keep track of your finances.
  6. Summary(ja): 個人用財務管理アプリケーション
  7. Version: %{ver}
  8. Release: %{rel}
  9. License: GPL/LGPL/GFDL
  10. Group: Applications/Productivity
  11. URL: http://www.gnucash.org/
  12. Source: %{name}-%{version}.tar.bz2
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: aqbanking-devel >= 3.7.2
  15. BuildRequires: bzip2-devel
  16. BuildRequires: expat-devel
  17. BuildRequires: gettext
  18. BuildRequires: goffice08-devel >= 0.8
  19. BuildRequires: gtk2-devel
  20. BuildRequires: WebKit-gtk-devel
  21. BuildRequires: guile-devel
  22. BuildRequires: libofx-devel
  23. BuildRequires: libgnomeui-devel
  24. BuildRequires: libdbi-devel
  25. BuildRequires: libjpeg-devel
  26. BuildRequires: libtool-ltdl-devel
  27. BuildRequires: pcre-devel
  28. BuildRequires: popt-devel
  29. BuildRequires: swig
  30. #BuildRequires: slib
  31. BuildRequires: gwenhywfar-devel
  32. BuildRequires: desktop-file-utils
  33. BuildRequires: libdbi-dbd-pgsql
  34. BuildRequires: libdbi-dbd-mysql
  35. BuildRequires: libdbi-dbd-sqlite
  36. Requires: aqbanking
  37. Requires: perl-DateManip
  38. Requires: yelp
  39. Requires(post,postun): gtk2
  40. Requires(postun,posttrans): glib2
  41. Obsoletes: gnucash-backend-postgres
  42. Vendor: Project Vine
  43. Distribution: Vine Linux
  44. Packager: kenta, inagaki
  45. %description
  46. GnuCash is a personal finance manager. A check-book like
  47. register GUI allows you to enter and track bank accounts,
  48. stocks, income and even currency trades. The interface is
  49. designed to be simple and easy to use, but is backed with
  50. double-entry accounting principles to ensure balanced books.
  51. %description -l ja
  52. GnuCashは 個人用財務管理をするアプリケーションです.
  53. 預金, 株式, 所得そして通貨取引さえ入力し、追跡することができる
  54. グラフィカルな小切手帖です.インターフェスはシンプルかつ簡単に
  55. 使用できるようにデザインされています.
  56. %prep
  57. %setup -q
  58. %build
  59. %configure \
  60. --enable-error-on-warning=no \
  61. --disable-sql \
  62. --enable-ofx \
  63. --enable-aqbanking \
  64. --disable-static \
  65. --enable-dbi \
  66. --with-html-engine=webkit \
  67. --docdir=%{_datadir}/doc/gnucash-%{version}
  68. make LIBTOOL=%{_bindir}/libtool
  69. %configure
  70. make
  71. %install
  72. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  73. make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
  74. %find_lang %name
  75. # vfolder desktop file install stuff
  76. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/applications/
  77. desktop-file-install --vendor gnome --delete-original \
  78. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  79. --add-category X-Red-Hat-Extra \
  80. --add-category Application \
  81. --add-category Office \
  82. $RPM_BUILD_ROOT%{_datadir}/applications/gnucash.desktop
  83. echo "StartupWMClass=GnuCash" >> $RPM_BUILD_ROOT%{_datadir}/applications/gnome-gnucash.desktop
  84. rm -rf $RPM_BUILD_ROOT/%{_infodir} \
  85. $RPM_BUILD_ROOT/%{_includedir} \
  86. $RPM_BUILD_ROOT/%{_libdir}/lib*.a \
  87. $RPM_BUILD_ROOT/%{_libdir}/gnucash/lib*.a
  88. %clean
  89. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  90. %post
  91. /sbin/ldconfig
  92. touch --no-create %{_datadir}/icons/hicolor || :
  93. gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
  94. %postun
  95. if [ $1 -eq 0 ] ; then
  96. /sbin/ldconfig
  97. touch --no-create %{_datadir}/icons/hicolor || :
  98. gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
  99. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  100. fi
  101. %posttrans
  102. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  103. %files -f %{name}.lang
  104. %defattr(-,root,root,755)
  105. %config %{_sysconfdir}/%{name}
  106. %{_bindir}/*
  107. %{_libexecdir}/%{name}
  108. %{_libdir}/*
  109. %{_datadir}/appdata/%{name}.appdata.xml
  110. %{_datadir}/applications/*
  111. %{_datadir}/glib-2.0/schemas/*.xml
  112. %{_datadir}/%{name}
  113. %{_datadir}/icons/hicolor/*/apps/*
  114. %{_docdir}/%{name}
  115. %{_mandir}/man*/*
  116. %doc AUTHORS COPYING ChangeLog* DOCUMENTERS HACKING NEWS README
  117. %doc doc/README.german doc/README.francais doc/guile-hackers.txt
  118. %doc doc/README.OFX
  119. %changelog
  120. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.6-1
  121. - new upstream release
  122. - add BuildRequires: libtool-ltdl-devel
  123. * Mon Mar 9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.6.5-2
  124. - rebuilt with libofx 0.9.10
  125. - added Vendor and Distribution tag
  126. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
  127. - update to 2.6.5
  128. - remove old patches
  129. - add BuildRequires: libdbi-devel
  130. - change BuildRequires: goffice08-devel instead of goffice-devel
  131. * Tue Sep 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-3
  132. - rebuilt with new toolchain, aqbanking-4.2.4, goffice-0.8.10
  133. - added Patch1 for building with aqbanking-4.2.4
  134. - added Patch2 for building with goffice-0.8.10
  135. * Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-2
  136. - added slib to BuildRequires: and Requires:
  137. * Sat May 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-1
  138. - new upstream release
  139. * Wed Jan 14 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.8-1
  140. - new upstream release
  141. * Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.7-2
  142. - rebuild with guile-1.8.6
  143. - add BuildRequires: gwenhywfar-devel
  144. * Sun Oct 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.7-1
  145. - new upstream release
  146. - applied new versioning policy
  147. - built with aqbanking-3.7.2, gwenheyfar-3.4.1, libofx-0.9.0
  148. * Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4-0vl1
  149. - new upstream release
  150. - rebuilt with goffice-0.6.0
  151. * Tue Jan 22 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl1
  152. - new upstream release
  153. * Sun Jan 20 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.2-0vl1
  154. - new upstream release
  155. - enable HBCI (Home Banking Computer Interface)
  156. * Tue Jan 08 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl2
  157. - rebuild with libofx-0.8.3 (libofx.so.3)
  158. * Sun Dec 30 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl1
  159. - new upstream release
  160. - disable postgresql backend, as it is unmaintained upstream
  161. - added Patch0: gnucash-2.2.0-quiet.patch
  162. * Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.12-0vl1
  163. - new upstream release
  164. - remove BuildRequiers: autoconf213
  165. - update ja.po
  166. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
  167. - new upstream release
  168. - added BuildPrereq: libtool-ltdl-devel
  169. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
  170. - rebuild with new toolchains
  171. - update ja.po
  172. * Sun Nov 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl1
  173. - new upstream release
  174. * Sun Oct 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-1vl1
  175. - merged gnucash-docs-1.8.3
  176. - added patch from Redhat Rawhide 1.8.7-1
  177. - changed Group, License
  178. * Mon Oct 6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-0vl1
  179. - updated to 1.8.7
  180. - updated print.patch
  181. - overwrite prefs.scm
  182. - s/Copyright/License/
  183. * Tue May 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl1
  184. - updated to 1.8.3
  185. - added datelength.patch
  186. - separated devel packages
  187. (and ofx, hbci, backend-postgres. But default is off)
  188. * Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl3
  189. - Build against with new gal.
  190. * Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl2
  191. - Fixed printing issue.
  192. * Tue Dec 25 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl1
  193. - New upstream release.
  194. * Thu Jul 26 2001 <sagami@vinelinux.org>
  195. - 1.6.0-0vl3: fix to not to own mandir itself, use %%{find_lang}
  196. * Tue Jun 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  197. - %%make line is now commented out (bash2 complains it)
  198. (BTW, what the hell is the macro %%make anyway? I don't even know...)
  199. * Tue Jun 12 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
  200. - update to 1.6.0 (stable release version)
  201. * Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.96-0vl1
  202. - update to 1.5.96 ( pre beta for 1.6.0 )
  203. * Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl2
  204. - added japanese patch for reporting and printing (thanx tagoh-san)
  205. * Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl1
  206. - updated to 1.5.6
  207. * Thu Apr 05 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.4-1vl2
  208. - added translation messages to ja.po
  209. - enable guppi
  210. * Mon Apr 2 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.4-1vl1
  211. - upstream update
  212. - fixed broken ja.po
  213. * Wed Mar 28 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl2
  214. - fixed registor window cursor position problem(gnucash-cursor_pos.patch)
  215. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl1
  216. - initial relese package