gnome-shell-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217
  1. %define pkg_version 3.2.1
  2. %define pkg_release 2%{?_dist_release}
  3. Summary: Window management and application launching for GNOME
  4. Name: gnome-shell
  5. Version: %{pkg_version}
  6. Release: %{pkg_release}
  7. Source0: %{name}-%{version}.tar.xz
  8. Patch0: gnome-shell-3.2.1-shell_parse_argv.patch
  9. Patch1: gnome-shell-3.2.1-ja.po.patch
  10. # settings for Vine
  11. Patch101: gnome-shell-vine-settings.patch
  12. Patch102: gnome-shell-vine-customize.patch
  13. Patch103: gnome-shell-ja.po-date.patch
  14. License: GPLv2+
  15. Group: User Interface/Desktops
  16. URL: http://live.gnome.org/GnomeShell
  17. Requires(post,postun): scrollkeeper >= 0.1.4
  18. Requires(post,pre,preun): GConf2 >= 2.14
  19. Requires: mutter
  20. Requires: caribou
  21. Requires: openssl
  22. BuildRequires: gnome-common
  23. BuildRequires: libtool
  24. BuildRequires: automake
  25. BuildRequires: autoconf
  26. BuildRequires: pkgconfig
  27. BuildRequires: gtk2-devel
  28. BuildRequires: clutter-devel
  29. BuildRequires: mutter-devel
  30. BuildRequires: gjs-devel
  31. BuildRequires: gnome-desktop3-devel
  32. BuildRequires: gnome-menus-devel
  33. BuildRequires: libSM-devel
  34. BuildRequires: libffi-devel
  35. BuildRequires: GConf2-devel
  36. BuildRequires: startup-notification-devel
  37. BuildRequires: gnome-doc-utils
  38. BuildRequires: desktop-file-utils
  39. BuildRequires: libcroco-devel
  40. BuildRequires: librsvg2-devel
  41. BuildRequires: gobject-introspection-devel
  42. BuildRequires: gstreamer-devel
  43. BuildRequires: dbus-glib-devel
  44. BuildRequires: telepathy-logger-devel
  45. BuildRequires: polkit-devel
  46. BuildRequires: pulseaudio-libs-devel
  47. BuildRequires: evolution-data-server-devel
  48. BuildRequires: folks-devel
  49. BuildRequires: NetworkManager-glib-devel
  50. BuildRequires: libgudev1-devel
  51. BuildRequires: openssl
  52. BuildRequires: intltool
  53. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  54. Vendor: Project Vine
  55. Distribution: Vine Linux
  56. Packager: Takemikaduchi
  57. %description
  58. GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
  59. It provides core interface functions like switching to windows and launching
  60. applications. GNOME Shell takes advantage of the capabilities of modern graphics
  61. hardware and introduces innovative user interface concepts to provide a delightful
  62. and easy to use experience.
  63. %prep
  64. %setup -q
  65. %patch0 -p1 -b .spawn
  66. %patch1 -p1 -b .old_po1
  67. %patch101 -p1 -b .vine
  68. #%patch102 -p1 -b .vine
  69. %patch103 -p1 -b .old_po2
  70. %build
  71. libtoolize --copy --force
  72. autoreconf
  73. %configure \
  74. --disable-static \
  75. --with-ca-certificates=%{_datadir}/ssl/certs/ca-bundle.crt
  76. %{__make} %{?_smp_mflags}
  77. %install
  78. %{__rm} -rf ${RPM_BUILD_ROOT}
  79. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  80. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  81. %find_lang %{name}
  82. %clean
  83. %{__rm} -rf ${RPM_BUILD_ROOT}
  84. %post
  85. /sbin/ldconfig
  86. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  87. gconftool-2 --makefile-install-rule \
  88. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  89. > /dev/null || :
  90. touch --no-create %{_datadir}/icons/hicolor
  91. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  92. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  93. fi
  94. %pre
  95. if [ "$1" -gt 1 ]; then
  96. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  97. gconftool-2 --makefile-uninstall-rule \
  98. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  99. > /dev/null || :
  100. fi
  101. %preun
  102. if [ "$1" -eq 0 ]; then
  103. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  104. gconftool-2 --makefile-uninstall-rule \
  105. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  106. > /dev/null || :
  107. fi
  108. %postun
  109. scrollkeeper-update -q || :
  110. /sbin/ldconfig
  111. touch --no-create %{_datadir}/icons/hicolor
  112. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  113. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  114. fi
  115. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  116. %posttrans
  117. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  118. %files -f %{name}.lang
  119. %defattr(-,root,root)
  120. %doc COPYING NEWS README
  121. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas
  122. %{_bindir}/gnome-shell
  123. %{_bindir}/gnome-shell-extension-tool
  124. %{_libdir}/gnome-shell/*
  125. %{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
  126. %{_libexecdir}/gnome-shell-calendar-server
  127. %{_libexecdir}/gnome-shell-hotplug-sniffer
  128. %{_libexecdir}/gnome-shell-perf-helper
  129. %{_datadir}/applications/gnome-shell.desktop
  130. %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
  131. %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
  132. %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
  133. %{_datadir}/gnome-shell/*
  134. %{_datadir}/man/man1/*.1.gz
  135. %changelog
  136. * Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
  137. - add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
  138. - add Patch1 (gnome-shell-3.2.1-ja.po.patch)
  139. - rename Patch103 (gnome-shell-ja.po-date.patch)
  140. - drop Patch102
  141. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  142. - new upstream release
  143. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  144. - new upstream release
  145. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  146. - new upstream release
  147. - update Patch101
  148. - update Patch102
  149. - update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
  150. - add BuildRequires: libgudev1-devel, openssl
  151. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
  152. - new upstream release
  153. - add BuildRequires: folks-devel, NetworkManager-glib-devel
  154. - add Requires: caribou
  155. - remove Patch0
  156. - update Patch101
  157. - update Patch102
  158. - update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
  159. * Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
  160. - rebuild with gnome-menus-3.1.5
  161. - add Patch0 (gnome-shell-git20110821.patch)
  162. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  163. - new upstream release
  164. - add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
  165. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  166. - remove BuildRequires: xulrunner-devel
  167. - add Patch101 (gnome-shell-vine-settings.patch)
  168. - add Patch102 (gnome-shell-vine-customize.patch)
  169. - add Patch103 (gnome-shell-3.1.4-ja.po.patch)
  170. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
  171. - add Requires: mutter
  172. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
  173. - new upstream release
  174. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  175. - initial build for Vine Linux