udisks-vl.spec 6.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224
  1. %define glib2_version 2.6.0
  2. %define dbus_version 1.2
  3. %define dbus_glib_version 0.82
  4. %define polkit_version 0.92
  5. %define parted_version 2.3
  6. %define udev_version 145
  7. %define mdadm_version 2.6.7
  8. %define device_mapper_version 1.02
  9. %define libatasmart_version 0.12
  10. %define sg3_utils_version 1.27
  11. %define smp_utils_version 0.94
  12. %define lvm2_version 2.02.78
  13. Summary: Storage Management Service
  14. Name: udisks
  15. Version: 1.0.4
  16. Release: 1%{?_dist_release}
  17. License: GPLv2+
  18. Group: System Environment/Libraries
  19. URL: http://www.freedesktop.org/wiki/Software/udisks
  20. Source0: http://hal.freedesktop.org/releases/%{name}-%{version}.tar.gz
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  22. BuildRequires: glib2-devel >= %{glib2_version}
  23. BuildRequires: dbus-devel >= %{dbus_version}
  24. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  25. BuildRequires: polkit-devel >= %{polkit_version}
  26. BuildRequires: parted-devel >= %{parted_version}
  27. BuildRequires: device-mapper-devel >= %{device_mapper_version}
  28. BuildRequires: intltool
  29. BuildRequires: libatasmart-devel >= %{libatasmart_version}
  30. BuildRequires: libgudev1-devel >= %{udev_version}
  31. BuildRequires: libudev-devel >= %{udev_version}
  32. BuildRequires: sg3_utils-devel >= %{sg3_utils_version}
  33. BuildRequires: lvm2-devel >= %{lvm2_version}
  34. # needed to pull in the system bus daemon
  35. Requires: dbus >= %{dbus_version}
  36. # needed to pull in the udev daemon
  37. Requires: udev >= %{udev_version}
  38. # we need at least this version for bugfixes / features etc.
  39. Requires: libatasmart >= %{libatasmart_version}
  40. Requires: mdadm >= %{mdadm_version}
  41. # for smp_rep_manufacturer
  42. Requires: smp_utils >= %{smp_utils_version}
  43. # for mount, umount, mkswap
  44. Requires: util-linux-ng
  45. # for mkfs.ext3, mkfs.ext3, e2label
  46. Requires: e2fsprogs
  47. # for mkfs.xfs, xfs_admin
  48. Requires: xfsprogs
  49. # for mkfs.vfat
  50. Requires: dosfstools
  51. # for mlabel
  52. Requires: mtools
  53. # for mkntfs - no ntfsprogs on ppc, though
  54. %ifnarch ppc ppc64
  55. Requires: ntfsprogs
  56. %endif
  57. # for /proc/self/mountinfo, only available in 2.6.26 or higher
  58. Conflicts: kernel < 2.6.26
  59. # we need liblvm2app at least this recent since the ABI changed (sizes
  60. # reported in number of bytes instead of number of sectors) without
  61. # the sonumber changing
  62. #
  63. Requires: lvm2-libs >= %{lvm2_version}
  64. # Obsolete and Provide DeviceKit-disks - udisks provides exactly the same
  65. # ABI just with a different name and versioning-scheme
  66. #
  67. Obsoletes: DeviceKit-disks <= 009
  68. Provides: DeviceKit-disks = 010
  69. Vendor: Project Vine
  70. Distribution: Vine Linux
  71. %description
  72. udisks provides a daemon, D-Bus API and command line tools
  73. for managing disks and storage devices.
  74. %package devel
  75. Summary: D-Bus interface definitions for udisks
  76. Group: Development/Libraries
  77. Requires: %{name} = %{version}-%{release}
  78. Requires: gtk-doc
  79. # See comment above
  80. #
  81. Obsoletes: DeviceKit-disks-devel <= 009
  82. Provides: DeviceKit-disks-devel = 010
  83. %description devel
  84. D-Bus interface definitions and documentation for udisks.
  85. %prep
  86. %setup -q
  87. %build
  88. %configure \
  89. --enable-gtk-doc \
  90. --enable-lvm2
  91. make
  92. %install
  93. rm -rf $RPM_BUILD_ROOT
  94. make install DESTDIR=$RPM_BUILD_ROOT
  95. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  96. rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
  97. # for now, include a compat symlink for the command-line tool
  98. # and man page
  99. ln -s udisks $RPM_BUILD_ROOT%{_bindir}/devkit-disks
  100. ln -s udisks.1 $RPM_BUILD_ROOT%{_datadir}/man/man1/devkit-disks.1
  101. # TODO: should be fixed upstream
  102. chmod 0644 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/udisks-bash-completion.sh
  103. %find_lang %{name}
  104. %clean
  105. rm -rf $RPM_BUILD_ROOT
  106. %files -f %{name}.lang
  107. %defattr(-,root,root,-)
  108. %doc README AUTHORS NEWS COPYING HACKING doc/TODO
  109. %{_sysconfdir}/avahi/services/udisks.service
  110. %{_sysconfdir}/dbus-1/system.d/*.conf
  111. %{_sysconfdir}/profile.d/*.sh
  112. /lib/udev/rules.d/*.rules
  113. /lib/udev/udisks-part-id
  114. /lib/udev/udisks-dm-export
  115. /lib/udev/udisks-probe-ata-smart
  116. /lib/udev/udisks-probe-sas-expander
  117. /lib/udev/udisks-lvm-pv-export
  118. /sbin/umount.udisks
  119. %{_bindir}/*
  120. %{_libexecdir}/*
  121. %{_mandir}/man1/*
  122. %{_mandir}/man7/*
  123. %{_mandir}/man8/*
  124. %{_datadir}/polkit-1/actions/*.policy
  125. %{_datadir}/dbus-1/system-services/*.service
  126. %attr(0700,root,root) %dir %{_localstatedir}/lib/udisks
  127. %files devel
  128. %defattr(-,root,root,-)
  129. %{_datadir}/dbus-1/interfaces/*.xml
  130. %{_datadir}/pkgconfig/udisks.pc
  131. %dir %{_datadir}/gtk-doc/html/udisks
  132. %{_datadir}/gtk-doc/html/udisks/*
  133. # Note: please don't forget the %{?dist} in the changelog. Thanks
  134. #
  135. %changelog
  136. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
  137. - new upstream release
  138. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
  139. - new upstream release
  140. - drop Patch0
  141. * Sun Aug 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
  142. - add Patch0 (10-ide-cd-support.patch) from ubuntu
  143. * Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
  144. - new upstream release
  145. * Tue Nov 9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1-2
  146. - rebuilt with parted 2.3
  147. * Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-1
  148. - new upstream release
  149. * Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.0-1
  150. - Initial build for Vine Linux
  151. * Tue Mar 30 2010 Richard W.M. Jones <rjones@redhat.com> - 1.0.0-2%{?dist}
  152. - Bump release and rebuild so we link to the new libparted.
  153. * Mon Mar 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-1%{?dist}
  154. - Update to release 1.0.0
  155. * Tue Feb 23 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100223.1%{?dist}
  156. - Update to new git snapshot
  157. * Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.3%{?dist}
  158. - Require lvm2-libs >= 2.02.61 to get the right ABI for liblvm2app
  159. * Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.2%{?dist}
  160. - Update for new liblvm2app library
  161. * Mon Feb 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.1%{?dist}
  162. - Update to git snapshot
  163. * Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.2%{?dist}
  164. - Rebuild
  165. * Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.1%{?dist}
  166. - New git snapshot with LVM support
  167. * Tue Jan 12 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.3%{?dist}
  168. - Rebuild for new libparted
  169. * Mon Dec 07 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.2%{?dist}
  170. - Rebuild
  171. * Fri Dec 04 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.1%{?dist}
  172. - Updated for package review (#543608)
  173. * Wed Dec 02 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202%{?dist}
  174. - Git snapshot for upcoming 1.0.0 release