gtk3-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361
  1. # Note that this is NOT a relocatable package
  2. %define glib2_base_version 2.28.8
  3. %define glib2_version %{glib2_base_version}-1
  4. %define pango_base_version 1.28.4
  5. %define pango_version %{pango_base_version}-1
  6. %define atk_base_version 2.0.1
  7. %define atk_version %{atk_base_version}-1
  8. %define cairo_base_version 1.10.2
  9. %define cairo_version %{cairo_base_version}-1
  10. %define gdkpixbuf2_base_version 2.23.2
  11. %define gdkpixbuf2_version %{gdkpixbuf2_base_version}-1
  12. %define gobject_introspection_version 0.10.8
  13. %define base_version 3.1.18
  14. %define bin_version 3.0.0
  15. # biarch support
  16. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  17. %define _query_suffix %{nil}
  18. %if %{build_compat32}
  19. %define _query_suffix -32
  20. %endif
  21. Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
  22. Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
  23. Name: gtk3
  24. Version: %{base_version}
  25. Release: 1%{?_dist_release}
  26. License: LGPL
  27. Group: System Environment/Libraries
  28. Source: http://ftp.gnome.org/pub/GNOME/sources/gtk+/3.1/gtk+-%{version}.tar.xz
  29. Patch0: gtk3-3.1.12-gtk-widget-size-allocate.patch
  30. Patch100: gtk+-2.99.3-vine-default-theme.patch
  31. BuildRequires: atk-devel >= %{atk_version}
  32. BuildRequires: pango-devel >= %{pango_version}
  33. BuildRequires: glib2-devel >= %{glib2_version}
  34. BuildRequires: cairo-devel >= %{cairo_version}
  35. BuildRequires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
  36. BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
  37. BuildRequires: libtiff-devel >= 3.7
  38. BuildRequires: libjpeg-turbo-devel
  39. BuildRequires: libpng-devel
  40. BuildRequires: jasper-devel
  41. BuildRequires: colord-devel
  42. BuildRequires: gtk-doc
  43. #BuildRequires: automake17, autoconf
  44. BuildRequires: gamin-devel
  45. BuildRequires: cups-devel
  46. BuildRequires: libICE-devel
  47. BuildRequires: libXext-devel
  48. BuildRequires: libXi-devel
  49. BuildRequires: libXrandr-devel >= 1.3.0
  50. BuildRequires: libXrender-devel
  51. BuildRequires: libXcursor-devel
  52. BuildRequires: libXfixes-devel
  53. BuildRequires: libXinerama-devel
  54. BuildRequires: libXcomposite-devel
  55. BuildRequires: libXdamage-devel
  56. BuildRoot: %{_tmppath}/gtk-%{version}-root
  57. URL: http://www.gtk.org
  58. # required for icon themes apis to work
  59. Requires: hicolor-icon-theme
  60. # We need to prereq these so we can run gtk-query-immodules-2.0
  61. Requires(post): glib2 >= %{glib2_version}
  62. Requires(post): atk >= %{atk_version}
  63. Requires(post): pango >= %{pango_version}
  64. Requires(post): libSM >= 1.1.0
  65. # We need to prereq libtiff >= 3.7 to run gdk-pixbuf-query-loaders
  66. Requires(post): libtiff >= 3.7
  67. Requires: libXrandr >= 1.3.0
  68. Vendor: Project Vine
  69. Distribution: Vine Linux
  70. Packager: Takemikaduchi
  71. %description
  72. GTK+ is a multi-platform toolkit for creating graphical user
  73. interfaces. Offering a complete set of widgets, GTK+ is suitable for
  74. projects ranging from small one-off tools to complete application
  75. suites.
  76. %package devel
  77. Summary: Development tools for GTK+ applications.
  78. Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
  79. Group: Development/Libraries
  80. Requires: %{name} = %{version}-%{release}
  81. Requires: pango-devel >= %{pango_version}
  82. Requires: atk-devel >= %{atk_version}
  83. Requires: glib2-devel >= %{glib2_version}
  84. Requires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
  85. Requires: libX11-devel, libXcursor-devel, libXinerama-devel
  86. Requires: libXext-devel, libXi-devel, libXrandr-devel
  87. Requires: libXfixes-devel, libXcomposite-devel
  88. Requires: libpng-devel
  89. %description devel
  90. The gtk+-devel package contains the header files and developer
  91. docs for the GTK+ widget toolkit.
  92. #######################################################################
  93. # compat32
  94. %package -n compat32-%{name}
  95. Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
  96. Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
  97. Group: System Environment/Libraries
  98. Requires(post): compat32-glib2 >= %{glib2_version}
  99. Requires(post): compat32-atk >= %{atk_version}
  100. Requires(post): compat32-pango >= %{pango_version}
  101. Requires(post): compat32-libSM >= 1.1.0
  102. Requires(post): compat32-libtiff >= 3.7
  103. Requires: compat32-libXrandr >= 1.3.0
  104. %description -n compat32-%{name}
  105. GTK+ is a multi-platform toolkit for creating graphical user
  106. interfaces. Offering a complete set of widgets, GTK+ is suitable for
  107. projects ranging from small one-off tools to complete application
  108. suites.
  109. %package -n compat32-%{name}-devel
  110. Summary: Development tools for GTK+ applications.
  111. Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
  112. Group: Development/Libraries
  113. Requires: compat32-%{name} = %{version}-%{release}
  114. Requires: %{name}-devel = %{version}
  115. Requires: compat32-libX11-devel, compat32-libXcursor-devel, compat32-libXinerama-devel
  116. Requires: compat32-libXext-devel, compat32-libXi-devel, compat32-libXrandr-devel
  117. Requires: compat32-libXfixes-devel, compat32-libXcomposite-devel
  118. Requires: compat32-libpng-devel
  119. %description -n compat32-%{name}-devel
  120. The gtk+-devel package contains the header files and developer
  121. docs for the GTK+ widget toolkit.
  122. %prep
  123. %setup -q -n gtk+-%{version}
  124. %patch0 -p1 -b .allocate
  125. %patch100 -p1 -b .vine-default-theme
  126. #for i in config.guess config.sub ; do
  127. # test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
  128. #done
  129. %build
  130. # if ! pkg-config --exists pangoxft ; then
  131. # echo "No pangoxft.pc!"
  132. # exit 1
  133. # fi
  134. #libtoolize --force --copy
  135. #autoreconf -i
  136. %configure --enable-gtk-doc \
  137. --enable-man \
  138. --enable-debug=minimum \
  139. --disable-rebuilds \
  140. --disable-glibtest \
  141. --enable-introspection=yes \
  142. --enable-xrandr \
  143. --enable-xfixes \
  144. --enable-xcomposite \
  145. --enable-xdamage \
  146. --enable-x11-backend
  147. make ARCH=%{_arch}
  148. #make
  149. %install
  150. rm -rf $RPM_BUILD_ROOT
  151. make install DESTDIR=$RPM_BUILD_ROOT RUN_QUERY_IMMODULES_TEST=false RUN_QUERY_LOADER_TEST=false
  152. %find_lang gtk30
  153. %find_lang gtk30-properties
  154. cat gtk30.lang gtk30-properties.lang > all.lang
  155. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gtk-3.0
  156. #
  157. # Make cleaned-up versions of examples and tutorial for installation
  158. #
  159. mkdir -p tmpdocs/tutorial
  160. # install -m 0644 docs/html/gtk_tut.html docs/html/gtk_tut-[0-9]*.html docs/html/*.gif tmpdocs/tutorial
  161. for dir in examples/* ; do
  162. if [ -d $dir ] ; then
  163. mkdir -p tmpdocs/$dir
  164. for file in $dir/* ; do
  165. case $file in
  166. *pre1.2.7)
  167. ;;
  168. *)
  169. install -m 0644 $file tmpdocs/$dir
  170. ;;
  171. esac
  172. done
  173. fi
  174. done
  175. # We need to have separate 32-bit and 64-bit binaries
  176. # for places where we have two copies of the GTK+ package installed.
  177. # (we might have x86_64 and i686 packages on the same system, for example.)
  178. %if %{build_compat32}
  179. cp $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0 \
  180. $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
  181. %endif
  182. touch $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/%{bin_version}/immodules.cache
  183. mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/modules
  184. mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/immodules
  185. # Remove unpackaged files
  186. find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
  187. rm -rf $RPM_BUILD_ROOT%{_datadir}/themes/Raleigh
  188. mv $RPM_BUILD_ROOT%{_bindir}/gtk-update-icon-cache \
  189. $RPM_BUILD_ROOT%{_bindir}/gtk-update-icon-cache-3.0
  190. %clean
  191. rm -rf $RPM_BUILD_ROOT
  192. %post
  193. /sbin/ldconfig
  194. %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
  195. %postun
  196. /sbin/ldconfig
  197. if [ $1 -gt 0 ]; then
  198. %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
  199. fi
  200. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  201. %posttrans
  202. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  203. %if %{build_compat32}
  204. %post -n compat32-%{name}
  205. /sbin/ldconfig
  206. %{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
  207. %postun -n compat32-%{name}
  208. /sbin/ldconfig
  209. if [ $1 = 0 ]; then
  210. %{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
  211. fi
  212. %endif
  213. %files -f all.lang
  214. %defattr(-, root, root)
  215. %doc AUTHORS COPYING ChangeLog NEWS README
  216. %{_bindir}/gtk3-demo
  217. %{_bindir}/gtk-query-immodules-3.0
  218. %{_bindir}/gtk-update-icon-cache-3.0
  219. %{_libdir}/libgtk-3.so.*
  220. %{_libdir}/libgdk-3.so.*
  221. %{_libdir}/libgailutil-3.so.*
  222. %dir %{_libdir}/gtk-3.0
  223. %{_libdir}/gtk-3.0/%{bin_version}
  224. %dir %{_libdir}/gtk-3.0/modules
  225. #%{_libdir}/gtk-3.0/modules/lib*.so
  226. %{_libdir}/girepository-1.0/*.typelib
  227. %{_datadir}/gtk-3.0
  228. %{_datadir}/themes/Default
  229. %{_datadir}/themes/Emacs
  230. %dir %{_sysconfdir}/gtk-3.0
  231. %{_sysconfdir}/gtk-3.0/im-multipress.conf
  232. %{_datadir}/glib-2.0/schemas/*.xml
  233. %files devel
  234. %defattr(-, root, root)
  235. %{_libdir}/lib*.so
  236. %dir %{_libdir}/gtk-3.0
  237. %{_datadir}/gtk-doc/
  238. %{_datadir}/gir-1.0/*.gir
  239. %{_mandir}/man1/*
  240. %exclude %{_mandir}/man1/gtk-update-icon-cache.1.gz
  241. %{_includedir}/*
  242. %{_datadir}/aclocal/*
  243. %{_libdir}/pkgconfig/*
  244. %doc tmpdocs/tutorial
  245. # compat32
  246. %if %{build_compat32}
  247. %files -n compat32-%{name}
  248. %defattr(-, root, root)
  249. %{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
  250. %{_libdir}/libgtk-3.so.*
  251. %{_libdir}/libgdk-3.so.*
  252. %{_libdir}/libgailutil-3.so.*
  253. %dir %{_libdir}/gtk-3.0
  254. %{_libdir}/gtk-3.0/%{bin_version}
  255. %dir %{_libdir}/gtk-3.0/modules
  256. #%{_libdir}/gtk-3.0/modules/lib*.so
  257. %dir %{_sysconfdir}/gtk-3.0
  258. %files -n compat32-%{name}-devel
  259. %defattr(-, root, root)
  260. %{_libdir}/lib*.so
  261. %dir %{_libdir}/gtk-3.0
  262. %{_libdir}/pkgconfig/*
  263. %endif
  264. %changelog
  265. * Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.18-1
  266. - new upstream release
  267. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.16-1
  268. - new upstream release
  269. * Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.12-1
  270. - new upstream release
  271. - add Patch0 (gtk3-3.1.12-gtk-widget-size-allocate.patch)
  272. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-2
  273. - fix %%files
  274. * Sat Jul 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-1
  275. - new upstream release
  276. - add BuildRequires: colord-devel
  277. * Sun Jun 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.11-1
  278. - new upstream release
  279. * Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.9-1
  280. - new upstream release
  281. * Sun Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.8-1
  282. - new upstream release
  283. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.7-1
  284. - new upstream release
  285. * Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.6-1
  286. - new upstream release
  287. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.4-1
  288. - new upstream release
  289. * Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
  290. - new upstream release
  291. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
  292. - new upstream release
  293. * Fri Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
  294. - new upstream release
  295. * Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
  296. - initial build for Vine Linux