clutter-vl.spec 9.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321
  1. %define clutter_version 1.7.14
  2. %define clutter_release 1%{?_dist_release}
  3. Name: clutter
  4. Version: %{clutter_version}
  5. Release: %{clutter_release}
  6. Summary: Open Source software library for creating rich graphical user interfaces
  7. Summary(ja): リッチなGUIを作成するためのオープンソースライブラリ
  8. Group: System Environment/Libraries
  9. License: LGPLv2+
  10. URL: http://www.clutter-project.org/
  11. Source0: http://www.clutter-project.org/sources/%{name}/1.7/%{name}-%{version}.tar.xz
  12. Patch0: clutter-fixdso.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Requires: gobject-introspection
  15. # FIXME to remove when all the bits have been merged into their
  16. # libraries
  17. BuildRequires: glib2-devel
  18. BuildRequires: mesa-libGL-devel
  19. BuildRequires: gdk-pixbuf2-devel
  20. BuildRequires: atk-devel
  21. BuildRequires: pkgconfig
  22. BuildRequires: pango-devel
  23. BuildRequires: libXdamage-devel
  24. BuildRequires: libXcomposite-devel
  25. BuildRequires: libXi-devel
  26. BuildRequires: gettext
  27. BuildRequires: gtk-doc
  28. BuildRequires: gobject-introspection-devel >= 0.9.5
  29. BuildRequires: json-glib-devel
  30. BuildRequires: cogl-devel >= 1.7.4
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. Packager: Takemikaduchi
  34. %description
  35. Clutter is an open source software library for creating fast,
  36. visually rich graphical user interfaces. The most obvious example
  37. of potential usage is in media center type applications.
  38. We hope however it can be used for a lot more.
  39. %description -l ja
  40. Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
  41. 最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
  42. しかしながら、我々はいろいろな分野で使用されることを願っています。
  43. %package devel
  44. Summary: Clutter development environment
  45. Summary(ja): Clutterの開発環境
  46. Group: Development/Libraries
  47. Requires: %{name} = %{version}-%{release}
  48. Requires: pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
  49. Requires: mesa-libGL-devel
  50. Requires: gobject-introspection-devel
  51. Requires: json-glib-devel
  52. %description devel
  53. Header files and libraries for building a extension library for the
  54. clutter
  55. %package doc
  56. Summary: Documentation for %{name}
  57. Summary(ja): %{name}用のドキュメント
  58. Group: Documentation
  59. Requires: %{name} = %{version}-%{release}
  60. BuildArch: noarch
  61. %description doc
  62. Clutter is an open source software library for creating fast,
  63. visually rich graphical user interfaces. The most obvious example
  64. of potential usage is in media center type applications.
  65. We hope however it can be used for a lot more.
  66. This package contains documentation for clutter.
  67. %prep
  68. %setup -q
  69. %patch0 -p1 -b .dso
  70. %build
  71. #%configure --enable-gtk-doc \
  72. # --enable-introspection=yes \
  73. # --disable-silent-rules \
  74. # --enable-xinput \
  75. # --disable-static
  76. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
  77. %configure $CONFIGFLAGS \
  78. --enable-introspection=yes \
  79. --disable-silent-rules \
  80. --enable-xinput \
  81. --disable-static
  82. # clutter git ships with some magic to put the git log in shipped tarballs
  83. # which gets listed in files; don't blow up if it's missing
  84. if ! test -f ChangeLog; then
  85. echo "Created from snapshot" > ChangeLog
  86. fi
  87. )
  88. make V=0
  89. %install
  90. rm -rf $RPM_BUILD_ROOT
  91. #make DESTDIR=$RPM_BUILD_ROOT install
  92. make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
  93. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  94. %find_lang %{name}-1.0
  95. %clean
  96. rm -rf $RPM_BUILD_ROOT
  97. %post -p /sbin/ldconfig
  98. %postun -p /sbin/ldconfig
  99. %files -f %{name}-1.0.lang
  100. %defattr(-,root,root,-)
  101. %doc AUTHORS COPYING NEWS README
  102. %{_libdir}/*.so.*
  103. %{_libdir}/girepository-1.0/*.typelib
  104. %files devel
  105. %defattr(-, root, root)
  106. %doc ChangeLog
  107. %{_includedir}/clutter-1.0
  108. %{_libdir}/*.so
  109. %{_libdir}/pkgconfig/*.pc
  110. %{_datadir}/gir-1.0/*.gir
  111. %files doc
  112. %defattr(-, root, root)
  113. %{_datadir}/gtk-doc/html/clutter
  114. %{_datadir}/gtk-doc/html/cally
  115. %changelog
  116. * Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.14-1
  117. - new upstream release
  118. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.12-1
  119. - new upstream release
  120. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.10-1
  121. - new upstream release
  122. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
  123. - new upstream release
  124. - add BuildRequires: cogl-devel
  125. - add "BuildArch: noarch" to doc sub package
  126. - add Patch0 (clutter-fixdso.patch)
  127. * Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
  128. - new upstream release
  129. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
  130. - new upstream release
  131. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
  132. - new upstream release
  133. * Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
  134. - new upstream release
  135. * Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
  136. - new upstream release
  137. - change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
  138. - add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
  139. - drop Patch0
  140. * Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  141. - new upstream release
  142. - drop Patch1
  143. * Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  144. - new upstream release
  145. - add BuildRequires: json-glib-devel
  146. - delete Requires: gir-repository
  147. - delete BuildRequires: gir-repository-devel
  148. - add Requires: json-glib-devel (devel package)
  149. - add Patch0, Patch1
  150. - fix %build
  151. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
  152. - rebuild with rpm-4.8.1 for pkg-config file
  153. * Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
  154. - new upstream release
  155. * Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
  156. - new upstream release
  157. * Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
  158. - new upstream release
  159. - add configure option (--enable-xinput)
  160. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
  161. - new upstream release
  162. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
  163. - new upstream release
  164. * Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  165. - new upstream release
  166. * Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
  167. - new upstream release
  168. * Tue Dec 1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
  169. - new upstream release
  170. - build for Vine Linux
  171. - add Summary(ja)
  172. - fix BuildRoot
  173. - remove Obsolete and Provides
  174. * Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
  175. - Update to 1.0.6
  176. * Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
  177. - Update to 1.0.4, update gobject-introspection requirement
  178. * Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
  179. - Update to 1.0.2
  180. * Sun Aug 1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
  181. - Move ChangeLog to -devel to save some space
  182. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
  183. - Drop the gir-repository-devel dep, which pulls a bunch of -devel
  184. onto the live cd
  185. * Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
  186. - Update to 1.0.0
  187. * Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
  188. - fix bz #507389
  189. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
  190. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  191. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
  192. - Update to 0.9.8
  193. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
  194. - Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
  195. introspection support to clutter (#512260)
  196. * Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
  197. - Update to 0.9.6
  198. * Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
  199. - Update to 0.9.4
  200. * Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
  201. - Update to 0.9.2
  202. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
  203. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  204. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
  205. - Remove noarch from doc subpackage
  206. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
  207. - Added gtk-doc for cogl
  208. - Created doc subpackage
  209. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
  210. - Update to 0.8.6
  211. * Mon Oct 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
  212. - Update to 0.8.2
  213. - Removed clutter-0.8.0-clutter-fixed.patch
  214. * Sat Sep 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
  215. - Update to 0.8.0
  216. - Added clutter-0.8.0-clutter-fixed.patch
  217. * Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
  218. - Update to 0.6.4
  219. * Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
  220. - Update to 0.6.2
  221. * Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
  222. - Update to 0.6.0
  223. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
  224. - Autorebuild for GCC 4.3
  225. * Wed Oct 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
  226. - Update to 0.4.2
  227. * Mon Sep 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
  228. - Update to 0.4.1
  229. * Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
  230. - Update to 0.3.1
  231. * Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
  232. - Update to 0.2.3
  233. * Sun Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
  234. - Changed buildrequires and requires
  235. * Sun Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
  236. - Fix .spec
  237. * Sun Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
  238. - Fix .spec
  239. * Sun Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
  240. - Initial RPM release