libxcb-vl.spec 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define xpyb_version 1.2
  3. Summary: A C binding to the X11 protocol
  4. Summary(ja): X11 プロトコルの C による実装
  5. Name: libxcb
  6. Version: 1.9.1
  7. Release: 1%{?_dist_release}
  8. Group: System Environment/Libraries
  9. License: MIT
  10. URL: http://xcb.freedesktop.org/
  11. Source0: http://xcb.freedesktop.org/dist/%{name}-%{version}.tar.bz2
  12. # This is stolen straight from the pthread-stubs source:
  13. # http://cgit.freedesktop.org/xcb/pthread-stubs/blob/?id=6900598192bacf5fd9a34619b11328f746a5956d
  14. # we don't need the library because glibc has working pthreads, but we need
  15. # the pkgconfig file so libs that link against libxcb know this...
  16. Source1: pthread-stubs.pc.in
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. BuildRequires: autoconf automake libtool pkgconfig
  19. #BuildRequires: doxygen
  20. #BuildRequires: graphviz
  21. BuildRequires: libXau-devel
  22. BuildRequires: libxslt
  23. BuildRequires: xcb-proto >= 1.6
  24. BuildRequires: xorg-x11-proto-devel
  25. BuildRequires: xorg-x11-util-macros
  26. BuildRequires: python-devel
  27. Obsoletes: %{name}-python < 1.8
  28. %description
  29. The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
  30. small footprint, latency hiding, direct access to the protocol, improved
  31. threading support, and extensibility.
  32. %package devel
  33. Summary: Development files for %{name}
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}-%{release}
  36. Requires: pkgconfig
  37. %description devel
  38. The %{name}-devel package contains libraries and header files for
  39. developing applications that use %{name}.
  40. %package doc
  41. Summary: Documentation for %{name}
  42. Group: Documentation
  43. %description doc
  44. The %{name}-doc package contains documentation for the %{name} library.
  45. %package -n compat32-%{name}
  46. Summary: A C binding to the X11 protocol
  47. Summary(ja): X11 プロトコルの C による実装
  48. Group: System Environment/Libraries
  49. %description -n compat32-%{name}
  50. The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
  51. small footprint, latency hiding, direct access to the protocol, improved
  52. threading support, and extensibility.
  53. %package -n compat32-%{name}-devel
  54. Summary: Development files for %{name}
  55. Group: Development/Libraries
  56. Requires: compat32-%{name} = %{version}-%{release}
  57. Requires: %{name}-devel = %{version}-%{release}
  58. %description -n compat32-%{name}-devel
  59. The %{name}-devel package contains libraries and header files for
  60. developing applications that use %{name}.
  61. %prep
  62. %setup -q
  63. %build
  64. sed -i 's/pthread-stubs //' configure.ac
  65. autoreconf -v --install
  66. %configure --disable-static \
  67. --docdir=%{_datadir}/doc/%{name}-%{version} \
  68. --disable-selinux \
  69. --enable-xkb \
  70. --disable-xprint
  71. make %{?_smp_mflags}
  72. %install
  73. rm -rf $RPM_BUILD_ROOT
  74. make install DESTDIR=$RPM_BUILD_ROOT
  75. find $RPM_BUILD_ROOT -name '*.la' | xargs rm -f
  76. install -m 644 COPYING NEWS README $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
  77. sed 's,@libdir@,%{_libdir},;s,@prefix@,%{_prefix},;s,@exec_prefix@,%{_exec_prefix},' %{SOURCE1} > $RPM_BUILD_ROOT%{_libdir}/pkgconfig/pthread-stubs.pc
  78. find $RPM_BUILD_ROOT -name '*.la' -delete
  79. %clean
  80. rm -rf $RPM_BUILD_ROOT
  81. %post -p /sbin/ldconfig
  82. %postun -p /sbin/ldconfig
  83. %post -n compat32-%{name} -p /sbin/ldconfig
  84. %postun -n compat32-%{name} -p /sbin/ldconfig
  85. %files
  86. %defattr(-,root,root,-)
  87. %{_libdir}/*.so.*
  88. %files devel
  89. %defattr(-,root,root,-)
  90. %{_includedir}/xcb
  91. %{_libdir}/*.so
  92. %{_libdir}/pkgconfig/*.pc
  93. %files doc
  94. %defattr(-,root,root,-)
  95. %{_datadir}/doc/%{name}-%{version}
  96. %{_mandir}/man3/*
  97. %if %{build_compat32}
  98. %files -n compat32-%{name}
  99. %defattr(-,root,root,-)
  100. %{_libdir}/*.so.*
  101. %files -n compat32-%{name}-devel
  102. %defattr(-,root,root,-)
  103. %{_libdir}/*.so
  104. %endif
  105. %changelog
  106. * Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.1-1
  107. - new upstream release
  108. (including security fix for CVE-2013-2064)
  109. * Sat Nov 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-2
  110. - add Source1: pthread-stubs.pc, remove patch10
  111. * Mon Oct 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9-1
  112. - new upstream release
  113. * Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
  114. - new upstream release
  115. - update Patch10 (libxcb-1.8.1-no-pthread-stubs.patch)
  116. * Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8-1
  117. - new upstream release
  118. - remove Source2
  119. - remove python sub package
  120. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7-1
  121. - new upstream release
  122. - update Patch10
  123. * Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5-3
  124. - add BuildRequires: python-devel
  125. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.5-2
  126. - build with rpm-4.8.1-1 for pkg-config file
  127. * Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-1
  128. - new upstream release
  129. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.4-2
  130. - rebuild with python-2.6
  131. * Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-1
  132. - new upstream release
  133. - add libxcb python binding (xpyb)
  134. * Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2-2
  135. - added compat32 package for x86_64 arch support
  136. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
  137. - new upstream release
  138. * Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.1-2
  139. - spec in utf-8
  140. - added japanese summary
  141. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
  142. - new versioning policy
  143. * Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
  144. - initial build for Vine Linux
  145. * Mon Nov 12 2007 Adam Jackson <ajax@redhat.com> 1.1-1
  146. - libxcb 1.1
  147. * Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> 1.0-3
  148. - libxcb-1.0-abstract-socket.patch: When connecting to the X server, prefer
  149. abstract-namespace unix sockets to filesystem-bound sockets.
  150. * Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 1.0-2
  151. - Rebuild for PPC toolchain bug
  152. * Fri Jun 29 2007 Adam Jackson <ajax@redhat.com> 1.0-1
  153. - Initial revision.