rhythmbox-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637
  1. # -*- coding: utf-8-unix -*-
  2. %define desktop_file_utils_version 0.9
  3. %define enable_DLNA_UPnP 0
  4. Summary: Music Management Application
  5. Summary(ja): 音楽管理アプリケーション
  6. Name: rhythmbox
  7. Version: 3.0.3
  8. Release: 2%{?_dist_release}
  9. License: GPL2+ with exceptions and GFDL
  10. Group: Applications/Multimedia
  11. URL: http://projects.gnome.org/rhythmbox/
  12. Source0: http://download.gnome.org/sources/${name}/3.0/%{name}-%{version}.tar.xz
  13. Source101: rhythmbox-png.tar.bz2
  14. Patch0: rhythmbox-3.0-disable-python3.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: gtk3-devel
  17. BuildRequires: avahi-glib-devel >= 0.6
  18. BuildRequires: brasero-devel >= 2.32.0
  19. BuildRequires: dbus-glib-devel
  20. BuildRequires: gstreamer1-plugins-base-devel
  21. BuildRequires: json-glib-devel
  22. BuildRequires: libSM-devel
  23. BuildRequires: libgnome-keyring-devel >= 2.30.0
  24. BuildRequires: libgpod-devel
  25. BuildRequires: eudev-libgudev1-devel
  26. BuildRequires: libmusicbrainz3-devel >= 3.0.2
  27. BuildRequires: libnotify-devel
  28. BuildRequires: libsoup-devel
  29. BuildRequires: pygobject3-devel
  30. BuildRequires: totem-pl-parser-devel
  31. BuildRequires: WebKit3-gtk-devel
  32. BuildRequires: libpeas-devel
  33. BuildRequires: clutter-gtk-devel
  34. BuildRequires: clutter-gst-devel
  35. BuildRequires: libmx-devel
  36. BuildRequires: check-devel
  37. BuildRequires: libmtp-devel
  38. BuildRequires: libtdb-devel
  39. BuildRequires: grilo-devel
  40. BuildRequires: libdmapsharing-devel
  41. BuildRequires: lirc
  42. BuildRequires: gnome-doc-utils >= 0.3.2
  43. BuildRequires: yelp-tools
  44. Requires: brasero
  45. Requires: libgnome-keyring
  46. %if %{enable_DLNA_UPnP}
  47. Requires: python-Coherence
  48. %endif
  49. Requires: desktop-file-utils >= %{desktop_file_utils_version}
  50. # # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
  51. # # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
  52. # # respectively.
  53. # Requires: self-build-gstreamer-plugins-ffmpeg
  54. # Requires: self-build-gstreamer-plugins-ugly
  55. Vendor: Project Vine
  56. Distribution: Vine Linux
  57. %description
  58. Rhythmbox is an integrated music management application based on the powerful
  59. GStreamer media framework. It has a number of features, including an easy to
  60. use music browser, searching and sorting, comprehensive audio format support
  61. through GStreamer, Internet Radio support, playlists and more.
  62. Rhythmbox is extensible through a plugin system.
  63. %description -l ja
  64. Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
  65. 統合音楽管理アプリケーションです。
  66. 見やすいユーザインターフェースを備え、検索や整列ができ、
  67. GStreamer により数多くの音声フォーマットをサポート、
  68. インターネットラジオをサポート、プレイリスト管理などの
  69. 数多くの特徴を持ちます。
  70. %package devel
  71. Summary: Development tools for rhythmbox applications.
  72. Summary(ja): rhythmbox アプリケーションの開発用ファイル
  73. Group: Development/Libraries
  74. Requires: %{name} = %{version}-%{release}
  75. Requires: pkgconfig
  76. Requires: libxml2-devel
  77. Requires: glib2-devel
  78. Requires: gtk3-devel
  79. Requires: libsoup-devel
  80. Requires: totem-pl-parser-devel
  81. Requires: gstreamer1-devel
  82. %description devel
  83. Header files and libraries for building a extension library for the rhythmbox.
  84. %description devel -l ja
  85. %prep
  86. %setup -q
  87. %patch0 -p1
  88. tar xjf %{SOURCE101}
  89. %build
  90. autoreconf -if
  91. intltoolize --force --copy
  92. %configure --with-ipod \
  93. --with-mtp \
  94. --enable-lirc \
  95. --disable-python \
  96. --disable-vala \
  97. --disable-browser-plugin \
  98. --disable-static \
  99. --enable-browser-plugin \
  100. --without-hal
  101. %__make %{?_smp_mflags}
  102. %install
  103. %__rm -rf $RPM_BUILD_ROOT
  104. %__make install DESTDIR=$RPM_BUILD_ROOT
  105. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
  106. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
  107. %__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  108. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
  109. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
  110. %__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
  111. %__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
  112. ## Don't package DLNA/UPnP plugin
  113. %if !%{enable_DLNA_UPnP}
  114. %__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
  115. %endif
  116. %find_lang %{name} --all-name --with-gnome
  117. # Don't package api docs
  118. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
  119. # And don't package vala
  120. %__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
  121. %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
  122. # remove sample plugins
  123. rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
  124. %clean
  125. %__rm -rf $RPM_BUILD_ROOT
  126. %post
  127. /sbin/ldconfig
  128. update-desktop-database -q
  129. touch --no-create %{_datadir}/icons/hicolor
  130. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  131. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  132. fi
  133. %postun
  134. /sbin/ldconfig
  135. update-desktop-database -q
  136. touch --no-create %{_datadir}/icons/hicolor
  137. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  138. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  139. fi
  140. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  141. %posttrans
  142. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  143. %files -f %{name}.lang
  144. %defattr(-, root, root)
  145. %doc AUTHORS COPYING ChangeLog README NEWS
  146. %{_bindir}/*
  147. %{_libdir}/girepository-1.0/*.typelib
  148. %{_libdir}/lib*.so.*
  149. %{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
  150. %{_libdir}/rhythmbox/plugins
  151. %{_datadir}/applications/rhythmbox.desktop
  152. %{_datadir}/applications/rhythmbox-device.desktop
  153. %{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
  154. %{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
  155. %{_datadir}/icons/*
  156. %{_datadir}/rhythmbox
  157. %{_mandir}/man1/*
  158. %{_libexecdir}/rhythmbox-metadata
  159. %files devel
  160. %defattr(-, root, root)
  161. %{_includedir}/%{name}/*
  162. %{_libdir}/*.so
  163. %{_libdir}/pkgconfig/*.pc
  164. %{_datadir}/gir-1.0/*.gir
  165. %changelog
  166. * Wed Jul 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.0.3-2
  167. - rebuild with new libimobiledevice
  168. * Sat Jun 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
  169. - new upstream release
  170. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
  171. - new upstream release
  172. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-2
  173. - rebuild with VineSeed environment
  174. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
  175. - new upstream release
  176. * Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
  177. - new upstream release
  178. - add Patch0 (rhythmbox-3.0-disable-python3.patch)
  179. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.1-1
  180. - new upstream release
  181. - add BuildRequies: yelp-tools
  182. - change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
  183. * Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-2
  184. - rebuild with libimobiledevice-1.1.5
  185. * Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
  186. - new upstream release
  187. - add BuildRequires: grilo-devel, libdmapsharing-devel
  188. * Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
  189. - new upstream release
  190. * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
  191. - new upstream release
  192. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
  193. - new upstream release
  194. - add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
  195. - remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
  196. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
  197. - rebuild with cogl-0.8.0
  198. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
  199. - rebuild with libnotify-0.7
  200. - change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
  201. - change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
  202. - add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
  203. - add Patch0 (rhythmbox-0.13.3-git20110809.patch)
  204. - add Source101 (rhythmbox-png.tar.bz2)
  205. * Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
  206. - add BuildRequires: json-glib-devel
  207. - remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
  208. * Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
  209. - new upstream release
  210. - change BuildRequires: gstreamer-python-devel instead of gstreamer-python
  211. * Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
  212. - new upstream release
  213. * Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
  214. - rebuild with brasero-2.32.0
  215. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
  216. - rebuild with rpm-4.8.1 for pkg-config file
  217. * Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
  218. - new upstream release
  219. - fix %files (add rhythmbox-device.desktop)
  220. * Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
  221. - new upstream release
  222. - change BuildRequires: gnome-media-devel instead of gnome-media
  223. - add devel package
  224. - drop Patch0
  225. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
  226. - new upstream release
  227. - drop Patch1, Patch2, Patch3
  228. - change BuildRequires: nautilus-cd-burner -> brasero-devel
  229. - change Requires: nautilus-cd-burner -> brasero
  230. - change BuildRequires: hal-devel -> libgudev1-devel
  231. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  232. - change Requires: gnome-keyring -> libgnome-keyring
  233. - add configure option (--without-hal)
  234. * Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
  235. - rebuilt with new environment
  236. * Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
  237. - new upstream release
  238. - dropped upstreamed/obsolete patches
  239. - added patches applied Fedora development
  240. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
  241. - new upstream release
  242. - added configure options:
  243. --disable-vala
  244. --disable-browser-plugin
  245. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
  246. - added Japanese description
  247. * Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
  248. - new upstream release
  249. - dropped rb-disable-power-plugin-by-default.patch
  250. - added BuildRequires:
  251. - libSM-devel
  252. - gnome-media
  253. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
  254. - rebuild with libgpod-0.7.2
  255. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
  256. - new upstream release
  257. - corrected License tag
  258. - dropped rhythmbox-0.11.6-libmtp.patch
  259. - added BuildRequires:
  260. - sqlite3-devel
  261. - libffi-devel
  262. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
  263. - defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
  264. - applied rhythmbox-0.11.6-libmtp.patch
  265. - added Requires:
  266. - libgpod
  267. - libnotify
  268. - libsexy
  269. - lirc
  270. - libmtp
  271. - libgnomeui
  272. - nautilus-cd-burner
  273. - gstreamer-python
  274. - gnome-vfs2
  275. - gnome-themes
  276. - gnome-keyring
  277. - python-Coherence, if enable_DLNA_UPnP = 1
  278. - added BuildRequires:
  279. - libnotify-devel
  280. - libsexy-devel
  281. - lirc
  282. - libmtp-devel
  283. - gnome-vfs2-devel, instead of gnome-vfs2
  284. - gnome-keyring-devel
  285. - dropped --with-internal-libsexy in configure options
  286. - added in configure options:
  287. --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
  288. - added %%preun to remove the schema
  289. * Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
  290. - new upstream release
  291. - changed to --with-metadata-helper in configure options
  292. - added BuildRequires:
  293. - gstreamer-python
  294. - intltool >= 0.35.0
  295. - popt-devel
  296. * Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
  297. - added BuildRequires: totem-pl-parser-devel, instead of totem-devel
  298. - rebuilt with python-2.5.2
  299. - applied new versioning policy
  300. - spec in utf-8
  301. * Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
  302. - rebuilt with libgpod-0.6.0
  303. * Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
  304. - new upstream release
  305. * Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
  306. - new upstream release
  307. * Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
  308. - rebuilt with new toolchain and libgpod-0.4.2
  309. - add BuildRequires: dbus-glib-devel
  310. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
  311. - new upstream release
  312. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
  313. - rebuilt for VineSeed
  314. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
  315. - new upstream release
  316. - added --enable-python option to %%configure
  317. - added Requires: gnome-python
  318. * Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
  319. - new upstream release
  320. - built with libsoup 2.2.99
  321. * Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
  322. - added --with-cd-burner to configure
  323. - added BuildRequires: libsexy-devel hal-devel libsoup-devel
  324. * Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
  325. - add BuildRequires:
  326. - gnome-doc-utils >= 0.3.2
  327. - python-devel
  328. - pygtk2-devel
  329. - check >= 0.8.2
  330. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
  331. - rebuild with gnutls-1.4.1
  332. * Sun Oct 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
  333. - new upstream release
  334. * Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
  335. - new upstream release
  336. - run scrollkeeper-update at %post and %postun
  337. - added BuildRequires: libnotify-devel
  338. * Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
  339. - new upstream release (dropped patch0)
  340. - added --without-metadata-helper at configure
  341. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
  342. - Initial build for Vine Linux based on FC pacakge
  343. * Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
  344. - add patch from James "Doc" Livingston to stop a hang
  345. for new users (bug 183883)
  346. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
  347. - bump again for double-long bug on ppc(64)
  348. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
  349. - rebuilt for new gcc4.1 snapshot and glibc changes
  350. * Sat Feb 4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
  351. - Update to 0.9.3.1
  352. - Use gstreamer (0.10)
  353. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
  354. - Remove hack for 173869, as its no longer needed.
  355. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
  356. - 0.9.3
  357. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
  358. - Newer CVS snapshot
  359. * Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
  360. - Update to latest CVS
  361. - Add hack to workaround bug #173869
  362. * Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
  363. - Rebuild, now that gstreamer08-plugins has been fixed
  364. * Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
  365. - bonobo multilib issue (bug 156982)
  366. * Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
  367. - rebuild with ipod support
  368. * Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
  369. - rebuilt again
  370. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  371. - rebuilt
  372. * Mon Dec 5 2005 Matthias Clasen <mclasen@redhat.com>
  373. - rebuild
  374. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
  375. - rebuild for new dbus
  376. * Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
  377. - Update to 0.9.2
  378. * Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
  379. - Update to 0.9.1
  380. * Fri Sep 02 2005 Colin Walters <walters@redhat.com>
  381. - Add configure flags --with-bonobo --with-dbus
  382. - BR nautilus-cd-burner-devel
  383. - New upstream CVS snapshot for testing
  384. - Drop IDL file and ui .xml
  385. - Add dbus service file
  386. - Drop upstreamed rhythmbox-bluecurve.tar.gz
  387. - Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
  388. * Mon Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
  389. - Add Bluecurve-ized icons from Jeff Schroeder (157716)
  390. - Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
  391. cell renderer for playback icon (no longer necessary) and
  392. changes the rating renderer to work with non-b&w icons
  393. * Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
  394. - Rebuild for GCC4
  395. * Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
  396. - New upstream version
  397. - Remove librb-nautilus-context-menu.so, killed upstream
  398. * Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
  399. - PreReq desktop-file-utils >= 0.9
  400. * Wed Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
  401. - New upstream version
  402. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
  403. - Fix postun to use correct syntax, thanks Nils Philippsen
  404. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
  405. - New upstream version
  406. - Call update-desktop-database in post and postun
  407. * Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
  408. - New upstream version
  409. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  410. - rebuilt
  411. * Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
  412. - New upstream version
  413. - Remove backported patches
  414. - Gratuitiously bump various BuildRequires versions
  415. * Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
  416. - Remove code to unregister GConf schema for now (Closes: #122532)
  417. * Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
  418. - Apply tiny patch from 0.8 arch to fix GConf key used
  419. for initial sorting
  420. * Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
  421. - Apply patch from 0.8 arch tree to fix a number of memleaks
  422. * Sun May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
  423. - Update to 0.8.3: fixes showstopper bug with internet radio
  424. * Fri Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
  425. - Update to 0.8.2
  426. - Fix Source url
  427. - Add smp_mflags
  428. - Bump BuildRequires on gstreamer to 0.8.1
  429. * Fri Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
  430. - Uninstall GConf schemas on removal
  431. * Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
  432. - Update to 0.8.1
  433. * Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
  434. - Update to 0.8.0
  435. * Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
  436. - Update to 0.7.2
  437. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
  438. - Remove BuildRequires on autoconf and libvorbis-devel
  439. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
  440. - New major version - I know we are past major version slush, but
  441. this should have been done two weeks ago along with the GNOME 2.6
  442. upload. As upstream author as well, I believe this version is
  443. good enough for FC2.
  444. - Remove --disable-mp3
  445. - Remove id3, flac variables
  446. - Remove GStreamer major version patch
  447. - Fix typo in description
  448. * Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
  449. - rebuild for new gstreamer
  450. * Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
  451. - update to 0.6.8
  452. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  453. - rebuilt
  454. * Mon Mar 1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
  455. - update to 0.6.7
  456. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  457. - rebuilt
  458. * Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
  459. - New upstream version
  460. - Don't re-run the autotools; upstream incorporates newer versions.
  461. * Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
  462. - new version
  463. - remove smp_flags
  464. * Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
  465. - remove the initial iradio channels as they all are mp3 based.
  466. * Wed Oct 8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
  467. - Fix category from Development/Libraries to Applications/Multimedia.
  468. - Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
  469. - Fix SCHEMES vs. SCHEMAS in the post scriplet.
  470. - Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
  471. - Removed unnecessary date expansion define.
  472. - Updated description, including mp3 reference removal.
  473. - Added libid3tag and flac optional support for convenient rebuild.
  474. - Removed obsolete omf.make and xmldocs.make (included ones are the same now).
  475. * Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
  476. - new version
  477. - use %{_sysconfdir} instead of /etc
  478. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  479. - rebuilt
  480. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  481. - gave up on other archs for the Beta
  482. - new version
  483. - remove werror and add missing files
  484. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  485. - update to newer cvs snap
  486. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  487. - update to cvs snap
  488. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  489. - use %%(lang)
  490. * Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
  491. - fix post to actually install the schema
  492. * Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  493. - Added gconf file
  494. - Added i18n directory
  495. * Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  496. - Updated for new rewrite of rhythmbox, thanks to Jeroen
  497. * Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
  498. - removed bonobo dependency
  499. * Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
  500. - created new spec file