python-crypto-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172
  1. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. Summary: Cryptography library for Python
  4. Summary(ja): Python 用 Cryptography ライブラリ
  5. Name: python-crypto
  6. Version: 2.6.1
  7. Release: 1%{?_dist_release}
  8. License: Python License (CNRI Python License)
  9. Group: Development/Libraries
  10. URL: http://www.dlitz.net/software/pycrypto/
  11. Source: http://ftp.dlitz.net/pub/dlitz/crypto/pycrypto/pycrypto-%{version}.tar.gz
  12. Patch0: dont-drop-g.patch
  13. Patch1: fix-epydoc-ignore.patch
  14. Patch2: fix-unresolved-reference-size.patch
  15. BuildRequires: python >= 2.2
  16. BuildRequires: python-devel >= 2.2
  17. BuildRequires: gmp-devel >= 5
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. %description
  20. Python-crypto is a collection of both secure hash functions
  21. (such as MD5 and SHA), and various encryption algorithms
  22. (AES, DES, IDEA, RSA, ElGamal, etc.).
  23. %prep
  24. %setup -n pycrypto-%{version} -q
  25. %patch0 -p1
  26. %patch1 -p1
  27. %patch2 -p1
  28. # Remove spurious shellbangs
  29. %{__sed} -i -e '\|^#!/usr/local/bin/python| d' lib/Crypto/Util/RFC1751.py
  30. %build
  31. CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
  32. %install
  33. %{__rm} -rf %{buildroot}
  34. %{__python} setup.py install -O1 --skip-build --root %{buildroot}
  35. # Remove group write permissions on shared objects
  36. /usr/bin/find %{buildroot}%{python_sitearch} -name '*.so' \
  37. -exec %{__chmod} g-w {} \;
  38. %clean
  39. rm -rf $RPM_BUILD_ROOT
  40. %files
  41. %defattr(-,root,root,-)
  42. %doc README TODO ACKS ChangeLog LEGAL/ COPYRIGHT Doc/
  43. #%{python_sitearch}/pycrypto-2.2-py2.6.egg-info
  44. %{python_sitearch}/
  45. %changelog
  46. * Sun Dec 15 2013 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.1-1
  47. - new upstream release
  48. - drop Patch3: doc.patch
  49. * Sat May 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6-1
  50. - new upstream release
  51. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5-2
  52. - rebuild with python-2.7.2
  53. * Mon Jan 16 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5-1
  54. - new upstream release
  55. - added patches(1,2,3) from Debian
  56. * Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.1-1
  57. - new upstream release
  58. - dropt patch1
  59. * Sun Oct 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.3-2
  60. - rebuilt with rpm-4.8.1 for pkg-config
  61. * Sat Aug 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.3-1
  62. - new upstream release
  63. - changed %%files
  64. * Sun Aug 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2-2
  65. - fix %files (change directory from %{python_sitelib} to %{python_sitearch})
  66. * Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.2-1
  67. - new upstream release
  68. * Wed Jul 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.1.0-1
  69. - new upstream release
  70. - changed URL and SOURCE to new upstream
  71. - dropt patch0,2
  72. - replaced patch1 from Debian newer
  73. - added pacth3 from Debian
  74. - changed document files dir in %%files
  75. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.1-3
  76. - rebuild with python-2.6
  77. * Fri Oct 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.0.1-2
  78. - added Patch0,1,2 from Debian to fix some problem
  79. * Wed Jul 29 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.0.1-1
  80. - initial build for VineSeed
  81. * Mon Jun 04 2007 David Woodhouse <dwmw2@infradead.org> - 2.0.1-7.1
  82. - Fix libdir handling so it works on more arches than x86_64
  83. * Wed Apr 18 2007 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-7
  84. - Fix typo
  85. * Wed Apr 18 2007 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-6
  86. - Remove dist
  87. - rebuild, because the older version was much bigger, as it was build when
  88. distutils was doing static links of libpython
  89. * Sat Dec 09 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-5
  90. - Rebuild for python 2.5
  91. * Thu Sep 07 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-4
  92. - Don't ghost pyo files (#205408)
  93. * Tue Aug 29 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-3
  94. - Rebuild for Fedora Extras 6
  95. * Mon Feb 13 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-2
  96. - Rebuild for Fedora Extras 5
  97. * Wed Aug 17 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0.1-1
  98. - Update to 2.0.1
  99. - Use Dist
  100. - Drop python-crypto-64bit-unclean.patch, similar patch was applied
  101. upstream
  102. * Thu May 05 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-4
  103. - add python-crypto-64bit-unclean.patch (#156173)
  104. * Mon Mar 21 2005 Seth Vidal <skvidal at phy.duke.edu> - 0:2.0-3
  105. - iterate release for build on python 2.4 based systems
  106. * Sat Dec 18 2004 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-2
  107. - Fix build on x86_64: use python_sitearch for files and patch source
  108. to find gmp
  109. * Thu Aug 26 2004 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-0.fdr.1
  110. - Update to 2.00
  111. * Fri Aug 13 2004 Ville Skytta <ville.skytta at iki.fi> - 0:1.9-0.fdr.6.a6
  112. - Don't use get_python_version(), it's available in Python >= 2.3 only.
  113. * Thu Aug 12 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.5.a6
  114. - Own dir python_sitearch/Crypto/
  115. * Wed Aug 11 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.4.a6
  116. - Match python spec template more
  117. * Sat Jul 17 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.3.a6
  118. - Own _libdir/python/site-packages/Crypto/
  119. * Wed Mar 24 2004 Panu Matilainen <pmatilai@welho.com> 0.3.2-0.fdr.2.a6
  120. - generate .pyo files during install
  121. - require exact version of python used to build the package
  122. - include more docs + demos
  123. - fix dependency on /usr/local/bin/python
  124. - use fedora.us style buildroot
  125. - buildrequires gmp-devel
  126. - use description from README
  127. * Sun Jan 11 2004 Ryan Boder <icanoop@bitwiser.org> 0.3.2-0.fdr.1.a6
  128. - Initial build.