libffi-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define name libffi
  3. %define version 3.2.1
  4. %define release 1%{?_dist_release}
  5. Summary: Foreign function interface library
  6. Summary(ja): Foreign function interface ライブラリ
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. Source0: ftp://sourceware.org/pub/libffi/%{name}-%{version}.tar.gz
  11. Patch0: libffi-3.1-fix-include-path.patch
  12. License: Distributable
  13. Group: System Environment/Libraries
  14. URL: http://sourceware.org/libffi/
  15. BuildRequires: gcc
  16. BuildRequires: texinfo
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. %description
  21. A foreign function interface is the popular name for the interface
  22. that allows code written in one language to call code written in
  23. another language.
  24. %description -l ja
  25. Foreign function interface は一般に普及しているインターフェイスで、
  26. ある言語で書かれたコードから、他の言語で書かれたコードを呼び出すこ
  27. とを可能にします。
  28. #-----------------------------------------------------------------------------
  29. %package devel
  30. Summary: Libraries and headers for %{name}
  31. Summary(ja): %{name} 用の開発ライブラリおよびヘッダファイル
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}
  34. Requires: pkgconfig
  35. %description devel
  36. This package includes the files needed for developing and compiling
  37. applications which use the ffi library.
  38. You should install the libffi-devel package if you would like to
  39. develop applications using libffi.
  40. %description devel -l ja
  41. このパッケージは ffi ライブラリを使用するアプリケーションを開発
  42. するのに必要なライブラリやヘッダファイルを含んでいます。
  43. libffi を使用したアプリケーションを開発するなら、このパッケージ
  44. をインストールしてください。
  45. #compat32
  46. %package -n compat32-%{name}
  47. Summary: Foreign function interface library
  48. Summary(ja): Foreign function interface ライブラリ
  49. Group: System Environment/Libraries
  50. Requires: %{name} = %{version}
  51. %description -n compat32-%{name}
  52. A foreign function interface is the popular name for the interface
  53. that allows code written in one language to call code written in
  54. another language.
  55. %description -n compat32-%{name} -l ja
  56. Foreign function interface は一般に普及しているインターフェイスで、
  57. ある言語で書かれたコードから、他の言語で書かれたコードを呼び出すこ
  58. とを可能にします。
  59. %package -n compat32-%{name}-devel
  60. Summary: Libraries and headers for %{name}
  61. Summary(ja): %{name} 用の開発ライブラリおよびヘッダファイル
  62. Group: Development/Libraries
  63. Requires: compat32-%{name} = %{version}
  64. Requires: %{name}-devel = %{version}
  65. %description -n compat32-%{name}-devel
  66. This package includes the files needed for developing and compiling
  67. applications which use the ffi library.
  68. You should install the libffi-devel package if you would like to
  69. develop applications using libffi.
  70. %description -n compat32-%{name}-devel -l ja
  71. このパッケージは ffi ライブラリを使用するアプリケーションを開発
  72. するのに必要なライブラリやヘッダファイルを含んでいます。
  73. libffi を使用したアプリケーションを開発するなら、このパッケージ
  74. をインストールしてください。
  75. #-----------------------------------------------------------------------------
  76. %prep
  77. %setup -q
  78. %patch0 -p1
  79. %build
  80. autoreconf -ifv
  81. %configure
  82. %{__make}
  83. %install
  84. %{__rm} -rf ${RPM_BUILD_ROOT}
  85. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  86. # move include files.
  87. %{__mv} ${RPM_BUILD_ROOT}/%{_libdir}/libffi-%{version}/include ${RPM_BUILD_ROOT}/%{_includedir}
  88. sed -i -e "s|^includedir=.*include$|includedir=%{_includedir}|" \
  89. ${RPM_BUILD_ROOT}/%{_libdir}/pkgconfig/libffi.pc
  90. # remove unnecessary files.
  91. %{__rm} -rf ${RPM_BUILD_ROOT}/%{_libdir}/libffi.la
  92. %{__rm} -rf ${RPM_BUILD_ROOT}/%{_infodir}/dir
  93. %clean
  94. %{__rm} -rf ${RPM_BUILD_ROOT}
  95. %post -p /sbin/ldconfig
  96. %postun -p /sbin/ldconfig
  97. %files
  98. %defattr(-,root,root)
  99. %doc ChangeLog* LICENSE README
  100. %{_libdir}/libffi.so.*
  101. %{_infodir}/libffi.info*
  102. %{_mandir}/man3/ffi.3*
  103. %{_mandir}/man3/ffi_call.3*
  104. %{_mandir}/man3/ffi_prep_cif.3*
  105. %{_mandir}/man3/ffi_prep_cif_var.3*
  106. %files devel
  107. %defattr(-,root,root)
  108. %{_libdir}/pkgconfig/*
  109. %{_libdir}/libffi.a
  110. %{_libdir}/libffi.so
  111. %{_includedir}/*.h
  112. # compat32
  113. %if %{build_compat32}
  114. %files -n compat32-%{name}
  115. %defattr(-,root,root)
  116. %{_libdir}/libffi.so.*
  117. %files -n compat32-%{name}-devel
  118. %defattr(-,root,root)
  119. %{_libdir}/libffi.so
  120. %endif
  121. %changelog
  122. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.1-1
  123. - updated to 3.2.1.
  124. - imported Patch0 from rawhide.
  125. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.13-1
  126. - update to 3.0.13
  127. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.9-4
  128. - create compat32 sub packages
  129. * Fri Nov 26 2010 Shu KONNO <owa@bg.wakwak.com> 3.0.9-3
  130. - fixed includedir in libffi.pc
  131. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 3.0.9-2
  132. - build with rpm-4.8.1-1 for pkg-config file
  133. * Tue Feb 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.0.9-1
  134. - new upstream release
  135. - built with new toolchain
  136. * Wed Jan 21 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.0.8-1
  137. - new upstream release
  138. - spec in UTF-8
  139. * Thu Apr 17 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.0.5-1
  140. - updated to new upstream release
  141. * Wed Apr 02 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.0.4-1
  142. - apply new versioning policy
  143. * Sun Mar 02 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.0.4-0vl1
  144. - initial build for Vine Linux