libcrystalhd-vl.spec 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151
  1. Summary: Broadcom Crystal HD device interface library
  2. Name: libcrystalhd
  3. Version: 3.5.1
  4. Release: 1%{?_dist_release}
  5. License: LGPLv2
  6. Group: System Environment/Libraries
  7. #Source: http://www.broadcom.com/docs/support/crystalhd/crystalhd_linux_20100703.zip
  8. # This tarball and README are inside the above zip file...
  9. Source0: crystalhd_07032010.tbz2
  10. Source1: README_07032010
  11. # We're going to use even newer firmware for now
  12. Source2: bcm70012fw.bin
  13. Source3: bcm70015fw.bin
  14. # LICENSE file is copy-n-pasted from http://www.broadcom.com/support/crystal_hd/
  15. Source4: LICENSE
  16. Requires: crystalhd-firmware
  17. URL: http://www.broadcom.com/support/crystal_hd/
  18. # Patch generated from http://git.wilsonet.com/crystalhd.git/
  19. Patch0: libcrystalhd-updates.patch
  20. ExcludeArch: s390 s390x
  21. BuildRequires: autoconf automake
  22. %description
  23. The libcrystalhd library provides userspace access to Broadcom Crystal HD
  24. video decoder devices. The device supports hardware decoding of MPEG-2,
  25. h.264 and VC1 video codecs, up to 1080p at 40fps for the first-generation
  26. bcm970012 hardware, and up to 1080p at 60fps for the second-generation
  27. bcm970015 hardware.
  28. %package devel
  29. Summary: Development libs for libcrystalhd
  30. Group: Development/Libraries
  31. Requires: %{name} = %{version}-%{release}
  32. %description devel
  33. Development libraries needed to build applications against libcrystalhd.
  34. %package -n crystalhd-firmware
  35. Summary: Firmware for the Broadcom Crystal HD video decoder
  36. License: Redistributable, no modification permitted
  37. BuildArch: noarch
  38. Group: System Environment/Kernel
  39. Requires: %{name} = %{version}-%{release}
  40. %description -n crystalhd-firmware
  41. Firmwares for the Broadcom Crystal HD (bcm970012 and bcm970015)
  42. video decoders.
  43. %define majorminor 0.10
  44. %define _gst 0.10.30
  45. %define _gstpb 0.10.30
  46. %package -n gstreamer-plugin-crystalhd
  47. Summary: Gstreamer crystalhd decoder plugin
  48. Group: Applications/Multimedia
  49. Requires: %{name} = %{version}-%{release}
  50. Requires: gstreamer-plugins-base
  51. BuildRequires: gstreamer-devel >= %{_gst}
  52. BuildRequires: gstreamer-plugins-base-devel >= %{_gstpb}
  53. %description -n gstreamer-plugin-crystalhd
  54. Gstreamer crystalhd decoder plugin
  55. %prep
  56. %setup -q -n 07032010
  57. %patch0 -p1
  58. cp %{SOURCE1} %{SOURCE4} .
  59. %build
  60. pushd linux_lib/libcrystalhd/ > /dev/null 2>&1
  61. # FIXME: this doesn't work just yet...
  62. #make CPPFLAGS="%{optflags}" %{?_smp_mflags}
  63. make %{?_smp_mflags}
  64. popd > /dev/null 2>&1
  65. pushd filters/gst/gst-plugin/ > /dev/null 2>&1
  66. %configure
  67. make %{?_smp_mflags}
  68. popd > /dev/null 2>&1
  69. %install
  70. rm -rf $RPM_BUILD_ROOT
  71. pushd linux_lib/libcrystalhd/ > /dev/null 2>&1
  72. make install LIBDIR=%{_libdir} DESTDIR=$RPM_BUILD_ROOT
  73. popd > /dev/null 2>&1
  74. pushd filters/gst/gst-plugin/ > /dev/null 2>&1
  75. make install DESTDIR=$RPM_BUILD_ROOT
  76. rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-0.10/libgstbcmdec.{a,la}
  77. popd > /dev/null 2>&1
  78. cp -p %{SOURCE2} $RPM_BUILD_ROOT/lib/firmware/
  79. cp -p %{SOURCE3} $RPM_BUILD_ROOT/lib/firmware/
  80. %clean
  81. rm -rf $RPM_BUILD_ROOT
  82. %post -p /sbin/ldconfig
  83. %postun -p /sbin/ldconfig
  84. %files
  85. %defattr(-,root,root,0755)
  86. %doc README_07032010 LICENSE
  87. %{_libdir}/libcrystalhd.so.*
  88. %files devel
  89. %defattr(-,root,root,0755)
  90. %dir %{_includedir}/libcrystalhd
  91. %{_includedir}/libcrystalhd/*
  92. %{_libdir}/libcrystalhd.so
  93. %files -n crystalhd-firmware
  94. %defattr(-,root,root,0755)
  95. %doc LICENSE
  96. /lib/firmware/bcm70012fw.bin
  97. /lib/firmware/bcm70015fw.bin
  98. %files -n gstreamer-plugin-crystalhd
  99. %defattr(-,root,root,0755)
  100. %{_libdir}/gstreamer-%{majorminor}/*.so
  101. %changelog
  102. * Sun Feb 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 3.5.1-1
  103. - initial build based on Fedora rawhide
  104. * Sat Aug 28 2010 Jarod Wilson <jarod@redhat.com> - 3.5.1-1
  105. - Update to v3.5.1, now with nv12 support
  106. * Sun Jul 25 2010 Jarod Wilson <jarod@redhat.com> - 3.5.0-2
  107. - Tarball had object files in it, clean them out before building
  108. * Sat Jul 24 2010 Jarod Wilson <jarod@redhat.com> - 3.5.0-1
  109. - Rebase to 07032010 crystalhd sources
  110. - Large version-bump as driver and lib are now essentially 100%
  111. in sync with the Windows driver and lib
  112. - Ship firmware, now that Broadcom has posted a redistribution,
  113. no modification license to cover it
  114. - Build the gstreamer decoder plugin (will be moved to its own
  115. package sooner or later)
  116. * Sun Apr 04 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-4
  117. - Fix segfault on firmware upload
  118. * Fri Mar 26 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-3
  119. - Update to pre-0.9.26 libcrystalhd, which contains support
  120. for the new Broadcom BCM970015 Crystal HD decoder card
  121. * Thu Mar 11 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-2
  122. - Minor fixups to the as-yet-not-enabled firmware sub-package
  123. * Wed Jan 06 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-1
  124. - Initial package