chkconfig-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332
  1. Summary: A system tool for maintaining the /etc/rc*.d hierarchy.
  2. Summary(ja): /etc/rc.d の階層をメンテナンスするためのシステムツール
  3. Name: chkconfig
  4. Version: 1.3.51
  5. Release: 1%{?_dist_release}
  6. License: GPL
  7. Group: System Environment/Base
  8. Source: %{name}-%{version}.tar.bz2
  9. Source2: chkconfig.8
  10. Source3: ntsysv.8
  11. Source4: update-alternatives.ja.8
  12. Patch1: chkconfig-1.3.51-vine.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildPrereq: newt-devel popt
  15. Conflicts: initscripts <= 5.30-1
  16. %description
  17. Chkconfig is a basic system utility. It updates and queries runlevel
  18. information for system services. Chkconfig manipulates the numerous
  19. symbolic links in /etc/rc.d, to relieve system administrators of some
  20. of the drudgery of manually editing the symbolic links.
  21. %description -l ja
  22. chkconfig は基本的なシステムユーティリティである。これはシステムサービスの
  23. runlevel の情報をアップデートや検証する。chkconfig は /etc/rc.d の
  24. 多数のシンボリックリンクを操作しますので、システム管理者は手動で
  25. シンボリックリンクをたびたびエディットしなくてもよい。
  26. %package -n ntsysv
  27. Summary: A tool to set the stop/start of system services in a runlevel.
  28. Summary(ja): /etc/rc.d 階階層をメンテナンスするシステムツール
  29. Group: System Environment/Base
  30. %description -n ntsysv
  31. Ntsysv provides a simple interface for setting which system services
  32. are started or stopped in various runlevels (instead of directly
  33. manipulating the numerous symbolic links in /etc/rc.d). Unless you
  34. specify a runlevel or runlevels on the command line (see the man
  35. page), ntsysv configures the current runlevel (5 if you're using X).
  36. %description -n ntsysv -l ja
  37. ntsysv はシステムサービスの runlevel の情報をアップデートや検証する。
  38. ntsysv は システム管理者が直接/etc/rc.d の多数のシンボリックリンクを
  39. 操作することから解放する。
  40. %package -n alternatives
  41. Summary: maintain symbolic links determining default commands (from Debian dpkg utilities)
  42. Summary(ja): コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
  43. Group: System Environment/Base
  44. %description -n alternatives
  45. maintain symbolic links determining default commands (from Debian dpkg utilities)
  46. %description -n alternatives -l ja
  47. コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
  48. %prep
  49. %setup -q
  50. %patch1 -p1
  51. %build
  52. %ifarch sparc
  53. LIBMHACK=-lm
  54. %endif
  55. %__make %{?_smp_mflags} RPM_OPT_FLAGS="$RPM_OPT_FLAGS" LIBMHACK=$LIBMHACK
  56. %install
  57. rm -rf $RPM_BUILD_ROOT
  58. %__make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} SBINDIR=%{_sbindir} install
  59. mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
  60. ln -s rc.d/init.d $RPM_BUILD_ROOT/etc/init.d
  61. for n in 0 1 2 3 4 5 6; do
  62. mkdir -p $RPM_BUILD_ROOT/etc/rc.d/rc${n}.d
  63. ln -s rc.d/rc${n}.d $RPM_BUILD_ROOT/etc/rc${n}.d
  64. done
  65. mkdir -p $RPM_BUILD_ROOT%{_mandir}/ja/man8
  66. cp %SOURCE2 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/ja/man8
  67. # alternatives
  68. mv -f $RPM_BUILD_ROOT/%{_sbindir}/*alternatives $RPM_BUILD_ROOT/%{_syssbindir}
  69. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/alternatives
  70. mkdir -p $RPM_BUILD_ROOT/var/lib/rpm/alternatives
  71. install -m644 %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/ja/man8/alternatives.8
  72. ln -sf alternatives.8.gz $RPM_BUILD_ROOT%{_mandir}/ja/man8/update-alternatives.8.gz
  73. %clean
  74. rm -rf $RPM_BUILD_ROOT
  75. %files
  76. %defattr(-,root,root)
  77. /sbin/chkconfig
  78. /etc/init.d
  79. /etc/rc.d/init.d
  80. /etc/rc[0-6].d
  81. /etc/rc.d/rc[0-6].d
  82. %{_mandir}/*/chkconfig*
  83. %{_mandir}/ja/*/chkconfig*
  84. %{_localedir}/*/LC_MESSAGES/chkconfig.mo
  85. %files -n ntsysv
  86. %defattr(-,root,root)
  87. /usr/sbin/ntsysv
  88. %{_mandir}/*/ntsysv.8*
  89. %{_mandir}/ja/*/ntsysv.8*
  90. %files -n alternatives
  91. %defattr (-, root, root)
  92. /sbin/alternatives
  93. /sbin/update-alternatives
  94. %{_sysconfdir}/alternatives
  95. %{_mandir}/man8/*
  96. %{_mandir}/ja/man8/*
  97. /var/lib/rpm/alternatives
  98. %changelog
  99. * Fri Apr 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.51-1
  100. - new upstream release
  101. - enable fedora version of alternatives
  102. - add alternatives subpackage, replace debian's alternatives
  103. * Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.37-1
  104. - new upstream release
  105. * Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.34-1vl5
  106. - applied new versioning policy and spec in utf-8
  107. * Fri May 04 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.34-0vl2
  108. - dropped obsoleted Makefile.x86_64.patch
  109. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.34-0vl1
  110. - new upstream release
  111. * Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.17-1vl9
  112. - add Makefile.x86_64.patch
  113. * Wed May 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.17-1vl8
  114. - add Patch10 to skip xinetd parsing if not exist.
  115. * Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.17-1vl7
  116. - rebuild
  117. * Thu Sep 06 2001 akira yamada <akira@vinelinux.org> 1.2.17-1vl6
  118. - Requires -> Conflicts.
  119. apt-0.3.19.cnc.52-3vl1 can handle Conflicts-field nicely, so
  120. Conflicts/Pre-Depends-loop does not happen.
  121. * Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl5
  122. - Oops not PreReq but Requires. Fixed.
  123. * Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl4
  124. - change Conflicts: initscripts <= 5.30-1 to PreReq: initscripts > 5.30-1
  125. to avoid Conflicts/Pre-Depends loop on apt
  126. * Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
  127. - 1.2.17-1vl3
  128. - change checkbox color
  129. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  130. - 1.2.17-1vl2
  131. - rebuilt for VineSeed
  132. * Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org>
  133. - 1.2.17-1vl1
  134. * Wed Oct 18 2000 Bill Nottingham <notting@redhat.com>
  135. - ignore .rpmnew files (#18915)
  136. - fix typo in error message (#17575)
  137. * Wed Aug 30 2000 Nalin Dahyabhai <nalin@redhat.com>
  138. - make xinetd config files mode 0644, not 644
  139. * Thu Aug 24 2000 Erik Troan <ewt@redhat.com>
  140. - updated it and es translations
  141. * Sun Aug 20 2000 Bill Nottingham <notting@redhat.com>
  142. - get man pages in proper packages
  143. * Sun Aug 20 2000 Matt Wilson <msw@redhat.com>
  144. - new translations
  145. * Tue Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  146. - don't worry about extra whitespace on chkconfig: lines (#16150)
  147. * Wed Aug 10 2000 Trond Eivind Glomsr <teg@redhat.com>
  148. - i18n merge
  149. * Wed Jul 26 2000 Matt Wilson <msw@redhat.com>
  150. - new translations for de fr it es
  151. * Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
  152. - change prereqs
  153. * Sun Jul 23 2000 Bill Nottingham <notting@redhat.com>
  154. - fix ntsysv's handling of xinetd/init files with the same name
  155. * Fri Jul 21 2000 Bill Nottingham <notting@redhat.com>
  156. - fix segv when reading malformed files
  157. * Wed Jul 19 2000 Bill Nottingham <notting@redhat.com>
  158. - put links, rc[0-6].d dirs back, those are necessary
  159. * Tue Jul 18 2000 Bill Nottingham <notting@redhat.com>
  160. - add quick hack support for reading descriptions from xinetd files
  161. * Mon Jul 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  162. - don't own the /etc/rc[0-6].d symlinks; they're owned by initscripts
  163. * Sat Jul 15 2000 Matt Wilson <msw@redhat.com>
  164. - move back to old file layout
  165. * Thu Jul 13 2000 Preston Brown <pbrown@redhat.com>
  166. - bump copyright date
  167. * Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
  168. - no %pre today. Maybe tomorrow.
  169. * Thu Jul 6 2000 Bill Nottingham <notting@redhat.com>
  170. - put initscripts %pre here too
  171. * Mon Jul 3 2000 Bill Nottingham <notting@redhat.com>
  172. - oops, if we don't prereq initscripts, we *need* to own /etc/rc[0-6].d
  173. * Sun Jul 2 2000 Bill Nottingham <notting@redhat.com>
  174. - add xinetd support
  175. * Tue Jun 27 2000 Matt Wilson <msw@redhat.com>
  176. - changed Prereq: initscripts >= 5.18 to Conflicts: initscripts < 5.18
  177. - fixed sumary and description where a global string replace nuked them
  178. * Mon Jun 26 2000 Matt Wilson <msw@redhat.com>
  179. - what Bill said, but actually build this version
  180. * Thu Jun 15 2000 Bill Nottingham <notting@redhat.com>
  181. - don't own /etc/rc.*
  182. * Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
  183. - typo in man page
  184. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  185. - fix description
  186. * Wed Jan 12 2000 Bill Nottingham <notting@redhat.com>
  187. - link chkconfig statically against popt
  188. * Mon Oct 18 1999 Bill Nottingham <notting@redhat.com>
  189. - fix querying alternate levels
  190. * Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
  191. - don't use strchr to skip unwanted files, look at extension instead (#4166).
  192. * Thu Aug 5 1999 Bill Nottingham <notting@redhat.com>
  193. - fix --help, --verson
  194. * Mon Aug 2 1999 Matt Wilson <msw@redhat.com>
  195. - rebuilt ntsysv against newt 0.50
  196. * Mon Aug 2 1999 Jeff Johnson <jbj@redhat.com>
  197. - fix i18n problem in usage message (#4233).
  198. - add --help and --version.
  199. * Mon Apr 19 1999 Cristian Gafton <gafton@redhat.com>
  200. - release for Red Hat 6.0
  201. * Thu Apr 8 1999 Matt Wilson <msw@redhat.com>
  202. - added support for a "hide: true" tag in initscripts that will make
  203. services not appear in ntsysv when run with the "--hide" flag
  204. * Thu Apr 1 1999 Matt Wilson <msw@redhat.com>
  205. - added --hide flag for ntsysv that allows you to hide a service from the
  206. user.
  207. * Mon Mar 22 1999 Bill Nottingham <notting@redhat.com>
  208. - fix glob, once and for all. Really. We mean it.
  209. * Thu Mar 18 1999 Bill Nottingham <notting@redhat.com>
  210. - revert fix for services@levels, it's broken
  211. - change default to only edit the current runlevel
  212. * Mon Mar 15 1999 Bill Nottingham <notting@redhat.com>
  213. - don't remove scripts that don't support chkconfig
  214. * Tue Mar 09 1999 Erik Troan <ewt@redhat.com>
  215. - made glob a bit more specific so xinetd and inetd don't cause improper matches
  216. * Thu Feb 18 1999 Matt Wilson <msw@redhat.com>
  217. - removed debugging output when starting ntsysv
  218. * Thu Feb 18 1999 Preston Brown <pbrown@redhat.com>
  219. - fixed globbing error
  220. - fixed ntsysv running services not at their specified levels.
  221. * Tue Feb 16 1999 Matt Wilson <msw@redhat.com>
  222. - print the value of errno on glob failures.
  223. * Sun Jan 10 1999 Matt Wilson <msw@redhat.com>
  224. - rebuilt for newt 0.40 (ntsysv)
  225. * Tue Dec 15 1998 Jeff Johnson <jbj@redhat.com>
  226. - add ru.po.
  227. * Thu Oct 22 1998 Bill Nottingham <notting@redhat.com>
  228. - build for Raw Hide (slang-1.2.2)
  229. * Wed Oct 14 1998 Cristian Gafton <gafton@redhat.com>
  230. - translation updates
  231. * Thu Oct 08 1998 Cristian Gafton <gafton@redhat.com>
  232. - updated czech translation (and use cs instead of cz)
  233. * Tue Sep 22 1998 Arnaldo Carvalho de Melo <acme@conectiva.com.br>
  234. - added pt_BR translations
  235. - added more translatable strings
  236. - support for i18n init.d scripts description
  237. * Sun Aug 02 1998 Erik Troan <ewt@redhat.com>
  238. - built against newt 0.30
  239. - split ntsysv into a separate package
  240. * Thu May 07 1998 Erik Troan <ewt@redhat.com>
  241. - added numerous translations
  242. * Mon Mar 23 1998 Erik Troan <ewt@redhat.com>
  243. - added i18n support
  244. * Sun Mar 22 1998 Erik Troan <ewt@redhat.com>
  245. - added --back