123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342 |
- %{!?tcp_wrappers:%define tcp_wrappers 1}
- Summary: vsftpd - Very Secure Ftp Daemon
- Name: vsftpd
- Version: 3.0.2
- Release: 2%{?_dist_release}
- License: GPL
- Group: System Environment/Daemons
- URL: https://security.appspot.com/vsftpd.html
- Source: ftp://vsftpd.beasts.org/users/cevans/%{name}-%{version}.tar.gz
- Source1: vsftpd.xinetd
- Source2: vsftpd.pam
- Source3: vsftpd.ftpusers
- Source4: vsftpd.user_list
- Source5: vsftpd.init
- Source6: vsftpd_conf_migrate.sh
- Source7: vsftpd.service
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- # Build patches
- Patch1: vsftpd-2.1.0-libs.patch
- Patch2: vsftpd-2.1.0-build_ssl.patch
- Patch3: vsftpd-2.1.0-tcp_wrappers.patch
- # Use /etc/vsftpd/ instead of /etc/
- Patch4: vsftpd-2.1.0-configuration.patch
- # These need review
- Patch5: vsftpd-2.1.0-pam_hostname.patch
- Patch6: vsftpd-close-std-fds.patch
- Patch7: vsftpd-2.1.0-filter.patch
- Patch9: vsftpd-2.1.0-userlist_log.patch
- Patch10: vsftpd-2.1.0-trim.patch
- Patch12: vsftpd-2.1.1-daemonize_plus.patch
- Patch14: vsftpd-2.2.0-wildchar.patch
- Patch16: vsftpd-2.2.2-clone.patch
- Patch19: vsftpd-2.3.4-sd.patch
- Patch20: vsftpd-2.3.4-sqb.patch
- Patch21: vsftpd-2.3.5-aslim.patch
- Patch22: vsftpd-3.0.0-tz.patch
- Patch23: vsftpd-3.0.0-xferlog.patch
- Patch24: vsftpd-3.0.0-logrotate.patch
- Patch25: 07-utf8.patch
- #Vine custom
- Patch100: vsftpd-vine.patch
- %if %{tcp_wrappers}
- BuildRequires: tcp_wrappers
- %endif
- BuildRequires: libcap-devel
- BuildRequires: pam-devel
- BuildRequires: openssl-devel
- Requires: libcap
- Requires: logrotate
- Requires: openssl
- Requires: pam
- Requires(preun): /sbin/service
- Requires(postun): /sbin/service
- Provides: ftpserver
- %description
- vsftpd is a Very Secure FTP daemon. It was written completely from
- scratch.
- %prep
- %setup -q -n %{name}-%{version}
- cp %{SOURCE1} .
- %patch1 -p1 -b .libs
- %patch2 -p1 -b .build_ssl
- %if %{tcp_wrappers}
- %patch3 -p1 -b .tcp_wrappers
- %endif
- %patch4 -p1 -b .configuration
- %patch5 -p1 -b .pam_hostname
- %patch6 -p1 -b .close_fds
- %patch7 -p1 -b .filter
- %patch9 -p1 -b .userlist_log
- %patch10 -p1 -b .trim
- %patch12 -p1 -b .daemonize_plus
- %patch14 -p1 -b .wildchar
- %patch16 -p1 -b .clone
- %patch19 -p1 -b .sd
- %patch20 -p1 -b .sqb
- %patch21 -p1 -b .aslim
- %patch22 -p1 -b .tz
- %patch23 -p1 -b .xferlog
- %patch24 -p1 -b .logrotate
- %patch25 -p1
- %patch100 -p1 -b .vine_custom
- %build
- make CFLAGS="$RPM_OPT_FLAGS -fpie -pipe" \
- LINK="-pie -lssl" \
- %{?_smp_mflags}
- %install
- rm -rf $RPM_BUILD_ROOT
- mkdir -p $RPM_BUILD_ROOT%{_sbindir}
- mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
- mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/{vsftpd,pam.d,logrotate.d,rc.d/init.d}
- mkdir -p $RPM_BUILD_ROOT%{_mandir}/man{5,8}
- install -m 755 vsftpd $RPM_BUILD_ROOT%{_sbindir}/vsftpd
- install -m 600 vsftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/vsftpd/vsftpd.conf
- install -m 644 vsftpd.conf.5 $RPM_BUILD_ROOT/%{_mandir}/man5/
- install -m 644 vsftpd.8 $RPM_BUILD_ROOT/%{_mandir}/man8/
- install -m 644 RedHat/vsftpd.log $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/vsftpd
- install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/vsftpd
- install -m 600 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/vsftpd/ftpusers
- install -m 600 %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/vsftpd/user_list
- install -m 755 %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/vsftpd
- install -m 744 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/vsftpd/vsftpd_conf_migrate.sh
- mkdir -p $RPM_BUILD_ROOT/var/ftp/pub
- %clean
- [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
- %post
- /sbin/chkconfig --add vsftpd
- #/usr/sbin/usermod -d /var/ftp ftp >/dev/null 2>&1 || :
- %preun
- if [ $1 = 0 ]; then
- /sbin/service vsftpd stop > /dev/null 2>&1
- /sbin/chkconfig --del vsftpd
- fi
- %files
- %defattr(-,root,root,-)
- %{_sbindir}/vsftpd
- %dir %{_sysconfdir}/vsftpd
- %{_sysconfdir}/vsftpd/vsftpd_conf_migrate.sh
- %{_sysconfdir}/rc.d/init.d/vsftpd
- %config(noreplace) %{_sysconfdir}/vsftpd/ftpusers
- %config(noreplace) %{_sysconfdir}/vsftpd/user_list
- %config(noreplace) %{_sysconfdir}/vsftpd/vsftpd.conf
- %config(noreplace) %{_sysconfdir}/pam.d/vsftpd
- %config(noreplace) %{_sysconfdir}/logrotate.d/vsftpd
- %doc FAQ INSTALL BUGS AUDIT Changelog LICENSE README README.security REWARD
- %doc SPEED TODO BENCHMARKS COPYING SECURITY/ EXAMPLE/ TUNING SIZE vsftpd.xinetd
- %{_mandir}/man5/vsftpd.conf.*
- %{_mandir}/man8/vsftpd.*
- %{_var}/ftp
- %changelog
- * Sat Mar 08 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.3-2
- - rebuilt with new toolchain
- - changed URL
- * Sat Mar 30 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.2-1
- - new upstream release
- - synced Fedora rawhide sources
- - deleted customized configure for IPv6 in Patch4
- - added Patch25 from Debian to add UTF-8 support
- * Mon Oct 6 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.7-1
- - new upstream release
- - update patches from FedoraCore
- - add Source6 from FedoraCore
- * Sun May 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.5-0vl1
- - new upstream release
- - build with openssl-0.9.8e
- * Fri Sep 9 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.3-0vl1
- - new upstream release
- * Thu Mar 3 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.2-0vl1
- - new upstream release
- - disable patch5
- * Sat Nov 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-5vl2
- - rename patch1 and disable anonymous FTP
- * Mon Oct 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-5vl1
- - build for VineSeed
- - remove lines about s390, pie and patch4
- - add %%{_datadir}/empty to %%files
- - rename patch1 and add "use_localtime=YES"
- - remove Prereq: /sbin/chkconfig, /sbin/service, /usr/sbin/usermod
- because they must be installed
- - remove Obsoletes: anonftp
- - remove BuildRequires: libcap-devel and Requires: libcap
- * Fri Oct 01 2004 Radek Vokal <rvokal@redhat.com> 2.0.1-5
- - vsftpd under xinetd reads its config file (#134314)
- * Thu Sep 16 2004 Radek Vokal <rvokal@redhat.com> 2.0.1-4
- - spec file changed, ftp dir change commented (#130119)
- - added doc files (#113056)
- * Wed Sep 08 2004 Jan Kratochvil <project-vsftpd@jankratochvil.net>
- - update for 2.0.1 for SSL
- * Fri Aug 27 2004 Radek Vokal <rvokal@redhat.com> 2.0.1-2
- - vsftpd.conf file changed, default IPv6 support
- * Fri Aug 20 2004 Radek Vokal <rvokal@redhat.com> 2.0.1-1
- - tcp_wrapper patch updated, signal patch updated
- - upgrade to 2.0.1, fixes several bugs, RHEL and FC builds
- * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Wed May 19 2004 Bill Nottingham <notting@redhat.com> 1.2.1-6
- - fix the logrotate config (#116253)
- * Mon May 3 2004 Bill Nottingham <notting@redhat.com> 1.2.1-5
- - fix all references to vsftpd.conf to be /etc/vsftpd/vsftpd.conf,
- including in the binary (#121199, #104075)
- * Thu Mar 25 2004 Bill Nottingham <notting@redhat.com> 1.2.1-4
- - don't call malloc()/free() in signal handlers (#119136,
- <olivier.baudron@m4x.org>)
- * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Mon Nov 24 2003 Karsten Hopp <karsten@redhat.de> 1.2.1-1
- - update to 1.2.1, which fixes #89765 and lot of other issues
- - remove manpage patch, it isn't required anymore
- - clean up init script
- - don't use script to find libs to link with (lib64 issues)
- * Sun Oct 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
- - allow compiling without tcp_wrappers support
- * Mon Sep 15 2003 Bill Nottingham <notting@redhat.com> 1.2.0-4
- - fix errant newline (#104443)
- * Fri Aug 8 2003 Bill Nottingham <notting@redhat.com> 1.2.0-3
- - tweak man page (#84584, #72798)
- - buildprereqs for pie (#99336)
- - free ride through the build system to fix (#101582)
- * Thu Jun 26 2003 Bill Nottingham <notting@redhat.com> 1.2.0-2
- - update to 1.2.0
- * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Mon Apr 28 2003 Bill Nottingham <notting@redhat.com> 1.1.3-9
- - fix tcp_wrappers usage (#89765, <dale@riyescott.com>)
- * Fri Feb 28 2003 Nalin Dahyabhai <nalin@redhat.com> 1.1.3-8
- - enable use of tcp_wrappers
- * Tue Feb 11 2003 Bill Nottingham <notting@redhat.com> 1.1.3-7
- - provide /var/ftp & /var/ftp/pub. obsolete anonftp.
- * Mon Feb 10 2003 Bill Nottingham <notting@redhat.com> 1.1.3-6
- - clean up comments in init script (#83962)
- * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
- - rebuilt
- * Mon Dec 30 2002 Florian La Roche <Florian.LaRoche@redhat.de>
- - change to /etc/rc.d/init.d for better compatibility
- * Mon Dec 16 2002 Bill Nottingham <notting@redhat.com> 1.1.3-3
- - fix initscript perms
- - fix typo in initscript (#76587)
- * Fri Dec 13 2002 Bill Nottingham <notting@redhat.com> 1.1.3-2
- - update to 1.1.3
- - run standalone, don't run by default
- - fix reqs
-
- * Fri Nov 22 2002 Joe Orton <jorton@redhat.com> 1.1.0-3
- - fix use with xinetd-ipv6; add flags=IPv4 in xinetd file (#78410)
- * Tue Nov 12 2002 Nalin Dahyabhai <nalin@redhat.com> 1.0.1-9
- - remove absolute paths from PAM configuration so that the right modules get
- used for whichever arch we're built for on multilib systems
- * Thu Aug 15 2002 Elliot Lee <sopwith@redhat.com> 1.0.1-8
- - -D_FILE_OFFSET_BITS=64
- - smp make
- - remove forced optflags=-g for lack of supporting documentation
-
- * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
- - automated rebuild
- * Thu May 23 2002 Tim Powers <timp@redhat.com>
- - automated rebuild
- * Wed Apr 10 2002 Bill Nottingham <notting@redhat.com> 1.0.1-5
- - don't spit out ugly errors if anonftp isn't installed (#62987)
- - fix horribly broken userlist setup (#62321)
- * Thu Feb 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.0.1-4
- - s/Copyright/License/
- - add "missingok" to the logrotate script, so we don't get errors
- when nothing has happened
- * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
- - automated rebuild
- * Wed Nov 28 2001 Bill Nottingham <notting@redhat.com>
- - initial packaging for RHL, munge included specfile
- * Thu Mar 22 2001 Seth Vidal <skvidal@phy.duke.edu>
- - updated to 0.0.15
- - added entry for vsftpd.8 man page
- - added entry for vsftpd.log logrotate file
- - added TUNING file to docs list
- * Wed Mar 7 2001 Seth Vidal <skvidal@phy.duke.edu>
- - Updated to 0.0.14
- - made %%files entry for man page
- * Wed Feb 21 2001 Seth Vidal <skvidal@phy.duke.edu>
- - Updated to 0.0.13
- * Mon Feb 12 2001 Seth Vidal <skvidal@phy.duke.edu>
- - Updated to 0.0.12
- * Wed Feb 7 2001 Seth Vidal <skvidal@phy.duke.edu>
- - updated to 0.0.11
- * Thu Feb 1 2001 Seth Vidal <skvidal@phy.duke.edu>
- - Update to 0.0.10
- * Thu Feb 1 2001 Seth Vidal <skvidal@phy.duke.edu>
- - First RPM packaging
- - Stolen items from wu-ftpd's pam setup
- - Separated rh 7 and rh 6.X's packages
- - Built for Rh6
|