yatex-vl.spec 9.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. Name: yatex
  4. Version: 1.74
  5. Release: 8%{?_dist_release}
  6. License: Distributable
  7. Source0: http://www.yatex.org/yatex%{version}.tar.gz
  8. #Source0: http://www.yatex.org/yatex10203151806.tar.gz
  9. Source1: %{name}-install.sh
  10. Source2: %{name}-remove.sh
  11. Source3: %{name}-init.el
  12. Source4: vine-default-%{name}.el
  13. Source5: vine-default-yahtml.el
  14. ## pre-formatted info files here
  15. Source10: yatexe
  16. Source11: yatexj
  17. Source12: yahtmle
  18. Source13: yahtmlj
  19. ## Vine Patch(es)
  20. Patch0: yatex-info.diff
  21. Patch1: yatexhlp-emacs.diff
  22. Patch2: yatex-make.diff
  23. # based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
  24. # and modified to suit 1.70 release
  25. Patch3: yahtml-1.70-timestamp.patch
  26. URL: http://www.yatex.org/
  27. Group: Applications/Editors/Emacs
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  29. Summary: YaTeX - Yet Another TeX mode for Emacs
  30. Summary(ja): 野鳥(YaTeX) - Yet Another TeX mode for Emacs
  31. BuildArch: noarch
  32. PreReq: emacsen
  33. %prereq_ge emacsen-common
  34. Requires(post): make
  35. BuildRequires: emacsen-common
  36. Obsoletes: yatex-xemacs
  37. Distribution: Vine Linux
  38. Vendor: Project Vine
  39. %description
  40. YaTeX is an intelligent, acquisitive and integrated package which reduces
  41. your efforts of composing LaTeX source on GNU Emacs.
  42. If you are YaTeX user and you install both yatex and auctex on your system,
  43. you may add the following configure in your emacs init file
  44. %if %{?_dist_release} == "vl5"
  45. ~/.emacs.el:
  46. %else
  47. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
  48. %endif
  49. ;; I am YaTeX user!!!
  50. (setq vine-default-auctex nil
  51. vine-default-preview-latex nil)
  52. %description -l ja
  53. YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
  54. してくれる、LaTeX 入力支援環境です。
  55. yatex と auctex パッケージの両方をインストールする場合、
  56. %if %{?_dist_release} == "vl5"
  57. ~/.emacs.el:
  58. %else
  59. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
  60. %endif
  61. に以下の設定を追加するとよいでしょう。
  62. ;; YaTeX ユーザです!!!
  63. (setq vine-default-auctex nil
  64. vine-default-preview-latex nil)
  65. %prep
  66. %setup -n yatex%{version}
  67. %patch0 -p1
  68. %patch1 -p1
  69. %patch2 -p1
  70. %patch3 -p1
  71. %build
  72. (cd docs
  73. chmod 644 *
  74. %__install -v -m 644 %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} .
  75. )
  76. %install
  77. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  78. %__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
  79. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
  80. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
  81. %__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
  82. #
  83. # install el files
  84. #
  85. %__cp -a *.el makefile help \
  86. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
  87. %__cp -a %{SOURCE3} %{SOURCE4} %{SOURCE5} \
  88. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
  89. #
  90. # install info files
  91. #
  92. %__install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
  93. ${RPM_BUILD_ROOT}%{_infodir}
  94. #
  95. # install script (bytecompile el and install elc, remove)
  96. #
  97. %_installemacsenscript %{name} %{SOURCE1}
  98. %_removeemacsenscript %{name} %{SOURCE2}
  99. %clean
  100. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  101. %post
  102. #
  103. # bytecompile and install
  104. #
  105. if [ "$1" = 2 ] ; then
  106. %_emacsenPackageRemove %{name}
  107. fi
  108. %_addemacsenlist %{name}
  109. %_emacsenPackageInstall %{name}
  110. /sbin/install-info %{_infodir}/yatexe.gz %{_infodir}/dir \
  111. --section="Emacs"
  112. /sbin/install-info %{_infodir}/yatexj.gz %{_infodir}/dir \
  113. --section="Emacs"
  114. /sbin/install-info %{_infodir}/yahtmle.gz %{_infodir}/dir \
  115. --section="Emacs"
  116. /sbin/install-info %{_infodir}/yahtmlj.gz %{_infodir}/dir \
  117. --section="Emacs"
  118. %preun
  119. if [ "$1" = 0 ]; then
  120. %_emacsenPackageRemove %{name}
  121. %_removeemacsenlist %{name}
  122. /sbin/install-info --delete %{_infodir}/yatexe.gz %{_infodir}/dir \
  123. --section="Emacs"
  124. /sbin/install-info --delete %{_infodir}/yatexj.gz %{_infodir}/dir \
  125. --section="Emacs"
  126. /sbin/install-info --delete %{_infodir}/yahtmle.gz %{_infodir}/dir \
  127. --section="Emacs"
  128. /sbin/install-info --delete %{_infodir}/yahtmlj.gz %{_infodir}/dir \
  129. --section="Emacs"
  130. fi
  131. %files
  132. %defattr(-,root,root)
  133. %doc 00readme install manifest yatex.new
  134. %doc docs
  135. %{_datadir}/emacs/site-lisp/yatex/
  136. %{_infodir}/*
  137. %{emacsen_pkgdir}/install/%{name}
  138. %{emacsen_pkgdir}/remove/%{name}
  139. %changelog
  140. * Thu Aug 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-8
  141. - added Requires(post): make
  142. * Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-7
  143. - updated vine-default-yatex.el
  144. - check 'YaTeX-inhibit-prefix-letter
  145. - used "pbibtex -kanji=utf8" as default bibtex-command
  146. - used "mendex -U" as default makeindex-command
  147. * Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-6
  148. - updated vine-default-{yatex,yahtml}.el
  149. - revived auto-fill-mode on {yatex,yahtml}-mode
  150. * Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-5
  151. - updated yatex-init.el
  152. - dropped all pathes of auctex and preview-latex from load-path
  153. * Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-4
  154. - updated vine-default-yatex.el
  155. - added (setq YaTeX-inhibit-prefix-letter t) [yatex:04567]
  156. - supported TeX Live
  157. - used "eplatex", "pxdvi", "pdvips" as default commands
  158. - updated yatex-init.el
  159. - output "Loading vine-default-yatex ..." to the buffer *Messages*
  160. - defined vine-default-yahtml
  161. - added vine-default-yahtml.el
  162. * Tue Jan 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-3
  163. - updated vine-default-yatex.el
  164. - added bbl extension in auto-mode-alist to run yatex-mode
  165. * Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-2
  166. - updated vine-default-yatex.el
  167. - supported new vine-default
  168. * Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
  169. - new upstream release
  170. * Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
  171. - updated vine-default-yatex.el
  172. - dropped (setq YaTeX-no-begend-shortcut t)
  173. - use %{emacsen_pkgdir}
  174. * Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
  175. - updated vine-default-yatex.el
  176. - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
  177. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
  178. - updated yatex-install.sh
  179. - *-init.el: changed from hard copy to symbolic link
  180. on /etc/emacs-XX.YY/site-start.d
  181. * Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
  182. - fixed yatex-init.el
  183. * Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
  184. - added yatex-init.el, vine-default-yatex.el
  185. - updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
  186. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
  187. - spec in utf8
  188. * Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
  189. - applied new versioning policy
  190. * Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
  191. - new upstream release
  192. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
  193. - s/Copyright/License/
  194. - changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
  195. * Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
  196. - update yatex-1.72
  197. * Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
  198. - update yatex-1.71
  199. * Fri Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
  200. - added Patch3 to add hhmts timestamp feature
  201. * Tue May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
  202. - update yatex-1.70
  203. * Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
  204. - update yatex10203151806
  205. * Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
  206. - fixed: bytecompile yatex19
  207. * Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
  208. - now emacsen-common aware
  209. - FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
  210. * Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
  211. - 1.68-0vl2
  212. - no kanji code conversion of documents
  213. * Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
  214. - 1.68-0vl1
  215. - update to 1.68
  216. * Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  217. - 1.67-6vl5
  218. - YATEXHLP.{jp,eng} moved to appropriate dir
  219. * Thu Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  220. - 1.67-6vl3
  221. - rebuilt for emacs-20.7
  222. * Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  223. - 1.67-6vl2
  224. - oops ... fixed target dir for help files
  225. * Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  226. - 1.67-6vl1
  227. - rebuilt for emacs-20.6
  228. * Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  229. - 1.67-6
  230. - included forgotten info file for YaHTML
  231. * Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  232. - 1.67-5
  233. - updated for emacs-20.5a release
  234. * Wed Dec 1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  235. - 1.67-4
  236. - change Group to Applications/Editors/EmacsLisp
  237. * Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  238. - 1.67-3
  239. - %post and %preun section modified
  240. * Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  241. - 1.67-2
  242. - fixed minor problem in the %files section
  243. * Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  244. - 1.67-1
  245. - updated to 1.67 release
  246. - rebuilt for emacs-20.4 on Vine Linux 1.9
  247. - updated URL for the new web site of YaTeX
  248. - some typo fix
  249. * Tue May 4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  250. - Initial Release