deluge-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. Name: deluge
  4. Version: 1.2.3
  5. Release: 1%{?_dist_release}
  6. Summary: A GTK+ BitTorrent client with support for DHT, UPnP, and PEX
  7. Summary(ja): DHT・UPnP・PEX をサポートした GTK+ BitTorrent クライアント
  8. Group: Applications/Internet
  9. License: GPLv3 with exceptions
  10. URL: http://deluge-torrent.org/
  11. Source0: http://download.deluge-torrent.org/source/%{version}/%{name}-%{version}.tar.bz2
  12. ## The scalable icon needs to be installed to the proper place.
  13. Patch0: %{name}-scalable-icon-dir.diff
  14. Patch1: 010_new_release_check.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildArch: noarch
  17. BuildRequires: desktop-file-utils
  18. BuildRequires: python-devel
  19. BuildRequires: python-setuptools
  20. ## The build script checks for the libtorrent module and skips compiling the
  21. ## in-tarball one if this is found.
  22. BuildRequires: libtorrent-rasterbar-python >= 0.14.9
  23. Requires: gnome-python
  24. ## Required for the proper ownership of icon dirs.
  25. Requires: hicolor-icon-theme
  26. Requires: notify-python
  27. Requires: pygtk2-libglade
  28. Requires: pyOpenSSL
  29. Requires: python-chardet
  30. Requires: python-mako
  31. Requires: python-setuptools
  32. Requires: python-simplejson
  33. Requires: python-twisted
  34. Requires: pyxdg
  35. Requires: libtorrent-rasterbar-python >= 0.14.9
  36. %description
  37. Deluge is a new BitTorrent client, created using Python and GTK+. It is
  38. intended to bring a native, full-featured client to Linux GTK+ desktop
  39. environments such as GNOME and Xfce.
  40. %description -l ja
  41. Deluge は Python と GTK+ を用いて作成された新しい BitTorrent クライアントです。
  42. GNOME や Xfce のような Linux の GTK+ デスクトップ環境にネイティブかつフル機能の
  43. クライアントを提供することを意図しています。
  44. %package flags
  45. Summary: Country flags for peer location display in Deluge
  46. Group: Applications/Internet
  47. License: GPLv3
  48. Requires: %{name} = %{version}-%{release}
  49. %description flags
  50. The %{name}-flags package contains optional country flags which are used to
  51. display the location of peers in the "Peers" information tab.
  52. %prep
  53. %setup -qn "%{name}-%{version}"
  54. %patch0 -p0 -b .fix-scalable-icon-dir
  55. %patch1 -p1
  56. %build
  57. CFLAGS="%{optflags}" %{__python} setup.py build
  58. %install
  59. rm -rf %{buildroot}
  60. %{__python} setup.py install -O1 --skip-build --root %{buildroot}
  61. desktop-file-install --vendor vine \
  62. --dir %{buildroot}%{_datadir}/applications \
  63. --copy-name-to-generic-name \
  64. --add-mime-type=application/x-bittorrent \
  65. --delete-original \
  66. --remove-category=Application \
  67. %{buildroot}%{_datadir}/applications/%{name}.desktop
  68. ## NOTE: The lang files should REEEAALLLY be in a standard place such as
  69. ## /usr/share/locale or similar. It'd make things so much nicer for
  70. ## the packaging. :O
  71. ## A bit of sed magic to mark the translation files with %%lang, taken from
  72. ## find-lang.sh (part of the rpm-build package) and tweaked somewhat. We
  73. ## cannot (unfortunately) call find-lang directly since it's not on a
  74. ## "$PREFIX/share/locale/"-ish directory tree.
  75. pushd %{buildroot}
  76. find -type f -o -type l \
  77. | sed '
  78. s:%{buildroot}%{python_sitelib}::
  79. s:^\.::
  80. s:\(.*/deluge/i18n/\)\([^/_]\+\)\(.*\.mo$\):%lang(\2) \1\2\3:
  81. s:^\([^%].*\)::
  82. s:%lang(C) ::
  83. /^$/d' \
  84. > %{name}.filelist
  85. ## We've got the .mo files now; but we need the rest of the files in those
  86. ## dirs. We can't just glob in the %%files, as that would add duplicate
  87. ## entries for the .mo files which we've already marked with appropriate
  88. ## %%lang-fu.
  89. find ./%{python_sitelib}/%{name} -not -iname '%{name}.mo' -type f \
  90. | grep -v 'pixmaps/flags' | sed 's:^\./::' >> %{name}.filelist
  91. find ./%{python_sitelib}/%{name} -type d | grep -v 'pixmaps/flags' \
  92. | sed 's:^\./:%%dir :' >> %{name}.filelist
  93. ## Now we move that list back to our sources, so that '%%files -f' can find it
  94. ## properly.
  95. popd && mv %{buildroot}/%{name}.filelist .
  96. %clean
  97. rm -rf %{buildroot}
  98. %files -f %{name}.filelist
  99. %defattr(-,root,root,-)
  100. %doc ChangeLog LICENSE README
  101. %{python_sitelib}/%{name}-%{version}-py?.?.egg-info/
  102. %{_bindir}/%{name}
  103. %{_bindir}/%{name}-*
  104. %{_bindir}/%{name}d
  105. %{_datadir}/applications/vine-%{name}.desktop
  106. %{_datadir}/pixmaps/%{name}.*
  107. %{_datadir}/icons/hicolor/*/apps/%{name}.*
  108. %{_mandir}/man?/%{name}*
  109. %files flags
  110. %defattr(-,root,root,-)
  111. %doc LICENSE
  112. %{python_sitelib}/%{name}/data/pixmaps/flags/
  113. %post
  114. update-desktop-database &>/dev/null ||:
  115. touch --no-create %{_datadir}/icons/hicolor
  116. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  117. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  118. fi
  119. %postun
  120. update-desktop-database &> /dev/null ||:
  121. touch --no-create %{_datadir}/icons/hicolor
  122. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  123. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  124. fi
  125. %changelog
  126. * Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.3-1
  127. - new upstream release
  128. * Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.1-1
  129. - new upstream release
  130. - added Requires: python-mako, notify-python, gnome-python
  131. - removed Requires: /bin/sh, dbus-python, dbus-x11
  132. - changed BuildRequires and Requires: libtorrent-rasterbar-python >= 0.14.9
  133. - applied new naming policy to spec
  134. * Tue Feb 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-2
  135. - rebuilt with python-2.6.4
  136. * Tue Jan 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-1
  137. - new upstream release
  138. - added Patch1 from Debian to disable update
  139. - added Requires: python-twisted, python-simplejson
  140. * Mon Sep 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.9-1
  141. - initial build for VineSeed
  142. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-3
  143. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  144. * Wed Jul 08 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.9-2
  145. - Fixed rb_libtorrent-python dependency, so as not to use the
  146. %%min_rblibtorrent_ver macro any more (#510264).
  147. * Wed Jun 17 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.9-1
  148. - Update to new upstream bug-fix release (1.1.9).
  149. - Do not hard-code minimum rb_libtorrent version. (We're only building against
  150. the system rb_libtorrent for Fedora 11+, which already has the necessary
  151. version.)
  152. * Wed May 27 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.8-1
  153. - Update to new upstream release (1.1.8) for bug-fixes and some translation
  154. updates. Adds dependency on chardet for fixing lots of bugs with torrents
  155. which are not encoded as UTF-8.
  156. - Add back the flags, in an optional -flags subpackage as per the new Flags
  157. policy (Package_Maintainers_Flags_Policy on the wiki).
  158. - Add LICENSE and README to installed documentation.
  159. * Fri May 08 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.7-2
  160. - Rebuild for the Boost 1.39.0 update.
  161. * Sat May 02 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.7-1
  162. - Update to new upstream bug-fix release (1.1.7).
  163. * Mon Apr 06 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.6-1
  164. - Update to new upstream bug-fix release (1.1.6)
  165. - Fix GPL version, add OpenSSL exception to License.
  166. - Remove libtool, openssl-devel, and boost-devel BuildRequires (were only
  167. necessary when building the in-tarball libtorrent copy).
  168. * Mon Mar 16 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.5-1
  169. - Update to new upstream bug-fix release (1.1.5)
  170. - Remove FIXME comment about parallel-compilation. We're not building the
  171. in-tarball libtorrent copy anymore, so no compilation (other than the python
  172. bytecode) happens and we no longer need to worry about this.
  173. * Tue Mar 10 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.4-2
  174. - Fix the installed location of the scalable (SVG) icon (#483443).
  175. + scalable-icon-dir.diff
  176. * Mon Mar 09 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.4-1
  177. - Update to new upstream bug-fix release (1.1.4)
  178. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-2
  179. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  180. * Sun Feb 15 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.3-1
  181. - Update to new upstream bug-fix release (1.1.3)
  182. * Sun Feb 01 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.2-2
  183. - Fix scalable icon directory ownership (#483443).
  184. * Sat Jan 31 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.2-1
  185. - Update to new upstream bug-fix release (1.1.2)
  186. * Sun Jan 25 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.1-1
  187. - Update to new upstream bug-fix release (1.1.1)
  188. * Sun Jan 11 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-1
  189. - Update to new upstream release (1.1.0 Final - yay!)
  190. - Drop the get_tracker_host patch (fixed upstream):
  191. - fix-get_tracker-host-if-no-tracker.patch
  192. * Fri Jan 09 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.4.rc3
  193. - Do not package the country flags data.
  194. - Resolves: #479265 (country flags should not be used in Deluge)
  195. * Wed Jan 07 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.3.rc3
  196. - Add patch from upstream SVN to fix an error where torrents are not shown (or
  197. possibly shown in "Error" states) due to a bad inet_aton call:
  198. + fix-get_tracker-host-if-no-tracker.patch
  199. - Resolves: #479097 (No torrent shown in menu); thanks to Mamoru Tasaka for
  200. the bug report.
  201. - Fix day of previous %%changelog entry.
  202. * Tue Jan 06 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.2.rc3
  203. - Update to new upstream release candidate (1.1.0 RC3)
  204. - Build against the system rb_libtorrent instead of using the in-tarball copy
  205. (requires rb_libtorrent 0.14+), and adjust dependencies accordingly. Drop
  206. the hacked setup.py script formerly used to enable this (fixed upstream):
  207. - fixed-setup.py
  208. - Make it a noarch package now that it's just python scripts and related
  209. data files (translations, images, etc.)
  210. * Mon Dec 29 2008 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.1.rc2
  211. - Update to new upstream release candidate (1.1.0 RC2)
  212. * Thu Dec 18 2008 Petr Machata <pmachata@redhat.com> - 1.0.7-2
  213. - Rebuild for new boost.
  214. * Tue Dec 16 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.7-1
  215. - Update to new upstream bug-fix release (1.0.7)
  216. - Remove CC-BY-SA license (the Tango WebUI images have been replaced by upstream).
  217. * Mon Dec 01 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.6-1
  218. - Update to new upstream release (1.0.6)
  219. - Adds Tango images to the WebUI data (CC-BY-SA) and some man pages.
  220. - Properly mark translation files with %%lang.
  221. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.5-3
  222. - Fix locations for Python 2.6
  223. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.5-2
  224. - Rebuild for Python 2.6
  225. * Thu Nov 13 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.5-1
  226. - Update to new upstream release (1.0.5)
  227. * Fri Oct 31 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.4-1
  228. - Update to new upstream release (1.0.4).
  229. * Fri Oct 24 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.3-1
  230. - Update to new upstream release (1.0.3)
  231. * Sun Oct 12 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.2-1
  232. - Update to new upstream release (1.0.2)
  233. - Drop multithreaded boost compilation patch (fixed upstream, again).
  234. - mt-boost-fix.patch
  235. * Sat Sep 27 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.0-1
  236. - Update to new upstream release (1.0.0 Final)
  237. - Apply patch from Mamoru Tasaka to build against the multi-threaded Boost
  238. libraries once more:
  239. + mt-boost-fix.patch
  240. - Resolves: #464151 (About 1.0.0 build failure)
  241. * Tue Sep 16 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.09-1
  242. - Update to new upstream release candidate (1.0.0 RC9)
  243. - Drop mt-boost patch (fixed upstream):
  244. - use-mt-boost.patch
  245. * Sun Sep 07 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.08-1
  246. - Update to new upstream release candidate (1.0.0 RC8)
  247. - Drop state_upgrade script from the documentation. (This is now handled
  248. automatically.)
  249. - Fix version in previous %%changelog entry.
  250. * Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.07-1
  251. - Update to new upstream release candidate (1.0.0 RC7)
  252. - Drop desktop file icon name hack (fixed upstream).
  253. * Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.06-1
  254. - Update to new upstream release candidate (1.0.0 RC6)
  255. - Drop desktop file icon name hack (fixed upstream).
  256. * Fri Aug 01 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.04-1
  257. - Update to new upstream release candidate (1.0.0 RC4)
  258. * Wed Jul 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.03-2
  259. - Add setuptools runtime dependency, to fix "No module named pkg_resources"
  260. error messages.
  261. * Mon Jul 21 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.03-1
  262. - Update to new upstream release candidate (1.0.0 RC3)
  263. - Re-add the blocklist plugin, at upstream's suggestion. (The rewrite is
  264. complete.)
  265. * Tue Jul 15 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.02-1
  266. - Update to new upstream release candidate (1.0.0 RC2)
  267. - Force building against the multithreaded Boost libs.
  268. + use-mt-boost.patch
  269. - Remove python-libtorrent Obsoletes. (It's been dead for 3 releases now; and
  270. is just clutter.)
  271. - Remove the blocklist plugin, at upstream's recommendation.
  272. * Tue Jun 24 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.3-1
  273. - Update to new upstream release (0.5.9.3)
  274. * Fri May 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.1-1
  275. - Update to new upstream release (0.5.9.1)
  276. * Fri May 02 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.0-1
  277. - Update to new upstream release (0.5.9.0)
  278. - Drop upstreamed default-preferences patch for disabling new version
  279. notifications:
  280. - default-prefs-no-release-notifications.patch
  281. * Tue Apr 15 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.9-1
  282. - Update to new upstream release (0.5.8.9)
  283. * Wed Mar 26 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.7-1
  284. - Update to new upstream release (0.5.8.7)
  285. * Mon Mar 17 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.6-1
  286. - Update to new upstream release (0.5.8.6)
  287. * Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.5-1
  288. - Update to new upstream release (0.5.8.5)
  289. * Sat Feb 16 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.4-1
  290. - Update to new upstream release (0.5.8.4)
  291. - Rebuild for GCC 4.3
  292. * Mon Jan 28 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.3-1
  293. - Update to new upstream security fix release (0.5.8.3), which includes a fix
  294. for a potential remotely-exploitable stack overflow with a malformed
  295. bencoded message.
  296. * Sat Jan 19 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.1-1
  297. - Update to new upstream bugfix release (0.5.8.1)
  298. * Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8-3
  299. - Add runtime dependency on dbus-x11 for the dbus-launch utility. Fixes bug
  300. 428106 (Missing BR dbus-x11).
  301. - Bump release to 3 to maintain a proper F8->F9+ upgrade path.
  302. * Mon Dec 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.8-1
  303. - Update to new upstream release (0.5.8)
  304. - Merge Mamoru Tasaka's no-release-notification patch into the default-prefs
  305. patch.
  306. * Sat Dec 29 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.5.7.98-1
  307. - Update to new upstream release candidate (0.5.8 RC2)
  308. * Mon Dec 24 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.5.7.95-1
  309. - Update to new upstream release candidate (0.5.8 RC1)
  310. - Completely suppress updates notification (bug 299601, 426642)
  311. * Sun Dec 09 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7.1-2
  312. - Add missing icon cache %%post and %%postun scriptlets.
  313. - Add missing egg-info to the %%files list.
  314. * Fri Dec 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7.1-1
  315. - Update to new upstream bug-fix release (0.5.7.1).
  316. - Sort %%files list (aesthetic-only change).
  317. * Wed Dec 05 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7-3
  318. - Fix previous %%changelog Version.
  319. - Cleanup the installed .desktop file. Fixes bug 413101 (deluge fails to build
  320. in rawhide bad .desktop file.)
  321. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.7-2
  322. - Rebuild for deps
  323. * Tue Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7-1
  324. - Update to new upstream release (0.5.7)
  325. * Sat Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.96-1
  326. - Update to new upstream release candidate (0.5.7 RC2)
  327. - Drop plugin error patch (fixed upstream):
  328. - plugin-not-found-OK.patch
  329. * Sat Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.95-1
  330. - Update to new upstream release candidate (0.5.7 RC)
  331. - Update Source0 url
  332. - Add upstream patch to prevent dying if plugin in prefs.state is not found on
  333. the filesystem:
  334. + plugin-not-found-OK.patch
  335. * Wed Oct 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.2-1
  336. - Update to new upstream bug-fix release (0.5.6.2)
  337. * Tue Oct 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.1-1
  338. - Update to new upstream bug-fix release (0.5.6.1)
  339. - Drop use-mt-boost build script patch (fixed upstream):
  340. - use-mt-boost.patch
  341. * Sat Oct 27 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6-1
  342. - Update to new upstream release (0.5.6)
  343. * Wed Oct 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5.95-1
  344. - Update to new upstream release candidate (0.5.6 RC1)
  345. * Thu Sep 20 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5-2
  346. - Fix release on previous %%changelog entry.
  347. - Disable the version update notifications by default:
  348. + default-prefs-no-release-notifications.patch
  349. (Resolves bug 299601: Deluge alerts of new versions)
  350. * Wed Sep 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5-1
  351. - Update to new upstream release (0.5.5)
  352. * Mon Sep 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4.1.95-1
  353. - Update to new upstream release candidate (0.5.5 RC1)
  354. * Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4.1-1
  355. - Update to new upstream release (0.5.4.1)
  356. - Build with new binutils to gain BuildID debugging goodness.
  357. * Mon Aug 06 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4-1
  358. - Update to new upstream release (0.5.4)
  359. * Fri Aug 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.3-2
  360. - Update License tag (GPLv2+).
  361. - Rebuild against new Boost libraries, adding a patch to build against the
  362. multi-threaded ("*-mt") libraries:
  363. + use-mt-boost.patch
  364. * Wed Jul 25 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.3-1
  365. - Update to new upstream release candidate (0.5.3)
  366. - Drop %%ifarch invocations for 64-bit builds. The internal setup script now
  367. properly determines this and adds the AMD64 compiler definition if necessary.
  368. * Fri Jul 20 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2.90-1
  369. - Update to new upstream release candidate (0.5.3 RC1)
  370. - Drop stale persistence fix patch (applied upstream):
  371. - fix-persistence-upgrade-rhbz_247927.patch
  372. * Wed Jul 11 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2-2
  373. - Add patch to fix the existence of stale persistence files by automatically
  374. updating the deluge.deluge module name to deluge.core, or removing them if
  375. empty (bug 247927):
  376. + fix-persistence-upgrade-rhbz_247927.patch
  377. * Sun Jul 08 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2-1
  378. - Update to new upstream release (0.5.2)
  379. - Update Summary and %%description to reflect new µTorrent-compatible Peer
  380. Exchange ("PEX") functionality.
  381. * Thu Jun 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0.90.2-2
  382. - Update to new upstream release (0.5.1 Beta 2)
  383. * Sun Apr 08 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0-2
  384. - Make Deluge the upgrade path of the now-orphaned python-libtorrent package.
  385. * Mon Mar 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0-1
  386. - Update to new upstream release (0.5.0).
  387. * Mon Mar 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.2-1
  388. - Update to new upstream release (0.5 RC2).
  389. - Drop IndexError exception-handling fix (applied upstream):
  390. - delugegtk.py-fix-IndexError-exception-handling.patch
  391. - Use the system libtool instead of the one from the sources to ensure
  392. that no unnecessary RPATH hacks are added to the final build.
  393. * Wed Mar 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-3
  394. - Add a patch (submitted upstream) to properly catch a thrown IndexError in
  395. state message updates. This should resolve the bug wherein the UI stops
  396. updating its details and torrent listing.
  397. + delugegtk.py-fix-IndexError-exception-handling.patch
  398. * Wed Mar 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-2
  399. - Drop unneeded 64bit-python_long patch; as it seems to cause more trouble than
  400. it's worth. Instead, pass -DAMD64 as a compiler flag on 64-bit arches.
  401. - 64bit-python_long patch
  402. (This should fix the bug where, even though torrents are active, they are not
  403. shown in the GtkTreeView listing.)
  404. * Tue Mar 06 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-1
  405. - Update to new upstream release (0.5 RC1).
  406. - Use rewritten setup.py instead of patching it so much, since it's easier to
  407. maintain across version upgrades and whatnot:
  408. + fixed-setup.py
  409. - Remove the setup.py patches (no longer needed, since I'm packaging my own):
  410. - setup.py-dont-store-the-install-dir.patch
  411. - setup.py-build-against-system-libtorrent.patch
  412. * Fri Mar 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.3-1
  413. - Update to new upstream release (0.5 Beta 3).
  414. - Add patch to fix storing of installation directory:
  415. + setup.py-dont-store-the-install-dir.patch
  416. (to be applied after setup.py-build-against-system-libtorrent.patch)
  417. * Sun Feb 25 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.2-2
  418. - Add patch to fix 64-bit python_long type.
  419. + 64bit-python_long.patch
  420. * Sat Feb 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.2-1
  421. - Update to new upstream release (0.5 Beta 2)
  422. - Add patch to force building against system copy of rb_libtorrent:
  423. + setup.py-build-against-system-libtorrent.patch
  424. - Remove python-libtorrent and a few other dependencies that are no longer
  425. used.
  426. * Fri Feb 23 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-6
  427. - Fix Source0 URL.
  428. * Wed Feb 21 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-5
  429. - Make notify-python dependency conditional (FC6+ only)
  430. - Strip the unneeded shebang lines from the plugin scripts, since they are not
  431. meant to be directly executed.
  432. * Wed Feb 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-4
  433. - Update .desktop file: Icon should not have the "-256" size suffix.
  434. - Add Requires: notify-python
  435. - Remove strict dependency on python 2.3+, since we're targetting FC5+
  436. only, which has 2.4+.
  437. * Wed Jan 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-3
  438. - Use install instead of the cp/find/chmod fiasco of earlier releases for
  439. clarity and proper permissions setting.
  440. - Be more consistent about use of %%{name} and other macros in file naming as
  441. well as whitespace between sections.
  442. * Sun Jan 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-2
  443. - Bump python-libtorrent dependency to 0.3.0-4, which contains a fix for
  444. 64-bit systems.
  445. * Wed Jan 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-1
  446. - Initial packaging for Fedora Extras.