yatex-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371
  1. %define _noVersionedDependencies 1
  2. #% define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. Name: yatex
  4. Version: 1.77
  5. Release: 1%{?_dist_release}
  6. License: Distributable
  7. Source0: http://www.yatex.org/yatex%{version}.tar.gz
  8. #Source0: http://www.gentei.org/~yuuji/tmp/yatex11205111805.tar.gz
  9. Source1: %{name}-install.sh
  10. Source2: %{name}-remove.sh
  11. Source3: %{name}-init.el
  12. Source4: vine-default-%{name}.el
  13. Source5: vine-default-yahtml.el
  14. ## Vine Patch(es)
  15. Patch1: yatexhlp-emacs.diff
  16. Patch2: yatex-make.diff
  17. # based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
  18. # and modified to suit 1.70 release
  19. Patch3: yahtml-1.70-timestamp.patch
  20. Patch10: yatex-1.77-vine-vl7.patch
  21. Patch11: yatex-1.77-vine-vl6.patch
  22. URL: http://www.yatex.org/
  23. Group: Applications/Editors/Emacs
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. Summary: YaTeX - Yet Another TeX mode for Emacs
  26. Summary(ja): 野鳥(YaTeX) - Yet Another TeX mode for Emacs
  27. BuildArch: noarch
  28. Requires(post): emacsen
  29. Requires(post): emacsen-common
  30. Requires(post): make
  31. BuildRequires: emacsen-common
  32. BuildRequires: nkf perl
  33. Obsoletes: yatex-xemacs
  34. Distribution: Vine Linux
  35. Vendor: Project Vine
  36. Packager: munepi
  37. %description
  38. YaTeX is an intelligent, acquisitive and integrated package which reduces
  39. your efforts of composing LaTeX source on GNU Emacs.
  40. If you are YaTeX user and you install both yatex and auctex on your system,
  41. you may add the following configure in your emacs init file
  42. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
  43. ;; I am a YaTeX user!!!
  44. (setq vine-default-auctex nil
  45. vine-default-preview-latex nil)
  46. %description -l ja
  47. YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
  48. してくれる、LaTeX 入力支援環境です。
  49. yatex と auctex パッケージの両方をインストールする場合、
  50. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
  51. に以下の設定を追加するとよいでしょう。
  52. ;; YaTeX ユーザです!!!
  53. (setq vine-default-auctex nil
  54. vine-default-preview-latex nil)
  55. %prep
  56. %setup -n yatex%{version}
  57. %patch1 -p1
  58. %patch2 -p1
  59. %patch3 -p1
  60. %if %{?_dist_release} == "vl7"
  61. %patch10 -p1 -b .vine
  62. %endif
  63. %if %{?_dist_release} == "vl6"
  64. %patch11 -p1 -b .vine
  65. %endif
  66. (cd docs
  67. # change permissions
  68. chmod 644 *
  69. # encode as utf-8 (LF)
  70. # NOTE: This changes needs to entry info files to Info DIR
  71. for i in yatexj yatexe yahtmlj yahtmle; do nkf --unix -w --overwrite $i; done
  72. )
  73. %build
  74. %install
  75. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  76. %__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
  77. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
  78. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
  79. %__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
  80. #
  81. # install el files
  82. #
  83. %__cp -a *.el makefile help \
  84. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
  85. %__cp -a %{SOURCE3} %{SOURCE4} %{SOURCE5} \
  86. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
  87. #
  88. # install info files
  89. #
  90. %__install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
  91. ${RPM_BUILD_ROOT}%{_infodir}
  92. #
  93. # install script (bytecompile el and install elc, remove)
  94. #
  95. %_installemacsenscript %{name} %{SOURCE1}
  96. %_removeemacsenscript %{name} %{SOURCE2}
  97. %clean
  98. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  99. %post
  100. #
  101. # bytecompile and install
  102. #
  103. if [ "$1" = 2 ] ; then
  104. %_emacsenPackageRemove %{name}
  105. fi
  106. %_addemacsenlist %{name}
  107. %_emacsenPackageInstall %{name}
  108. for i in yatexe yatexj yahtmle yahtmlj; do
  109. /sbin/install-info --dir-file %{_infodir}/dir --section="Emacs" \
  110. %{_infodir}/${i}.gz
  111. done
  112. %preun
  113. if [ "$1" = 0 ]; then
  114. %_emacsenPackageRemove %{name}
  115. %_removeemacsenlist %{name}
  116. for i in yatexe yatexj yahtmle yahtmlj; do
  117. /sbin/install-info --delete --dir-file %{_infodir}/dir --section="Emacs" \
  118. %{_infodir}/${i}.gz
  119. done
  120. fi
  121. %files
  122. %defattr(-,root,root)
  123. %doc 00readme install manifest yatex.new
  124. %doc docs
  125. %{_datadir}/emacs/site-lisp/yatex/
  126. %{_infodir}/yahtmle*
  127. %{_infodir}/yahtmlj*
  128. %{_infodir}/yatexe*
  129. %{_infodir}/yatexj*
  130. %{emacsen_pkgdir}/install/%{name}
  131. %{emacsen_pkgdir}/remove/%{name}
  132. %changelog
  133. * Mon May 13 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.77-1
  134. - new upstream release
  135. - applied yatex-1.77-vine-vl{6,7}.patch instead
  136. * Tue May 22 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.76-2
  137. - new upstream release
  138. - updated yatex-1.76-vine-vl{6,7}.patch
  139. * Sat May 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.76-1.20120511
  140. - source snapshot 20120511: testing version 1.76 development
  141. - dropped obsoleted/upstreamed patches
  142. - applied yatex-1.76-vine-vl{6,7}.patch
  143. * Fri May 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-3
  144. - added BuildRequires: nkf perl
  145. - updated yatex-1.74-vine.patch as yatex-1.75-vine-vl{6,7}.patch
  146. - dropped pre-formatted info files
  147. - use original info files
  148. - encode info files as utf-8
  149. - add INFO-DIR-ENTRY
  150. * Thu May 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-2
  151. - fixed vine-default-yatex.el
  152. - applied yatex-1.74-vine.patch for vl6
  153. - updated yatex-1.74-vine.patch: support some extensions for \includegraphics
  154. * Thu Feb 9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-1
  155. - new upstream release
  156. - updated vine-default-yatex.el
  157. * Sat Dec 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-9
  158. - support TeX Live 2011
  159. - applied yatex-1.74-vine-vl7.patch
  160. - updated vine-default-yatex.el
  161. * Thu Aug 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-8
  162. - added Requires(post): make
  163. * Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-7
  164. - updated vine-default-yatex.el
  165. - check 'YaTeX-inhibit-prefix-letter
  166. - used "pbibtex -kanji=utf8" as default bibtex-command
  167. - used "mendex -U" as default makeindex-command
  168. * Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-6
  169. - updated vine-default-{yatex,yahtml}.el
  170. - revived auto-fill-mode on {yatex,yahtml}-mode
  171. * Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-5
  172. - updated yatex-init.el
  173. - dropped all pathes of auctex and preview-latex from load-path
  174. * Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-4
  175. - updated vine-default-yatex.el
  176. - added (setq YaTeX-inhibit-prefix-letter t) [yatex:04567]
  177. - supported TeX Live
  178. - used "eplatex", "pxdvi", "pdvips" as default commands
  179. - updated yatex-init.el
  180. - output "Loading vine-default-yatex ..." to the buffer *Messages*
  181. - defined vine-default-yahtml
  182. - added vine-default-yahtml.el
  183. * Tue Jan 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-3
  184. - updated vine-default-yatex.el
  185. - added bbl extension in auto-mode-alist to run yatex-mode
  186. * Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-2
  187. - updated vine-default-yatex.el
  188. - supported new vine-default
  189. * Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
  190. - new upstream release
  191. * Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
  192. - updated vine-default-yatex.el
  193. - dropped (setq YaTeX-no-begend-shortcut t)
  194. - use %{emacsen_pkgdir}
  195. * Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
  196. - updated vine-default-yatex.el
  197. - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
  198. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
  199. - updated yatex-install.sh
  200. - *-init.el: changed from hard copy to symbolic link
  201. on /etc/emacs-XX.YY/site-start.d
  202. * Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
  203. - fixed yatex-init.el
  204. * Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
  205. - added yatex-init.el, vine-default-yatex.el
  206. - updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
  207. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
  208. - spec in utf8
  209. * Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
  210. - applied new versioning policy
  211. * Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
  212. - new upstream release
  213. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
  214. - s/Copyright/License/
  215. - changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
  216. * Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
  217. - update yatex-1.72
  218. * Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
  219. - update yatex-1.71
  220. * Wed Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
  221. - added Patch3 to add hhmts timestamp feature
  222. * Mon May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
  223. - update yatex-1.70
  224. * Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
  225. - update yatex10203151806
  226. * Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
  227. - fixed: bytecompile yatex19
  228. * Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
  229. - now emacsen-common aware
  230. - FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
  231. * Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
  232. - 1.68-0vl2
  233. - no kanji code conversion of documents
  234. * Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
  235. - 1.68-0vl1
  236. - update to 1.68
  237. * Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  238. - 1.67-6vl5
  239. - YATEXHLP.{jp,eng} moved to appropriate dir
  240. * Fri Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  241. - 1.67-6vl3
  242. - rebuilt for emacs-20.7
  243. * Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  244. - 1.67-6vl2
  245. - oops ... fixed target dir for help files
  246. * Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  247. - 1.67-6vl1
  248. - rebuilt for emacs-20.6
  249. * Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  250. - 1.67-6
  251. - included forgotten info file for YaHTML
  252. * Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  253. - 1.67-5
  254. - updated for emacs-20.5a release
  255. * Wed Dec 1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  256. - 1.67-4
  257. - change Group to Applications/Editors/EmacsLisp
  258. * Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  259. - 1.67-3
  260. - %post and %preun section modified
  261. * Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  262. - 1.67-2
  263. - fixed minor problem in the %files section
  264. * Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  265. - 1.67-1
  266. - updated to 1.67 release
  267. - rebuilt for emacs-20.4 on Vine Linux 1.9
  268. - updated URL for the new web site of YaTeX
  269. - some typo fix
  270. * Tue May 4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  271. - Initial Release