xnoise-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245
  1. %define XNOISE_BIN %{_libexecdir}/%{name}
  2. Name: xnoise
  3. Version: 0.2.19
  4. Release: 1%{?_dist_release}
  5. Summary: Tracklist-centric Media Player
  6. Summary(ja): トラックリストを中心とするメディアプレーヤー
  7. Group: Applications/Multimedia
  8. License: GPLv2+ with exceptions
  9. URL: http://www.xnoise-media-player.com/
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. Source0: http://xnoise.googlecode.com/files/xnoise-%{version}.tar.gz
  12. Source1: xnoise_ja.po
  13. Source10: xnoise.sh
  14. BuildRequires: pkgconfig
  15. BuildRequires: gettext
  16. BuildRequires: glib2-devel >= 2.30.0
  17. BuildRequires: gtk3-devel
  18. BuildRequires: gstreamer1-plugins-base-devel >= 1.0.1
  19. BuildRequires: intltool
  20. BuildRequires: libxml2-devel >= 2.6.32
  21. BuildRequires: libsoup-devel >= 2.26.0
  22. BuildRequires: libtaginfo-devel >= 0.1.6
  23. BuildRequires: perl-XML-Parser
  24. BuildRequires: sqlite3-devel >= 3.6
  25. BuildRequires: taglib-devel >= 1.6.0
  26. BuildRequires: unique-devel
  27. BuildRequires: vala-devel >= 0.16.0
  28. BuildRequires: desktop-file-utils gettext intltool
  29. Requires: hicolor-icon-theme
  30. Requires: libtaginfo >= 0.1.6
  31. # xnoise >= 0.1.14 bundles the plug-ins
  32. Provides: xnoise-plugins-core = %{version}-%{release}
  33. %description
  34. Xnoise is a Gtk+ media player with a tracklist-centric design. The
  35. tracklist is a list of video or music tracks that are played one by
  36. one without being removed (right side of window). This gives you the
  37. possibility to enqueue any track in any order, regardless if they are
  38. on the same album or not. The tracks can be reordered at any time by
  39. using drag and drop.
  40. %package devel
  41. Summary: Development files for %{name}
  42. Summary(ja): %{name} の開発ファイル
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. %description devel
  46. The %{name}-devel package contains libraries and header files for
  47. developing applications that use %{name}.
  48. %prep
  49. %setup -q
  50. %{__cp} -f %{SOURCE1} po/ja.po
  51. #sed -i s/hu/hu\\nja/g po/LINGUAS
  52. sed -i -e '16,$d' -e '13d' data/misc/xnoise.desktop*
  53. %build
  54. %configure --enable-soundmenu2=no
  55. make %{?_smp_mflags}
  56. %install
  57. rm -rf $RPM_BUILD_ROOT
  58. make install DESTDIR=$RPM_BUILD_ROOT
  59. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  60. # remove invalid locale file
  61. rm -rf $RPM_BUILD_ROOT%{_share}/locale/default
  62. ## wrapper install
  63. %__mkdir_p $RPM_BUILD_ROOT%{_libexecdir}
  64. %__mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{XNOISE_BIN}
  65. %{__install} -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
  66. %find_lang %{name}
  67. %check
  68. make check
  69. desktop-file-validate $RPM_BUILD_ROOT/%{_datadir}/applications/xnoise.desktop
  70. %post
  71. /sbin/ldconfig
  72. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  73. update-desktop-database &> /dev/null || :
  74. %postun
  75. /sbin/ldconfig
  76. if [ $1 -eq 0 ] ; then
  77. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  78. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  79. fi
  80. update-desktop-database &> /dev/null || :
  81. %posttrans
  82. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  83. %files -f %{name}.lang
  84. %defattr(-,root,root,-)
  85. %doc AUTHORS COPYING README
  86. %{XNOISE_BIN}
  87. %{_bindir}/xnoise
  88. %{_bindir}/xnoise_image_extractor_service
  89. # libxnoise.so *needs* to be in main package
  90. # otherwise plugins currently don't work
  91. #%exclude %{_libdir}/xnoise/libxnoisetest.so
  92. %{_libdir}/xnoise
  93. %{_libdir}/libxnoise.so*
  94. %{_mandir}/man1/xnoise.1*
  95. %{_datadir}/xnoise
  96. %{_datadir}/applications/xnoise.desktop
  97. %{_datadir}//dbus-1/services/org.gtk.xnoise.ImageExtractor.service
  98. %{_datadir}//dbus-1/services/org.gtk.xnoise.PlayerEngine.service
  99. %{_datadir}/icons/hicolor/*
  100. %{_datadir}/icons/ubuntu-mono-*/*
  101. %files devel
  102. %defattr(-,root,root,-)
  103. %{_includedir}/xnoise
  104. #%{_libdir}/libxnoise*.so*
  105. %{_libdir}/pkgconfig/xnoise-1.0.pc
  106. # make package own the vala API dir:
  107. # xnoise plugins don't have to be written in vala
  108. %dir %{_datadir}/vala
  109. %dir %{_datadir}/vala/vapi
  110. %{_datadir}/vala/vapi/xnoise-1.0.*
  111. %changelog
  112. * Sat Oct 12 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.19-1
  113. - new upstream release
  114. - updated Source1
  115. * Sun May 12 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.18-1
  116. - new upstream release
  117. - updated Source1
  118. - changed BuildRequires: libtaginfo-devel >= 0.1.6
  119. - changed Rquires: libtaginfo >= 0.1.6
  120. - fixed desktop error
  121. - deleted unrecognize option: --disable-ubuntuone
  122. * Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.17-1
  123. - new upstream release
  124. - updated Source1
  125. - changed BuildRequires: gstreamer-plugins-base-devel >= 0.10.23 to
  126. gstreamer1-plugins-base-devel >= 1.0.1
  127. - added BuildRequires: libtaginfo-devel
  128. - added Requires: libtaginfo
  129. - fixed Source10
  130. * Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.15-1
  131. - new upstream release
  132. - updated Source1
  133. * Fri Jan 11 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.14-1
  134. - new upstream release
  135. - updated Source1
  136. * Sat Nov 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.13-1
  137. - new upstream release
  138. - updated Source1
  139. * Thu Oct 04 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.12-1
  140. - new upstream release
  141. - updated Source1
  142. - deleted BuildRequires: libnotify-devel >= 0.7.0
  143. - changed BuildRequires: vala-devel >= 0.15.0 to 0.16.0
  144. * Sat Sep 22 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.11-1
  145. - new upstream release
  146. - updated Source1
  147. - deleted %%configure option: --disable-magnatune
  148. * Sat Sep 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.9-1
  149. - new upstream release
  150. - updated Source1
  151. * Sat Aug 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.8-1
  152. - new upstream release
  153. - updated Source1
  154. - added %%configure option: --disable-magnatune
  155. * Fri Aug 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.5-1
  156. - new upstream release
  157. - updated Source1
  158. - added %%configure option: --disable-ubuntuone
  159. * Thu Aug 02 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.4-1
  160. - initial build for VineSeed
  161. * Wed Oct 5 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.29-1
  162. - Update to 0.1.29
  163. * Wed Sep 21 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.28-1
  164. - Update to 0.1.28
  165. * Sat Sep 10 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.27-1
  166. - Update to 0.1.27
  167. * Thu Jul 28 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.26-1
  168. - Update to 0.1.26
  169. - Enable tests
  170. * Mon Apr 4 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.18-1
  171. - Update to 0.1.18
  172. * Sun Mar 13 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.16-1
  173. - Update to 0.1.16
  174. - Now bundles the plugins, obsoleting xnoise-plugins-core
  175. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.12-4
  176. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  177. * Sat Nov 6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-3
  178. - Own %%{_libdir}/xnoise for plugins
  179. * Sat Nov 6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-2
  180. - invoke ldconfig on (un)install
  181. - remove %%clean section; only targeting F-14+
  182. - re-enable deletion of invalid locale dir
  183. * Sat Nov 6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-1
  184. - Update to 0.1.12
  185. - Specify the correct location for Vala API files in *.pc
  186. * Fri Jun 25 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.6-2
  187. - Make xnoise-devel co-own Vala's VAPI dir
  188. - Remove invalid locale file
  189. * Wed Jun 23 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
  190. - Update to final 0.1.6 release
  191. * Sat Apr 3 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.2-0.1.331hg
  192. - Initial package