libmemcached-vl.spec 7.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256
  1. %global with_tests %{?_with_tests:1}%{!?_with_tests:0}
  2. Name: libmemcached
  3. Summary: Client library and command line tools for memcached server
  4. Version: 1.0.7
  5. Release: 2%{?_dist_release}
  6. License: BSD
  7. Group: System Environment/Libraries
  8. URL: http://libmemcached.org/
  9. # Original sources:
  10. # http://launchpad.net/libmemcached/1.0/%{version}/+download/libmemcached-%{version}.tar.gz
  11. # The source tarball must be repackaged to remove the Hsieh hash
  12. # code, since the license is non-free. When upgrading, download the new
  13. # source tarball, and run "./strip-hsieh.sh <version>" to produce the
  14. # "-exhsieh" tarball.
  15. Source0: libmemcached-%{version}-exhsieh.tar.gz
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  17. BuildRequires: cyrus-sasl-devel
  18. BuildRequires: flex bison
  19. %if %{with_tests}
  20. BuildRequires: memcached
  21. %endif
  22. BuildRequires: libevent-devel
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. Packager: tomop
  26. %description
  27. libmemcached is a C/C++ client library and tools for the memcached server
  28. (http://memcached.org/). It has been designed to be light on memory
  29. usage, and provide full access to server side methods.
  30. It also implements several command line tools:
  31. memcapable Checking a Memcached server capibilities and compatibility
  32. memcat Copy the value of a key to standard output
  33. memcp Copy data to a server
  34. memdump Dumping your server
  35. memerror Translate an error code to a string
  36. memexist Check for the existance of a key
  37. memflush Flush the contents of your servers
  38. memparse Parse an option string
  39. memping Test to see if a server is available.
  40. memrm Remove a key(s) from the server
  41. memslap Generate testing loads on a memcached cluster
  42. memstat Dump the stats of your servers to standard output
  43. memtouch Touches a key
  44. %package devel
  45. Summary: Header files and development libraries for %{name}
  46. Group: Development/Libraries
  47. Requires: %{name}%{?_isa} = %{version}-%{release}
  48. Requires: pkgconfig
  49. Requires: cyrus-sasl-devel%{?_isa}
  50. %description devel
  51. This package contains the header files and development libraries
  52. for %{name}. If you like to develop programs using %{name},
  53. you will need to install %{name}-devel.
  54. %prep
  55. %setup -q
  56. mkdir examples
  57. cp -p tests/*.{cc,h} examples/
  58. # Will be regenerated during build
  59. rm -f libmemcached/csl/{parser,scanner}.cc
  60. # Temporary fix for SASL detection
  61. sed -i -e s/ax_cv_sasl/ac_enable_sasl/ configure
  62. %build
  63. # option --with-memcached=false to disable server binary check (as we don't run test)
  64. %configure --disable-static \
  65. %if ! %{with_tests}
  66. --with-memcached=false
  67. %endif
  68. make %{_smp_mflags}
  69. %install
  70. rm -rf %{buildroot}
  71. make install DESTDIR="%{buildroot}" AM_INSTALL_PROGRAM_FLAGS=""
  72. %check
  73. %if %{with_tests}
  74. # test suite cannot run in mock (same port use for memcache servers on all arch)
  75. # All tests completed successfully
  76. # diff output.res output.cmp fails but result depend on server version
  77. make test
  78. %else
  79. echo 'Test suite disabled (missing "--with tests" option)'
  80. %endif
  81. %clean
  82. rm -rf %{buildroot}
  83. %post
  84. /sbin/ldconfig
  85. %postun
  86. /sbin/ldconfig
  87. %files
  88. %defattr (-,root,root,-)
  89. %doc AUTHORS COPYING README THANKS TODO ChangeLog
  90. %{_bindir}/mem*
  91. %exclude %{_libdir}/lib*.la
  92. %{_libdir}/libhashkit.so.2*
  93. %{_libdir}/libmemcached.so.10*
  94. %{_libdir}/libmemcachedprotocol.so.0*
  95. %{_libdir}/libmemcachedutil.so.2*
  96. %{_mandir}/man1/mem*
  97. %files devel
  98. %defattr (-,root,root,-)
  99. %doc examples
  100. %{_includedir}/libmemcached
  101. %{_includedir}/libmemcached-1.0
  102. %{_includedir}/libhashkit
  103. %{_includedir}/libhashkit-1.0
  104. %{_includedir}/libmemcachedprotocol-0.0
  105. %{_includedir}/libmemcachedutil-1.0
  106. %{_libdir}/libhashkit.so
  107. %{_libdir}/libmemcached.so
  108. %{_libdir}/libmemcachedprotocol.so
  109. %{_libdir}/libmemcachedutil.so
  110. %{_libdir}/pkgconfig/libmemcached.pc
  111. %{_mandir}/man3/libmemcached*
  112. %{_mandir}/man3/libhashkit*
  113. %{_mandir}/man3/memcached*
  114. %{_mandir}/man3/hashkit*
  115. %changelog
  116. * Thu May 03 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.7-2
  117. - built for Vine Linux.
  118. * Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.7-1
  119. - update to 1.0.7
  120. - regenerate parser using flex/bison (#816766)
  121. * Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-2
  122. - workaround for SASL detection
  123. * Sat Apr 21 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-1
  124. - update to 1.0.6
  125. - soname bump to libmemcached.so.10 and libhashkit.so.2
  126. * Sat Mar 03 2012 Remi Collet <remi@fedoraproject.org> - 1.0.4-1
  127. - update to 1.0.4
  128. - soname bump to libmemcached.so.9
  129. - update description
  130. * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-3
  131. - Rebuilt for c++ ABI breakage
  132. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
  133. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  134. * Thu Oct 27 2011 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
  135. - update to 1.0.2
  136. * Sun Oct 16 2011 Remi Collet <remi@fedoraproject.org> - 0.53-1
  137. - update to 0.53
  138. * Sat Sep 17 2011 Remi Collet <remi@fedoraproject.org> - 0.52-1
  139. - update to 0.52
  140. * Sun Jul 31 2011 Remi Collet <remi@fedoraproject.org> - 0.51-1
  141. - update to 0.51 (soname bump libmemcached.so.8)
  142. * Thu Jun 02 2011 Remi Collet <Fedora@famillecollet.com> - 0.49-1
  143. - update to 0.49
  144. - add build option : --with tests
  145. * Mon Feb 28 2011 Remi Collet <Fedora@famillecollet.com> - 0.47-1
  146. - update to 0.47
  147. - remove patch merged upstream
  148. * Sun Feb 20 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-2
  149. - patch Makefile.in instead of include.am (to avoid autoconf)
  150. - donc requires pkgconfig with arch
  151. * Fri Feb 18 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-1
  152. - update to 0.46
  153. * Sat Feb 12 2011 Remi Collet <Fedora@famillecollet.com> - 0.44-6
  154. - arch specific requires
  155. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-5
  156. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  157. * Wed Nov 24 2010 Joe Orton <jorton@redhat.com> - 0.44-4
  158. - repackage source tarball to remove non-free Hsieh hash code
  159. * Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-3
  160. - improves SASL patch
  161. * Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-2
  162. - enable SASL support
  163. * Fri Oct 01 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-1
  164. - update to 0.44
  165. - add soname version in %%file to detect change
  166. * Fri Jul 30 2010 Remi Collet <Fedora@famillecollet.com> - 0.43-1
  167. - update to 0.43
  168. * Wed Jul 07 2010 Remi Collet <Fedora@famillecollet.com> - 0.42-1
  169. - update to 0.42
  170. * Tue May 04 2010 Remi Collet <Fedora@famillecollet.com> - 0.40-1
  171. - update to 0.40 (new soname for libmemcached.so.5)
  172. - new URI (site + source)
  173. * Sat Mar 13 2010 Remi Collet <Fedora@famillecollet.com> - 0.38-1
  174. - update to 0.38
  175. * Sat Feb 06 2010 Remi Collet <Fedora@famillecollet.com> - 0.37-1
  176. - update to 0.37 (soname bump)
  177. - new libhashkit (should be a separated project in the futur)
  178. * Sun Sep 13 2009 Remi Collet <Fedora@famillecollet.com> - 0.31-1
  179. - update to 0.31
  180. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.30-2
  181. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  182. * Sun Jun 14 2009 Remi Collet <Fedora@famillecollet.com> - 0.30-1
  183. - update to 0.30
  184. * Tue May 19 2009 Remi Collet <Fedora@famillecollet.com> - 0.29-1
  185. - update to 0.29
  186. * Fri May 01 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-2
  187. - add upstream patch to disable nonfree hsieh hash method
  188. * Sat Apr 25 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-1
  189. - Initial RPM from Brian Aker spec
  190. - create -devel subpackage
  191. - add %%post %%postun %%check section