libdatrie-vl.spec 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Double-Array Trie Library
  3. Name: libdatrie
  4. Version: 0.2.6
  5. Release: 1%{?_dist_release}
  6. Source0: http://linux.thai.net/pub/thailinux/software/libthai/%{name}-%{version}.tar.xz
  7. License: GPLv2
  8. Group: System Environment/Libraries
  9. URL: http://linux.thai.net/~thep/datrie/datrie.html
  10. BuildRequires: doxygen
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. Packager: Takemikaduchi
  15. %description
  16. This is an implementation of double-array structure for representing trie,
  17. as proposed by Junichi Aoe.
  18. Trie is a kind of digital search tree, an efficient indexing method with
  19. O(1) time complexity for searching. Comparably as efficient as hashing,
  20. trie also provides flexibility on incremental matching and key spelling
  21. manipulation. This makes it ideal for lexical analyzers, as well as spelling
  22. dictionaries.
  23. %package devel
  24. Summary: Development tools for libdatrie
  25. Summary(ja): libdatrie の開発環境
  26. Group: Development/Libraries
  27. Requires: %{name} = %{version}-%{release}
  28. Requires: pkgconfig
  29. %description devel
  30. Header files and libraries for building a extension library for the
  31. libdatrie.
  32. %package docs
  33. Summary: Documentation for libdatrie
  34. Summary(ja): libdatrie 用のドキュメント
  35. Group: Documentation
  36. Requires: %{name} = %{version}-%{release}
  37. BuildArch: noarch
  38. Provides: %{name}-doc = %{version}-%{release}
  39. %description docs
  40. This package contains documentation for libdatrie
  41. # compat32
  42. %package -n compat32-%{name}
  43. Summary: Double-Array Trie Library
  44. Group: System Environment/Libraries
  45. Requires: %{name} = %{version}-%{release}
  46. %description -n compat32-%{name}
  47. This is an implementation of double-array structure for representing trie,
  48. as proposed by Junichi Aoe.
  49. Trie is a kind of digital search tree, an efficient indexing method with
  50. O(1) time complexity for searching. Comparably as efficient as hashing,
  51. trie also provides flexibility on incremental matching and key spelling
  52. manipulation. This makes it ideal for lexical analyzers, as well as spelling
  53. dictionaries.
  54. %package -n compat32-%{name}-devel
  55. Summary: Development tools for libdatrie
  56. Summary(ja): libdatrie の開発環境
  57. Group: Development/Libraries
  58. Requires: compat32-%{name} = %{version}-%{release}
  59. Requires: pkgconfig
  60. %description -n compat32-%{name}-devel
  61. Header files and libraries for building a extension library for the
  62. libdatrie.
  63. %prep
  64. %setup -q
  65. %build
  66. %configure \
  67. --disable-static
  68. %{__make} %{?_smp_mflags}
  69. %install
  70. %{__rm} -rf ${RPM_BUILD_ROOT}
  71. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  72. find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
  73. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  74. %clean
  75. %{__rm} -rf ${RPM_BUILD_ROOT}
  76. %post -p /sbin/ldconfig
  77. %postun -p /sbin/ldconfig
  78. %post -n compat32-%{name} -p /sbin/ldconfig
  79. %postun -n compat32-%{name} -p /sbin/ldconfig
  80. %files
  81. %defattr(-,root,root,-)
  82. %doc COPYING ChangeLog NEWS README
  83. %{_bindir}/trietool-0.2
  84. %{_libdir}/%{name}.so.*
  85. %{_mandir}/man1/*.gz
  86. %files devel
  87. %defattr(-,root,root,-)
  88. %{_includedir}/datrie
  89. %{_libdir}/%{name}.so
  90. %{_libdir}/pkgconfig/datrie-0.2.pc
  91. %files docs
  92. %defattr(-,root,root,-)
  93. %{_docdir}/%{name}/README.migration
  94. %{_docdir}/datrie
  95. %if %{build_compat32}
  96. %files -n compat32-%{name}
  97. %defattr(-, root, root,-)
  98. %{_libdir}/%{name}.so.*
  99. %files -n compat32-%{name}-devel
  100. %defattr(-, root, root,-)
  101. %{_libdir}/%{name}.so
  102. %endif
  103. %changelog
  104. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.6-1
  105. - update to 0.2.6
  106. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.5-2
  107. - remove *.pc from compat32-%{name}-devel
  108. - fix typo
  109. * Wed Jan 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.5-1
  110. - initial build for Vine Linux