libcdio-vl.spec 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227
  1. Summary: CD-ROM input and control library
  2. Summary(ja): CD-ROM 入力・制御ライブラリ
  3. Name: libcdio
  4. Version: 0.82
  5. Release: 2%{?_dist_release}
  6. Group: System Environment/Libraries
  7. License: GPLv3+
  8. URL: http://www.gnu.org/software/libcdio/
  9. Source0: http://ftp.gnu.org/gnu/libcdio/libcdio-%{version}.tar.bz2
  10. Source1: http://ftp.gnu.org/gnu/libcdio/libcdio-%{version}.tar.bz2.sig
  11. Source2: libcdio-no_date_footer.hml
  12. Patch1: libcdio-0.80-paranoia-fix.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: pkgconfig doxygen
  15. BuildRequires: ncurses-devel
  16. BuildRequires: libcddb-devel
  17. BuildRequires: help2man
  18. BuildRequires: gcc-c++
  19. Requires(post): /sbin/install-info
  20. Requires(preun): /sbin/install-info
  21. %description
  22. This library provides an interface for CD-ROM access. It can be used
  23. by applications that need OS- and device-independent access to CD-ROM
  24. devices.
  25. %package devel
  26. Summary: Development files for %{name}
  27. Summary(ja): %{name} の開発用ファイル
  28. Group: Development/Libraries
  29. Requires: %{name} = %{version}-%{release}
  30. %description devel
  31. This package contains development files for %{name}.
  32. %prep
  33. %setup -q
  34. #patch1 -p1 -b .paranoia_pc
  35. f=src/cd-paranoia/doc/ja/cd-paranoia.1.in
  36. iconv -f euc-jp -t utf-8 -o $f.utf8 $f && mv $f.utf8 $f
  37. %build
  38. #libtoolize --force || :
  39. #aclocal || :
  40. #autoheader || :
  41. #automake || :
  42. #autoconf || :
  43. %configure \
  44. --disable-vcd-info \
  45. --disable-dependency-tracking \
  46. --disable-rpath \
  47. --enable-cddb \
  48. --disable-static
  49. # --disable-cddb \
  50. make %{?_smp_mflags}
  51. cd doc/doxygen
  52. sed -i -e "s,HTML_FOOTER.*$,HTML_FOOTER = libcdio-no_date_footer.hml,g" Doxyfile
  53. cp %{SOURCE2} .
  54. ./run_doxygen
  55. %install
  56. rm -rf $RPM_BUILD_ROOT
  57. make install DESTDIR=$RPM_BUILD_ROOT
  58. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  59. find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
  60. mv $RPM_BUILD_ROOT%{_mandir}/{jp,ja}
  61. rm -rf examples
  62. mkdir -p examples/C++
  63. cp -a example/{*.c,README} examples
  64. cp -a example/C++/{*.cpp,README} examples/C++
  65. %check
  66. # disable test using local CDROM
  67. %{__sed} -i -e "s,testiso9660\$(EXEEXT),,g" \
  68. -e "s,check_paranoia.sh check_opts.sh, check_opts.sh,g" \
  69. test/Makefile
  70. make check
  71. %clean
  72. rm -rf $RPM_BUILD_ROOT
  73. %post
  74. /sbin/ldconfig
  75. /sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir 2>/dev/null || :
  76. %preun
  77. if [ $1 = 0 ]; then
  78. /sbin/install-info --delete %{_infodir}/%{name}.info \
  79. %{_infodir}/dir 2>/dev/null || :
  80. fi
  81. %postun -p /sbin/ldconfig
  82. %files
  83. %defattr(-,root,root,-)
  84. %doc AUTHORS COPYING NEWS README README.libcdio THANKS TODO
  85. %{_bindir}/*
  86. %{_libdir}/*.so.*
  87. %{_infodir}/*
  88. %{_mandir}/man1/*
  89. %lang(ja) %{_mandir}/ja/man1/*
  90. %files devel
  91. %defattr(-,root,root,-)
  92. %doc doc/doxygen/html examples
  93. %{_includedir}/cdio
  94. %{_includedir}/cdio++
  95. %{_libdir}/*.so
  96. %{_libdir}/pkgconfig/*.pc
  97. %changelog
  98. * Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 0.82-2
  99. - rebuilt with rpm-4.8.1 for pkg-config
  100. - added --enable-cddb
  101. * Fri May 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 0.82-1
  102. - new upstream release
  103. - dropt Patch1
  104. - removed static libraries from devel package
  105. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.80-1
  106. - initial build for Vine Linux
  107. * Wed Jun 4 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.80-2
  108. - added patch enabling libcdio_paranoia.pc
  109. * Thu May 29 2008 Adrian Reber <adrian@lisas.de> - 0.80-1
  110. - updated to 0.80
  111. - removed upstreamed patches
  112. - last GPLv2+ release
  113. * Thu Feb 14 2008 Adrian Reber <adrian@lisas.de> - 0.79-3
  114. - added patch to compile with gcc43
  115. * Fri Jan 04 2008 Adrian Reber <adrian@lisas.de> - 0.79-2
  116. - fixed security fix (was off by two)
  117. * Wed Jan 02 2008 Adrian Reber <adrian@lisas.de> - 0.79-1
  118. - updated to 0.79
  119. - fixes #427197 (Long Joliet file name overflows cdio's buffer)
  120. - fixes #341981 (multiarch conflicts in libcdio)
  121. * Fri Aug 24 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-3
  122. - rebuilt
  123. * Mon Jul 23 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-2
  124. - updated to 0.78.2 (#221359) (this time for real)
  125. * Thu Jan 04 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-1
  126. - updated to 0.78.2 (#221359)
  127. * Thu Oct 05 2006 Adrian Reber <adrian@lisas.de> - 0.77-3
  128. - disabled iso9660 test case (fails for some reason with date problems)
  129. this seems to be a known problem according to the ChangeLog
  130. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.77-2
  131. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  132. * Fri Sep 22 2006 Adrian Reber <adrian@lisas.de> - 0.77-1
  133. - Updated to 0.77
  134. * Mon Sep 18 2006 Adrian Reber <adrian@lisas.de> - 0.76-3
  135. - Rebuilt
  136. * Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-2
  137. - Rebuilt
  138. * Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-1
  139. - Updated to 0.76.
  140. - Included doxygen generated documentation into -devel
  141. - Included examples into -devel
  142. * Mon Aug 01 2005 Adrian Reber <adrian@lisas.de> - 0.75-4
  143. - disable test accessing local CDROM drive (#164266)
  144. * Wed Jul 27 2005 Adrian Reber <adrian@lisas.de> - 0.75-3
  145. - Rebuilt without libcddb dependency (#164270)
  146. * Tue Jul 26 2005 Adrian Reber <adrian@lisas.de> - 0.75-2
  147. - Rebuilt
  148. * Thu Jul 14 2005 Adrian Reber <adrian@lisas.de> - 0.75-1
  149. - Updated to 0.75.
  150. * Fri Jun 03 2005 Adrian Reber <adrian@lisas.de> - 0.74-2
  151. - Updated to 0.74.
  152. * Sun Apr 24 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.73-2
  153. - BuildRequire ncurses-devel (for cdda-player and cd-paranoia).
  154. - Run test suite during build.
  155. - Install Japanese man pages.
  156. * Sun Apr 24 2005 Adrian Reber <adrian@lisas.de> - 0.73-1
  157. - Updated to 0.73.
  158. * Fri Mar 18 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.70-2
  159. - Fix FC4 build (#151468).
  160. - Build with dependency tracking disabled.
  161. * Sun Sep 5 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.70-0.fdr.1
  162. - Updated to 0.70.
  163. * Sat Jul 17 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.69-0.fdr.1
  164. - Updated to 0.69.
  165. - Removed broken iso-read.
  166. - Split Requires(pre,post).
  167. - Added BuildReq pkgconfig.
  168. * Mon Mar 29 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.68-0.fdr.1
  169. - Initial RPM release.