lzo-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: lzo
  3. Summary: Data compression library with very fast (de)compression
  4. Summary(ja): 高速なデータ圧縮ライブラリ
  5. Version: 2.03
  6. Release: 4%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: GPLv2+
  9. URL: http://www.oberhumer.com/opensource/lzo/
  10. Source0: http://www.oberhumer.com/opensource/lzo/download/%{name}-%{version}.tar.gz
  11. Patch0: lzo-2.02-configure.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildRequires: zlib-devel
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. %description
  17. LZO is a portable lossless data compression library written in ANSI C.
  18. It offers pretty fast compression and very fast decompression.
  19. Decompression requires no memory. In addition there are slower
  20. compression levels achieving a quite competitive compression ratio
  21. while still decompressing at this very high speed.
  22. %package minilzo
  23. Summary: Mini version of lzo for apps which don't need the full version
  24. Group: System Environment/Libraries
  25. %description minilzo
  26. A small (mini) version of lzo for embedding into applications which don't need
  27. full blown lzo compression support.
  28. %package devel
  29. Summary: Development files for the lzo library
  30. Summary(ja): lzo ライブラリの開発ファイル
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}-%{release}
  33. Requires: %{name}-minilzo = %{version}-%{release}
  34. Requires: zlib-devel
  35. %description devel
  36. LZO is a portable lossless data compression library written in ANSI C.
  37. It offers pretty fast compression and very fast decompression.
  38. This package contains development files needed for lzo.
  39. %package -n compat32-%{name}
  40. Summary: Data compression library with very fast (de)compression
  41. Summary(ja): 高速なデータ圧縮ライブラリ
  42. Group: System Environment/Libraries
  43. %description -n compat32-%{name}
  44. LZO is a portable lossless data compression library written in ANSI C.
  45. It offers pretty fast compression and very fast decompression.
  46. Decompression requires no memory. In addition there are slower
  47. compression levels achieving a quite competitive compression ratio
  48. while still decompressing at this very high speed.
  49. %package -n compat32-%{name}-minilzo
  50. Summary: Mini version of lzo for apps which don't need the full version
  51. Group: System Environment/Libraries
  52. Requires: %{name}-minilzo = %{version}-%{release}
  53. %description -n compat32-%{name}-minilzo
  54. A small (mini) version of lzo for embedding into applications which don't need
  55. full blown lzo compression support.
  56. %package -n compat32-%{name}-devel
  57. Summary: Development files for the lzo library
  58. Summary(ja): lzo ライブラリの開発ファイル
  59. Group: Development/Libraries
  60. Requires: compat32-%{name} = %{version}-%{release}
  61. Requires: %{name}-minilzo = %{version}-%{release}
  62. Requires: compat32-zlib-devel
  63. %description -n compat32-%{name}-devel
  64. LZO is a portable lossless data compression library written in ANSI C.
  65. It offers pretty fast compression and very fast decompression.
  66. This package contains development files needed for lzo.
  67. %prep
  68. %setup -q
  69. %patch0 -p1 -z .configure
  70. # mark asm files as NOT needing execstack
  71. for i in asm/i386/src_gas/*.S; do
  72. echo '.section .note.GNU-stack,"",@progbits' >> $i
  73. done
  74. %build
  75. %configure --disable-dependency-tracking --disable-static --enable-shared
  76. make %{?_smp_mflags}
  77. # build minilzo too (bz 439979)
  78. gcc %{optflags} -fpic -Iinclude/lzo -o minilzo/minilzo.o -c minilzo/minilzo.c
  79. gcc -g -shared -o libminilzo.so.0 -Wl,-soname,libminilzo.so.0 minilzo/minilzo.o
  80. %install
  81. rm -rf $RPM_BUILD_ROOT
  82. make install DESTDIR=$RPM_BUILD_ROOT
  83. rm $RPM_BUILD_ROOT%{_libdir}/liblzo2.la
  84. install -m 755 libminilzo.so.0 $RPM_BUILD_ROOT%{_libdir}
  85. ln -s libminilzo.so.0 $RPM_BUILD_ROOT%{_libdir}/libminilzo.so
  86. install -p -m 644 minilzo/minilzo.h $RPM_BUILD_ROOT%{_includedir}/lzo
  87. %check
  88. make check test
  89. %clean
  90. rm -rf $RPM_BUILD_ROOT
  91. %post -p /sbin/ldconfig
  92. %postun -p /sbin/ldconfig
  93. %post minilzo -p /sbin/ldconfig
  94. %postun minilzo -p /sbin/ldconfig
  95. %post -n compat32-%{name} -p /sbin/ldconfig
  96. %postun -n compat32-%{name} -p /sbin/ldconfig
  97. %post -n compat32-%{name}-minilzo -p /sbin/ldconfig
  98. %postun -n compat32-%{name}-minilzo -p /sbin/ldconfig
  99. %files
  100. %defattr(-,root,root,-)
  101. %doc AUTHORS COPYING THANKS NEWS
  102. %{_libdir}/liblzo2.so.*
  103. %files minilzo
  104. %defattr(-,root,root,-)
  105. %doc minilzo/README.LZO
  106. %{_libdir}/libminilzo.so.0
  107. %files devel
  108. %defattr(-,root,root,-)
  109. %doc doc/LZOAPI.TXT doc/LZO.FAQ doc/LZO.TXT
  110. %{_includedir}/lzo
  111. %{_libdir}/lib*lzo*.so
  112. # compat32
  113. %if %{build_compat32}
  114. %files -n compat32-%{name}
  115. %defattr(-,root,root,-)
  116. %{_libdir}/liblzo2.so.*
  117. %files -n compat32-%{name}-minilzo
  118. %defattr(-,root,root,-)
  119. %{_libdir}/libminilzo.so.0
  120. %files -n compat32-%{name}-devel
  121. %defattr(-,root,root,-)
  122. %{_libdir}/lib*lzo*.so
  123. %endif
  124. %changelog
  125. * Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.03-4
  126. - rebuild with VineSeed environment
  127. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.03-3
  128. - rebuilt with current VineSeed
  129. * Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.03-2
  130. - added compat32 package for x86_64 arch support
  131. * Fri Aug 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.03-1
  132. - initial build for Vine Linux
  133. * Thu May 1 2008 Lubomir Rintel <lkundrak@v3.sk> 2.03-1
  134. - New upstream release
  135. - Changed the license to GPLv2+
  136. * Wed Apr 2 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 2.02-5
  137. - Fix configure failure with -Werror-implicit-function-declaration in CFLAGS
  138. - Add a minilzo subpackage which contains a shared version of minilzo, to be
  139. used by all applications which ship with their own copy of it (bz 439979)
  140. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.02-4
  141. - Autorebuild for GCC 4.3
  142. * Wed Aug 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 2.02-3
  143. - Update License tag for new Licensing Guidelines compliance
  144. * Mon Aug 28 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 2.02-2
  145. - FE6 Rebuild
  146. * Wed Jul 26 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 2.02-1
  147. - New upstream release 2.02, soname change!
  148. * Mon Jul 24 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 1.08-7
  149. - Taking over as maintainer since Anvil has other priorities
  150. - Add a patch to fix asm detection on i386 (bug 145882, 145893). Thanks to
  151. Carlo Marcelo Arenas Belon <carenas@sajinet.com.pe> for the initial patch.
  152. - Removed unused build dependency on nasm
  153. - Remove static lib
  154. - Cleanup %%doc a bit
  155. * Thu Mar 16 2006 Dams <anvil[AT]livna.org> - 1.08-6.fc5
  156. - Rebuild for new gcc
  157. * Tue Jan 17 2006 Dams <anvil[AT]livna.org> - 1.08-5.fc5
  158. - Bumped release for gcc 4.1 rebuild
  159. * Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1.08-4
  160. - rebuild on all arches
  161. * Thu Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
  162. - rebuilt
  163. * Sun Apr 27 2003 Dams <anvil[AT]livna.org> 0:1.08-0.fdr.2
  164. - Typo un devel description
  165. - Added post and postun scriptlets
  166. - Added URL in Source0
  167. * Fri Apr 25 2003 Dams <anvil[AT]livna.org>
  168. - Initial build.