lv-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169
  1. %define major 4
  2. %define minor 51
  3. %define teeny 0
  4. %if %{teeny}
  5. %define srcname %{name}%{major}%{minor}%{teeny}
  6. %else
  7. %define srcname %{name}%{major}%{minor}
  8. %endif
  9. Summary: a powerful multilingual file viewer
  10. Summary(ja): パワフルな多言語対応ファイルビュウワー
  11. Name: lv
  12. Version: %{major}.%{minor}.%{teeny}
  13. Release: 2%{?_dist_release}
  14. License: GPL
  15. Group: Applications/Text
  16. Source: http://www.ff.iij4u.or.jp/~nrt/freeware/%{srcname}.tar.gz
  17. URL: http://www.ff.iij4u.or.jp/~nrt/lv/
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. Provides: pager
  20. Requires(post,preun): alternatives
  21. BuildRequires: ncurses-devel >= 5.6
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. %description
  25. lv is a powerful file viewer like less. lv can decode and encode
  26. multilingual streams through many coding systems: ISO-8859, ISO-2022,
  27. EUC, SJIS, Big5, HZ, Unicode. It recognizes multi-bytes patterns as
  28. regular expressions, lv also provides multilingual grep. In addition,
  29. lv can recognize ANSI escape sequences for text devoration.
  30. %description -l ja
  31. lv は less に似たパワフルなファイルビュウワーです。lv は多言語文字列を
  32. ISO-8859, ISO-2022, EUC, SJIS, Big5, HZ, Unicode といった様々な文字コー
  33. ドにエンコード・デコードできます。また多バイト正規表現をサポートしてお
  34. り、多言語 grep としての機能も備えています。さらに lv は ANSI エスケー
  35. プシーケンスによるテキスト装飾を扱うこともできます。
  36. %prep
  37. %setup -q -c
  38. %build
  39. cd %{srcname}/build
  40. ../src/configure %{_target_platform} \
  41. --prefix=%{_prefix} \
  42. --exec-prefix=%{_exec_prefix} \
  43. --bindir=%{_bindir} \
  44. --sbindir=%{_sbindir} \
  45. --sysconfdir=%{_sysconfdir} \
  46. --datadir=%{_datadir} \
  47. --includedir=%{_includedir} \
  48. --libdir=%{_libdir} \
  49. --libexecdir=%{_libexecdir} \
  50. --localstatedir=%{_localstatedir} \
  51. --sharedstatedir=%{_sharedstatedir} \
  52. --mandir=%{_mandir} \
  53. --infodir=%{_infodir}
  54. make
  55. cd ../..
  56. %install
  57. rm -rf ${RPM_BUILD_ROOT}
  58. mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
  59. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
  60. # installing binaries ...
  61. cd %{srcname}/build
  62. %makeinstall
  63. cd ../..
  64. # listing all files in drb-all.files
  65. (find \
  66. $RPM_BUILD_ROOT%{_bindir} \
  67. $RPM_BUILD_ROOT%{_mandir} \
  68. -type f -o -type l) |
  69. sort | sed -e "s,^$RPM_BUILD_ROOT,," \
  70. -e "s,\(/man/man./.*\)$,\1*," > lv-all.files
  71. %clean
  72. rm -rf ${RPM_BUILD_ROOT}
  73. rm -f *.files
  74. #%post -p /sbin/ldconfig -n lv
  75. %post
  76. %{_syssbindir}/update-alternatives --install %{_bindir}/pager pager %{_bindir}/lv 20
  77. %preun
  78. if [ "$1" = "0" ]; then
  79. %{_syssbindir}/update-alternatives --remove pager %{_bindir}/lv
  80. fi
  81. #%postun -p /sbin/ldconfig -n lv
  82. %files -f lv-all.files
  83. %defattr(-, root, root)
  84. %doc %{srcname}/GPL.txt
  85. %doc %{srcname}/README
  86. %doc %{srcname}/hello.sample
  87. %doc %{srcname}/hello.sample.gif
  88. %doc %{srcname}/index.html
  89. %doc %{srcname}/relnote.html
  90. %{_libdir}/lv
  91. %changelog
  92. * Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.51.0-2
  93. - rebuild for Vine 6
  94. * Sun Aug 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.51.0-1
  95. - new versioning policy
  96. - build with ncurses-5.6
  97. * Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 4.51.0-0vl6
  98. - add Provides: pager
  99. - add Requires(post,preun): alternatives
  100. * Mon Apr 09 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 4.51.0-0vl5
  101. - add update-alternatives: pager in %%post and %%preun scriptlet
  102. * Tue Apr 20 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.51.0-0vl4
  103. - rebuild on VineSeed
  104. * Tue Apr 20 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.51.0-0vl3
  105. - add (Build)Requires: libtermcap(-devel)
  106. - add Vendor/Distribution tag
  107. - add GPL.txt
  108. * Wed Feb 11 2004 KAZUKI SHIMURA <rito@pos.to> 4.51.0-0vl2
  109. - rebuild on VineSeed
  110. * Wed Feb 11 2004 KAZUKI SHIMURA <rito@pos.to> 4.51.0-0vl1
  111. - upstream release
  112. - drop obsolete patch lv-Makefile.in.patch (Patch1)
  113. * Sat Jan 10 2004 KAZUKI SHIMURA <rito@pos.to> 4.50.0-0vl1
  114. - upstream release
  115. - define %%{srcname}
  116. - s/Copyright/License/
  117. * Thu May 15 2003 IWAI Masaharu <iwai@alib.jp> 4.49.5-0vl2
  118. - rebuild on VineSeed
  119. * Thu May 15 2003 IWAI Masaharu <iwai@alib.jp> 4.49.5-0vl1
  120. - SECURITY FIX - upstream release
  121. - fix CAN-2003-0188: possible local root exploit using config files
  122. * Mon Mar 24 2003 IWAI Masaharu <iwai@alib.jp> 4.49.4-0vl4
  123. - rebuild with new toolchain
  124. * Fri Sep 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.49.4-0vl3
  125. - URL was incorrect (http was hhttp)... Fixed the typo.
  126. * Sun Jul 21 2002 IWAI Masaharu <iwai@alib.jp> 4.49.4-0vl2
  127. - added the help file for executing with h option
  128. * Wed Jan 10 2001 akira yamada <akira@vinelinux.org>
  129. - Initial packaging.