lapack-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450
  1. %global shortver 3
  2. %global mediumver %{shortver}.4
  3. Summary: The LAPACK libraries for numerical linear algebra.
  4. Name: lapack
  5. Version: %{mediumver}.0
  6. Release: 1%{?_dist_release}
  7. License: Freely distributable
  8. Group: Development/Libraries
  9. URL: http://www.netlib.org/lapack/
  10. Source0: http://www.netlib.org/lapack/lapack-%{version}.tgz
  11. Source1: http://www.netlib.org/lapack/manpages.tgz
  12. Source2: Makefile.blas
  13. Source3: Makefile.lapack
  14. Source4: http://www.netlib.org/lapack/lapackqref.ps
  15. Source5: http://www.netlib.org/blas/blasqr.ps
  16. Patch3: lapack-3.4.0-make.inc.patch
  17. Patch4: lapack-3.4.0-lapacke-shared.patch
  18. BuildRequires: gcc-gfortran
  19. BuildRequires: coreutils findutils
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. Packager: inagaki, kenta
  24. %description
  25. LAPACK (Linear Algebra PACKage) is a standard library for numerical
  26. linear algebra. LAPACK provides routines for solving systems of
  27. simultaneous linear equations, least-squares solutions of linear
  28. systems of equations, eigenvalue problems, and singular value problems.
  29. Associated matrix factorizations (LU, Cholesky, QR, SVD, Schur, and
  30. generalized Schur) and related computations (i.e., reordering of
  31. Schur factorizations and estimating condition numbers) are also
  32. included. LAPACK can handle dense and banded matrices, but not general
  33. sparse matrices. Similar functionality is provided for real and complex
  34. matrices in both single and double precision. LAPACK is coded in
  35. Fortran90 and built with gcc.
  36. %description -l ja
  37. LAPACK(Linear Algebra PACKage)は線形代数用数値計算の標準ライブラリです。
  38. LAPACKには、連立一次方程式、線形最小二乗解、固有値問題、特異値問題を解く
  39. ためのルーチンがあります。関連する行列因子分解(LU、Cholesky、QR、SVD、
  40. Schur、一般化Schur)と、それに関連する計算処理 (つまりSchur分解の再配列
  41. およびコンディションナンバーの推定)も含まれます。LAPACKは密なbanded行列は
  42. 処理できますが、一般的な疎行列は処理できません。同じ計算機能が、実行列
  43. および複素行列の単制度および倍精度で利用できます。LAPACKはFortran 90で
  44. 記述され、gccでビルドされています。
  45. %package devel
  46. Summary: LAPACK development libraries
  47. Group: Development/Libraries
  48. Requires: %{name} = %{version}-%{release}
  49. Requires: blas-devel = %{version}-%{release}
  50. %description devel
  51. LAPACK development libraries (shared).
  52. %package static
  53. Summary: LAPACK static libraries
  54. Group: Development/Libraries
  55. Requires: %{name}-devel = %{version}-%{release}
  56. %description static
  57. LAPACK static libraries.
  58. %package -n blas
  59. Summary: The BLAS (Basic Linear Algebra Subprograms) library.
  60. Group: Development/Libraries
  61. %description -n blas
  62. BLAS (Basic Linear Algebra Subprograms) is a standard library which
  63. provides a number of basic algorithms for numerical algebra.
  64. %description -n blas -l ja
  65. BLAS(Basic Linear Algebra Subprograms)は数値代数計算の標準ライブラリです。BLASでは、線形代数計算における多くの基本アルゴリズムを利用できます。Blasの計算は高速で十分テストされているFORTRAN 90のプログラムで、gccでビルドされています。
  66. %description -n blas
  67. BLAS (Basic Linear Algebra Subprograms) is a standard library which
  68. provides a number of basic algorithms for numerical algebra.
  69. %package -n blas-devel
  70. Summary: LAPACK development libraries
  71. Group: Development/Libraries
  72. Requires: blas = %{version}-%{release}
  73. Requires: gcc-gfortran
  74. %description -n blas-devel
  75. BLAS development libraries (shared).
  76. %package -n blas-static
  77. Summary: BLAS static libraries
  78. Group: Development/Libraries
  79. Requires: blas-devel = %{version}-%{release}
  80. %description -n blas-static
  81. BLAS static libraries.
  82. %prep
  83. %setup -q
  84. %setup -q -D -T -a1
  85. # using gfortran
  86. %patch3 -p1
  87. %patch4 -p1 -b .shared
  88. mkdir manpages
  89. mv man/ manpages/
  90. cp -f INSTALL/make.inc.gfortran make.inc
  91. cp -f %{SOURCE2} BLAS/SRC/Makefile
  92. cp -f %{SOURCE3} SRC/Makefile
  93. sed -i "s|@SHORTVER@|%{shortver}|g" BLAS/SRC/Makefile
  94. sed -i "s|@SHORTVER@|%{shortver}|g" SRC/Makefile
  95. sed -i "s|@SHORTVER@|%{shortver}|g" lapacke/Makefile
  96. sed -i "s|@LONGVER@|%{version}|g" BLAS/SRC/Makefile
  97. sed -i "s|@LONGVER@|%{version}|g" SRC/Makefile
  98. sed -i "s|@LONGVER@|%{version}|g" lapacke/Makefile
  99. %build
  100. RPM_OPT_O_FLAGS=$(echo $RPM_OPT_FLAGS | sed 's|-O2|-O0|')
  101. # using gfortran
  102. export FC=gfortran
  103. # Build BLAS
  104. pushd BLAS/SRC
  105. FFLAGS="$RPM_OPT_O_FLAGS" make dcabs1.o
  106. FFLAGS="$RPM_OPT_FLAGS" CFLAGS="$RPM_OPT_FLAGS" make static
  107. cp libblas.a ${RPM_BUILD_DIR}/%{name}-%{version}/
  108. make clean
  109. FFLAGS="$RPM_OPT_O_FLAGS -fPIC" make dcabs1.o
  110. FFLAGS="$RPM_OPT_FLAGS -fPIC" CFLAGS="$RPM_OPT_FLAGS -fPIC" make shared
  111. cp libblas.so.%{version} ${RPM_BUILD_DIR}/%{name}-%{version}/
  112. popd
  113. ln -s libblas.so.%{version} libblas.so
  114. # Build the static dlamch, dsecnd, lsame, second, slamch bits
  115. pushd INSTALL
  116. make NOOPT="$RPM_OPT_O_FLAGS" OPTS="$RPM_OPT_FLAGS"
  117. popd
  118. # Build the static lapack library
  119. pushd SRC
  120. make FFLAGS="$RPM_OPT_FLAGS" CFLAGS="$RPM_OPT_FLAGS" static
  121. cp liblapack.a ${RPM_BUILD_DIR}/%{name}-%{version}/
  122. popd
  123. # Build the static with pic dlamch, dsecnd, lsame, second, slamch bits
  124. pushd INSTALL
  125. make clean
  126. make NOOPT="$RPM_OPT_O_FLAGS -fPIC" OPTS="$RPM_OPT_FLAGS -fPIC"
  127. popd
  128. # Build the static with pic lapack library
  129. pushd SRC
  130. make clean
  131. make FFLAGS="$RPM_OPT_FLAGS -fPIC" CFLAGS="$RPM_OPT_FLAGS -fPIC" static
  132. cp liblapack.a ${RPM_BUILD_DIR}/%{name}-%{version}/liblapack_pic.a
  133. popd
  134. # Build the shared dlamch, dsecnd, lsame, second, slamch bits
  135. pushd INSTALL
  136. make clean
  137. make NOOPT="$RPM_OPT_O_FLAGS -fPIC" OPTS="$RPM_OPT_FLAGS -fPIC"
  138. popd
  139. # Build the shared lapack library
  140. pushd SRC
  141. make clean
  142. make FFLAGS="$RPM_OPT_FLAGS -fPIC" CFLAGS="$RPM_OPT_FLAGS -fPIC" shared
  143. cp liblapack.so.%{version} ${RPM_BUILD_DIR}/%{name}-%{version}/
  144. popd
  145. ln -s liblapack.so.%{version} liblapack.so
  146. # Build the lapacke libraries
  147. pushd lapacke
  148. make clean
  149. make CFLAGS="$RPM_OPT_FLAGS" lapacke
  150. cp liblapacke.a ${RPM_BUILD_DIR}/%{name}-%{version}/
  151. make clean
  152. make CFLAGS="$RPM_OPT_FLAGS -fPIC" shlib
  153. cp liblapacke.so.%{version} ${RPM_BUILD_DIR}/%{name}-%{version}/
  154. popd
  155. cp -p %{SOURCE4} lapackqref.ps
  156. cp -p %{SOURCE5} blasqr.ps
  157. %install
  158. rm -fr ${RPM_BUILD_ROOT}
  159. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  160. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man3
  161. chmod 755 ${RPM_BUILD_ROOT}%{_mandir}/man3
  162. for f in liblapack.so.%{version} libblas.so.%{version} liblapacke.so.%{version} libblas.a liblapack.a liblapack_pic.a liblapacke.a; do
  163. cp -f $f ${RPM_BUILD_ROOT}%{_libdir}/$f
  164. done
  165. # Blas manpages
  166. pushd manpages/
  167. mkdir -p blas/man/man3
  168. cd man/man3/
  169. mv caxpy.f.3 CAXPY.3 ccopy.f.3 CCOPY.3 cdotc.f.3 CDOTC.3 cdotu.f.3 CDOTU.3 cgbmv.f.3 CGBMV.3 \
  170. cgemm.f.3 CGEMM.3 cgemv.f.3 CGEMV.3 cgerc.f.3 CGERC.3 cgeru.f.3 CGERU.3 chbmv.f.3 CHBMV.3 \
  171. chemm.f.3 CHEMM.3 chemv.f.3 CHEMV.3 cher.f.3 CHER.3 cher2.f.3 CHER2.3 cher2k.f.3 CHER2K.3 \
  172. cherk.f.3 CHERK.3 chpmv.f.3 CHPMV.3 chpr.f.3 CHPR.3 chpr2.f.3 CHPR2.3 crotg.f.3 CROTG.3 \
  173. cscal.f.3 CSCAL.3 csrot.f.3 CSROT.3 csscal.f.3 CSSCAL.3 cswap.f.3 CSWAP.3 csymm.f.3 \
  174. CSYMM.3 csyr2k.f.3 CSYR2K.3 csyrk.f.3 CSYRK.3 ctbmv.f.3 CTBMV.3 ctbsv.f.3 CTBSV.3 ctpmv.f.3 \
  175. CTPMV.3 ctpsv.f.3 CTPSV.3 ctrmm.f.3 CTRMM.3 ctrmv.f.3 CTRMV.3 ctrsm.f.3 CTRSM.3 ctrsv.f.3 \
  176. CTRSV.3 dasum.f.3 DASUM.3 daxpy.f.3 DAXPY.3 dcabs1.f.3 DCABS1.3 dcopy.f.3 DCOPY.3 ddot.f.3 \
  177. DDOT.3 dgbmv.f.3 DGBMV.3 dgemm.f.3 DGEMM.3 dgemv.f.3 DGEMV.3 dger.f.3 DGER.3 dnrm2.f.3 \
  178. DNRM2.3 drot.f.3 DROT.3 drotg.f.3 DROTG.3 drotm.f.3 DROTM.3 drotmg.f.3 DROTMG.3 dsbmv.f.3 \
  179. DSBMV.3 dscal.f.3 DSCAL.3 dsdot.f.3 DSDOT.3 dspmv.f.3 DSPMV.3 dspr.f.3 DSPR.3 dspr2.f.3 \
  180. DSPR2.3 dswap.f.3 DSWAP.3 dsymm.f.3 DSYMM.3 dsymv.f.3 DSYMV.3 dsyr.f.3 DSYR.3 dsyr2.f.3 \
  181. DSYR2.3 dsyr2k.f.3 DSYR2K.3 dsyrk.f.3 DSYRK.3 dtbmv.f.3 DTBMV.3 dtbsv.f.3 DTBSV.3 dtpmv.f.3 \
  182. DTPMV.3 dtpsv.f.3 DTPSV.3 dtrmm.f.3 DTRMM.3 dtrmv.f.3 DTRMV.3 dtrsm.f.3 DTRSM.3 dtrsv.f.3 \
  183. DTRSV.3 dzasum.f.3 DZASUM.3 dznrm2.f.3 DZNRM2.3 icamax.f.3 ICAMAX.3 idamax.f.3 IDAMAX.3 \
  184. isamax.f.3 ISAMAX.3 izamax.f.3 IZAMAX.3 LSAME.3 sasum.f.3 SASUM.3 saxpy.f.3 SAXPY.3 \
  185. scabs1.f.3 SCABS1.3 scasum.f.3 SCASUM.3 scnrm2.f.3 SCNRM2.3 scopy.f.3 SCOPY.3 sdot.f.3 SDOT.3 \
  186. sdsdot.f.3 SDSDOT.3 sgbmv.f.3 SGBMV.3 sgemm.f.3 SGEMM.3 sgemv.f.3 SGEMV.3 sger.f.3 SGER.3 \
  187. snrm2.f.3 SNRM2.3 srot.f.3 SROT.3 srotg.f.3 SROTG.3 srotm.f.3 SROTM.3 srotmg.f.3 SROTMG.3 \
  188. ssbmv.f.3 SSBMV.3 sscal.f.3 SSCAL.3 sspmv.f.3 SSPMV.3 sspr.f.3 SSPR.3 sspr2.f.3 SSPR2.3 \
  189. sswap.f.3 SSWAP.3 ssymm.f.3 SSYMM.3 ssymv.f.3 SSYMV.3 ssyr.f.3 SSYR.3 ssyr2.f.3 SSYR2.3 \
  190. ssyr2k.f.3 SSYR2K.3 ssyrk.f.3 SSYRK.3 stbmv.f.3 STBMV.3 stbsv.f.3 STBSV.3 stpmv.f.3 STPMV.3 \
  191. stpsv.f.3 STPSV.3 strmm.f.3 STRMM.3 strmv.f.3 STRMV.3 strsm.f.3 STRSM.3 strsv.f.3 STRSV.3 \
  192. XERBLA.3 XERBLA_ARRAY.3 zaxpy.f.3 ZAXPY.3 zcopy.f.3 ZCOPY.3 \
  193. zdotc.f.3 ZDOTC.3 zdotu.f.3 ZDOTU.3 zdrot.f.3 ZDROT.3 zdscal.f.3 ZDSCAL.3 zgbmv.f.3 ZGBMV.3 \
  194. zgemm.f.3 ZGEMM.3 zgemv.f.3 ZGEMV.3 zgerc.f.3 ZGERC.3 zgeru.f.3 ZGERU.3 zhbmv.f.3 ZHBMV.3 \
  195. zhemm.f.3 ZHEMM.3 zhemv.f.3 ZHEMV.3 zher.f.3 ZHER.3 zher2.f.3 ZHER2.3 zher2k.f.3 ZHER2K.3 \
  196. zherk.f.3 ZHERK.3 zhpmv.f.3 ZHPMV.3 zhpr.f.3 ZHPR.3 zhpr2.f.3 ZHPR2.3 zrotg.f.3 ZROTG.3 \
  197. zscal.f.3 ZSCAL.3 zswap.f.3 ZSWAP.3 zsymm.f.3 ZSYMM.3 zsyr2k.f.3 ZSYR2K.3 zsyrk.f.3 ZSYRK.3 \
  198. ztbmv.f.3 ZTBMV.3 ztbsv.f.3 ZTBSV.3 ztpmv.f.3 ZTPMV.3 ztpsv.f.3 ZTPSV.3 ztrmm.f.3 ZTRMM.3 \
  199. ztrmv.f.3 ZTRMV.3 ztrsm.f.3 ZTRSM.3 ztrsv.f.3 ZTRSV.3 ../../blas/man/man3
  200. cd ../..
  201. popd
  202. find manpages/blas/man/man3 -type f -printf "%{_mandir}/man3/%f*\n" > blasmans
  203. find manpages/man/man3 -type f -printf "%{_mandir}/man3/%f*\n" > lapackmans
  204. cp -f manpages/blas/man/man3/* ${RPM_BUILD_ROOT}%{_mandir}/man3
  205. cp -f manpages/man/man3/* ${RPM_BUILD_ROOT}%{_mandir}/man3
  206. # Lapacke headers
  207. mkdir -p %{buildroot}%{_includedir}/lapacke/
  208. cp -a lapacke/include/*.h %{buildroot}%{_includedir}/lapacke/
  209. cd ${RPM_BUILD_ROOT}%{_libdir}
  210. ln -sf liblapack.so.%{version} liblapack.so
  211. ln -sf liblapack.so.%{version} liblapack.so.%{shortver}
  212. ln -sf liblapack.so.%{version} liblapack.so.%{mediumver}
  213. ln -sf liblapacke.so.%{version} liblapacke.so
  214. ln -sf liblapacke.so.%{version} liblapacke.so.%{shortver}
  215. ln -sf liblapacke.so.%{version} liblapacke.so.%{mediumver}
  216. ln -sf libblas.so.%{version} libblas.so
  217. ln -sf libblas.so.%{version} libblas.so.%{shortver}
  218. ln -sf libblas.so.%{version} libblas.so.%{mediumver}
  219. %post -p /sbin/ldconfig
  220. %postun -p /sbin/ldconfig
  221. %post -n blas -p /sbin/ldconfig
  222. %postun -n blas -p /sbin/ldconfig
  223. %clean
  224. rm -fr ${RPM_BUILD_ROOT}
  225. %files -f lapackmans
  226. %defattr(-,root,root)
  227. %doc README LICENSE lapackqref.ps
  228. %dir %{_mandir}/man3/
  229. %{_libdir}/liblapack.so.*
  230. %{_libdir}/liblapacke.so.*
  231. %files devel
  232. %defattr(-,root,root,-)
  233. %{_includedir}/lapacke/
  234. %{_libdir}/liblapack.so
  235. %{_libdir}/liblapacke.so
  236. %files static
  237. %defattr(-,root,root,-)
  238. %{_libdir}/liblapack*.a
  239. %files -n blas -f blasmans
  240. %defattr(-,root,root)
  241. %doc blasqr.ps LICENSE
  242. %dir %{_mandir}/man3/
  243. %{_libdir}/libblas.so.*
  244. %files -n blas-devel
  245. %defattr(-,root,root,-)
  246. %{_libdir}/libblas.so
  247. %files -n blas-static
  248. %defattr(-,root,root,-)
  249. %{_libdir}/libblas*.a
  250. %changelog
  251. * Thu Feb 23 2012 NAKAMURA Kenta <kenta@vinelinux.org> 3.4.0-1
  252. - update to 3.4.0
  253. - build and include lapacke
  254. * Sat Nov 26 2011 NAKAMURA Kenta <kenta@vinelinux.org> 3.3.1-1
  255. - new upstream release
  256. - update package descriptions
  257. * Fri Feb 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.1-1
  258. - new upstream release
  259. - built with new toolchain
  260. - added SOURCE1
  261. * Wed Sep 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.1-2
  262. - applied new versioning policy
  263. - spec in UTF-8
  264. * Wed Aug 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.1-1vl3
  265. - rebuilt for VineSeed
  266. * Wed Aug 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.1-1vl2
  267. - rebuilt for VinePlus/4.0
  268. - added Patch4, Source102 and Source103 for compiling in g77
  269. - added BuildRequires: coreutils, findutils
  270. * Tue Aug 7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.1-1vl1
  271. - new upstream release based on Fedora packages
  272. * Wed Sep 14 2005 Tom "spot" Callaway <tcallawa@redhat.com> 3.0-30
  273. - make -devel packages
  274. - make liblapack_pic.a package
  275. * Wed Aug 20 2003 Jeremy Katz <katzj@redhat.com> 3.0-22
  276. - nuke -man subpackages (#97506)
  277. - rebuilt with gfortran
  278. * Thu Dec 26 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.0-17vl3
  279. - rebuild with new toolchains
  280. * Mon Oct 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.0-17vl2
  281. - rebuild with new toolchains
  282. * Thu Jul 18 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0-17vl1
  283. - modified for Vine.
  284. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  285. - automated rebuild
  286. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  287. - automated rebuild
  288. * Wed May 1 2002 Trond Eivind Glomsr� <teg@redhat.com> 3.0-15
  289. - Rebuild
  290. * Wed Feb 27 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 3.0-14bw
  291. - rebuild for RH7.2.
  292. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  293. - automated rebuild
  294. * Mon Aug 13 2001 Trond Eivind Glomsrod <teg@redhat.com> 3.0-12
  295. - The man-pages for xerbla and lsame were in blas-man and lapack-man (#51605)
  296. * Fri Jun 8 2001 Trond Eivind Glomsrod <teg@redhat.com>
  297. - Reenable optimization for IA64
  298. * Fri May 25 2001 Trond Eivind Glomsrod <teg@redhat.com>
  299. - Add all patches from the LAPACK site as of 2001-05-25
  300. - Use this workaround for IA64 instead
  301. - Remove SPARC workaround
  302. - Don't exclude IA64
  303. * Thu Dec 07 2000 Trond Eivind Glomsrod <teg@redhat.com>
  304. - rebuild for main distribution
  305. * Mon Nov 20 2000 Trond Eivind Glomsrod <teg@redhat.com>
  306. - add the LAPACK Quick Reference Guide to the docs
  307. - add the BLAS Quick Reference Guide to the docs
  308. * Tue Aug 01 2000 Trond Eivind Glomsrod <teg@redhat.com>
  309. - fix lack of ldconfig in postuninstall script
  310. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  311. - rebuilt
  312. * Mon Jul 10 2000 Trond Eivind Glomsrod <teg@redhat.com>
  313. - updated with the latest updates (new tarfile..) from netlib
  314. * Thu Jun 15 2000 Trond Eivind Glomsrod <teg@redhat.com>
  315. - use %%{_mandir}
  316. - added some flags to work around SPARC compiler bug
  317. * Wed Jan 19 2000 Tim Powers <timp@redhat.com>
  318. - bzipped sources to conserve space
  319. * Tue Jan 4 2000 Jeff Johnson <jbj@redhat.com>
  320. - build for PowerTools 6.2.
  321. * Sat Dec 25 1999 Joachim Frieben <jfrieben@hotmail.com>
  322. - updated to version v3.0 + update as of Tue Nov 30 1999
  323. * Sat Oct 23 1999 Joachim Frieben <jfrieben@hotmail.com>
  324. - updated Red Hat makefiles to v3.0
  325. * Mon Aug 2 1999 Tim Powers <timp@redhat.com>
  326. - updated to v3.0
  327. - built for 6.1
  328. * Mon Apr 12 1999 Michael Maher <mike@redhat.com>
  329. - built package for 6.0
  330. * Sat Oct 24 1998 Jeff Johnson <jbj@redhat.com>
  331. - new description/summary text.
  332. * Fri Jul 17 1998 Jeff Johnson <jbj@redhat.com>
  333. - repackage for powertools.
  334. * Sun Feb 15 1998 Trond Eivind Glomsrod <teg@pvv.ntnu.no>
  335. [lapack-2.0-9]
  336. - No code updates, just built with a customized rpm -
  337. this should make dependencies right.
  338. * Sat Feb 07 1998 Trond Eivind Glomsrod <teg@pvv.ntnu.no>
  339. [lapack-2.0-8]
  340. - Total rewrite of the spec file
  341. - Added my own makefiles - libs should build better,
  342. static libs should work (and be faster than they
  343. would be if they had worked earlier ;)
  344. - No patch necessary anymore.
  345. - Renamed lapack-blas and lapack-blas-man to
  346. blas and blas-man. "Obsoletes:" tag added.
  347. (oh - and as always: Dedicated to the girl I
  348. love, Eline Skirnisdottir)
  349. * Sat Dec 06 1997 Trond Eivind Glomsrod <teg@pvv.ntnu.no>
  350. [lapack-2.0-7]
  351. - added a dependency to glibc, so people don't try with libc5
  352. * Thu Nov 20 1997 Trond Eivind Glomsrod <teg@pvv.ntnu.no>
  353. [lapack-2.0-6]
  354. - removed etime.c
  355. - compiled with egcs, and for glibc 2.0
  356. * Sun Oct 12 1997 Trond Eivind Glomsrod <teg@pvv.ntnu.no>
  357. [lapack-2.0-5]
  358. - added a changelog
  359. - cleaned up building of shared libs
  360. - now uses a BuildRoot
  361. - cleaned up the specfile