guile-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define mver 1.8
  3. Name: guile
  4. Summary: A GNU implementation of Scheme for application extensibility.
  5. Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
  6. Version: 1.8.8
  7. Release: 1%{?_dist_release}
  8. Group: Development/Languages
  9. License: GPLv2+ and LGPLv2+ and GFDL and OFSFDL
  10. URL: http://www.gnu.org/software/guile/
  11. Source: ftp://ftp.gnu.org/gnu/guile-%{version}.tar.gz
  12. # following patchs are imported from fedora-dev
  13. Patch1: guile-1.8.7-multilib.patch
  14. Patch2: guile-1.8.7-testsuite.patch
  15. Patch4: guile-1.8.6-deplibs.patch
  16. Buildroot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: libtool libtool-ltdl-devel >= 2.2.6a
  18. BuildRequires: gmp-devel readline-devel emacs
  19. Requires(post): /sbin/install-info
  20. Requires(preun): /sbin/install-info
  21. Requires: coreutils
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: yasumichi
  25. %description
  26. GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
  27. implementation of the Scheme programming language, written in C. GUILE
  28. provides a machine-independent execution platform that can be linked in
  29. as a library during the building of extensible programs.
  30. Install the guile package if you'd like to add extensibility to programs
  31. that you are developing.
  32. %package devel
  33. Summary: Libraries and header files for the GUILE extensibility library.
  34. Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
  35. Group: Development/Libraries
  36. Requires: %{name} = %{version}-%{release}
  37. Requires: gmp-devel
  38. %description devel
  39. The guile-devel package includes the libraries, header files, etc.,
  40. that you'll need to develop applications that are linked with the
  41. GUILE extensibility library.
  42. You need to install the guile-devel package if you want to develop
  43. applications that will be linked to GUILE. You'll also need to
  44. install the guile package.
  45. %package -n compat32-%{name}
  46. Summary: A GNU implementation of Scheme for application extensibility.
  47. Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
  48. Group: Development/Languages
  49. Requires: %{name} = %{version}-%{release}
  50. %description -n compat32-%{name}
  51. GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
  52. implementation of the Scheme programming language, written in C. GUILE
  53. provides a machine-independent execution platform that can be linked in
  54. as a library during the building of extensible programs.
  55. Install the guile package if you'd like to add extensibility to programs
  56. that you are developing.
  57. %package -n compat32-%{name}-devel
  58. Summary: Libraries and header files for the GUILE extensibility library.
  59. Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
  60. Group: Development/Libraries
  61. Requires: %{name}-devel = %{version}-%{release}
  62. Requires: compat32-%{name} = %{version}-%{release}
  63. Requires: compat32-gmp-devel
  64. %description -n compat32-%{name}-devel
  65. The guile-devel package includes the libraries, header files, etc.,
  66. that you'll need to develop applications that are linked with the
  67. GUILE extensibility library.
  68. You need to install the guile-devel package if you want to develop
  69. applications that will be linked to GUILE. You'll also need to
  70. install the guile package.
  71. %prep
  72. %setup -q
  73. %patch1 -p1 -b .multilib
  74. %patch2 -p1 -b .testsuite
  75. %patch4 -p1 -b .deplibs
  76. %build
  77. %configure --disable-static --disable-error-on-warning
  78. # Remove RPATH
  79. sed -i 's|" $sys_lib_dlsearch_path "|" $sys_lib_dlsearch_path %{_libdir} "|' \
  80. {,guile-readline/}libtool
  81. make %{?_smp_mflags}
  82. %install
  83. rm -rf $RPM_BUILD_ROOT
  84. make DESTDIR=$RPM_BUILD_ROOT install
  85. mkdir -p $RPM_BUILD_ROOT%{_datadir}/guile/site
  86. rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.la
  87. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  88. # Compress large documentation
  89. bzip2 NEWS
  90. for i in ${RPM_BUILD_ROOT}%{_infodir}/goops.info; do
  91. iconv -f iso8859-1 -t utf-8 < $i > $i.utf8 && mv -f ${i}{.utf8,}
  92. done
  93. touch $RPM_BUILD_ROOT%{_datadir}/guile/%{mver}/slibcat
  94. ln -s ../../slib $RPM_BUILD_ROOT%{_datadir}/guile/%{mver}/slib
  95. %clean
  96. rm -rf $RPM_BUILD_ROOT
  97. %post
  98. /sbin/ldconfig
  99. /sbin/install-info %{_infodir}/guile.info.gz %{_infodir}/dir
  100. /sbin/install-info %{_infodir}/r5rs.info.gz %{_infodir}/dir
  101. /sbin/install-info %{_infodir}/goops.info.gz %{_infodir}/dir
  102. /sbin/install-info %{_infodir}/guile-tut.info.gz %{_infodir}/dir
  103. %postun -p /sbin/ldconfig
  104. %preun
  105. if [ "$1" = 0 ]; then
  106. /sbin/install-info --delete %{_infodir}/guile.info.gz %{_infodir}/dir
  107. /sbin/install-info --delete %{_infodir}/r5rs.info.gz %{_infodir}/dir
  108. /sbin/install-info --delete %{_infodir}/goops.info.gz %{_infodir}/dir
  109. /sbin/install-info --delete %{_infodir}/guile-tut.info.gz %{_infodir}/dir
  110. fi
  111. :
  112. %post -n compat32-%{name} -p /sbin/ldconfig
  113. %postun -n compat32-%{name} -p /sbin/ldconfig
  114. %files
  115. %defattr(-,root,root,-)
  116. %doc AUTHORS COPYING* ChangeLog HACKING NEWS.bz2 README THANKS
  117. %{_bindir}/guile
  118. %{_bindir}/guile-tools
  119. %{_libdir}/libguile*.so.*
  120. %{_libdir}/libguilereadline-*.so
  121. %{_libdir}/libguile-srfi-srfi-*.so
  122. %dir %{_datadir}/guile
  123. %dir %{_datadir}/guile/%{mver}
  124. %{_datadir}/guile/%{mver}/ice-9
  125. %{_datadir}/guile/%{mver}/lang
  126. %{_datadir}/guile/%{mver}/oop
  127. %{_datadir}/guile/%{mver}/scripts
  128. %{_datadir}/guile/%{mver}/srfi
  129. %{_datadir}/guile/%{mver}/guile-procedures.txt
  130. %ghost %{_datadir}/guile/%{mver}/slibcat
  131. %ghost %{_datadir}/guile/%{mver}/slib
  132. %dir %{_datadir}/guile/site
  133. %dir %{_datadir}/emacs/site-lisp
  134. %{_datadir}/emacs/site-lisp/*.el
  135. %{_infodir}/*
  136. %{_mandir}/man1/guile.1*
  137. %files devel
  138. %defattr(-,root,root,-)
  139. %{_bindir}/guile-config
  140. %{_bindir}/guile-snarf
  141. %{_datadir}/aclocal/*
  142. %{_libdir}/libguile.so
  143. %{_libdir}/pkgconfig/*.pc
  144. %{_includedir}/guile
  145. %{_includedir}/libguile
  146. %{_includedir}/libguile.h
  147. # compat32
  148. %if %{build_compat32}
  149. %files -n compat32-%{name}
  150. %defattr(-,root,root,-)
  151. %{_libdir}/libguile*.so.*
  152. %{_libdir}/libguilereadline-*.so
  153. %{_libdir}/libguile-srfi-srfi-*.so
  154. %files -n compat32-%{name}-devel
  155. %defattr(-,root,root,-)
  156. %{_libdir}/libguile.so
  157. %{_libdir}/pkgconfig/*.pc
  158. %endif
  159. %changelog
  160. * Tue Nov 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.8-1
  161. - update to 1.8.8
  162. - remove Patch3,5,6 (guile-1.8.7-ia64jmp.patch)
  163. * Sat Oct 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-2
  164. - rebuilt with rpm-4.8.1
  165. - added Patch1, 2, 3, 5 and 6 from Fedora
  166. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.8.7-1
  167. - new upstream release.
  168. - comment out Patch11,12.
  169. * Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-4
  170. - added Requires: gmp-devel to guile-devel
  171. * Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-3
  172. - added compat32 package for x86_64 arch support
  173. * Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-2
  174. - rebuild with libtool-2.2.6a
  175. * Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.8.6-1
  176. - new upstream release
  177. - import some patches from fedora development
  178. - drop some old patches
  179. - update spec based on fedora package
  180. - spec in utf-8
  181. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-6vl5
  182. - use macro for Release
  183. * Sat May 10 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-5vl5
  184. - apply new virsioning policy.
  185. - remove *.la
  186. * Sun Apr 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl2
  187. - rebuilt with readline 5.1
  188. * Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl1
  189. - added Patches from Fedora
  190. * Fri Sep 02 2005 Phil Knirsch <pknirsch@redhat.com> 5:1.6.7-4
  191. - Fix dynamic linking on 64bit archs (#159971)
  192. * Tue Dec 21 2004 Phil Knirsch <pknirsch@redhat.com> 5:1.6.4-16
  193. - Moved info files to base package as they are not devel related (#139948)
  194. - Moved static guilereadline and guile-srfi-srfi libs to devel package (#140893)
  195. - Fixed guile-tools not finding guile lib dir (#142642)
  196. - Added some nice tools (#142642)
  197. - Removed smp build, seems to be broken atm
  198. * Fri Jan 7 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-0vl1
  199. - new upstream release
  200. - dropped patch2, 4, 6
  201. - added BuildPrereq: perl
  202. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl2
  203. - rebuild with new toolchains
  204. - s/Copyright/License/
  205. - added srfi libs
  206. - patch for ppc64 from Fedora package
  207. * Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl1
  208. - update to 1.6.4
  209. * Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.6.3-0vl3
  210. - rebuild with readline-4.3
  211. * Thu Feb 13 2003 Ryoichi INAGAKI <ryo1i@bc.wakwak.com> 1.6.3-0vl2
  212. - based on Rawhide 1.6.0-4
  213. - Included s390 as working arch as well, switch to general unknown arch patch
  214. - rebuild to fix broken deps
  215. - fix continuations.h on ia64
  216. - new upstream 1.6.3
  217. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.3.4-9vl1
  218. - porting for Vine Linux
  219. - remove 1.3 patches( not required so that upstream upgrade )
  220. * Fri Jul 14 2000 Nalin Dahyabhai <nalin@redhat.com>
  221. - Add version number to prereq for umb-scheme to get the post-install to
  222. work properly.
  223. * Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
  224. - Add an Epoch = 1 in case anyone happened to have 1.4 installed.
  225. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  226. - automatic rebuild
  227. * Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  228. - Back down to 1.3.4.
  229. - Fix to actually link against the version of libguile in the package.
  230. * Sun Jun 4 2000 Nalin Dahyabhai <nalin@redhat.com>
  231. - FHS fixups using the %%{makeinstall} macro.
  232. * Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  233. - fix preun-devel
  234. - call ldconfig directly in postun
  235. * Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  236. - rebuild with new readline
  237. - update to 1.3.4
  238. * Mon Feb 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  239. - using the same catalog as umb-scheme makes umb-scheme a prereq
  240. * Thu Feb 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  241. - readline is needed for %post
  242. * Tue Feb 8 2000 Nalin Dahyabhai <nalin@redhat.com>
  243. - use the same catalog as umb-scheme
  244. * Thu Sep 2 1999 Jeff Johnson <jbj@redhat.com>
  245. - fix broken %postun
  246. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  247. - auto rebuild in the new build environment (release 6)
  248. * Wed Mar 17 1999 Michael Johnson <johnsonm@redhat.com>
  249. - added .ansi patch to fix #endif
  250. * Wed Feb 10 1999 Cristian Gafton <gafton@redhat.com>
  251. - add patch for the scm stuff
  252. * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
  253. - integrate changes from rhcn version (#640)
  254. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  255. - call libtoolize first to get it to compile on the arm
  256. * Sat Jan 9 1999 Todd Larason <jtl@molehill.org>
  257. - Added "Requires: guile" at suggestion of Manu Rouat <emmanuel.rouat@wanadoo.fr>
  258. * Fri Jan 1 1999 Todd Larason <jtl@molehill.org>
  259. - guile-devel does depend on guile
  260. - remove devel dependancy on m4
  261. - move guile-snarf from guile to guile-devel
  262. - Converted to rhcn
  263. * Wed Oct 21 1998 Jeff Johnson <jbj@redhat.com>
  264. - update to 1.3.
  265. - don't strip libguile.so.*.0.0. (but set the execute bits).
  266. * Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
  267. - spec file fixups
  268. * Wed Sep 2 1998 Michael Fulbright <msf@redhat.com>
  269. - Updated for RH 5.2
  270. * Mon Jan 26 1998 Marc Ewing <marc@redhat.com>
  271. - Started with spec from Tomasz Koczko <kloczek@idk.com.pl>
  272. - added slib link
  273. * Thu Sep 18 1997 Tomasz Koczko <kloczek@idk.com.pl> (1.2-3)
  274. - added %attr(-, root, root) for %doc,
  275. - in %post, %postun ldconfig runed as parameter "-p",
  276. - removed /bin/sh from requires,
  277. - added %description,
  278. - changes in %files.
  279. * Fri Jul 11 1997 Tomasz Koczko <kloczek@rudy.mif.pg.gda.pl> (1.2-2)
  280. - all rewrited for using Buildroot,
  281. - added %postun,
  282. - removed making buid logs,
  283. - removed "--inclededir", added "--enable-dynamic-linking" to configure
  284. parameters,
  285. - added striping shared libs and /usr/bin/guile,
  286. - added "Requires: /bin/sh" (for guile-snarf) in guile package and
  287. "Requires: m4" for guile-devel,
  288. - added macro %{PACKAGE_VERSION} in "Source:" and %files,
  289. - added %attr macros in %files.