gsoap-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339
  1. Summary: Generator Tools for Coding SOAP/XML Web Services in C and C++
  2. Name: gsoap
  3. Version: 2.7.12
  4. Release: 2%{?_dist_release}
  5. License: GPLv2+
  6. Group: Development/Tools
  7. URL: http://gsoap2.sourceforge.net
  8. Source0: http://downloads.sourceforge.net/gsoap2/gsoap_2.7.12.tar.gz
  9. Patch0: use_libtool-2.7.12.patch
  10. Patch1: unused_args.patch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildRequires: flex
  13. BuildRequires: bison
  14. BuildRequires: findutils
  15. BuildRequires: nkf
  16. BuildRequires: openssl-devel
  17. BuildRequires: autoconf
  18. BuildRequires: automake
  19. BuildRequires: libtool
  20. Requires: openssl
  21. %description
  22. The gSOAP Web services development toolkit offers an XML to C/C++
  23. language binding to ease the development of SOAP/XML Web services in C
  24. and C/C++.
  25. %package devel
  26. Summary: Devel libraries and headers for linking with gSOAP generated stubs
  27. Group: Development/System
  28. Requires: %name = %version-%release
  29. Requires: pkgconfig
  30. %description devel
  31. gSOAP libraries, headers and generators for linking with and creating
  32. gSOAP generated stubs
  33. %prep
  34. %setup -q -n gsoap-2.7
  35. # enable use of libtool in configure.in and a few Makefile.am files
  36. %patch0 -p1
  37. %patch1 -p1
  38. # a number of ~ files are distribute, but we do not want them
  39. find . -name "*~" -exec rm {} \;
  40. # we want all txt files to have unix end-of-line encoding
  41. nkf --unix --in-place README.txt LICENSE.txt NOTES.txt
  42. %build
  43. # patches change autoconf and automake files, so we must reconfigure
  44. autoreconf --install --force
  45. %configure --disable-static --prefix=/usr
  46. # dependencies are not declared properly
  47. #make %{?_smp_mflags}
  48. make
  49. # during the build a number of files that we should not distribute are
  50. # created in soapcpp2/samples/ (a doc directory), we must remove them
  51. #find soapcpp2/samples/ -name ".deps" -prune -exec rm -rf {} \;
  52. # we do not want to bother distributing samples for Windows or OS X
  53. #rm -rf soapcpp2/samples/magic_VC
  54. #rm -rf soapcpp2/samples/quote_VC
  55. #rm -rf soapcpp2/samples/quote_MAC_ProjBuild
  56. # samples do not need to be executable by default
  57. #chmod a-x soapcpp2/samples/ssl/root.sh
  58. #chmod a-x soapcpp2/samples/ssl/cacerts.pem
  59. %install
  60. rm -rf %{buildroot}
  61. make install DESTDIR=%{buildroot}
  62. rm -f %{buildroot}/%_libdir/*.la
  63. %clean
  64. rm -rf %{buildroot}
  65. %check
  66. make check
  67. %files
  68. %defattr(-,root,root,-)
  69. %doc README.txt NOTES.txt LICENSE.txt
  70. %_libdir/libgsoapck.so.0
  71. %_libdir/libgsoapck++.so.0
  72. %_libdir/libgsoapck.so.0.0.0
  73. %_libdir/libgsoapck++.so.0.0.0
  74. %_libdir/libgsoap.so.0
  75. %_libdir/libgsoap++.so.0
  76. %_libdir/libgsoap.so.0.0.0
  77. %_libdir/libgsoap++.so.0.0.0
  78. %_libdir/libgsoapssl.so.0
  79. %_libdir/libgsoapssl++.so.0
  80. %_libdir/libgsoapssl.so.0.0.0
  81. %_libdir/libgsoapssl++.so.0.0.0
  82. %files devel
  83. %defattr(-,root,root,-)
  84. %doc README.txt NOTES.txt LICENSE.txt
  85. %_bindir/soapcpp2
  86. %_bindir/wsdl2h
  87. %_libdir/libgsoapck.so
  88. %_libdir/libgsoapck++.so
  89. %_libdir/libgsoap.so
  90. %_libdir/libgsoapssl.so
  91. %_libdir/libgsoapssl++.so
  92. %_libdir/libgsoap++.so
  93. %_includedir/stdsoap2.h
  94. %dir %_datadir/gsoap
  95. %dir %_datadir/gsoap/import
  96. %_datadir/gsoap/import/c14n.h
  97. %_datadir/gsoap/import/dom.h
  98. %_datadir/gsoap/import/ds2.h
  99. %_datadir/gsoap/import/ds.h
  100. %_datadir/gsoap/import/README.txt
  101. %_datadir/gsoap/import/soap12.h
  102. %_datadir/gsoap/import/stldeque.h
  103. %_datadir/gsoap/import/stl.h
  104. %_datadir/gsoap/import/stllist.h
  105. %_datadir/gsoap/import/stlset.h
  106. %_datadir/gsoap/import/stlvector.h
  107. %_datadir/gsoap/import/wsa3.h
  108. %_datadir/gsoap/import/wsa4.h
  109. %_datadir/gsoap/import/wsa5.h
  110. %_datadir/gsoap/import/wsa.h
  111. %_datadir/gsoap/import/WS-example.c
  112. %_datadir/gsoap/import/WS-example.h
  113. %_datadir/gsoap/import/WS-Header.h
  114. %_datadir/gsoap/import/wsp.h
  115. %_datadir/gsoap/import/wsrp.h
  116. %_datadir/gsoap/import/wsse2.h
  117. %_datadir/gsoap/import/wsse.h
  118. %_datadir/gsoap/import/wsu.h
  119. %_datadir/gsoap/import/xlink.h
  120. %_datadir/gsoap/import/xmime4.h
  121. %_datadir/gsoap/import/xmime5.h
  122. %_datadir/gsoap/import/xmime.h
  123. %_datadir/gsoap/import/xml.h
  124. %_datadir/gsoap/import/xmlmime5.h
  125. %_datadir/gsoap/import/xmlmime.h
  126. %_datadir/gsoap/import/xop.h
  127. %dir %_datadir/gsoap/WS
  128. %_datadir/gsoap/WS/README.txt
  129. %_datadir/gsoap/WS/WS-Addressing.xsd
  130. %_datadir/gsoap/WS/WS-Addressing03.xsd
  131. %_datadir/gsoap/WS/WS-Addressing04.xsd
  132. %_datadir/gsoap/WS/WS-Addressing05.xsd
  133. %_datadir/gsoap/WS/WS-Discovery.wsdl
  134. %_datadir/gsoap/WS/WS-Enumeration.wsdl
  135. %_datadir/gsoap/WS/WS-Policy.xsd
  136. %_datadir/gsoap/WS/WS-Routing.xsd
  137. %_datadir/gsoap/WS/WS-typemap.dat
  138. %_datadir/gsoap/WS/discovery.xsd
  139. %_datadir/gsoap/WS/ds.xsd
  140. %_datadir/gsoap/WS/enumeration.xsd
  141. %_datadir/gsoap/WS/typemap.dat
  142. %_datadir/gsoap/WS/wsse.xsd
  143. %_datadir/gsoap/WS/wsu.xsd
  144. %dir %_datadir/gsoap/custom
  145. %_datadir/gsoap/custom/README.txt
  146. %_datadir/gsoap/custom/long_double.c
  147. %_datadir/gsoap/custom/long_double.h
  148. %_datadir/gsoap/custom/struct_timeval.c
  149. %_datadir/gsoap/custom/struct_timeval.h
  150. %_datadir/gsoap/custom/struct_tm.c
  151. %_datadir/gsoap/custom/struct_tm.h
  152. %dir %_datadir/gsoap/extras
  153. %_datadir/gsoap/extras/README.txt
  154. %_datadir/gsoap/extras/ckdb.c
  155. %_datadir/gsoap/extras/ckdb.h
  156. %_datadir/gsoap/extras/ckdbtest.c
  157. %_datadir/gsoap/extras/ckdbtest.h
  158. %_datadir/gsoap/extras/fault.cpp
  159. %_datadir/gsoap/extras/logging.cpp
  160. %_datadir/gsoap/extras/soapdefs.h
  161. %dir %_datadir/gsoap/plugin
  162. %_datadir/gsoap/plugin/README.txt
  163. %_datadir/gsoap/plugin/cacerts.c
  164. %_datadir/gsoap/plugin/cacerts.h
  165. %_datadir/gsoap/plugin/httpda.c
  166. %_datadir/gsoap/plugin/httpda.h
  167. %_datadir/gsoap/plugin/httpdatest.c
  168. %_datadir/gsoap/plugin/httpdatest.h
  169. %_datadir/gsoap/plugin/httpform.c
  170. %_datadir/gsoap/plugin/httpform.h
  171. %_datadir/gsoap/plugin/httpget.c
  172. %_datadir/gsoap/plugin/httpget.h
  173. %_datadir/gsoap/plugin/httpgettest.c
  174. %_datadir/gsoap/plugin/httpgettest.h
  175. %_datadir/gsoap/plugin/httpmd5.c
  176. %_datadir/gsoap/plugin/httpmd5.h
  177. %_datadir/gsoap/plugin/httpmd5test.c
  178. %_datadir/gsoap/plugin/httpmd5test.h
  179. %_datadir/gsoap/plugin/httppost.c
  180. %_datadir/gsoap/plugin/httppost.h
  181. %_datadir/gsoap/plugin/logging.c
  182. %_datadir/gsoap/plugin/logging.h
  183. %_datadir/gsoap/plugin/md5evp.c
  184. %_datadir/gsoap/plugin/md5evp.h
  185. %_datadir/gsoap/plugin/plugin.c
  186. %_datadir/gsoap/plugin/plugin.h
  187. %_datadir/gsoap/plugin/smdevp.c
  188. %_datadir/gsoap/plugin/smdevp.h
  189. %_datadir/gsoap/plugin/threads.c
  190. %_datadir/gsoap/plugin/threads.h
  191. %_datadir/gsoap/plugin/wsaapi.c
  192. %_datadir/gsoap/plugin/wsaapi.h
  193. %_datadir/gsoap/plugin/wsse2api.c
  194. %_datadir/gsoap/plugin/wsse2api.h
  195. %_datadir/gsoap/plugin/wsseapi.c
  196. %_datadir/gsoap/plugin/wsseapi.h
  197. %_libdir/pkgconfig/gsoapck.pc
  198. %_libdir/pkgconfig/gsoapck++.pc
  199. %_libdir/pkgconfig/gsoap.pc
  200. %_libdir/pkgconfig/gsoap++.pc
  201. %_libdir/pkgconfig/gsoapssl.pc
  202. %_libdir/pkgconfig/gsoapssl++.pc
  203. # Additions in 2.7.12-1
  204. %_datadir/gsoap/WS/WS-ReliableMessaging.wsdl
  205. %_datadir/gsoap/WS/WS-ReliableMessaging.xsd
  206. %_datadir/gsoap/WS/reference-1.1.xsd
  207. %_datadir/gsoap/WS/ws-reliability-1.1.xsd
  208. %_datadir/gsoap/import/ref.h
  209. %_datadir/gsoap/import/wsrm.h
  210. %_datadir/gsoap/import/wsrm4.h
  211. %_datadir/gsoap/import/wsrx.h
  212. %post -p /sbin/ldconfig
  213. %postun -p /sbin/ldconfig
  214. %changelog
  215. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.7.12-2
  216. - rebuilt with rpm-4.8.1 for pkg-config
  217. * Sat May 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.12-1
  218. - initial build for Vine Linux
  219. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.12-3
  220. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  221. * Fri Jan 16 2009 Tomas Mraz <tmraz@redhat.com> - 2.7.12-2
  222. - rebuild with new openssl
  223. * Wed Dec 24 2008 <matt@redhat> - 2.7.12-1
  224. - Updated to gsoap 2.7.12:
  225. - Numerous bug fixes - xml:lang, maxOccurs="unbounded", SSL, xmlns="", ...
  226. - New features, maintaining backward compatibility - MinGW, wsseapi, multi-endpoint connect, ...
  227. - Patches removed (incorporated upstream):
  228. - datadir_importpath-2.7.10.patch
  229. - install_soapcpp2_wsdl2h_aux-2.7.10.patch
  230. - no_locale.patch as default off, enable by defining WITH_C_LOCALE
  231. - Patches added (sent upstream):
  232. - unused_args.patch - eliminate many unused param warnings
  233. * Thu Feb 21 2008 <mfarrellee@redhat> - 2.7.10-4
  234. - Applied upd patch from upstream. It fixes glibc C locale issues,
  235. hp-ux h_errno definition, and xsd:dateTime timezone processing for
  236. WS-I
  237. - Removed tru64_hp_ux patches, they are present in upstream's upd
  238. patch
  239. - Added no_locale.patch to stop configure from checking for locale
  240. version of functions
  241. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.7.10-3
  242. - Autorebuild for GCC 4.3
  243. * Mon Feb 18 2008 <mfarrellee@redhat> - 2.7.10-2
  244. - Removed --disable-namespaces from configure, result is code compiled
  245. against gsoap does not need to call set_soap_namespaces
  246. * Sun Jan 27 2008 <mfarrellee@redhat> - 2.7.10-1
  247. - Upgraded to 2.7.10 release
  248. - Stopped hosting patches on grid.et.redhat.com
  249. - Removed import_dom_h patch, it was integrated
  250. - Removed large autotools patch, replaced with patch
  251. (use_libtool-2.7.10.patch) changing configure.in, gsoap/Makefile.am
  252. and gsoap/wsdl/Makefile.am, which enable libtool use, and a
  253. call to autoreconf
  254. - Changed soapcpp2 references to gsoap as per new layout of source
  255. distribution
  256. - Updated tru64_hp_up_c/pp patches to handle new source layout
  257. - Install of soapcpp2/import with cp removed in favor of a patch to
  258. gsoap/Makefile.am (install_soapcpp2_wsdl2h_aux-2.7.10.patch)
  259. - No pre-generated Makefiles are distributed, no longer removing them
  260. - stdsoap2_cpp.cpp not in distribution, no longer removing it
  261. - Added datadir_importpath-2.7.10.patch to set SOAPCPP2_IMPORT_PATH
  262. and WSDL2H_IMPORT_PATH, useful defaults, using ${datadir} instead of
  263. `pwd`
  264. - Added autoconf, automake and libtool to BuildRequires, because
  265. configure.in and gsoap/Makefile.am are patched
  266. - Added ?dist to Release
  267. * Fri Nov 30 2007 <mfarrellee@redhat> - 2.7.9-0.4.l
  268. - Added OpenSSL requirement
  269. * Tue Nov 27 2007 <mfarrellee@redhat> - 2.7.9-0.3.l
  270. - Decided soapcpp2/import/ files should be in /usr/share instead of
  271. /usr/include because they are not really headers gcc can
  272. process. Also, this is likely the location new versions of gsoap
  273. will install the import headers. People should use -I
  274. /usr/share/gsoap/import
  275. * Mon Nov 26 2007 <mfarrellee@redhat> - 2.7.9-0.2.l
  276. - Changed license tag to GPLv2+, which is more accurate
  277. - Resolved bz399761 by adding soapcpp2/import/*.h to the -devel
  278. package as /usr/include/gsoap, users will need to add -I
  279. /usr/include/gsoap to their soapcpp2 line
  280. * Sun Sep 30 2007 <mfarrellee@redhat> - 2.7.9-0.1.l
  281. - Updated to 2.7.9l (2.7.9k patches still apply)
  282. - Added patch for import/dom.h missing xsd__anyAttribute definitions
  283. - Removed removal of .deps directories and autom4te.cache
  284. * Mon Sep 24 2007 <mfarrellee@redhat> - 2.7.9-0.2.k
  285. - Moved pkgconfig requirement to -devel package
  286. * Tue Sep 11 2007 <mfarrellee@redhat> - 2.7.9-0.1.k
  287. - Initial release