google-gadgets-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295
  1. #define svnrev 1449
  2. #define alphatag 20090430svn%{svnrev}
  3. Name: google-gadgets
  4. Summary: Google Gadgets platform for Linux
  5. Version: 0.11.2
  6. Release: 3%{?_dist_release}
  7. Group: User Interface/Desktops
  8. License: ASL 2.0
  9. URL: http://code.google.com/p/google-gadgets-for-linux/
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: inagaki,yasumichi
  13. Source0: http://google-gadgets-for-linux.googlecode.com/files/google-gadgets-for-linux-%{version}.tar.bz2
  14. #Source0: %{name}-%{version}-r%{svnrev}.tar.bz2
  15. Patch0: NM-0.9.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: curl-devel libxml2-devel zlib-devel libtool-ltdl-devel
  18. # still needed even if we're not buliding gtkmoz element, for JavaScript
  19. #%%if %{?_dist_release} == "vl5"
  20. #BuildRequires: xulrunner-devel-unstable
  21. #%%else
  22. #BuildRequires: xulrunner-devel
  23. #%%endif
  24. BuildRequires: WebKit-gtk-devel
  25. BuildRequires: dbus-devel gstreamer-devel gstreamer-plugins-base-devel
  26. BuildRequires: cairo-devel gtk2-devel librsvg2-devel
  27. BuildRequires: qt4-devel zip
  28. # Desktop integration
  29. BuildRequires: NetworkManager-devel startup-notification-devel
  30. # libxml2-devel needed for desktop file generation
  31. BuildRequires: libxml2-devel desktop-file-utils
  32. BuildRequires: pkgconfig
  33. Requires: %{name}-frontend = %{version}-%{release}
  34. Requires: hicolor-icon-theme
  35. %description
  36. Google Gadgets for Linux provides a platform for running desktop
  37. gadgets under Linux, catering to the unique needs of Linux users. It
  38. can run, without modification, many Google Desktop gadgets as well as
  39. the Universal Gadgets on iGoogle.
  40. %package gtk
  41. Summary: GTK+ front-end for %{name}
  42. Summary(ja): Google Gadgets の GTK+ 版フロントエンド
  43. Group: User Interface/Desktops
  44. Requires: %{name} = %{version}-%{release}
  45. Provides: %{name}-frontend = %{version}-%{release}
  46. %description gtk
  47. The %{name}-gtk package contains the GTK+ front-end for %{name}.
  48. %package qt
  49. Summary: Qt front-end for %{name}
  50. Summary(ja): Google Gadgets の Qt 版フロントエンド
  51. Group: User Interface/Desktops
  52. Requires: %{name} = %{version}-%{release}
  53. Provides: %{name}-frontend = %{version}-%{release}
  54. %description qt
  55. The %{name}-qt package contains the Qt front-end for %{name}.
  56. %package devel
  57. Summary: Development files for %{name}
  58. Summary(ja): %{name} の開発用ファイル
  59. Group: Development/Libraries
  60. Requires: %{name} = %{version}-%{release}
  61. Requires: pkgconfig dbus-devel gtk2-devel qt4-devel
  62. Requires: %{name}-gtk
  63. Requires: %{name}-qt
  64. %description devel
  65. The %{name}-devel package contains libraries and header files for
  66. developing applications that use %{name}.
  67. %prep
  68. %setup -q -n %{name}-for-linux-%{version}
  69. %patch0 -p1
  70. # Permission fixes
  71. chmod -x ggadget/qt/utilities.h
  72. # Fix invalid desktop file MIME type
  73. # http://code.google.com/p/google-gadgets-for-linux/issues/detail?id=360
  74. for f in hosts/*/ggl-*.desktop.in; do
  75. sed -i 's|;app/gg;|;|' $f
  76. done
  77. %build
  78. #autotools/bootstrap.sh
  79. #ln -s %{_datadir}/automake-*/mkinstalldirs libltdl/
  80. %configure --disable-static \
  81. --with-browser-plugins-dir=%{_libdir}/mozilla/plugins \
  82. --disable-gtkmoz-browser-element --disable-smjs-script-runtime
  83. # Rpath fix by Mamoru Tasaka
  84. # we don't want to obliterate all RPATHs, since it is used during build
  85. # Add library search path
  86. sed -i.libdir_syssearch -e \
  87. '/sys_lib_dlsearch_path_spec/s|/usr/lib |/usr/lib /usr/lib64 /lib /lib64 |' \
  88. configure
  89. # Remove the redundant RPATH for %%{_libdir}, already searched by Fedora libtool
  90. sed -i.extra_R -e \
  91. 's|-R\$(libdir)||' \
  92. hosts/*/Makefile.in
  93. # default compile flags are impossibly strict
  94. make %{?_smp_mflags} DEFAULT_COMPILE_FLAGS=
  95. # Remove quotes from .pc files
  96. find . -name '*.pc' -exec sed -i 's|\"||g' '{}' \;
  97. %install
  98. rm -rf $RPM_BUILD_ROOT
  99. make install DESTDIR=$RPM_BUILD_ROOT \
  100. INSTALL="install -p" CPPROG="cp -p"
  101. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  102. # reinstall desktop files
  103. for i in gtk qt; do
  104. desktop-file-install \
  105. --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
  106. --delete-original \
  107. $RPM_BUILD_ROOT%{_datadir}/applications/ggl-$i.desktop
  108. done
  109. # wipe prematurely-generated MIME info
  110. rm -rf $RPM_BUILD_ROOT%{_datadir}/mime
  111. rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
  112. %clean
  113. rm -rf $RPM_BUILD_ROOT
  114. %post
  115. /sbin/ldconfig
  116. touch --no-create %{_datadir}/icons/hicolor || :
  117. %postun
  118. /sbin/ldconfig
  119. if [ $1 -eq 0 ] ; then
  120. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  121. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  122. fi
  123. %posttrans
  124. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  125. %post gtk
  126. /sbin/ldconfig
  127. update-desktop-database &> /dev/null || :
  128. %postun gtk
  129. /sbin/ldconfig
  130. update-desktop-database &> /dev/null || :
  131. %post qt
  132. /sbin/ldconfig
  133. update-desktop-database &> /dev/null || :
  134. %postun qt
  135. /sbin/ldconfig
  136. update-desktop-database &> /dev/null || :
  137. %files
  138. %defattr(-,root,root,-)
  139. %doc AUTHORS COPYING README
  140. %{_libdir}/google-gadgets
  141. #%%exclude %{_libdir}/google-gadgets/gtkmoz-browser-child
  142. %exclude %{_libdir}/google-gadgets/modules/gtk*.so
  143. %exclude %{_libdir}/google-gadgets/modules/qt*.so
  144. %exclude %{_libdir}/google-gadgets/include
  145. %{_libdir}/lib*.so.*
  146. %exclude %{_libdir}/lib*gtk*
  147. %exclude %{_libdir}/lib*qt*
  148. %{_datadir}/google-gadgets
  149. %{_datadir}/pixmaps/google-gadgets.png
  150. %{_datadir}/icons/hicolor/*/*/*.png
  151. %files gtk
  152. %defattr(-,root,root,-)
  153. %{_bindir}/ggl-gtk
  154. %{_libdir}/libggadget-gtk*.so.*
  155. #%%{_libdir}/google-gadgets/gtkmoz-browser-child
  156. %{_libdir}/google-gadgets/modules/gtk*.so
  157. %{_datadir}/applications/*gtk.desktop
  158. %{_datadir}/applications/*designer.desktop
  159. %files qt
  160. %defattr(-,root,root,-)
  161. %{_bindir}/ggl-qt
  162. %{_libdir}/libggadget-qt*.so.*
  163. %{_libdir}/google-gadgets/modules/qt*.so
  164. %{_datadir}/applications/*qt.desktop
  165. %files devel
  166. %defattr(-,root,root,-)
  167. %{_includedir}/google-gadgets
  168. %{_libdir}/lib*.so
  169. %{_libdir}/google-gadgets/include
  170. %{_libdir}/pkgconfig/*.pc
  171. %changelog
  172. * Sat Aug 27 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.11.2-3
  173. - add patch for building with NetworkManager-0.9.0
  174. - add Vendor, Distribution and Packager tag
  175. * Thu Aug 18 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.11.2-2
  176. - not work with xulrunner 2.0, remove from BR.
  177. - add --disable-gtkmoz-browser-element , --disable-smjs-script-runtime
  178. * Thu Sep 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.2-1
  179. - new upstream release
  180. - built with rpm-4.8.1 for pkg-config
  181. - dropt Patch0
  182. - added BR: WebKit-gtk-devel
  183. - removed invalid MIME entry from .desktop files
  184. * Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.1-1
  185. - new upstream release
  186. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.0-2
  187. - Initial build for Vine Linux
  188. * Wed Jul 1 2009 Michel Salim <michel@erdos.localdomain> - 0.11.0-1
  189. - Update to 0.11.0
  190. * Sat May 2 2009 Michel Salim <salimma@fedoraproject.org> - 0.10.6-0.1.20090430svn1449%{?dist}
  191. - Update to SVN checkout, for xulrunner 1.9.1 compatibility
  192. * Mon Apr 27 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-6
  193. - Rebuild against newer gecko
  194. * Fri Mar 27 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-4
  195. - Rebuild against newer gecko
  196. * Fri Mar 06 2009 Jan Horak <jhorak@redhat.com> - 0.10.5-3
  197. - Rebuild against newer gecko
  198. * Wed Feb 04 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-2
  199. - Rebuild against newer gecko
  200. * Wed Jan 14 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.10.5-1
  201. - 0.10.5, req'd by kde
  202. * Tue Dec 30 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.4-2
  203. - BR: Network-Manager-devel, startup-notification-devel
  204. - Pass the browser plugin directory to ./configure
  205. - Move designer desktop entry to -gtk subpackage
  206. * Sat Dec 20 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.10.4-1
  207. - Update to 0.10.4 (#477251)
  208. - -devel: Requires: %%name-gtk %%name-qt (devel symlinks)
  209. - BR: pkgconfig (automatic pkgconfig deps)
  210. * Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.3-1
  211. - Update to 0.10.3
  212. * Sat Nov 8 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.10.1-5
  213. - s/qt-devel/qt4-devel/
  214. - -qt: fix summary
  215. * Tue Sep 2 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-4
  216. - Unquote version strings in .pc files
  217. * Thu Aug 28 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-3
  218. - RPATH and timestamp fixes from Mamoru Tasaka
  219. * Tue Aug 26 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-2
  220. - Fix desktop file creation
  221. * Mon Aug 25 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-1
  222. - Update to 0.10.1
  223. * Mon Jul 14 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.0-1
  224. - Update to 0.10.0
  225. - Add missing dependencies for -devel subpackage
  226. * Sun Jul 6 2008 Michel Salim <salimma@fedoraproject.org> - 0.9.3-1
  227. - Update to 0.9.3
  228. * Fri Jun 6 2008 Michel Salim <salimma@fedoraproject.org> - 0.9.1-1
  229. - Initial package