gnuplot-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231
  1. %define gpmainver 4.4
  2. %define gpver %{gpmainver}.3
  3. Summary: A program for plotting mathematical expressions and data.
  4. Summary(ja): 数学系の関数やデータのプロット・プログラム
  5. Name: gnuplot
  6. Version: %{gpver}
  7. Release: 2%{?_dist_release}
  8. License: gnuplot and GPLv2
  9. Group: Applications/Engineering
  10. URL: http://gnuplot.sourceforge.net/
  11. Source: http://prdownloads.sourceforge.net/gnuplot/gnuplot-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-root
  13. BuildRequires: gd-devel >= 2.0.27, libpng-devel, zlib-devel
  14. BuildRequires: libX11-devel, libXt-devel, wxGTK-devel
  15. BuildRequires: readline-devel
  16. BuildRequires: lua-devel cairo-devel pango-devel
  17. BuildRequires: libXpm-devel libjpeg-turbo-devel
  18. BuildRequires: texlive
  19. BuildRequires: texlive-common
  20. BuildRequires: texlive-collection-latexextra
  21. BuildRequires: texinfo, emacsen
  22. Requires(post): install-info
  23. Requires(preun): install-info
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. Packager: daisuke, inagaki
  27. %description
  28. Gnuplot is a command-line driven, interactive function plotting
  29. program especially suited for scientific data representation. Gnuplot
  30. can be used to plot functions and data points in both two and three
  31. dimensions and in many different formats.
  32. Install gnuplot if you need a graphics package for scientific data
  33. representation.
  34. %description -l ja
  35. Gnuplotはとりわけ科学データ・プレゼンテーションに適した、コマンド
  36. 操作によるインタラクティブな関数プロット・プログラムです。
  37. Gnuplotは関数や座標データを同時にプロットしたり、3次元化やさまざ
  38. まな形式で表現するのに利用することができます。
  39. 科学データプレゼンテーション用のグラフィック・パッケージが必要な
  40. 場合、gnuplotをインストールしてください。
  41. %prep
  42. %setup -q
  43. %build
  44. #autoreconf -f -i
  45. %ifarch alpha
  46. %define optflags -O0
  47. %endif
  48. %configure --with-readline=gnu --with-png --without-linux-vga --enable-history-file
  49. make %{?_smp_mflags}
  50. %install
  51. rm -rf $RPM_BUILD_ROOT
  52. make install DESTDIR=$RPM_BUILD_ROOT
  53. rm -f demo/Makefile* tutorial/Makefile*
  54. # move app-dafaults to %%_datadir
  55. #mv $RPM_BUILD_ROOT%{_libdir}/X11 $RPM_BUILD_ROOT%{_datadir}/
  56. # move texmf config
  57. mv $RPM_BUILD_ROOT%{_datadir}/texmf-local $RPM_BUILD_ROOT%{_datadir}/texmf
  58. # remove unneeded files
  59. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  60. %clean
  61. rm -rf $RPM_BUILD_ROOT
  62. %post
  63. /sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/gnuplot.info.gz
  64. %preun
  65. if [ $1 = 0 ]; then
  66. /sbin/install-info --quiet --info-dir=%{_infodir} \
  67. --delete %{_infodir}/gnuplot.info.gz
  68. fi
  69. %files
  70. %defattr(-,root,root)
  71. %doc demo tutorial
  72. %doc README README.1ST INSTALL Copyright TODO
  73. %doc PATCHLEVEL VERSION BUGS ChangeLog
  74. %{_bindir}/gnuplot
  75. %{_libexecdir}/gnuplot/%{gpmainver}/*
  76. %{_datadir}/gnuplot/%{gpmainver}/*
  77. #{_datadir}/X11/app-defaults/Gnuplot
  78. %{_datadir}/texmf/tex/latex/gnuplot
  79. %{_datadir}/emacs/site-lisp/*
  80. %{_infodir}/gnuplot.info*
  81. %{_mandir}/man1/gnuplot.*
  82. %changelog
  83. * Wed Jul 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 4.4.3-2
  84. - changed BuildRequires: wx-gtk2-devel >= 2.8.12 to wxGTK-devel >= 2.8.12
  85. - added BuildRequires: libXpm-devel libjpeg-turbo-devel texlive-common
  86. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
  87. - update to gnuplot-4.4.3
  88. - use BR: texlive instead of tetex
  89. * Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.5-1
  90. - update to gnuplot-4.2.5
  91. - drop plus patch (merged in upstream)
  92. - update URL: to new upstream homepage
  93. - fix License:
  94. - build with wxGTK
  95. - add BR: libX11-devel, libXt-devel, wx-gtk2-devel
  96. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.0.0-1vl5
  97. - applied new versioning policy, spec in utf-8
  98. * Tue Aug 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl6
  99. - add BuildRequires: texinfo, emacsen
  100. * Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl5
  101. - rebuild with readline-5.1
  102. * Wed Jun 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.0-0vl4
  103. - update Patch0 to fix 'Invalid char in eps file'
  104. (thanks to HANAWA Toshihiro)
  105. - add BuildRequires: autoconf, automake
  106. * Sat Nov 20 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.0-0vl2
  107. - enabled history-file
  108. * Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.0-0vl1
  109. - source update
  110. * Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.8k.3-0vl1
  111. - source update
  112. - patch update and modified
  113. - add info
  114. * Wed Mar 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl3
  115. - rebuild
  116. - fix license
  117. - remove -DUSE_SYSTEM_TIME ([VinePlus:01805])
  118. * Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl2
  119. - rebuild with readline-4.3
  120. * Thu Feb 20 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl1
  121. - syncd with RH 3.7.3-2
  122. - modified Yamaga-san's gnuplot3.7.2+1.2.0rc2.patch for 3.7.3
  123. * Fri Jan 25 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 16vl1
  124. - added pathes (patch1,2) from RH
  125. * Sat Aug 25 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 12vl1
  126. - syncd rawhide
  127. - updated to 3.7.1-1.2.0
  128. * Mon Jun 5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  129. - updated to 3.7.1
  130. - updated gnuplot+ patch to 1.1.9 for gnuplot 3.7.1.
  131. - remake SPEC from rawhide.
  132. * Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  133. - rebuild with new gd, changing gif terminal to jpeg terminal (release 7)
  134. * Mon May 08 2000 Preston Brown <pbrown@redhat.com>
  135. - build for 7.0
  136. * Thu Apr 6 2000 Bill Nottingham <notting@redhat.com>
  137. - use gnu readline, not built-in version
  138. * Mon Apr 3 2000 Bill Nottingham <notting@redhat.com>
  139. - add latex tutorial, demo files, other docs (#10508)
  140. * Wed Mar 1 2000 Bill Nottingham <notting@redhat.com>
  141. - update to 3.7.1. Oops.
  142. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  143. - handle compressed man pages
  144. * Thu Nov 4 1999 Bill Nottingham <notting@redhat.com>
  145. - update to 3.7.1
  146. * Mon Oct 11 1999 Bill Nottingham <notting@redhat.com>
  147. - ship some docs.
  148. * Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
  149. - add a patch to fix postscript output from Bernd Kischnick
  150. (kisch@die-herrmanns.de)
  151. * Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
  152. - fix license
  153. * Thu Jul 15 1999 Bill Nottingham <notting@redhat.com>
  154. - rebuild without svgalib
  155. * Tue Jun 15 1999 Bill Nottingham <notting@redhat.com>
  156. - update to 3.7.0.1
  157. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  158. - auto rebuild in the new build environment (release 2)
  159. * Tue Feb 2 1999 Jeff Johnson <jbj@redhat.com>
  160. - update to 3.7.
  161. * Thu Dec 17 1998 Michael Maher <mike@redhat.com>
  162. - built package for 6.0
  163. * Fri Sep 11 1998 Jeff Johnson <jbj@redhat.com>
  164. - update to 2.6beta347
  165. * Sat Aug 15 1998 Jeff Johnson <jbj@redhat.com>
  166. - build root
  167. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  168. - translations modified for de, fr, tr
  169. * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
  170. - spec file cleanups
  171. * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
  172. - built against glibc