geany-plugins-vl.spec 34 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878879880881882883884885886887888889890891892893894895896897898899900901902903904905906907908909910911912913914915916917918919920921922923924925926927928929930931932933934935936937938939940941942943944945946947948949950951952953954955956957958959960961962963964965966967968969970971972973974975976977978979980981982983984985986987988989990991992993994995996997
  1. %global geany_plug_docdir %{_defaultdocdir}/%{name}-%{version}
  2. %global req_geany_ver 0.21
  3. Name: geany-plugins
  4. Version: 1.23
  5. Release: 2%{?_dist_release}
  6. Summary: Plugins for Geany
  7. Summary(ja): Geany のプラグイン集
  8. Group: Development/Tools
  9. License: GPLv3
  10. URL: http://plugins.geany.org/
  11. Source0: http://plugins.geany.org/geany-plugins/geany-plugins-%{version}.tar.bz2
  12. #Patch0: fix_installation_path_of_geanylatex_documents.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: ctpl-devel >= 0.2
  15. #BuildRequires: devhelp-devel
  16. BuildRequires: enchant-devel
  17. BuildRequires: geany-devel >= %{req_geany_ver}
  18. BuildRequires: gettext
  19. BuildRequires: gdk-pixbuf2-devel
  20. BuildRequires: glib2-devel
  21. BuildRequires: gpgme-devel
  22. BuildRequires: gtk2-devel
  23. BuildRequires: gtkspell-devel
  24. BuildRequires: intltool
  25. BuildRequires: libtool
  26. BuildRequires: libsoup-devel >= 2.4
  27. BuildRequires: lua-devel
  28. BuildRequires: libxml2-devel >= 2.6.27
  29. BuildRequires: pango-devel
  30. BuildRequires: pkgconfig
  31. BuildRequires: python-docutils
  32. BuildRequires: vala-devel
  33. BuildRequires: vte-devel
  34. BuildRequires: WebKit-gtk-devel
  35. Requires: %{name}-addons %{name}-geanydoc %{name}-geanylatex
  36. Requires: %{name}-geanylipsum %{name}-geanylua %{name}-geanyprj %{name}-geanysendmail
  37. Requires: %{name}-geanyvc %{name}-shiftcolumn %{name}-spellcheck
  38. Requires: %{name}-codenav %{name}-treebrowser %{name}-geanyextrasel
  39. Requires: %{name}-geanyinsertnum %{name}-pretty-printer %{name}-geanygendoc
  40. Requires: %{name}-updatechecker %{name}-webhelper
  41. Requires: %{name}-debugger %{name}-xmlsnippets %{name}-geanymacro %{name}-geanynumberedbookmarks
  42. Requires: %{name}-geanypg %{name}-gproject %{name}-tableconvert
  43. Requires: %{name}-geanyminiscript %{name}-geniuspaste %{name}-multiterm
  44. Requires: %{name}-commander %{name}-markdown %{name}-scope
  45. %description
  46. Plugins for Geany. Plugins included are:
  47. * Addons (Various small Addons)
  48. * Code navigation (Navigate through your source code easily)
  49. * Commander (Provides a command panel for rapid access to any action)
  50. * Debugger (Enables debugging in Geany)
  51. * Geanydoc (Call specific documentation from within Geany)
  52. * Geanyextrasel (Additional features for selecting code)
  53. * GeanyGenDoc (Automatically generate documentation source code)
  54. #* GeanyGDB (Integration with GDB)
  55. * Geanyinsertnum (Insert huge number ranges with small efforts)
  56. * GeanyLaTeX (Improved Support for LaTeX documents)
  57. * GeanyLipsum (Inserting blocks of Lorem Ipsum text)
  58. * Geanylua (Support for Scripting with Lua)
  59. * GeanyMacro (User defined Macros for Geany)
  60. * GeanyMiniScript (A tool to apply a script on a text selection or current document(s))
  61. * GeanyNumberedBookmarks (Provide users with 10 numbered Bookmarks)
  62. * GeniusPaste (Paste your code on your favorite pastebin)
  63. * GeanyPG (Encrypt, decrypt and verify signatures with GnuPG)
  64. * Geanyprj (Alternate project management for Geany)
  65. * GeanySendMail (Sending of documents from within Geany)
  66. * GeanyVC (Support for various Version Control Systems)
  67. * GProject (Extension of Geany's Project Management)
  68. * Markdown (provides a real-time preview of rendered Markdown)
  69. * MultiTerm (Multi-tabbed virtual terminal emulator)
  70. * Pretty-Print (XML Pretty Printer)
  71. * Scope (graphical GDB front-end with the normal functions)
  72. * Shiftcolumn (Moving blocks of text horizontally)
  73. * Spellcheck (Spell checking of documents or marked text)
  74. * Tableconvert (Helps on converting a tabulator separated selection into a table)
  75. * Treebrowser (Alternate file browser with tree view of folders)
  76. * Updatechecker (Automatically check for Geany updates)
  77. * Webhelper (Preview and Debug Web documents from within Geany using WebKit)
  78. * XMLSnippets (Extends XML/HTML tag autocompletion provided by Geany)
  79. This package is meta package to install all geany-plugins.
  80. %description -l ja
  81. Geany のプラグインです。プラグインには以下のものが含まれています。
  82. * Addons (色々な小さなアドオン)
  83. * Code navigation (ソースコード間を簡単に移動)
  84. * Commander (任意のアクションに迅速にアクセスするためのコマンドパネルを提供)
  85. * Debugger (Geany でデバッグを有効化)
  86. * Geanydoc (geany から固有のドキュメントを呼び出す)
  87. * Geanyextrasel (コード選択のための追加機能)
  88. * GeanyGenDoc (ソースコードから自動的にドキュメントの元を生成)
  89. #* GeanyGDB (GDB 統合環境を提供)
  90. * GeanyLaTex (LaTeX ドキュメントのサポートを改善)
  91. * GeanyLipsum (Lorem Ipsum テキストのブロックを挿入)
  92. * GeanySendMail (Geany からドキュメントの送信を許可)
  93. * GeanyVC (色々なバージョン管理システムのサポート)
  94. * GProject (Geany のプロジェクト管理拡張)
  95. * Geanyinsertnum (僅かな労力で膨大な範囲の番号を挿入)
  96. * Geanylua (lua スクリプトのサポートを提供)
  97. * GeanyMacro (Geany のユーザー定義マクロ)
  98. * GeanyMiniScript (A tool to apply a script on a text selection or current document(s))
  99. * GeanyNumberedBookmarks (ユーザーに 10 個の番号付ブックマークを提供)
  100. * GeniusPaste (お気に入りの pastebin からコードを貼り付け)
  101. * GeanyPG (GnuPG で暗号化・復号化及び署名を検証する)
  102. * Geanyprj (geany の代替プロジェクト管理)
  103. * Markdown (provides a real-time preview of rendered Markdown)
  104. * MultiTerm (マルチタブの仮想端末エミュレーター)
  105. * Scope (graphical GDB front-end with the normal functions)
  106. * Shiftcolumn (テキストブロックを水平方向に移動)
  107. * Spellcheck (ドキュメントのスペルチェック)
  108. * Tableconvert (テーブルにタブで区切られた選択項目を変換する際役立つ)
  109. * Treebrowser (フォルダの内容をツリービューする代替ファイルブラウザ)
  110. * Pretty-Print (XML Pretty Printer)
  111. * Updatechecker (Geany の更新を自動的にチェック)
  112. * Webhelper (WebKit を使い Geany から Web ドキュメントのプレビューとデバッグを実行)
  113. * XMLSnippets (Geany により提供される拡張 XML/HTML タグの自動補完)
  114. このパッケージは、geany-plugins をすべてインストールするための
  115. メタパッケージです。
  116. %package common
  117. Summary: Common files used by all geany plugins
  118. Summary(ja): すべての Geany プラグインに用いられる共通ファイル
  119. Group: Development/Tools
  120. Requires: geany >= %{req_geany_ver}
  121. %description common
  122. This package contains some common files which are used by every Geany plugin,
  123. e.g. language translations.
  124. %description common -l ja
  125. このパッケージには、例えば翻訳ファイルなどの
  126. すべての Geany プラグイン で用いられる共通ファイルが含まれています。
  127. %package addons
  128. Summary: Miscellaneous Addons for Geany
  129. Summary(ja): Geany のその他のアドオン
  130. Group: Development/Tools
  131. Requires: geany >= %{req_geany_ver}
  132. Requires: geany-plugins-common = %{version}-%{release}
  133. Obsoletes: geany-plugin-addons
  134. %description addons
  135. This plugins consists of various small addons too small to justify their own
  136. plugin, but are useful to have. The following functionality is implemented:
  137. * Doclist: This addon places a new item in the toolbar and when clicked offers
  138. a menu listing all open files plus the 'Close All' and 'Close Other
  139. Documents' menu items. This can be useful to quickly access open files and
  140. switch to them.
  141. * OpenURI: Adds 'Open URI' and 'Copy URI' menu items to the editor menu when
  142. the word under the cursor looks like a URI. 'Open URI' uses the browser
  143. command configured in Geany to open it.
  144. * Tasks:The tasks plugin goes through a file being edited and picks out lines
  145. with "TODO" or "FIXME" in them. It collects the text after those words and
  146. puts them in a new "Tasks" tab in the message window. Clicking on a task in
  147. that tab takes you to the line in the file where the task was defined.
  148. * Systray: Adds a status icon to the notification area (systray) and provides
  149. a simple popup menu with some basic actions. It can also be used to quickly
  150. show and hide the Geany main window.
  151. %package codenav
  152. Summary: Navigate through your source code easily
  153. Summary(ja): ソースコード間を簡単に移動
  154. Group: Development/Tools
  155. Requires: geany >= %{req_geany_ver}
  156. Requires: geany-plugins-common = %{version}-%{release}
  157. %description codenav
  158. This plugin adds some facilities for navigating in the code.
  159. Actually, it will make it possible to:
  160. - switch between header and implementation
  161. - go to a file by typing its name
  162. %package commander
  163. Summary: provides a command panel for rapid access to any action
  164. Summary(ja): 任意のアクションに迅速にアクセスするためのコマンドパネルを提供
  165. Group: Development/Tools
  166. Requires: geany >= %{req_geany_ver}
  167. Requires: geany-plugins-common = %{version}-%{release}
  168. %description commander
  169. Commander is a plugin for Geany that provides a command panel
  170. for rapid access to any action.
  171. %package debugger
  172. Summary: enables debugging in Geany
  173. Group: Development/Tools
  174. Requires: geany-plugins-common = %{version}-%{release}
  175. Requires: vte >= 0.24
  176. Obsoletes: geany-plugin-gdb
  177. Obsoletes: geany-plugins-geanygdb < %{version}-%{release}
  178. %description debugger
  179. Plugin enables debugging in Geany. Currently supports GDB only, but was
  180. developed with multiple debuggers support in mind, so the other backends
  181. support is planned as well.
  182. %package geanydoc
  183. Summary: Call documentation from within Geany
  184. Summary(ja): Geany 内からドキュメントを呼び出す
  185. Group: Development/Tools
  186. Requires: geany >= %{req_geany_ver}
  187. Requires: geany-plugins-common = %{version}-%{release}
  188. %description geanydoc
  189. Geanydoc allows you to execute specific commands on the word under the cursor.
  190. This word is passed as an argument to the command. The output of the command
  191. can either be placed into a special buffer called "DOC" or can be used to
  192. execute an external program. Geanydoc is intended to be used for searching
  193. through API documentation.
  194. %package geanyextrasel
  195. Summary: Additional features for selecting code
  196. Summary(ja): コード選択のための追加機能
  197. Group: Development/Tools
  198. Requires: geany >= %{req_geany_ver}
  199. Requires: geany-plugins-common = %{version}-%{release}
  200. %description geanyextrasel
  201. Geanyextrasel provides some special features for selecting code, e.g. from
  202. opening brace to closed brace and so on. This plugin will be very useful for
  203. you if you're a programmer and working with much sourcecodes.
  204. #%package geanygdb
  205. #Summary: Debugger Plugin for Geany using GDB
  206. #Summary(ja): GDB を使った Geany のデバッガプラグイン
  207. #Group: Development/Tools
  208. #Requires: geany >= %{req_geany_ver}
  209. #Requires: geany-plugins-common = %{version}-%{release}
  210. #Requires: gdb
  211. #Obsoletes: geany-plugin-gdb
  212. #%description geanygdb
  213. #GeanyGDB plugin provides an integrated debugging environment for the
  214. #GNU debugger (gdb).
  215. #%description geanygdb -l ja
  216. #GeanyGDB プラグインは GNU debugger (gdb) のための
  217. #統合的デバッグ環境を提供します。
  218. %package geanygendoc
  219. Summary: Automatically generate documentation source code
  220. Group: Development/Tools
  221. Requires: geany >= %{req_geany_ver}
  222. Requires: geany-plugins-common = %{version}-%{release}
  223. %description geanygendoc
  224. GeanyGenDoc is a plugin for Geany that aims to automatically generate
  225. documentation comment basis from the source code.
  226. You may also want to install the following packages which enable
  227. some extra features:
  228. - Docutils (http://docutils.sourceforge.net/) -- or another implementation of
  229. rst2html -- is needed to (re)generate the HTML manual.
  230. %package geanyinsertnum
  231. Summary: Insert huge number ranges with small efforts
  232. Summary(ja): 僅かな労力で膨大な範囲の番号を挿入
  233. Group: Development/Tools
  234. Requires: geany >= %{req_geany_ver}
  235. Requires: geany-plugins-common = %{version}-%{release}
  236. %description geanyinsertnum
  237. Geanyinsertnum replaces a (possibly zero-width) rectangular selection with
  238. integer numbers, using start/step/base etc. specified by the user. For
  239. practical reasons, the number of lines is limited to 500000.
  240. %package geanylatex
  241. Summary: to improve LaTeX support plugin for Geany
  242. Summary(ja): Geany のための LaTeX サポート改善プラグイン
  243. Group: Development/Tools
  244. Requires: geany >= %{req_geany_ver}
  245. Requires: geany-plugins-common = %{version}-%{release}
  246. Requires: texlive
  247. Obsoletes: geany-plugin-latex
  248. %description geanylatex
  249. This plugin improves LaTeX support in Geany. It provides several templates for
  250. new documents, help with adding labels and inserting special characters,
  251. and much more.
  252. %description geanylatex -l ja
  253. このプラグインは Geany で LaTeX のサポートを改善するプラグインです。
  254. 新しい文書のためのいくつかのテンプレート、
  255. ラベルの追加や特殊文字の挿入機能などを提供します。
  256. %package geanylipsum
  257. Summary: Lorem Ipsum generator for Inserting Placeholder Text
  258. Group: Development/Tools
  259. Requires: geany >= %{req_geany_ver}
  260. Requires: geany-plugins-common = %{version}-%{release}
  261. %description geanylipsum
  262. GeanyLipsum is a Lorem Ipsum generator for inserting placeholder text into a
  263. document.
  264. %package geanylua
  265. Summary: Support developing Lua Scripting for Geany
  266. Summary(ja): Geany で Lua スクリプト開発をサポート
  267. Group: Development/Tools
  268. Requires: geany >= %{req_geany_ver}
  269. Requires: geany-plugins-common = %{version}-%{release}
  270. Requires: lua
  271. %description geanylua
  272. This plugin provides extensive support for developing in the lua programming
  273. language.
  274. %description geanylua -l ja
  275. このプラグインは、lua プログラミング言語で開発するための
  276. 広範なサポートを提供します。
  277. %package geanymacro
  278. Summary: User defined Macros for Geany
  279. Group: Development/Tools
  280. Requires: geany-plugins-common = %{version}-%{release}
  281. %description geanymacro
  282. GeanyMacro is a plugin to provide user defined macros for Geany. It started
  283. out as part of the ConText feature parity plugin, which was split into
  284. individual plugins to better suit Geany's ethos of being as light as
  285. possible while allowing users to select which features they want to add to
  286. the core editor. The idea was taken from a Text Editor for Windows called
  287. ConText.
  288. This plugin alows you to record and use your own macros. Macros are
  289. sequences of actions that can then be repeated with a single key
  290. combination. So if you had dozens of lines where you wanted to delete the
  291. last 2 characters, you could simple start recording, press End, Backspace,
  292. Backspace, down line and then stop recording. Then simply trigger the macro
  293. and it would automaticaly edit the line and move to the next. You could then
  294. just repeatedly trigger the macro to do as many lines as you want.
  295. %package geanyminiscript
  296. Summary: Geany Mini-Script filter plugin
  297. Group: Development/Tools
  298. Requires: geany-plugins-common = %{version}-%{release}
  299. %description geanyminiscript
  300. gms is a Geany Mini-Script filter plugin.
  301. %package geanynumberedbookmarks
  302. Summary: Provide users 10 numbered Bookmarks
  303. Group: Development/Tools
  304. Requires: geany-plugins-common = %{version}-%{release}
  305. %description geanynumberedbookmarks
  306. GeanyNumberedBookmarks is a plugin to provide users with 10 numbered
  307. bookmarks (in addition to the usual bookmarks). It started out as part of
  308. the ConText feature parity plugin, which was split into individual plugins
  309. to better suit Geany's ethos of being as light as possible while allowing
  310. users to select which features they want to add to the core editor. The idea
  311. was taken from a Text Editor for Windows called ConText.
  312. Normally if you had more than one bookmark, you would have to cycle through
  313. them until you reached the one you wanted. With this plugin you can go
  314. straight to the bookmark that you want with a single key combination.
  315. %package geanypg
  316. Summary: encrypt, decrypt and verify signatures with GnuPG
  317. Group: Development/Tools
  318. Requires: geany-plugins-common = %{version}-%{release}
  319. Requires: gpgme
  320. %description geanypg
  321. GeanyPG is a plugin for Geany that allows the user to encrypt, decrypt and
  322. verify signatures with GnuPG.
  323. %package geanyprj
  324. Summary: Provides an alternate project management tool for Geany
  325. Summary(ja): Geany で代替プロジェクト管理ツールを提供
  326. Group: Development/Tools
  327. Requires: geany >= %{req_geany_ver}
  328. Requires: geany-plugins-common = %{version}-%{release}
  329. %description geanyprj
  330. Geanyprj provides an alternate project management approach to Geany's built-in
  331. project facility. The idea is to be less a "session manager" as the built-in
  332. project management does: It allows/requires you to manually open and close
  333. project and allows you to store project files in different locations from
  334. project sources.
  335. Geanyprj takes a different approach:
  336. It never saves session information, so that project files can be stored in
  337. version control without constant noise from changes of opened files or cursor
  338. position. You also will never have to open/close projects manually. If a
  339. *.geanyprj file is found somewhere up in path it will be opened automatically.
  340. %package geanysendmail
  341. Summary: Send E-Mails from within Geany
  342. Summary(ja): Geany 内から E-Mail を送信するプラグイン
  343. Group: Development/Tools
  344. Requires: geany >= %{req_geany_ver}
  345. Requires: geany-plugins-common = %{version}-%{release}
  346. %description geanysendmail
  347. GeanySendMail is a little plugin to send a document as attachment using the
  348. preferred mail client from inside Geany. It is similar to the envelope symbol
  349. of most office tools and requires a mail client that supports remote calls.
  350. %package geanyvc
  351. Summary: Version Control plugin for Geany
  352. Summary(ja): Geany のバージョン管理プラグイン
  353. Group: Development/Tools
  354. Requires: geany >= %{req_geany_ver}
  355. Requires: geany-plugins-common = %{version}-%{release}
  356. Obsoletes: geany-plugin-vc
  357. Provides: geanyvc = %{version}-%{release}
  358. %description geanyvc
  359. Geanyvc is a plugin that provides a uniform way of accessing different version
  360. control systems from within the Geany IDE. Currently, support for the following
  361. version control systems is provided:
  362. * Bazaar
  363. * Git
  364. * Mercurial
  365. * Subversion
  366. * SVK
  367. * CVS
  368. %description geanyvc -l ja
  369. Geanyvc は Geany IDE から異なるバージョン管理システムにアクセスする
  370. 均一的方法を提供するプラグインです。
  371. 現在、サポートするバージョン管理システムは以下の通りです。
  372. * Bazaar
  373. * Git
  374. * Mercurial
  375. * Subversion
  376. * SVK
  377. * CVS
  378. %package geniuspaste
  379. Summary: allows the user to paste the code from Geany into five different pastebins
  380. Group: Development/Tools
  381. Requires: geany-plugins-common = %{version}-%{release}
  382. %description geniuspaste
  383. This plugin allows the user to paste the code from Geany into five different
  384. pastebins. At the moment it supports this services:
  385. * codepad.org
  386. * tinypaste.com
  387. * pastebin.geany.org
  388. * dpaste.de
  389. * sprunge.us
  390. %package gproject
  391. Summary: Extension of Geany's project management
  392. Group: Development/Tools
  393. Requires: geany-plugins-common = %{version}-%{release}
  394. %description gproject
  395. GProject is an extension of Geany's project management displaying a tree of
  396. files belonging to the project in the sidebar. In addition, it enables quick
  397. swapping between header and source files, searching project files by name
  398. and more. The plugin was created with big projects in mind so everything
  399. works fast enough even with projects consisting of hundreds of thousands of
  400. files.
  401. %package markdown
  402. Summary: provides a real-time preview of rendered Markdown
  403. Group: Development/Tools
  404. Requires: geany-plugins-common = %{version}-%{release}
  405. %description markdown
  406. This plugin provides a real-time preview of rendered Markdown, that is,
  407. `Markdown <http://daringfireball.net/projects/markdown>`_ converted to HTML
  408. and inserted into an HTML template and loaded into a
  409. `WebKit <http://www.webkit.org>`_ view.
  410. %package multiterm
  411. Summary: supports multiple terminals
  412. Group: Development/Tools
  413. Requires: geany-plugins-common = %{version}-%{release}
  414. %description multiterm
  415. MultiTerm is similar to Geany's built-in VTE terminal except that it
  416. supports multiple terminals in tabs and supports different shells in
  417. each of the terminal tabs.
  418. %package pretty-printer
  419. Summary: XML pretty printing plugin for Geany
  420. Group: Development/Tools
  421. Requires: geany >= %{req_geany_ver}
  422. Requires: geany-plugins-common = %{version}-%{release}
  423. Requires: libxml2 >= 2.6.27
  424. Obsoletes: %{name}-pretty-print
  425. %description pretty-printer
  426. Plugin for Geany to easily beautify XML code.
  427. %package scope
  428. Summary: graphical GDB front-end with the normal functions
  429. Group: Development/Tools
  430. Requires: geany >= %{req_geany_ver}
  431. Requires: geany-plugins-common = %{version}-%{release}
  432. Requires: gdb
  433. %description scope
  434. Scope is a graphical GDB front-end with the normal functions you would
  435. expect (stepping, breakpoints...), and a few notable features:
  436. - The comminication between Scope and gdb is asynchronous.
  437. - You can enter any gdb command, at any time (of course, for the command to
  438. be executed, gdb must be[come] available).
  439. - All gdb I/O (along with some other messages) is displayed in a
  440. terminal-like "Debug Console".
  441. Whenever you find the GUI lacking, simply switch to that console and work
  442. directly with gdb.
  443. - 7-bit/Locale/UTF-8 support for values.
  444. %package shiftcolumn
  445. Summary: Move Blocks of Text horizontally
  446. Summary(ja): テキストブロックを水平方向に移動
  447. Group: Development/Tools
  448. Requires: geany >= %{req_geany_ver}
  449. Requires: geany-plugins-common = %{version}-%{release}
  450. %description shiftcolumn
  451. Shiftcolumn allows you to move blocks of text horizontally in Geany.
  452. %description shiftcolumn -l ja
  453. Shiftcolumn は Geany 内でテキストブロックを水平方向に移動させることが
  454. できます。
  455. %package spellcheck
  456. Summary: Spellcheck Text in Geany using the Enchant Library
  457. Summary(ja): Enchant ライブラリを使い Geany でスペルチェック
  458. Group: Development/Tools
  459. Requires: geany >= %{req_geany_ver}
  460. Requires: geany-plugins-common = %{version}-%{release}
  461. Requires: enchant
  462. %description spellcheck
  463. Spellcheck checks the selected text (or the whole document) with the spellcheck
  464. library Enchant.
  465. %description spellcheck -l ja
  466. Spellcheck は、選択したテキスト(または文書全体)のスペルチェックを
  467. スペルチェックライブラリの Enchant で行います。
  468. %package treebrowser
  469. Summary: Alternate file browser plugin providing a tree view of directories.
  470. Summary(ja): ディレクトリのツリービューを提供する代替ファイルブラウザプラグイン
  471. Group: Development/Tools
  472. Requires: geany >= %{req_geany_ver}
  473. Requires: geany-plugins-common = %{version}-%{release}
  474. %description treebrowser
  475. The tree browser plugin for Geany provides an alternate way to browse through
  476. your files. It displays files and directories in a tree view and has more
  477. features than the file browser plugin delivered with Geany itself.
  478. %package tableconvert
  479. Summary: Helps on converting a tabulator separated selection into a table
  480. Group: Development/Tools
  481. Requires: geany-plugins-common = %{version}-%{release}
  482. %description tableconvert
  483. Tableconvert is a plugin which helps on converting a tabulator separated
  484. selection into a table.
  485. %package updatechecker
  486. Summary: Automatically check for Geany updates
  487. Summary(ja): Geany の更新を自動的にチェック
  488. Group: Development/Tools
  489. Requires: geany-plugins-common = %{version}-%{release}
  490. %description updatechecker
  491. UpdateChecker is a plugin for Geany, which is able to check whether there is
  492. a more recent version of Geany available.
  493. %package webhelper
  494. Summary: Preview and Debug Web documents from within Geany using WebKit
  495. Summary(ja): WebKit を使い Geany から Web ドキュメントのプレビューとデバッグを実行
  496. Group: Development/Tools
  497. Requires: geany-plugins-common = %{version}-%{release}
  498. %description webhelper
  499. WebHelper is a plugin for Geany that provides some web development
  500. facilities, such as a web page preview and some debugging tools (web
  501. inspector).
  502. Prominent features:
  503. * A basic web view, allowing to display any web page (using WebKit)
  504. * Possible automatic reloading of the web view upon document saving
  505. * A web inspector/debugging tool for the web view's content (including a
  506. JavaScript console, a viewer and editor of processed HTML and CSS, a network
  507. usage analysis tool and many more, thanks to WebKit).
  508. %package xmlsnippets
  509. Summary: Extends XML/HTML tag autocompletion provided by Geany
  510. Group: Development/Tools
  511. Requires: geany-plugins-common = %{version}-%{release}
  512. %description xmlsnippets
  513. This plugin extends XML/HTML tag autocompletion provided by Geany. It
  514. automatically inserts a matching snippet after you type an opening tag.
  515. %prep
  516. %setup -q
  517. #%patch0 -p1
  518. %build
  519. %configure --docdir=%{geany_plug_docdir}
  520. make %{?_smp_mflags}
  521. %install
  522. rm -rf $RPM_BUILD_ROOT
  523. make install -p DESTDIR=$RPM_BUILD_ROOT
  524. # Remove static library *.la files
  525. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f '{}' \;
  526. # Remove zero-length files
  527. find $RPM_BUILD_ROOT -type f -empty -delete
  528. # copy geanylatex document images
  529. cp -pr geanylatex/doc/img/ $RPM_BUILD_ROOT%{geany_plug_docdir}/geanylatex/
  530. %find_lang %{name}
  531. %clean
  532. rm -rf $RPM_BUILD_ROOT
  533. %files
  534. %files common -f %{name}.lang
  535. %defattr(-,root,root,-)
  536. %dir %{_libdir}/%{name}/
  537. %dir %{_datadir}/%{name}/
  538. %files addons
  539. %defattr(-,root,root,-)
  540. %doc %{geany_plug_docdir}/addons
  541. %{_libdir}/geany/addons.so
  542. %files codenav
  543. %defattr(-,root,root,-)
  544. %doc %{geany_plug_docdir}/commander
  545. %{_libdir}/geany/commander.so
  546. %files commander
  547. %defattr(-,root,root,-)
  548. %doc %{geany_plug_docdir}/codenav
  549. %{_libdir}/geany/codenav.so
  550. %files debugger
  551. %defattr(-,root,root,-)
  552. %doc %{geany_plug_docdir}/debugger
  553. %{_datadir}/%{name}/debugger/
  554. %{_libdir}/geany/debugger.so
  555. %files geanydoc
  556. %defattr(-,root,root,-)
  557. %doc %{geany_plug_docdir}/geanydoc/
  558. %{_libdir}/geany/geanydoc.so
  559. %files geanyextrasel
  560. %defattr(-,root,root,-)
  561. %doc %{geany_plug_docdir}/geanyextrasel/
  562. %{_libdir}/geany/geanyextrasel.so
  563. #%files geanygdb
  564. #%defattr(-,root,root,-)
  565. #%doc %{geany_plug_docdir}/geanygdb/
  566. #%{_libdir}/geany/geanygdb.so
  567. #%{_libexecdir}/geany-plugins/geanygdb/ttyhelper
  568. %files geanygendoc
  569. %defattr(-,root,root,-)
  570. %doc %{geany_plug_docdir}/geanygendoc/
  571. %{_libdir}/geany/geanygendoc.so
  572. %{_datadir}/%{name}/geanygendoc/
  573. %files geanyinsertnum
  574. %defattr(-,root,root,-)
  575. %doc %{geany_plug_docdir}/geanyinsertnum/
  576. %{_libdir}/geany/geanyinsertnum.so
  577. %files geanylatex
  578. %defattr(-,root,root,-)
  579. %doc %{geany_plug_docdir}/geanylatex/
  580. %{_libdir}/geany/geanylatex.so
  581. %files geanylipsum
  582. %defattr(-,root,root,-)
  583. %doc %{geany_plug_docdir}/geanylipsum/
  584. %{_libdir}/geany/geanylipsum.so
  585. %files geanylua
  586. %defattr(-,root,root,-)
  587. %doc %{geany_plug_docdir}/geanylua/
  588. %{_libdir}/geany/geanylua.so
  589. %{_datadir}/%{name}/geanylua/
  590. %{_libdir}/%{name}/geanylua/
  591. %files geanymacro
  592. %defattr(-,root,root,-)
  593. %doc %{geany_plug_docdir}/geanymacro/
  594. %{_libdir}/geany/geanymacro.so
  595. %files geanyminiscript
  596. %defattr(-,root,root,-)
  597. %doc %{geany_plug_docdir}/geanyminiscript/
  598. %{_libdir}/geany/geanyminiscript.so
  599. %files geanynumberedbookmarks
  600. %defattr(-,root,root,-)
  601. %doc %{geany_plug_docdir}/geanynumberedbookmarks/
  602. %{_libdir}/geany/geanynumberedbookmarks.so
  603. %files geanypg
  604. %defattr(-,root,root,-)
  605. %doc %{geany_plug_docdir}/geanypg/
  606. %{_libdir}/geany/geanypg.so
  607. %files geanyprj
  608. %defattr(-,root,root,-)
  609. %doc %{geany_plug_docdir}/geanyprj/
  610. %{_libdir}/geany/geanyprj.so
  611. %files geanysendmail
  612. %defattr(-,root,root,-)
  613. %doc %{geany_plug_docdir}/geanysendmail/
  614. %{_libdir}/geany/geanysendmail.so
  615. %files gproject
  616. %defattr(-,root,root,-)
  617. %doc %{geany_plug_docdir}/gproject/
  618. %{_datadir}/icons/hicolor/16x16/apps/gproject-*.png
  619. %{_libdir}/geany/gproject.so
  620. %files geanyvc
  621. %defattr(-,root,root,-)
  622. %doc %{geany_plug_docdir}/geanyvc/
  623. %{_libdir}/geany/geanyvc.so
  624. %files geniuspaste
  625. %defattr(-,root,root,-)
  626. %doc %{geany_plug_docdir}/geniuspaste/
  627. %{_libdir}/geany/geniuspaste.so
  628. %files markdown
  629. %defattr(-,root,root,-)
  630. %doc %{geany_plug_docdir}/markdown/
  631. %{_libdir}/geany/markdown.so
  632. %files multiterm
  633. %defattr(-,root,root,-)
  634. %doc %{geany_plug_docdir}/multiterm/
  635. %{_libdir}/geany/multiterm.so
  636. %files pretty-printer
  637. %defattr(-,root,root,-)
  638. %{_libdir}/geany/pretty-printer.so
  639. %files scope
  640. %defattr(-,root,root,-)
  641. %doc %{geany_plug_docdir}/scope/
  642. %{_libdir}/geany/scope.so
  643. %{_datadir}/%{name}/scope/
  644. %files shiftcolumn
  645. %defattr(-,root,root,-)
  646. %doc %{geany_plug_docdir}/shiftcolumn/
  647. %{_libdir}/geany/shiftcolumn.so
  648. %files spellcheck
  649. %defattr(-,root,root,-)
  650. %doc %{geany_plug_docdir}/spellcheck/
  651. %{_libdir}/geany/spellcheck.so
  652. %files tableconvert
  653. %defattr(-,root,root,-)
  654. %doc %{geany_plug_docdir}/tableconvert/
  655. %{_libdir}/geany/tableconvert.so
  656. %files treebrowser
  657. %defattr(-,root,root,-)
  658. %doc %{geany_plug_docdir}/treebrowser/
  659. %{_libdir}/geany/treebrowser.so
  660. %files updatechecker
  661. %defattr(-,root,root,-)
  662. %doc %{geany_plug_docdir}/updatechecker/
  663. %{_libdir}/geany/updatechecker.so
  664. %files webhelper
  665. %defattr(-,root,root,-)
  666. %doc %{geany_plug_docdir}/webhelper/
  667. %{_libdir}/geany/webhelper.so
  668. %files xmlsnippets
  669. %defattr(-,root,root,-)
  670. %doc %{geany_plug_docdir}/xmlsnippets/
  671. %{_libdir}/geany/xmlsnippets.so
  672. %changelog
  673. * Sat Mar 30 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.23-2
  674. - fixed meta package
  675. * Sat Mar 23 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.23-1
  676. - new upstream release
  677. - deleted Patch0
  678. - added new plugins
  679. - Commander, Markdown, Scope
  680. * Fri Jul 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.22-1
  681. - new upstream release
  682. - added BuildRequires: vala-devel
  683. - added new plugins
  684. - GeanyMiniScript, GeniusPaste, MultiTerm
  685. - added Patch0 to fix installation path of geanylatex documents
  686. - renamed pretty-print to pretty-printer
  687. - obsoleted geany-plugins-geanygdb to provide same function as geany-plugins-debugger
  688. * Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.21-2
  689. - added BuildRequires: vte-devel, WebKit-gtk-devel, gtk2-devel, glib2-devel,
  690. gdk-pixbuf2-devel, pango-devel, python-docutils
  691. - fixed %%changelog in Sat Oct 29 2011
  692. * Sat Oct 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.21-1
  693. - new upstream release
  694. - added new plugins
  695. - Debugger, GeanyPG, GeanyMacro, GeanyNumberedBookmarks, GProject, Tableconvert, XMLSnippets
  696. - added BuildRequires: gpgme-devel
  697. * Sun Jan 23 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.20-1
  698. - new upstream release
  699. - added geany-plugins-updatechecker and geany-plugins-webhelper
  700. * Sun Aug 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.19-3
  701. - added geany-plugins-geanygendoc
  702. - added BuildRequires: ctpl-devel >= 0.2
  703. - changed geany-plugins-latex Requires: tetex to Requires: texlive
  704. - removed zero-length documentation files
  705. * Sun Jul 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.19-2
  706. - correct license to GPLv3+
  707. - added BuildRequires: libxml2-devel >= 2.6.27
  708. - added Requires: geany-plugins-codenav, geany-plugins-treebrowser,
  709. geany-plugins-geanyextrasel, geany-plugins-geanyinsertnum, geany-plugins-pretty-print
  710. * Mon Jun 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.19-1
  711. - new upstream release
  712. * Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.18-3
  713. - fixed Requires geany-plugins
  714. - applied new naming policy to spec
  715. * Thu Jan 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.18-2
  716. - fixed Obsoletes geany-plugin-addons, geany-plugin-gdb, geany-plugin-latex, geany-plugin-vc
  717. (see [BTS:VineLinux:0894])
  718. - proved Summary(ja)
  719. * Wed Nov 18 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.18-1
  720. - initial build for Vine Linux (instead of now provided some geany-plugins)
  721. * Sat Oct 31 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.18-1
  722. - update to new upstream release
  723. * Sun Aug 16 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-6
  724. - build against and require geany 0.18
  725. * Mon Aug 10 2009 Ville Skyttä <ville.skytta@iki.fi> - 0.17.1-5
  726. - Use bzipped upstream tarball.
  727. * Sat Jul 25 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-4
  728. - write BuildRequires at the beginning of this file
  729. * Wed Jul 22 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-3
  730. - remove Requires: geany from the main package
  731. - change Group to Development/Tools
  732. - add release to the geanyvc Provides
  733. - entirely remove %%files stanza for the main package
  734. * Wed Jul 22 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-2
  735. - fix the required geany version also in the subpackages
  736. - remove the requires to sub-packages to avoid building the metapackage since
  737. all geany plugins also can be installed by something like
  738. 'yum install geany-plugins-*'
  739. - fix the requires of geany-plugins-common to include the release
  740. * Wed Jul 22 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-1
  741. - bump upstream version to 0.17.1
  742. - fix required geany version to be 0.16 at the present
  743. * Sat Jul 18 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-5
  744. - add Requires for metapackage
  745. - rename subpackages back to geany-plugins-* instead of geany-plugin-*
  746. * Fri Jul 17 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-4
  747. - readd the geany_plug_docdir global to fix the versioned directory issue for
  748. documentation files
  749. - replace geany-plugins with %%{name} to be more consistent with macro usage
  750. - remove zero-length documentation files
  751. - fix the changelog
  752. - remove static *.la-files
  753. - split up packages
  754. * Wed Jul 15 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-3
  755. - add %%{_datadir}/geany-plugins/geanylua/ to %%files-section
  756. * Wed Jul 15 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-2
  757. - fix %%files-section again, thanks to Jonathan for the hint.
  758. * Tue Jul 14 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-1
  759. - update URL to plugins.geany.org
  760. * Tue Jul 14 2009 Jonathan G. Underwood <jonathan.underwood@gmail.com> - 0.17-0.2
  761. - Add Obsoletes for geanyvc
  762. - Add more BuildRequires and Requires
  763. * Tue Jul 14 2009 Jonathan G. Underwood <jonathan.underwood@gmail.com> - 0.17-0.1
  764. - Update to 0.17 (first upstream release of tarball)
  765. - Fix handling of docs
  766. - Spec file cleanups
  767. * Mon Jun 22 2009 Pingou <pingou@pingoured.fr> 0.1-1
  768. - First RPM for Fedora