foomatic-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655
  1. %define dbver_rel 4.0
  2. %define dbver_snap 20110405
  3. %define enginever 4.0.7
  4. %define filtersver 4.0.7
  5. Summary: Foomatic printer database.
  6. Name: foomatic
  7. Version: %{enginever}
  8. Release: 2%{?_dist_release}
  9. License: GPL
  10. Group: System Environment/Libraries
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Packager: tomop, daisuke, machino
  14. Source0: http://www.linuxprinting.org/download/foomatic/foomatic-db-engine-%{enginever}.tar.gz
  15. Source1: http://www.linuxprinting.org/download/foomatic/foomatic-filters-%{filtersver}.tar.gz
  16. Source2: http://www.linuxprinting.org/download/foomatic/foomatic-db-%{dbver_rel}-%{dbver_snap}.tar.gz
  17. # Use libdir.
  18. Patch1: foomatic-filters-libdir.patch
  19. Patch2: foomatic-db-engine-libdir.patch
  20. # Handle non-UTF-8 encodings in imported PPD files.
  21. Patch15: foomatic-bad-utf8.patch
  22. Url: http://www.linuxprinting.org
  23. Requires: perl >= 5.12.3
  24. Requires: %(eval `perl -V:version`; echo "perl(:MODULE_COMPAT_$version)")
  25. Requires: hplip
  26. BuildRequires: perl >= 5.12.3
  27. BuildRequires: libxml2-devel
  28. BuildRequires: ghostscript-devel
  29. BuildRequires: autoconf, automake
  30. BuildRequires: mpage
  31. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  32. Provides: perl(Foomatic::GrovePath)
  33. # For 'rm' and '/sbin/service' in post
  34. Requires(pre): coreutils initscripts
  35. Obsoletes: foomatic-db < 4.0.0
  36. Obsoletes: foomatic-ppd < 4.0.0
  37. Obsoletes: foomatic-ppd-gimp-print < 4.0.0
  38. Obsoletes: foomatic-ppd-gimp-print-ijs < 4.0.0
  39. Obsoletes: foomatic-ppd-omni < 4.0.0
  40. # We need ghostscript to have the gimp-print-4.2.0 driver, and hpijs 1.1.
  41. Conflicts: ghostscript < 7.05
  42. %description
  43. Foomatic is a comprehensive, spooler-independent database of printers,
  44. printer drivers, and driver descriptions. It contains utilities to
  45. generate driver description files and printer queues for CUPS, LPD,
  46. LPRng, and PDQ using the database. There is also the possibility to
  47. read the PJL options out of PJL-capable laser printers and take them
  48. into account at the driver description file generation.
  49. There are spooler-independent command line interfaces to manipulate
  50. queues (foomatic-configure) and to print files/manipulate jobs
  51. (foomatic printjob).
  52. The site http://www.linuxprinting.org/ is based on this database.
  53. %prep
  54. %setup -q -c -a 1 -a 2
  55. pushd foomatic-filters-%{filtersver}
  56. %patch1 -p1 -b .libdir
  57. popd
  58. pushd foomatic-db-engine-%{enginever}
  59. chmod a+x mkinstalldirs
  60. %patch2 -p1 -b .libdir
  61. %patch15 -p1
  62. popd
  63. pushd foomatic-db-%{dbver_snap}
  64. cd db/source
  65. # For gutenprint printers, use gutenprint-ijs-simplified.5.2.
  66. perl -pi -e 's,>gutenprint<,>gutenprint-ijs-simplified.5.2<,' printer/*.xml
  67. # Remove references to foo2zjs, foo2oak, foo2hp and foo2qpdl (bug #208851).
  68. # Also foo2lava, foo2kyo, foo2xqx (bug #438319).
  69. for x in zjs oak hp qpdl lava kyo xqx
  70. do
  71. find printer -name '*.xml' |xargs grep -l "<driver>foo2${x}"|xargs rm -vf
  72. rm -f driver/foo2${x}.xml opt/foo2${x}-*
  73. done
  74. # Same for m2300w/m2400w
  75. find printer -name '*.xml' |xargs grep -l '<driver>m2[34]00w<'|xargs rm -vf
  76. rm -f driver/m2300w.xml driver/m2400w.xml opt/m2300w-*
  77. # Same for all these.
  78. for x in drv_x125 ml85p pbm2lwxl pbmtozjs bjc800j
  79. do
  80. find printer -name '*.xml' |xargs grep -l "<driver>${x}</driver>"|xargs rm -vf
  81. rm -vf driver/${x}.xml opt/${x}-*
  82. done
  83. popd
  84. %build
  85. export LIB_CUPS=%{_libdir}/cups
  86. export CUPS_BACKENDS=%{_libdir}/cups/backend
  87. export CUPS_FILTERS=%{_libdir}/cups/filter
  88. export CUPS_PPDS=%{_datadir}/cups/model
  89. pushd foomatic-filters-%{filtersver}
  90. %configure
  91. make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
  92. INSTALLDIRS=vendor
  93. popd
  94. pushd foomatic-db-engine-%{enginever}
  95. %configure --disable-xmltest
  96. make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
  97. INSTALLDIRS=vendor defaults
  98. make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
  99. INSTALLDIRS=vendor
  100. popd
  101. pushd foomatic-db-%{dbver_snap}
  102. %configure
  103. make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
  104. INSTALLDIRS=vendor
  105. popd
  106. %install
  107. rm -rf %{buildroot}
  108. pushd foomatic-filters-%{filtersver}
  109. eval `perl '-V:installvendorlib' '-V:installvendorarch'`
  110. mkdir -p %{buildroot}/$installvendorlib
  111. echo %{buildroot}
  112. make DESTDIR=%{buildroot} PREFIX=%{_prefix} \
  113. INSTALLDIRS=vendor \
  114. INSTALLVENDORLIB=$installvendorlib \
  115. INSTALLVENDORARCH=$installvendorarch \
  116. install-main install-cups
  117. popd
  118. pushd foomatic-db-engine-%{enginever}
  119. make DESTDIR=%buildroot PREFIX=%{_prefix} \
  120. INSTALLDIRS=vendor \
  121. INSTALLVENDORLIB=$installvendorlib \
  122. INSTALLVENDORARCH=$installvendorarch \
  123. install
  124. popd
  125. pushd foomatic-db-%{dbver_snap}
  126. make DESTDIR=%buildroot PREFIX=%{_prefix} \
  127. INSTALLDIRS=vendor \
  128. INSTALLVENDORLIB=$installvendorlib \
  129. INSTALLVENDORARCH=$installvendorarch \
  130. install
  131. popd
  132. # Remove ghostscript UPP drivers that are gone in 7.07
  133. rm -f %buildroot%{_datadir}/foomatic/db/source/driver/{bjc6000a1,PM760p,PM820p,s400a1,sharp,Stc670pl,Stc670p,Stc680p,Stc760p,Stc777p,Stp720p,Stp870p}.upp.xml
  134. # Remove drivers with no command line.
  135. pushd foomatic-db-engine-%{enginever}
  136. perl -Ilib ./foomatic-cleanupdrivers %buildroot%{_datadir}/foomatic
  137. popd
  138. # Update any old-style printer IDs still left around.
  139. echo '#!/usr/bin/perl -pi' > convert-printerids.pl
  140. sed -e 's|^\(.*\) \(.*\)$|s,printer/\1,printer/\2,g;|' \
  141. %{buildroot}%{_datadir}/foomatic/db/oldprinterids \
  142. >> convert-printerids.pl
  143. chmod a+x convert-printerids.pl
  144. ./convert-printerids.pl %{buildroot}%{_datadir}/foomatic/db/source/{opt,driver}/*.xml
  145. find %{buildroot}%{_datadir}/foomatic/db/source/ -type f | xargs chmod 0644
  146. # Use relative, not absolute, symlink for CUPS filter.
  147. ln -sf ../../../bin/foomatic-rip %{buildroot}%{_libdir}/cups/filter/foomatic-rip
  148. mkdir %{buildroot}%{_datadir}/foomatic/db/source/PPD/Custom
  149. mkdir -p %{buildroot}%{_var}/cache/foomatic
  150. echo cups > %{buildroot}%{_sysconfdir}/foomatic/defaultspooler
  151. # Remove things we don't ship.
  152. rm -rf %{buildroot}%{_libdir}/perl5/site_perl \
  153. %{buildroot}%{_libdir}/ppr \
  154. %{buildroot}%{_sysconfdir}/foomatic/filter.conf.sample
  155. find %{buildroot} -name .packlist -o -name '*.xml.*' | xargs rm -f
  156. %post
  157. /bin/rm -f /var/cache/foomatic/*
  158. # restart the print server if it is running now
  159. /sbin/service lpd condrestart >/dev/null 2>&1
  160. /sbin/service cups condrestart >/dev/null 2>&1
  161. exit 0
  162. %clean
  163. rm -fr %buildroot $RPM_BUILD_DIR/%{name}
  164. %files
  165. %defattr(-,root,root)
  166. %doc --parents */README */USAGE */ChangeLog
  167. %dir %{_sysconfdir}/foomatic
  168. %config(noreplace) %{_sysconfdir}/foomatic/filter.conf
  169. %config(noreplace) %{_sysconfdir}/foomatic/defaultspooler
  170. %{_bindir}/*
  171. %{_sbindir}/*
  172. %{perl_vendorlib}/Foomatic
  173. %{_libdir}/cups/backend/*
  174. %{_libdir}/cups/driver/*
  175. %{_libdir}/cups/filter/*
  176. %{_datadir}/foomatic
  177. %{_datadir}/cups/model/foomatic-db-ppds
  178. %{_mandir}/*/*
  179. %{_var}/cache/foomatic
  180. %changelog
  181. * Mon Jun 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
  182. - added hplip and coreutils to "Requires:".
  183. - removed hpijs and fileutils from "Requires:".
  184. * Wed Apr 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
  185. - new upstream release.
  186. - dropped Source3 (no longer provided by upstream).
  187. - updated Patch2.
  188. * Thu Mar 24 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.1-3
  189. - rebuild with perl 5.12.3
  190. * Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.0.1-2
  191. - add Requires: hpijs
  192. * Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
  193. - new upstream release
  194. * Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.0-1
  195. - new upstream release.
  196. - applied some patches from Fedora development.
  197. - remove subpackages.
  198. * Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
  199. - applied new versioning policy
  200. - used rpm macros: %%perl_sitelib %%perl_sitearch
  201. - added foomatic-db-engine-3.1-20050411-combo-xml.patch
  202. - added foomatic-db-engine-3.1-20050411-perl-data.patch
  203. - fixed permission of %%{_datadir}/foomatic/db
  204. * Sat Dec 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.0.2-0vl5
  205. - add BuildRequires: libxml2-devel, mpage, Omni
  206. - use %%{_prefix}/lib/{cups,ppr} instead of %%{_libdir}/{cups,ppr}
  207. - run foomatic-cleanupdrivers, foomatic-compiledb with 'perl -Ilib'
  208. - not create ppd-omni package if omni support is disabled
  209. * Tue Apr 11 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl4
  210. - updated foomatic-db to 20050411
  211. - updated foomatic-db-engine to 3.1-20050411
  212. - updated foomatic-db-hpijs to 1.5-20050411
  213. - updated foomatic-filters to 3.1-20050411
  214. * Wed Jan 12 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl3
  215. - updated foomatic-db to 20050112
  216. - updated foomatic-db-engine to 3.1-20050112
  217. - updated foomatic-db-hpijs to 1.5-20050112
  218. * Tue Dec 21 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl2
  219. - updated foomatic-db to 20041220
  220. - updated foomatic-db-hpijs to 1.5-20041220
  221. * Sun Sep 19 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl1
  222. - updated foomatic-db to 20040919
  223. - updated foomatic-db-engine to 3.0.2
  224. - updated foomatic-db-hpijs to 1.5-20040919
  225. - updated foomatic-filters to 3.0.2
  226. * Wed May 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl4
  227. - update foomatic-db to 20040526
  228. - update foomatic-db-hpijs to 1.5-20040526
  229. * Tue May 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl3
  230. - sprit foomatic-ppd to ppd,ppd-hpijs,ppd-omni,ppd-gimp-print,
  231. ppd-gimp-print-ijs
  232. - add Requires: to ppd-* subpackages.
  233. * Thu Apr 15 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.1-0vl2
  234. - new upstream version
  235. -- Omni-printers-0.9.1
  236. -- gimp-print-foomatic-db-4.2.6
  237. - foomatic.spec -> foomatic-vl.spec
  238. * Fri Feb 20 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.1-0vl1
  239. - new upstream version
  240. -- foomatic-filters-3.0.1
  241. -- foomatic-db-engine-3.0.1
  242. -- foomatic-db-20040219
  243. -- foomatic-db-hpijs-1.5-20040219
  244. * Mon Jan 26 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl11
  245. - new upstream version
  246. -- foomatic-filters-3.0.1rc3(bug fix. in configure script)
  247. -- defined filterver
  248. - dropped patch101
  249. * Sun Jan 25 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl10
  250. - new upstream cvs version(foomatic-3.0.1rc2)
  251. -- foomatic-db-20040125
  252. -- foomatic-db-engine-3.0.1rc2
  253. -- foomatic-db-hpijs-1.5-20040125
  254. -- foomatic-filters-3.0.1rc2
  255. - added patch101
  256. -- tests diris null in foomatic-filters-3.0.1rc2
  257. * Fri Jan 23 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl9
  258. - new upstream cvs version
  259. -- foomatic-db-20040123
  260. -- foomatic-db-engine-3.0-20040123
  261. -- foomatic-db-hpijs-1.5-20040123
  262. -- foomatic-filters-3.0-20040123
  263. - dropped old patches
  264. * Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl8
  265. - built on perl-5.8.2
  266. * Tue Nov 11 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl7
  267. - separated foomatic-db package included xml files
  268. * Mon Nov 10 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl6
  269. - added description of ppd sub package
  270. * Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl5
  271. - separated foomatic-ppd package included PPD files
  272. * Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl4
  273. - new upstream version
  274. -- foomatic-db-20031109, foomatic-db-engine-3.0-20031109
  275. -- foomatic-filters-3.0-20031109, foomatic-db-hpijs-1.4-1
  276. - dropped patches
  277. -- foomatic-filters-path.patch(patch0)
  278. -- foomatic-2.0.2-fontpath.patch(patch3)
  279. - updated patches
  280. -- foomatic-filters-3.0-20031109-libdir.patch (patch1)
  281. -- foomatic-db-engine-3.0-20031109-libdir.patch (patch2)
  282. -- foomatic-filters-3.0-20031109-vine.patch (patch100)
  283. * Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl3
  284. - built on perl-5.8.1
  285. - fixed install section in spec file
  286. * Sat Aug 30 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 3.0.0-0vl2
  287. - fix some bugs of foomatic-filters.
  288. A
  289. * Sat Jun 07 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl1
  290. - new upstream version
  291. -- rewrote spec file
  292. -- added some patches from rawhide(foomatic-3.0.0-5)
  293. - enable cups support
  294. * Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl2
  295. - imported some patches from foomatic-2.0.2-18
  296. -- added foomatic-2.0.2-psc2210.patch
  297. -- added foomatic-2.0.2-duplex184.patch
  298. * Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl1
  299. - imported foomatic-2.0.2-15
  300. * Tue Feb 4 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-15
  301. - Update data-generators to CVS.
  302. * Thu Jan 30 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-14
  303. - Use hpijs, not hpijs-rss (we don't ship the RSS patch now).
  304. * Thu Jan 23 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-13
  305. - Pacify printers that don't understand duplex (bug #82385).
  306. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.2-12
  307. - rebuilt
  308. * Thu Jan 21 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-11
  309. - Add autodetect info for HP DeskJet 656C. It doesn't really do
  310. IEEE 1284 IDs, but since it's a USB device we can figure out it's
  311. manufacturer and model anyway.
  312. * Thu Jan 9 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-10
  313. - Set GS_FONTPATH in gs wrapper (bug #81410).
  314. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.2-9
  315. - use internal dep generator.
  316. * Sun Dec 15 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-8
  317. - Add several device IDs.
  318. * Sat Dec 14 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-7
  319. - Update Omni printers to 0.7.2.
  320. - No longer need Omni badxml patch.
  321. * Sat Dec 14 2002 Tim Powers <timp@redhat.com> 2.0.2-6
  322. - don't use rpms internal dep generator
  323. * Fri Dec 6 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-5
  324. - Omni XML wasn't well-formed.
  325. * Wed Nov 20 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-4
  326. - Update gimp-print data.
  327. - Add 'generic postscript' model.
  328. * Mon Nov 11 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-3
  329. - Update Omni printers to 0.7.1.
  330. * Tue Oct 22 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-2
  331. - Fix file manifest for perl modules.
  332. - Add autodetect information for HP DeskJet 990C.
  333. * Mon Oct 21 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-1
  334. - 2.0.2.
  335. - No longer need 67973, 970c patches.
  336. - Remove cups-drivers-* packages (no longer needed).
  337. - Remove files not shipped. Ship filter.conf.
  338. - Conditionally restart cups.
  339. - Use libdir.
  340. - Don't put things in site_perl; use vendor_perl instead (bug #73528).
  341. * Fri Aug 9 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.6
  342. - Fix autodetect information for HPDJ970C.
  343. * Thu Aug 8 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.5
  344. - For gimp-print, use the Ghostscript stp driver in preference to the
  345. IJS interface.
  346. * Thu Jul 25 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.4
  347. - Quieten scriptlets.
  348. * Fri Jul 5 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.3
  349. - Fix autodetect information for HPLJ2100/2100M.
  350. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.9-1.20020617.2
  351. - automated rebuild
  352. * Wed Jun 19 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.2
  353. - Omni 0.7.0 printers.
  354. * Mon Jun 17 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.1
  355. - Update to CVS.
  356. - Remove some more explicit perl dependencies that are picked up
  357. automatically.
  358. * Wed May 29 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.3
  359. - Remove explicit perl-Storable dependency; it should be perl(Storable),
  360. and that is picked up automatically.
  361. * Tue May 28 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.2
  362. - Fix release number.
  363. - Drop gen-ppds from the file manifest---use foomatic-compiledb instead
  364. (bug #63622).
  365. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  366. - automated rebuild
  367. * Thu May 23 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.1
  368. - Remove ghostscript UPP drivers that are gone in 7.05.
  369. * Sat May 18 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.0.1
  370. - Update to CVS.
  371. - Updated requirements.
  372. - Updated path and libdir patches.
  373. - Drop hpijs 1.0.2 patch.
  374. - foomatic-datafile has moved to %%{_bindir}.
  375. - Update gimp-print data to 4.2.1.
  376. - Update Omni printer data to 0.6.1.
  377. * Thu Apr 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.3
  378. - Fix the hpijs option data too (bug #62587).
  379. * Wed Apr 3 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.2
  380. - Back off to 1.0.2 for hpijs driver data (bug #62587).
  381. * Thu Mar 14 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.1
  382. - Update to CVS.
  383. * Wed Mar 6 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020306.1
  384. - Update to CVS.
  385. - Patches no longer needed: conffile, sys, cachedir, fd0.
  386. - Adapted path patch.
  387. * Tue Mar 5 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.10
  388. - Fix bug #58319.
  389. - Drop dbg patch.
  390. * Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.9
  391. - Fix file lists.
  392. * Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.8
  393. - Fix %post scriplet bug (bug #59942).
  394. * Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.7
  395. - Rebuild in new environment.
  396. * Wed Feb 13 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.6
  397. - Merge cups-drivers. No epoch needed.
  398. - Require perl-URI.
  399. * Wed Feb 06 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.5
  400. - Cache fix.
  401. * Mon Feb 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.4
  402. - Don't ship backup files.
  403. * Mon Feb 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.3
  404. - Rebuild to pick up new perl installsitelib.
  405. * Thu Jan 31 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.2
  406. - Fix a thinko in DB.pl.
  407. * Wed Jan 30 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.1
  408. - Update to CVS.
  409. - No longer need the cachedir patch.
  410. - Fix config file path.
  411. - Look in /usr/local/bin last, not first, in lpdomatic (bug #57915).
  412. * Tue Jan 29 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020129.1
  413. - Update to CVS.
  414. - Patches no longer needed: prepend, fd3.
  415. - Use RPM_OPT_FLAGS.
  416. - Allow non-root users to use foomatic-datafile (bug #58956).
  417. * Sat Jan 26 2002 Jeff Johnson <jbj@redhat.com> 1.1-0.20020124.2
  418. - added Provides: perl(Foomatic::GrovePath)
  419. * Thu Jan 24 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020124.1
  420. - Update to CVS.
  421. - Updated Omni printers to those in Omni 0.5.1.
  422. - Updated patches: prepend, fd3.
  423. - Patches no longer needed: utf8, lpdomatic.
  424. - Added gimp-print (formerly stp) foomatic db info, and removed the old
  425. stp.xml file.
  426. - Conflict with ghostscript if it doesn't have gimp-print-4.2.0 yet.
  427. * Fri Jan 18 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20011218.2
  428. - REALLY fix PCL fixup code (bug #55909, others).
  429. - PreReq fileutils, initscripts (bug #56984).
  430. - Fix prepends in lpdomatic (bug #57371).
  431. - Run foomatic-cleanupdrivers during install, to remove driver entries
  432. with no command line.
  433. - Put lpdomatic in /usr/sbin again.
  434. - Fix foomatic-gswrapper's file descriptor manipulations (bug #56871).
  435. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011218.1
  436. - re-imported from upstream to fix some perl fixup code on pcl printers.
  437. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.2
  438. - fix the rest of the quoting issues with foomatic-combo-xml with the patch
  439. - foomatic-1.1-20011217-quotes.patch. This has been sent upstream.
  440. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.1
  441. - respin to pull in latest foomatic database, fixes:
  442. - properly use the cache in relation to foomatic-combo-xml's output
  443. - fix _some_ of the quoting issues with calling foomatic-combo-xml
  444. * Thu Dec 5 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011205.1
  445. - respin to pull in latest foomatic database, fixes:
  446. - droping half of a large job
  447. - -Mutf8 added to the upstream filters
  448. - miscelaneous printer db updates
  449. * Mon Nov 29 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.8
  450. - added Requires: fileutils for the 'rm' in post
  451. * Mon Nov 26 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.7
  452. - /var/chache => /var/cache, doh!
  453. * Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 1.1-0.20011018.6
  454. - fix %%post scriptlet
  455. * Tue Nov 13 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.5
  456. - changed the patch to use the -Mutf8 command line option,
  457. - and to restart the printserver, after rebuilding the settings.
  458. * Fri Nov 9 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.4
  459. - grumble. Some drivers use inline perl scripts, and need the 'use utf8;'
  460. - pragma. Without it, they break on _some_ of their options.
  461. * Wed Oct 31 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.3
  462. - patched lpdomatic to prepend PostScript options in the _right_ place.
  463. * Thu Oct 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.2
  464. - zap the foomatic cache on install
  465. * Thu Oct 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.1
  466. - rolled to pull in latest information.
  467. - added Omni printers to the printer list.
  468. * Fri Oct 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011005.1
  469. - rolled to pull in an ia64 fix to foomatic-combo-xml.c
  470. * Mon Oct 01 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011001.1
  471. - rolled to pull in foomatic fixes to foomatic-combo-xml.c
  472. * Wed Sep 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010905.1
  473. - upgraded to latest foomatic, we now have fast overview generation!
  474. - this means that there is no prebuilt overview file.
  475. * Tue Aug 28 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010828.1
  476. - WOW! The latest foomatic uses Till Kamppeter's C based combo compiler.
  477. - It is now fast enough that there is no real benifit to precompiling.
  478. - NOTE: this forces the package to stop being noarched.
  479. * Mon Aug 27 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010827.1
  480. - fresh pull, maybe it fixes the build errors.
  481. * Sat Aug 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010825.1
  482. - did a fresh database pull, which contains the old japanese printers as well.
  483. - removed japanese hack.
  484. * Tue Aug 14 2001 Akira TAGOH <tagoh@redhat.com> 1.1-0.20010717.5
  485. - Add Japanese printer entry.
  486. * Mon Aug 6 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.4
  487. - move the cache back to /var, sigh.
  488. * Mon Jul 23 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.2
  489. - made foomatic pre-compute its db
  490. * Thu Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.1
  491. - imported from mandrake.
  492. * Tue Jul 17 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010717mdk
  493. - Added job listing/removal/manipulation and queue control to
  494. foomatic-printjob
  495. - Support for printing multiple copies with PDQ
  496. * Fri Jul 14 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010714mdk
  497. - Included the cupsomatic filter script
  498. - When a queue is set up, default options can be set now
  499. - Help messages of foomatic-configure and foomatic-printjob cleaned up.
  500. * Fri Jul 13 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010713mdk
  501. - Many bugfixes in "foomatic-printjob".
  502. - "foomatic-configure" adds the Foomatic config file directory automatically
  503. to the search paths of PDQ.
  504. - Printing a help page under PDQ was broken.
  505. * Thu Jul 12 2001 Stefan van der Eijk <stefan@eijk.nu> 1.1-0.20010712mdk
  506. - BuildRequires: perl-devel
  507. * Wed Jul 11 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010711mdk
  508. - initial release.
  509. - Deleted the obsolete drivers "stp", "cZ11", and "hpdj".
  510. - Patch applied which flushes the memory cache regularly, otherwise
  511. foomatic-configure would hang when the Foomatic data of GIMP-Print is
  512. installed.