flex-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204
  1. Summary: A tool for creating scanners (text pattern recognizers).
  2. Summary(ja): スキャナ (テキストパターン認識器) 作成ツール
  3. Name: flex
  4. Version: 2.5.37
  5. Release: 1%{?_dist_release}
  6. Group: Development/Tools
  7. License: BSD
  8. URL: http://flex.sourceforge.net/
  9. Source: flex-%{version}.tar.bz2
  10. Patch0: flex-2.5.36-bison-2.6.1.patch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: gettext bison m4
  13. Requires: m4
  14. Requires(post): /sbin/install-info
  15. Requires(preun): /sbin/install-info
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. %description
  19. The flex program generates scanners. Scanners are programs which can
  20. recognize lexical patterns in text. Flex takes pairs of regular
  21. expressions and C code as input and generates a C source file as
  22. output. The output file is compiled and linked with a library to
  23. produce an executable. The executable searches through its input for
  24. occurrences of the regular expressions. When a match is found, it
  25. executes the corresponding C code. Flex was designed to work with
  26. both Yacc and Bison, and is used by many programs as part of their
  27. build process.
  28. You should install flex if you are going to use your system for
  29. application development.
  30. %description -l ja
  31. flex はスキャナを生成するプログラムです.スキャナとは,
  32. テキストの語彙を認識するプログラムです.flex は正規表現と
  33. C のコードを入力とし,C のソースファイルを出力します.
  34. 出力されたファイルはコンパイルされ,ライブラリとリンクされて
  35. 実行ファイルが作られます.この実行ファイルは入力を調べ,正規表現に
  36. マッチするものがないか探します.もしマッチするものが見付かれば,
  37. 対応する C コードが実行されます.flex は yacc と bison と共に
  38. 動作する様設計されており,多くのプログラムを作成する際に使われます.
  39. アプリケーション開発を行う場合は flex をインストールして下さい.
  40. %prep
  41. %setup -q
  42. %patch0 -p1
  43. %build
  44. %configure --disable-dependency-tracking CFLAGS="-fPIC $RPM_OPT_FLAGS"
  45. make %{?_smp_mflags}
  46. %install
  47. rm -rf $RPM_BUILD_ROOT
  48. make DESTDIR=$RPM_BUILD_ROOT install
  49. rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
  50. ( cd ${RPM_BUILD_ROOT}
  51. strip .%{_bindir}/flex
  52. ln -sf flex .%{_bindir}/lex
  53. ln -s flex.1 .%{_mandir}/man1/lex.1
  54. ln -s flex.1 .%{_mandir}/man1/flex++.1
  55. ln -s libfl.a .%{_libdir}/libl.a
  56. )
  57. %find_lang %{name}
  58. rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
  59. %check
  60. echo ============TESTING===============
  61. make check
  62. echo ============END TESTING===========
  63. %clean
  64. rm -rf $RPM_BUILD_ROOT
  65. %post
  66. /sbin/install-info %{_infodir}/flex.info.gz --dir-file=%{_infodir}/dir ||:
  67. %preun
  68. if [ $1 = 0 ]; then
  69. /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir ||:
  70. fi
  71. %files -f %{name}.lang
  72. %defattr(-,root,root)
  73. %doc COPYING NEWS README
  74. %{_bindir}/*
  75. %{_mandir}/man1/*
  76. %{_libdir}/*.a
  77. %{_includedir}/FlexLexer.h
  78. %{_infodir}/flex.info*
  79. %changelog
  80. * Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.37-1
  81. - update to 2.5.37
  82. - remove old patches
  83. - add Patch0 (flex-2.5.36-bison-2.6.1.patch) from Fedora
  84. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.35-3
  85. - rebuilt with current VineSeed
  86. - inserted the "-fPIC" on configure command-line and dropt the -fPIC patch.
  87. - removed BR: info
  88. - added Patch0-3 from Fedora
  89. * Tue Jul 13 2010 Petr Machata <pmachata@redhat.com> - 2.5.35-10
  90. - Declare yyget_column and yyset_column in reentrant mode.
  91. - Resolves: #612465
  92. * Mon Apr 20 2009 Debarshi Ray <rishi@fedoraproject.org> - 2.5.35-5
  93. - Resolves: #496548.
  94. * Mon Apr 20 2009 Petr Machata <pmachata@redhat.com> - 2.5.35-4
  95. - Get rid of warning caused by ignoring return value of fwrite() in
  96. ECHO macro. Debian patch.
  97. - Resolves: #484961
  98. * Mon May 12 2008 Petr Machata <pmachata@redhat.com> - 2.5.35-2
  99. - Resolves: #445950
  100. * Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.35-2
  101. - spec in utf-8
  102. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.35-1
  103. - new upstream release
  104. - updated Patch0, dropped Patch1
  105. * Tue Nov 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.33-5vl1
  106. - rebuilt with new toolchains
  107. - updated to 2.5.33 based on Fedora packages
  108. * Fri Mar 30 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-5
  109. - Make yy-prefixed variables available to scanner even with -P.
  110. * Fri Feb 2 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-4
  111. - Use %%find_lang to package locale files.
  112. * Wed Jan 31 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-3
  113. - Compile with -fPIC.
  114. * Fri Jan 19 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-1
  115. - Rebase to 2.5.33
  116. * Sat Jan 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4a-30vl2
  117. - rebuild with gcc 3.3.6
  118. * Sun Jul 6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4a-30vl1
  119. - rebuild with new toolchains
  120. - based on Redhat Rawhide 2.5.4-30
  121. - Mon Nov 4 2002 Than Ngo <than@redhat.com> 2.5.4a-27
  122. - YY_NO_INPUT patch from Jean Marie
  123. - Tue Apr 2 2002 Than Ngo <than@redhat.com> 2.5.4a-23
  124. - More ISO C++ 98 fixes (#59670)
  125. - Wed Feb 20 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.5.4a-21
  126. - More ISO C++ 98 fixes (#59670)
  127. - s/Copyright/License/
  128. * Mon Feb 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  129. - 2.5.4a-13vl1
  130. - based on 2.5.4a-13 from Rawhide
  131. - use better macros (%%{_tmppath})
  132. - added Japanese summary and description
  133. * Sat Sep 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  134. - Fix generation of broken code (conflicting isatty() prototype w/ glibc 2.2)
  135. This broke, among other things, the kdelibs 2.0 build
  136. - Fix source URL
  137. * Thu Sep 7 2000 Jeff Johnson <jbj@redhat.com>
  138. - FHS packaging (64bit systems need to use libdir).
  139. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  140. - automatic rebuild
  141. * Tue Jun 6 2000 Bill Nottingham <notting@redhat.com>
  142. - rebuild, FHS stuff.
  143. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  144. - handle compressed man pages
  145. * Fri Jan 28 2000 Bill Nottingham <notting@redhat.com>
  146. - add a libl.a link to libfl.a
  147. * Wed Aug 25 1999 Jeff Johnson <jbj@redhat.com>
  148. - avoid uninitialized variable warning (Erez Zadok).
  149. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  150. - auto rebuild in the new build environment (release 6)
  151. * Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
  152. - build for 6.0 tree
  153. * Mon Aug 10 1998 Jeff Johnson <jbj@redhat.com>
  154. - build root
  155. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  156. - translations modified for de, fr, tr
  157. * Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
  158. - updated from 2.5.4 to 2.5.4a
  159. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  160. - built against glibc
  161. * Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
  162. - Updated to v. 2.5.4