fcitx-kkc-vl.spec 2.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394
  1. %define ver 0.1.0
  2. %define rel 1
  3. %define from_git 1
  4. %if %{from_git}
  5. %define githash 51112956
  6. %endif
  7. Summary: Japanese Kana Kanji Engine for Fcitx
  8. Name: fcitx-kkc
  9. Version: %{ver}
  10. %if %{from_git}
  11. Release: %{rel}.git%{githash}%{_dist_release}
  12. %else
  13. Release: %{rel}%{_dist_release}
  14. %endif
  15. License: GPLv3
  16. Group: System Environment/Libraries
  17. URL: https://fcitx-im.org
  18. %if %{from_git}
  19. Source0: %{name}-%{githash}.tar.xz
  20. %else
  21. Source0: http://download.fcitx-im.org/fcitx-kkc/%{name}-%{version}.tar.xz
  22. %endif
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
  24. BuildRequires: cmake
  25. BuildRequires: fcitx-devel >= 4.2.8
  26. BuildRequires: libkkc-devel >= 0.2.3
  27. Requires: fcitx
  28. Distribution: Vine Linux
  29. Vendor: Project Vine
  30. Packager: iwaim
  31. %description
  32. Japanese Kana Kanji Engine for Fcitx.
  33. %prep
  34. %if %{from_git}
  35. %setup -q -n %{name}-%{githash}
  36. %else
  37. %setup -q
  38. %endif
  39. %build
  40. %__mkdir build
  41. pushd build
  42. %cmake ENABLE_QT=On ..
  43. make %{?_smp_mflags}
  44. popd
  45. %install
  46. rm -rf $RPM_BUILD_ROOT
  47. pushd build
  48. make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  49. popd
  50. %find_lang %{name}
  51. %clean
  52. rm -rf $RPM_BUILD_ROOT
  53. %post
  54. /bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  55. %postun
  56. if [ $1 -eq 0 ] ; then
  57. /bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  58. /usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  59. fi
  60. %posttrans
  61. /usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  62. %files -f %{name}.lang
  63. %defattr(-,root,root,-)
  64. %doc COPYING
  65. %{_libdir}/fcitx/fcitx-kkc.so
  66. %{_libdir}/fcitx/qt/libfcitx-kkc-config.so
  67. %{_datadir}/fcitx/addon/fcitx-kkc.conf
  68. %{_datadir}/fcitx/configdesc/fcitx-kkc.desc
  69. %{_datadir}/fcitx/imicon/kkc.png
  70. %{_datadir}/fcitx/inputmethod/kkc.conf
  71. %dir %{_datadir}/fcitx/kkc
  72. %{_datadir}/fcitx/kkc/dictionary_list
  73. %{_datadir}/fcitx/kkc/rule
  74. %{_datadir}/icons/hicolor/64x64/apps/fcitx-kkc.png
  75. %dir %{_includedir}/fcitx/module/kkc
  76. %{_includedir}/fcitx/module/kkc/fcitx-kkc.h
  77. %changelog
  78. * Sun Dec 22 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.1.0-1.git51112956
  79. - initial relase