f-spot-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438
  1. Name: f-spot
  2. Version: 0.8.2
  3. Release: 2%{?_dist_release}
  4. Summary: Photo management application
  5. Summary(ja): 写真管理アプリケーション
  6. Group: Applications/Multimedia
  7. License: GPLv2+ and LGPLv2+ and CPL and MIT
  8. URL: http://f-spot.org/
  9. Source0: http://ftp.gnome.org/pub/gnome/sources/f-spot/0.8/f-spot-%{version}.tar.bz2
  10. Patch1: f-spot-0.7.1-build-fixes.patch
  11. # unmount cameras before importing
  12. Patch3: 0002-enhance-the-f-spot-import-script.patch
  13. # Patch from fedora
  14. # two upstream patches to fix compile issue with Mono 2.8:
  15. # http://git.gnome.org/browse/f-spot/commit/?id=9d6e8052b188c2b1cb310ef05842da74a730a39f
  16. Patch13: 0001-PixbufLoader-from-gtk-sharp-master-does-not-have-a-C.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. BuildRequires: mono-devel mono-web mono-data mono-data-sqlite lcms-devel
  19. BuildRequires: libexif-devel gphoto2-devel >= 2.1.4
  20. BuildRequires: gtk-sharp2 libgnome-devel libgnomeui-devel
  21. BuildRequires: gtk2-devel mono-devel libjpeg-devel sqlite3-devel
  22. BuildRequires: gnome-sharp2 gnome-desktop-sharp2 gtk-sharp2-gapi
  23. BuildRequires: gconf-sharp2
  24. BuildRequires: gettext
  25. BuildRequires: autoconf, automake, libtool, intltool
  26. BuildRequires: perl-XML-Parser
  27. BuildRequires: gnome-doc-utils
  28. BuildRequires: ndesk-dbus-glib
  29. BuildRequires: mono-addins-devel >= 0.3
  30. BuildRequires: desktop-file-utils
  31. BuildRequires: gnome-keyring-sharp-devel
  32. BuildRequires: unique-devel
  33. BuildRequires: flickrnet-devel
  34. BuildRequires: libSM-devel
  35. Requires: sqlite3
  36. Requires: lcms
  37. Requires: dcraw
  38. Requires: hicolor-icon-theme
  39. Requires: yelp
  40. Requires(post): desktop-file-utils
  41. Requires(postun): desktop-file-utils
  42. # no mono available
  43. ExcludeArch: sparc64
  44. # Some compiler segfault on ia64:
  45. ExcludeArch: ia64
  46. # No libgphoto etc on s390
  47. ExcludeArch: s390
  48. Distribution: Vine Linux
  49. Vendor: Project Vine
  50. %description
  51. F-Spot is an application designed to provide personal photo management
  52. to the GNOME desktop. Features include import, export, printing and advanced
  53. sorting and tagging of digital images.
  54. %package screensaver
  55. Summary: F-Spot gnome-screensaver plugin
  56. Summary(ja): F-Spot gnome-screensaver plugin
  57. Group: Applications/Multimedia
  58. Requires: %{name} = %{version}-%{release}
  59. Requires: gnome-screensaver
  60. Obsoletes: f-spot < 0.6.1.1
  61. %description screensaver
  62. F-Spot provides a plugin for gnome-screensaver which displays parts of the
  63. photo collection in a slideshow as a screensaver.
  64. %prep
  65. %setup -q
  66. #%patch1 -p1 -b .buildfix
  67. %patch3 -p1 -b .gvfs-gphoto
  68. %patch13 -p1 -b mono28-compile-fix
  69. %build
  70. intltoolize --force --copy
  71. libtoolize --force --copy --automake
  72. aclocal -I build/m4/f-spot -I build/m4/shamrock -I build/m4/shave
  73. autoconf
  74. autoheader
  75. test -f config.h.in && touch config.h.in
  76. automake --gnu --add-missing --force --copy -Wno-portability
  77. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  78. %configure --disable-scrollkeeper
  79. make %{?_smp_mflags}
  80. %install
  81. rm -rf $RPM_BUILD_ROOT
  82. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  83. make install DESTDIR=$RPM_BUILD_ROOT
  84. rm $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
  85. rm $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
  86. rm $RPM_BUILD_ROOT%{_libdir}/pkgconfig/f-spot.pc
  87. # only files marked executable are used to auto-generate the
  88. # requires/provides of the package
  89. find $RPM_BUILD_ROOT \( -name '*.exe' -or -name '*.dll' \) \
  90. -exec chmod a+x {} \;
  91. for file in $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
  92. do
  93. desktop-file-validate $file
  94. done
  95. %find_lang %name
  96. %clean
  97. rm -rf $RPM_BUILD_ROOT
  98. %pre
  99. if [ "$1" -gt 1 ]; then
  100. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  101. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
  102. fi
  103. %post
  104. update-desktop-database &> /dev/null ||:
  105. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  106. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  107. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
  108. %preun
  109. if [ "$1" -eq 0 ]; then
  110. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  111. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
  112. fi
  113. %postun
  114. update-desktop-database &> /dev/null ||:
  115. if [ $1 -eq 0 ] ; then
  116. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  117. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  118. fi
  119. %posttrans
  120. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  121. %files -f %{name}.lang
  122. %defattr(-,root,root,-)
  123. %doc AUTHORS COPYING README NEWS
  124. %{_sysconfdir}/gconf/schemas/*
  125. %{_datadir}/applications/*.desktop
  126. %{_datadir}/gnome/help/f-spot/
  127. %{_datadir}/icons/hicolor/*/*/*.png
  128. %{_datadir}/f-spot/
  129. %dir %{_libdir}/f-spot/
  130. %{_libdir}/f-spot/*.dll
  131. %{_libdir}/f-spot/*.exe
  132. %{_libdir}/f-spot/*.addins
  133. %{_libdir}/f-spot/*.config
  134. %{_libdir}/f-spot/*.mdb
  135. %{_libdir}/f-spot/*.so
  136. %{_libdir}/f-spot/*.so.*
  137. %exclude %{_libdir}/f-spot/Extensions/FSpot.Tools.ScreensaverConfig.dll*
  138. %{_libdir}/f-spot/Extensions/
  139. %{_bindir}/f-spot
  140. %{_bindir}/f-spot-import
  141. %{_bindir}/f-spot-sqlite-upgrade
  142. %files screensaver
  143. %defattr(-,root,root,-)
  144. %{_libdir}/f-spot/Extensions/FSpot.Tools.ScreensaverConfig.dll
  145. %{_prefix}/libexec/gnome-screensaver/f-spot-screensaver
  146. %{_datadir}/applications/screensavers/f-spot-screensaver.desktop
  147. %changelog
  148. * Sun Dec 30 2012 IWAI, Masaharu <iwai@alib.jp> 0.8.2-2vl7
  149. - build with mono-addins 0.6.2-2
  150. - add BuildRequires: mono-addins-devel >= 0.3
  151. - add Vendor and Distribution tags
  152. * Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.2-1
  153. - new upstream release
  154. - delete Patch11,12
  155. * Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  156. - new upstream release
  157. - drop Patch1
  158. - add Patch11,12,13 from fedora
  159. - add BuildRequires: libSM-devel
  160. * Thu Aug 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.1-1
  161. - new upstream release
  162. - add patch1 to support parallel builds
  163. - add BR: unique-devel, flickrnet-devel
  164. * Sun May 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1.5-1
  165. - initial build for Vine Linux
  166. * Mon Dec 14 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.5-2
  167. - Corrected the permission fix for all .exe and .dll files in order
  168. to generate the dependencies correctly (BZ 547063)
  169. * Sun Nov 08 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.5-1
  170. - Update to 0.6.1.5 (BZ 531955)
  171. - Build f-spot against system gnome-keyring-sharp library (BZ 442343)
  172. - Make all .dll and .exe files executable so that they are respected
  173. by the find-requires/find-provides scripts
  174. - Remove upstreamed patch
  175. * Mon Oct 26 2009 Dennis Gilmore <dennis@ausil.us> - 0.6.1.3-2
  176. - ExcludeArch sparc64
  177. * Sun Oct 04 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.3-1
  178. - Update to 0.6.1.3 (BZ 526217)
  179. - Remove two upstreamed patches
  180. - Use a slightly different fix for the cairo-devel dependency
  181. (suggested by upstream)
  182. * Wed Sep 30 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-3
  183. - Add patch to fix f-spot crash when using "soft focus" and cairo-devel
  184. was not installed (BZ 526563)
  185. - Minor spec file beautification
  186. * Tue Sep 22 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-2
  187. - Add upstream patches (
  188. commit b87604bc9782bf92f053aaf3ceb739a32f44ea13
  189. commit 807dab4344ecdadc7e46793369821de8b49692e5 )
  190. to fix crash in facebook exporter (BZ 524860)
  191. * Thu Sep 17 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-1
  192. - Update to 0.6.1.2 (BZ 519290)
  193. * Fri Aug 28 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.1-2
  194. - Move the screensaver plugin into a sub-package (BZ 519640)
  195. - Let f-spot-screensaver obsolete older f-spot version so that it
  196. is pulled in during update (fresh installations of f-spot will not
  197. pull in gnome-screensaver)
  198. * Wed Aug 26 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.1-1
  199. - Update to 0.6.1.1
  200. - Remove upstreamed patch
  201. - Updated use-system-Mono.Addins-if-available patch
  202. - Add a patch to enable parallel build
  203. * Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-3
  204. - Build arch ppc64.
  205. * Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-2
  206. - Fix Icon Cache script in %%post section
  207. * Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-1
  208. - Update to new upstream version 0.6.0.0
  209. - Cleanup spec file
  210. * Sat Jul 25 2009 Christian Krause <chkr@fedoraproject.org> - 0.5.0.3-9
  211. - Avoid showing f-spot twice for photo imports
  212. - Make f-spot-import work with gvfs
  213. - Minor indentation fix
  214. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0.3-8
  215. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  216. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0.3-7
  217. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  218. * Sun Feb 8 2009 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.5.0.3-6
  219. - Rebuild against new mono stack to fix broken deps
  220. * Thu Dec 4 2008 Matthias Clasen <mclasen@redhat.com> - 0.5.0.3-5
  221. - Update to 0.5.0.3
  222. * Fri Nov 21 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.4-8
  223. - Better URL
  224. - Tweak %%description
  225. * Tue Oct 28 2008 Orion Poplawski <orion@cora.nwra.com.com> - 0.4.4-7
  226. - Run desktop-file-validate against desktop files
  227. * Mon Oct 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-6
  228. - rebuild against new gnome-sharp
  229. * Thu Oct 2 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.4-5
  230. - Use a standard icon name instead of a non-existing one
  231. * Mon Jul 14 2008 Nigel Jones <dev@nigelj.com> - 0.4.4-4
  232. - Remove Tom's patch in -2, there is a gtk-sharp 2.12.1, just nobody bothered
  233. packaging it.
  234. - Patch Makefile{.in,am} to use DESTDIR for the gio-sharp.dll, this is
  235. effectively a backport of r4010 Upstream.
  236. - Patch libfspot/Makefile{.in,am} to remove -DGTK_DISABLE_DEPRECATED per
  237. recommendation of upstream.
  238. - Re-add patch to use system mono-addins
  239. - Include GIO stuff for now (until it appears in gtk-sharp)
  240. * Wed Jul 5 2008 Alex Lancaster <alexlan[AT] fedoraproject org> - 0.4.4-3
  241. - gtkhtml dependency now provided by gnome-desktop-sharp-devel
  242. rather than gnome-sharp-devel, so add as BuildRequires
  243. * Wed Jun 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-2
  244. - Fix it to not look for non-existant glib-sharp-2.12.1
  245. * Wed Jun 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-1
  246. - update to 0.4.4
  247. - fix license tag
  248. * Tue May 13 2008 Matthias Clasen <mclasne@redhat.com> - 0.4.3.1-1
  249. - Update to 0.4.3.1
  250. * Tue Apr 15 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.4.2-5
  251. - Add patch from Debian to use system mono-addins (from #442343)
  252. * Sat Mar 1 2008 Christopher Aillon <caillon@redhat.com> - 0.4.2-4
  253. - Require dcraw
  254. * Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> - 0.4.2-3
  255. - Fix the build
  256. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
  257. - Autorebuild for GCC 4.3
  258. * Thu Feb 14 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.2-1
  259. - Update to 0.4.2
  260. * Fri Jan 18 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.1-2
  261. - Add support for content-types
  262. * Thu Dec 6 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.1-1
  263. - Update to 0.4.1
  264. * Sat Nov 17 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-4
  265. - Remove comments from ExclusiveArch line (#388581)
  266. * Tue Oct 2 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-3
  267. - Add alpha to ExclusiveArch
  268. * Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> - 0.4.0-2
  269. - Rebuild for build ID
  270. * Sat Aug 4 2007 Matthis Clasen <mclasen@redhat.com> - 0.4.0-1
  271. - Update to 0.4.0
  272. * Mon Jul 2 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-3
  273. - Hack to get screensavers to work again (#221546)
  274. * Fri Apr 13 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-2
  275. - Now with validated desktop files!
  276. * Wed Mar 7 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-1
  277. - Update to 0.3.5
  278. * Wed Feb 28 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
  279. - Update to 0.3.4
  280. * Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.3-1
  281. - Update to 0.3.3
  282. * Tue Jan 23 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  283. - Update to 0.3.2
  284. * Fri Oct 20 2006 Christopher Aillon <caillon@redhat.com> - 0.2.2-1
  285. - Update to 0.2.2
  286. * Mon Oct 16 2006 Matthias Clasen <mclasen@redhat.com> - 0.2.1-2
  287. - Fix a directory ownership issue (#211009)
  288. * Wed Sep 13 2006 Christopher Aillon <caillon@redhat.com> - 0.2.1-1
  289. - Update to 0.2.1
  290. * Tue Sep 12 2006 Matthias Clasen <mclasen@redhat.com> - 0.2.0-2
  291. - Add libgphoto2_port version to dll config (#205302)
  292. * Mon Sep 4 2006 Christopher Aillon <caillon@redhat.com> - 0.2.0-1
  293. - Update to 0.2.0
  294. * Fri Aug 18 2006 Alexander Larsson <alexl@redhat.com> - 0.1.11-5
  295. - Rebuild with new mono and gtk-sharp2
  296. * Thu Jul 27 2006 Matthias Clasen <mclasen@redhat.com> - 0.1.11-4
  297. - Fix dbus-sharp BR
  298. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.1.11-3.1
  299. - rebuild
  300. * Sun Jun 24 2006 Jesse Keating <jkeating@redhat.com> 0.1.11-3
  301. - Add missing BR gettext
  302. * Wed May 31 2006 Alexander Larsson <alexl@redhat.com> 0.1.11-2
  303. - Rebuild for gmime update
  304. * Fri Mar 17 2006 Christopher Aillon <caillon@redhat.com> 0.1.11-1
  305. - Update to 0.1.11
  306. * Fri Feb 24 2006 Christopher Aillon <caillon@redhat.com> 0.1.10-1
  307. - Update to 0.1.10
  308. * Tue Feb 21 2006 Karsten Hopp <karsten@redhat.de> 0.1.9-2
  309. - add BuildRequires libgnome-devel libgnomeui-devel
  310. gtk2-devel mono-devel libjpeg-devel sqlite-devel
  311. * Fri Feb 17 2006 Christopher Aillon <caillon@redhat.com> - 0.1.9-1
  312. - Update to 0.1.9
  313. * Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-3
  314. - Rebuild
  315. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.1.8-2.1
  316. - rebuilt for new gcc4.1 snapshot and glibc changes
  317. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-2
  318. - Add sqlite3.patch to ensure that sqlite3 is used if both
  319. sqlite2 and sqlite3 are installed.
  320. * Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-1
  321. - Update to 0.1.8
  322. - Use sqlite3 instead of sqlite2
  323. * Tue Jan 31 2006 Ray Strode <rstrode@redhat.com> - 0.1.5-3
  324. - don't blindly run f-spot from current working directory
  325. (bug 177407)
  326. * Tue Jan 10 2006 Alexander Larsson <alexl@redhat.com> - 0.1.5-2
  327. - Add lcms depencency
  328. * Mon Jan 9 2006 Alexander Larsson <alexl@redhat.com> - 0.1.5-1
  329. - Update to 0.1.5
  330. * Thu Dec 8 2005 Alexander Larsson <alexl@redhat.com> 0.1.3-3
  331. - Use sqlite2 to avoid problems with beagle
  332. * Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 0.1.3-2
  333. - Make exes and dlls executable to pick up dependencies
  334. - Remove .a and .la files
  335. * Wed Nov 16 2005 Alexander Larsson <alexl@redhat.com> - 0.1.3-1
  336. - Initial version