diald-vl.spec 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132
  1. %define _initdir %{_sysconfdir}/rc.d/init.d
  2. Summary: Daemon that provides on demand IP links via SLIP or PPP.
  3. Name: diald
  4. Version: 1.0
  5. Release: 0vl4
  6. License: distributable
  7. Group: System Environment/Daemons
  8. URL: http://diald.sourceforge.net/
  9. Source0: http://download.sourceforge.net/diald/diald-%{version}.tar.gz
  10. Source1: diald.init
  11. Source2: diald.conf.sample
  12. Source3: phone.filter
  13. Source4: connect.diald
  14. Patch0: diald-1.0-Makefile.patch
  15. Patch1: diald-route-0.99.4.patch
  16. Patch2: diald-1.0-glibc22.patch
  17. Requires: ppp
  18. PreReq: chkconfig
  19. BuildRoot: %{_tmppath}/%{name}-root
  20. %description
  21. Diald is a daemon that provides on demand IP links via SLIP or PPP. The
  22. purpose of diald is to make it transparently appear that you have a
  23. permanent connection to a remote site. Diald sets up a "proxy" device which
  24. stands in for the physical connection to a remote site. It then monitors the
  25. proxy, waiting for packets to arrive. When interesting packets arrive it
  26. will attempt to establish the physical link to the remote site using either
  27. SLIP or PPP, and if it succeeds it will forward traffic from the proxy to
  28. the physical link. As well, diald will monitor traffic once the physical
  29. link is up, and when it has determined that the link is idle, the remote
  30. connection is terminated. The criteria for bringing the link up and taking
  31. it down are configurable at run time, and are based upon the type of traffic
  32. passing over the link.
  33. %prep
  34. %setup -q
  35. %patch0 -p1 -b .orig
  36. %patch1 -p0 -b .route
  37. %patch2 -p1 -b .glibc22
  38. %build
  39. %configure --localstatedir=/var
  40. make
  41. %install
  42. rm -rf $RPM_BUILD_ROOT
  43. %makeinstall
  44. cp -p config/dynamic.filter $RPM_BUILD_ROOT%{_libdir}/diald/
  45. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/diald
  46. mknod -m 0660 $RPM_BUILD_ROOT%{_sysconfdir}/diald/diald.ctl p
  47. mkdir -p $RPM_BUILD_ROOT%{_initdir}
  48. install -p -m755 %{SOURCE1} $RPM_BUILD_ROOT%{_initdir}/diald
  49. # Source 2,3,4
  50. cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/diald.conf
  51. cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/diald
  52. cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/diald/connect
  53. # eliminate excessive executable bit
  54. find contrib/ -type f -perm +111 | xargs chmod -x
  55. find %{buildroot}%{_libdir}/diald -type f -perm +111 | xargs chmod -x
  56. %clean
  57. rm -rf $RPM_BUILD_ROOT
  58. %post
  59. /sbin/chkconfig --add diald
  60. %preun
  61. if [ $1 = 0 ]; then
  62. /sbin/chkconfig --del diald
  63. fi
  64. %files
  65. %defattr(-,root,root)
  66. %doc BUGS CHANGES LICENSE NOTES README* THANKS TODO TODO.budget
  67. %doc doc/diald-faq.txt contrib
  68. %config %{_initdir}/diald
  69. %config(noreplace) %{_sysconfdir}/diald.conf
  70. %config(noreplace) %{_sysconfdir}/diald/connect
  71. %config(noreplace) %{_sysconfdir}/diald/phone.filter
  72. %{_sysconfdir}/diald/diald.ctl
  73. %{_bindir}/dctrl
  74. %{_sbindir}/diald
  75. %{_libdir}/diald
  76. %{_mandir}/man1/dctrl.1*
  77. %{_mandir}/man5/diald-control.5*
  78. %{_mandir}/man5/diald-examples.5*
  79. %{_mandir}/man5/diald-monitor.5*
  80. %{_mandir}/man8/diald.8*
  81. %changelog
  82. * Wed Jan 30 2002 Toru Sagami <sagami@vinelinux.org> 1.0-0vl4
  83. - added adhoc patch to build on glibc22 system
  84. * Wed Aug 08 2001 <sagami@vinelinux.org>
  85. - 1.0-0vl3: fix again to handle pid file correctly
  86. * Fri Aug 03 2001 <sagami@vinelinux.org>
  87. - 1.0-0vl2: fix initscript to handle pid file correctly
  88. * Sun Jun 17 2001 <sagami@vinelinux.org>
  89. - 1.0-0vl0
  90. * Fri Jun 15 2001 <sagami@vinelinux.org>
  91. - 0.99.4-0vl2: %%{_mandir}
  92. * Wed Mar 01 2000 Toru Sagami <czs14350@nifty.ne.jp>
  93. - 0.99.4
  94. - add contrib to docdir
  95. - fix diald.init
  96. * Fri Feb 18 2000 Toru Sagami <czs14350@nifty.ne.jp>
  97. - handle RPM_OPT_FLAGS
  98. - add noreplace to configutation files
  99. * Fri Feb 11 2000 Toru Sagami <czs14350@nifty.ne.jp>
  100. - added diald-twoway.diff(it fixes diald_won't_redial problem?)
  101. - changed Group from Networking/Daemons to System Environment/Daemons
  102. - enabled %post and %preun
  103. * Fri Jan 28 2000 Toru Sagami <czs14350@nifty.ne.jp>
  104. - freshen URL Source tags
  105. * Fri Jan 14 2000 Toru Sagami <czs14350@nifty.ne.jp>
  106. - 0.99.3
  107. * Wed Dec 01 1999 Toru Sagami <czs14350@nifty.ne.jp>
  108. - build 0.99.2
  109. - include diald.conf.sample