cproto-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144
  1. Summary: Generates function prototypes and variable declarations from C code.
  2. Summary(ja): C コードから関数プロトタイプと変数宣言を生成するツール
  3. Name: cproto
  4. Version: 4.7j
  5. Release: 1%{?_dist_release}
  6. License: Public Domain
  7. Group: Development/Tools
  8. Source: ftp://invisible-island.net/%{name}/%{name}-%{version}.tgz
  9. Patch1: cproto-4.6.1-patch
  10. Patch2: cproto-4.6-varargs.patch
  11. Patch3: cproto-4.6-bison.patch
  12. Prefix: %{_prefix}
  13. BuildRequires: bison
  14. BuildRequires: flex
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. %description
  17. Cproto generates function prototypes and variable declarations from C
  18. source code. Cproto can also convert function definitions between the
  19. old style and the ANSI C style. This conversion will overwrite the
  20. original files, however, so be sure to make a backup copy of your
  21. original files in case something goes wrong. Cproto uses a Yacc
  22. generated parser, so it should not be confused by complex function
  23. definitions as much as other prototype generators.
  24. %description -l ja
  25. cproto は C のソースコードから関数プロトタイプと変数宣言を生成します.
  26. cproto は古い形式と ANSI C 形式の関数定義の相互変換も行うことが出来ます.
  27. この変換を行うとオリジナルのファイルを上書きしてしまいますので,もしもの
  28. 時の為にオリジナルファイルのバックアップは必ず取っておいて下さい.
  29. cproto は yacc により生成された解析器を使用しますので,他のプロトタイプ
  30. 生成プログラムとは異なり,複雑な関数定義も難なく処理出来ます.
  31. cproto は C プログラマにとっては便利なプログラムですので,
  32. C でプログラムをする際には cproto をインストールして下さい.
  33. %prep
  34. %setup -q
  35. %build
  36. export CPP="/lib/cpp"
  37. export CPPFLAGS="-DOPT_LINTLIBRARY $RPM_OPT_FLAGS"
  38. export CFLAGS="-DOPT_LINTLIBRARY $RPM_OPT_FLAGS"
  39. %configure --exec-prefix=%{_prefix}
  40. make
  41. %install
  42. rm -rf $RPM_BUILD_ROOT
  43. make install DESTDIR=$RPM_BUILD_ROOT
  44. %clean
  45. rm -rf $RPM_BUILD_ROOT
  46. %files
  47. %defattr(-,root,root)
  48. %doc CHANGES README
  49. %{_prefix}/bin/cproto
  50. %{_mandir}/man1/cproto.*
  51. %changelog
  52. * Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7j-1
  53. - update to 4.7j
  54. - add BuildRequires: bison, flex
  55. * Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 4.7c-6vl5
  56. - applied new versioning policy, spec in utf-8
  57. * Sun Apr 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7c-5vl1
  58. - based on 4.7c-5 from Fedora development
  59. * Wed Feb 9 2005 Jindrich Novy <jnovy@redhat.com> 4.7c-4
  60. - add RPM_OPT_FLAGS to CFLAGS
  61. - convert Copyright to License
  62. - rebuild with -D_FORTIFY_SOURCE=2
  63. * Thu Oct 14 2004 Jindrich Novy <jnovy@redhat.com> 4.7c-3
  64. - define OPT_LINTLIBRARY to enable type definitions output
  65. and other cproto features disabled otherwise
  66. - s/Copyright/License/
  67. - updated URL
  68. * Wed Dec 04 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.6-13vl1
  69. - based on 4.6-13 from Rawhide and built for Vine Linux
  70. - added Japanese summary and description
  71. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  72. - automated rebuild
  73. * Mon Jun 17 2002 Bill Nottingham <notting@redhat.com> 4.6-12
  74. - don't strip it
  75. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  76. - automated rebuild
  77. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  78. - automated rebuild
  79. * Mon Aug 13 2001 Bill Nottingham <notting@redhat.com>
  80. - predefine __builtin_va_list (#46246, original patch from <urban@teststation.com>)
  81. * Tue Jun 12 2001 Bill Nottingham <notting@redhat.com>
  82. - actually *apply* the 4.6.1 patch. Fixes #35654, at least.
  83. * Fri Dec 01 2000 Bill Nottingham <notting@redhat.com>
  84. - rebuild because of broken fileutils
  85. * Mon Oct 13 2000 Bill Nottingham <notting@redhat.com>
  86. - use /lib/cpp, not gcc -E, again (#20535)
  87. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  88. - automatic rebuild
  89. * Tue Jun 6 2000 Bill Nottingham <notting@redhat.com>
  90. - rebuild against glibc-2.2, FHS stuff
  91. * Tue Feb 1 2000 Bill Nottingham <notting@redhat.com>
  92. - use /lib/cpp, not gcc -E (#8612)
  93. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  94. - auto rebuild in the new build environment (release 2)
  95. * Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com>
  96. - update to 4.6.1 (#1516).
  97. - use %configure
  98. * Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
  99. - build for 6.0
  100. * Sat Aug 15 1998 Jeff Johnson <jbj@redhat.com>
  101. - build root
  102. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  103. - translations modified for de, fr, tr
  104. * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
  105. - built against glibc