bzip2-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define buildpdf 0
  3. Summary: A file compression utility.
  4. Summary(ja): ファイル圧縮ユーティリティ
  5. Name: bzip2
  6. Version: 1.0.6
  7. Release: 1%{?_dist_release}
  8. License: BSD
  9. Group: Applications/Archiving
  10. URL: http://www.bzip.org/
  11. Source: http://www.bzip.org/%{version}/bzip2-%{version}.tar.gz
  12. Patch0: bzip2-1.0.5-autoconflibtoolize.patch
  13. Patch1: bzip2-1.0.4-saneso.patch
  14. Patch2: bzip2-1.0.4-cflags.patch
  15. Patch3: bzip2-1.0.4-bzip2recover.patch
  16. # P2 implements a progress counter (in %). It also
  17. # display the percentage of the original file the new file is (size).
  18. # URL: http://www.vanheusden.com/Linux/bzip2-1.0.2.diff.gz
  19. Patch10: bzip2-1.0.2.diff.bz2
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. %if %buildpdf
  22. BuildRequires: tetex-dvips tetex-latex
  23. %endif
  24. BuildRequires: texinfo
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. %description
  28. Bzip2 is a freely available, patent-free, high quality data compressor.
  29. Bzip2 compresses files to within 10 to 15 percent of the capabilities
  30. of the best techniques available. However, bzip2 has the added benefit
  31. of being approximately two times faster at compression and six times
  32. faster at decompression than those techniques. Bzip2 is not the
  33. fastest compression utility, but it does strike a balance between speed
  34. and compression capability.
  35. Install bzip2 if you need a compression utility.
  36. %package devel
  37. Summary: Header files and libraries for developing apps which will use bzip2.
  38. Summary(ja): bzip2 を使うプログラム開発に必要なヘッダファイルとライブラリ
  39. Group: Development/Libraries
  40. Requires: %{name} = %{version}-%{release}
  41. %description devel
  42. Header files and a static library of bzip2 functions, for developing apps
  43. which will use the library.
  44. ## to build compat32 for x86_64 architecture support
  45. %package -n compat32-%{name}
  46. Summary: A file compression utility.
  47. Summary(ja): ファイル圧縮ユーティリティ
  48. Group: System Environment/Libraries
  49. Requires: %{name} = %{version}-%{release}
  50. %description -n compat32-%{name}
  51. Bzip2 is a freely available, patent-free, high quality data compressor.
  52. Bzip2 compresses files to within 10 to 15 percent of the capabilities
  53. of the best techniques available. However, bzip2 has the added benefit
  54. of being approximately two times faster at compression and six times
  55. faster at decompression than those techniques. Bzip2 is not the
  56. fastest compression utility, but it does strike a balance between speed
  57. and compression capability.
  58. Install bzip2 if you need a compression utility.
  59. %package -n compat32-%{name}-devel
  60. Summary: Header files and libraries for developing apps which will use bzip2.
  61. Summary(ja): bzip2 を使うプログラム開発に必要なヘッダファイルとライブラリ
  62. Group: Development/Libraries
  63. Requires: compat32-%{name} = %{version}-%{release}
  64. Requires: %{name}-devel = %{version}-%{release}
  65. %description -n compat32-%{name}-devel
  66. Header files and a static library of bzip2 functions, for developing apps
  67. which will use the library.
  68. %prep
  69. %setup -q
  70. %patch0 -p1 -b .autoconf
  71. %patch1 -p1 -b .saneso
  72. %patch2 -p1 -b .cflags
  73. %patch3 -p1 -b .bz2recover
  74. %patch10 -p1
  75. cp CHANGES ChangeLog
  76. mv CHANGES NEWS
  77. mv LICENSE COPYING
  78. cp m4/largefile.m4 .
  79. chmod a+x configure
  80. libtoolize -f --automake
  81. aclocal
  82. autoconf
  83. automake -a --foreign
  84. autoheader
  85. %build
  86. %configure --libdir=%{_libdir} --enable-shared --disable-static
  87. make
  88. %if %buildpdf
  89. texi2dvi --pdf manual.texi
  90. %endif
  91. %install
  92. rm -rf %{buildroot}
  93. %makeinstall
  94. cp bzgrep %{buildroot}%{_bindir}
  95. chmod 0755 %{buildroot}%{_bindir}/bzgrep
  96. rm -f %{buildroot}%{_libdir}/*.{a,la}
  97. %post -p /sbin/ldconfig
  98. %postun -p /sbin/ldconfig
  99. %post -n compat32-%{name} -p /sbin/ldconfig
  100. %postun -n compat32-%{name} -p /sbin/ldconfig
  101. %clean
  102. rm -rf %{buildroot}
  103. %files
  104. %defattr(-,root,root)
  105. %doc AUTHORS COPYING README README.COMPILATION.PROBLEMS NEWS ChangeLog
  106. %{_bindir}/*
  107. %{_mandir}/*/*
  108. %{_libdir}/*so.*
  109. %files devel
  110. %defattr(-,root,root)
  111. %{_includedir}/*
  112. %{_libdir}/*so
  113. ## to build compat32 for x86_64 architecture support
  114. %if %{build_compat32}
  115. %files -n compat32-%{name}
  116. %defattr(-,root,root)
  117. %{_libdir}/*so.*
  118. %files -n compat32-%{name}-devel
  119. %defattr(-,root,root)
  120. %{_libdir}/*so
  121. %endif
  122. %changelog
  123. * Sat Jul 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  124. - update to 1.0.6
  125. * Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 1.0.5-5vl6
  126. - build on current VineSeed
  127. - update URL and Source0 tags URL
  128. * Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-4
  129. - rebuild with new toolchain
  130. * Sun Jul 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-3
  131. - updated Patch0: bzip2-1.0.5-autoconflibtoolize.patch
  132. - removed unneccesary %if !%{build_compat32} case condition
  133. * Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-2
  134. - spec in utf-8
  135. - remove static library
  136. * Thu Mar 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-1
  137. - new upstream release with security fix
  138. - drop old patches (patch3-6) which are included in new release
  139. - build under new versioning policy
  140. * Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl2
  141. - changed Group to Applications/Archiving
  142. - changed compat32-bzip2 Group to System Environment/Libraries
  143. * Tue Feb 21 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl1
  144. - new upstream release
  145. - add Patch3-6 from Fedora Core (includes CAN-2005-0758/0953)
  146. * Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl5
  147. - fixed %%postun (missing to build as scriptlet by invalid comment)
  148. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl4
  149. - moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
  150. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
  151. - added compat32- packages for x86_64 architecture support
  152. - changed autoconf-2.13 to current autoconf
  153. * Mon May 05 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0.2-0vl2
  154. - added patch 1 from Rawhide 1.0.2-8
  155. - added patch 2 from Mandrake 1.0.2-14mdk
  156. * Sun Sep 29 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.0.2-0vl1
  157. - previous patch is so incomplete that "bzip2 -f" fails.
  158. instead, update the source which fixes this and other bugs.
  159. * Fri May 24 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
  160. - fix race condition.
  161. * Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  162. - 1.0.1-3vl2
  163. - added Japanese summary
  164. - rebuilt under new %%{_mandir} definition
  165. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.0.1-3vl1
  166. - build on Vine Linux with gcc-2.95.3
  167. - partially used rpmmacros
  168. * Fri Jul 21 2000 Trond Eivind Glomsr <teg@redhat.com>
  169. - new URL and source location
  170. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  171. - automatic rebuild
  172. * Sat Jul 01 2000 Trond Eivind Glomsr <teg@redhat.com>
  173. - 1.0.1
  174. - ported my patch
  175. * Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
  176. - FHS packaging to build on solaris2.5.1.
  177. - remove config.cache from autoconf patch.
  178. - sparc: use %%configure, but not the m4 macros.
  179. * Tue Jun 06 2000 Trond Eivind Glomsr <teg@redhat.com>
  180. - Use %%configure, %%makeinstall, %%{_manpath} and %%{_tmpdir}
  181. * Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
  182. - 1.0.0 - ported my 1.0pre8 libtoolizedautoconf patch
  183. * Tue May 16 2000 Trond Eivind Glomsr <teg@redhat.com>
  184. - use soft links, not hardlinks, for binaries
  185. - mv .so to devel
  186. * Mon May 15 2000 Trond Eivind Glomsr <teg@redhat.com>
  187. - autoconfed and libtoolized package
  188. - fixed Copyright (it's BSD, not GPL)
  189. - dumped bzless (less works fine with bz2-files)
  190. - rewrote build and install parts
  191. - separated main package and devel package
  192. * Mon May 8 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  193. - 1.0pre8
  194. * Fri Apr 14 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  195. - Add bzgrep (a version of zgrep hacked to do bzip2)
  196. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  197. - handle compressed manpages
  198. * Fri Dec 31 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
  199. - 0.9.5d
  200. - Update download URL, add URL: tag in header
  201. * Tue Aug 10 1999 Jeff Johnson <jbj@redhat.com>
  202. - upgrade to 0.9.5c.
  203. * Mon Aug 9 1999 Bill Nottingham <notting@redhat.com>
  204. - install actual bzip2 binary, not libtool cruft.
  205. * Sun Aug 8 1999 Jeff Johnson <jbj@redhat.com>
  206. - run ldconfig to get shared library.
  207. * Mon Aug 2 1999 Jeff Johnson <jbj@redhat.com>
  208. - create shared libbz1.so.* library.
  209. * Sun Apr 4 1999 Jeff Johnson <jbj@redhat.com>
  210. - update to bzip2-0.9.0c.
  211. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  212. - auto rebuild in the new build environment (release 4)
  213. * Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
  214. - build against glibc 2.1
  215. * Wed Sep 30 1998 Cristian Gafton <gafton@redhat.com>
  216. - force compilation with egcs to avoid gcc optimization bug (thank God
  217. we haven't been beaten by it)
  218. * Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
  219. - version 0.9.0b
  220. * Tue Sep 08 1998 Cristian Gafton <gafton@redhat.com>
  221. - updated to 0.9.0
  222. * Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
  223. - first build for Manhattan