bison-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210
  1. Summary: A GNU general-purpose parser generator.
  2. Summary(ja): GNU 汎用構文解析器生成プログラム
  3. Name: bison
  4. Version: 2.7.1
  5. Release: 1%{?_dist_release}
  6. License: GPL
  7. Group: Development/Tools
  8. Source: http://ftp.gnu.org/gnu/bison/bison-%{version}.tar.xz
  9. URL: http://www.gnu.org/software/bison/
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. Requires: m4 >= 1.4
  12. Requires(post): install-info
  13. Requires(preun): install-info
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. %description
  17. Bison is a general purpose parser generator which converts a grammar
  18. description for an LALR(1) context-free grammar into a C program to parse
  19. that grammar. Bison can be used to develop a wide range of language
  20. parsers, from ones used in simple desk calculators to complex programming
  21. languages. Bison is upwardly compatible with Yacc, so any correctly
  22. written Yacc grammar should work with Bison without any changes. If
  23. you know Yacc, you shouldn't have any trouble using Bison. You do need
  24. to be very proficient in C programming to be able to use Bison). Bison
  25. is only needed on systems that are used for development.
  26. If your system will be used for C development, you should install Bison
  27. since it is used to build many C programs.
  28. #'
  29. %description -l ja
  30. bison は汎用構文解析器を生成するプログラムで,LALR(1) 文脈自由文法で
  31. 書かれた文法記述を元に,その記述を解析する C プログラムを生成します.
  32. bison は簡単な電卓から複雑なプログラミング言語まで,幅広い種類の
  33. 言語解析器を開発するのに使うことが出来ます.
  34. bison は yacc の上位互換ですので,yacc で書かれた文法を修正すること
  35. なしに解析することが出来ます.yacc を知っているのであれば,bison を
  36. 使って困ることは何もないでしょう.bison を使うには C プログラミングの
  37. 豊富な知識が必要となります.bison は開発を行うシステム以外では特に
  38. 必要にならないでしょう.
  39. C 言語による開発を行う場合は,多くの C プログラムの作成に使われるので
  40. bison をインストールして下さい.
  41. %prep
  42. %setup -q
  43. %build
  44. %configure
  45. make
  46. make check
  47. %install
  48. rm -rf $RPM_BUILD_ROOT
  49. %makeinstall
  50. # Remove unpackaged files.
  51. rm -f $RPM_BUILD_ROOT/%{_bindir}/yacc
  52. rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
  53. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/yacc*
  54. %find_lang %{name}
  55. %clean
  56. rm -rf $RPM_BUILD_ROOT
  57. %post
  58. /sbin/install-info %{_infodir}/bison.info.gz %{_infodir}/dir \
  59. --entry="* bison: (bison). The GNU parser generator."
  60. %preun
  61. if [ $1 = 0 ]; then
  62. /sbin/install-info --delete %{_infodir}/bison.info.gz %{_infodir}/dir \
  63. --entry="* bison: (bison). The GNU parser generator."
  64. fi
  65. %files -f %{name}.lang
  66. %defattr(-,root,root)
  67. %doc AUTHORS COPYING ChangeLog NEWS OChangeLog README THANKS TODO
  68. %{_bindir}/bison
  69. %{_libdir}/liby.a
  70. %{_datadir}/bison
  71. %{_datadir}/aclocal/*.m4
  72. %{_datadir}/locale/*/LC_MESSAGES/%{name}-runtime.mo
  73. %{_mandir}/*/bison*
  74. %{_infodir}/bison.info*
  75. %changelog
  76. * Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.7.1-1
  77. - update to 2.7.1
  78. * Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 2.5-1
  79. - new upstream release
  80. * Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.3-1
  81. - new upstream release
  82. - delete Patch1
  83. * Wed Feb 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-2
  84. - rebuilt with new toolchain
  85. * Tue Feb 3 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.1-1
  86. - new upstream release
  87. - import Patch1 from Fedora
  88. * Sat Nov 8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
  89. - new upstream release
  90. - spec in UTF-8
  91. * Sun Apr 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.3-1
  92. - rebuild with new toolchain.
  93. - apply new versioning policy.
  94. * Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-0vl1
  95. - new upstream release
  96. * Tue Mar 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1-0vl1
  97. - new upstream release
  98. * Wed Jun 09 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0-6vl1
  99. - new upstream release
  100. - dropped Patch1
  101. - added %doc files
  102. - updated URL
  103. * Sun Feb 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.875-6vl1
  104. - add Patch1 from fedora
  105. - add Requires: m4
  106. * Thu Oct 30 2003 Roland McGrath <roland@redhat.com> 1.875-6
  107. - add dependency on m4 (bug #108655)
  108. * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 1.875-5
  109. - remove problematic __attribute__ use for label (bug #105034)
  110. * Sun Jul 6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.875-3vl1
  111. - based on Rawhide 1.875-3
  112. - s/Copyright/License/
  113. * Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.75-2vl1
  114. - new upstream release
  115. - merged with rawhide release
  116. * Thu Nov 21 2002 Tim Waugh <twaugh@redhat.com> 1.75-2
  117. - Run 'make check'.
  118. - Apply patch from bison-patches to fix bash compilation.
  119. * Thu Oct 17 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  120. - update to 1.75
  121. * Fri May 31 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
  122. - 1.35-2vl1: synced with rawhide
  123. * Thu Dec 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  124. - 1.28-5vl1
  125. - rebuilt with new %%{_mandir} definition
  126. - added Japanese summary and description
  127. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.28-5vl1
  128. - build on Vine Linux with gcc-2.95.3
  129. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  130. - automatic rebuild
  131. * Sun Jun 18 2000 Than Ngo <than@redhat.de>
  132. - rebuilt in the new build environment
  133. - FHS packaging
  134. * Sat May 27 2000 Ngo Than <than@redhat.de>
  135. - rebuild for 7.0
  136. - put man pages and info files to correct place
  137. * Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
  138. - rebuild to gzip man page.
  139. * Fri Jul 16 1999 Jeff Johnson <jbj@redhat.com>
  140. - update to 1.28.
  141. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  142. - auto rebuild in the new build environment (release 3)
  143. * Mon Mar 8 1999 Jeff Johnson <jbj@redhat.com>
  144. - configure with datadir=/usr/lib (#1386).
  145. * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
  146. - updated text in spec file.
  147. - update to 1.27
  148. * Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
  149. - build for glibc 2.1
  150. * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
  151. - translations modified for de, fr, tr
  152. * Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
  153. - built for Manhattan
  154. - added build root
  155. * Wed Oct 15 1997 Donnie Barnes <djb@redhat.com>
  156. - various spec file cleanups
  157. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  158. - built against glibc