apr-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428
  1. %define aprver 1
  2. # Arches on which the multilib apr.h hack is needed:
  3. %define multilib_arches %{ix86} ia64 ppc ppc64 s390 s390x x86_64
  4. Name: apr
  5. Summary: Apache Portable Runtime library
  6. Summary(ja): Apache ポータブルランタイムライブラリ
  7. Version: 1.4.5
  8. Release: 1%{?_dist_release}
  9. Group: System Environment/Libraries
  10. License: Apache Software License
  11. URL: http://apr.apache.org/
  12. Source0: %{name}-%{version}.tar.bz2
  13. Source1: apr-wrapper.h
  14. Patch2: apr-0.9.7-deepbind.patch
  15. Patch3: apr-1.2.2-locktimeout.patch
  16. Patch4: apr-1.2.2-libdir.patch
  17. Patch5: apr-1.3.3-pkgconf.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: autoconf, libtool, python, doxygen
  20. BuildRequires: libuuid-devel
  21. Conflicts: subversion < 0.20.1-2
  22. Obsoletes: apache2-apr
  23. %description
  24. The mission of the Apache Portable Runtime (APR) is to provide a
  25. free library of C data structures and routines, forming a system
  26. portability layer to as many operating systems as possible,
  27. including Unices, MS Win32, BeOS and OS/2.
  28. %package devel
  29. Summary: APR library development kit
  30. Summary(ja): APR ライブラリ開発キット
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}-%{release}
  33. Conflicts: subversion-devel < 0.20.1-2
  34. Obsoletes: apache2-apr-devel
  35. %description devel
  36. This package provides the support files which can be used to
  37. build applications using the APR library. The mission of the
  38. Apache Portable Runtime (APR) is to provide a free library of
  39. C data structures and routines.
  40. %prep
  41. %setup -q
  42. %patch2 -p1 -b .deepbind
  43. %patch3 -p1 -b .locktimeout
  44. %patch4 -p1 -b .libdir
  45. %patch5 -p1 -b .pkgconf
  46. %build
  47. # regenerate configure script etc.
  48. ./buildconf
  49. # Forcibly prevent detection of shm_open (which then picks up but
  50. # does not use -lrt).
  51. export ac_cv_search_shm_open=no
  52. %configure \
  53. --includedir=%{_includedir}/apr-%{aprver} \
  54. --with-installbuilddir=%{_libdir}/apr-%{aprver}/build \
  55. --with-devrandom=/dev/urandom \
  56. --disable-static \
  57. CC=gcc CXX=g++
  58. make %{?_smp_mflags} && make dox
  59. %install
  60. rm -rf $RPM_BUILD_ROOT
  61. make install DESTDIR=$RPM_BUILD_ROOT
  62. # Move docs to more convenient location
  63. rm -rf html
  64. mkdir -p html
  65. cp -pr docs/dox/html/* html/
  66. # mv docs/dox/html html
  67. # Trim exported dependecies
  68. sed -ri '/^dependency_libs/{s,-l(uuid|crypt) ,,g}' \
  69. $RPM_BUILD_ROOT%{_libdir}/libapr*.la
  70. sed -ri '/^LIBS=/{s,-l(uuid|crypt) ,,g;s/ */ /g}' \
  71. $RPM_BUILD_ROOT%{_bindir}/apr-%{aprver}-config
  72. %ifarch %{multilib_arches}
  73. # Ugly hack to allow parallel installation of 32-bit and 64-bit apr-devel
  74. # packages:
  75. mv $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h \
  76. $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr-%{_arch}.h
  77. install -c -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h
  78. %endif
  79. # Unpackaged files:
  80. rm -f $RPM_BUILD_ROOT%{_libdir}/apr.exp
  81. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  82. %check
  83. # Fail if LFS support isn't present in a 32-bit build, since this
  84. # breaks ABI and the soname doesn't change: see #254241
  85. if grep 'define SIZEOF_VOIDP 4' include/apr.h \
  86. && ! grep off64_t include/apr.h; then
  87. cat config.log
  88. : LFS support not present in 32-bit build
  89. exit 1
  90. fi
  91. %clean
  92. rm -rf $RPM_BUILD_ROOT
  93. %post -p /sbin/ldconfig
  94. %postun -p /sbin/ldconfig
  95. %files
  96. %defattr(-,root,root,-)
  97. %doc CHANGES LICENSE NOTICE
  98. %{_libdir}/libapr-%{aprver}.so.*
  99. %files devel
  100. %defattr(-,root,root,-)
  101. %doc docs/APRDesign.html docs/canonical_filenames.html
  102. %doc docs/incomplete_types docs/non_apr_programs
  103. %doc --parents html
  104. %{_bindir}/apr-%{aprver}-config
  105. #{_libdir}/libapr-%{aprver}.a
  106. %{_libdir}/libapr-%{aprver}.so
  107. %{_libdir}/pkgconfig/*.pc
  108. %dir %{_libdir}/apr-%{aprver}
  109. %dir %{_libdir}/apr-%{aprver}/build
  110. %{_libdir}/apr-%{aprver}/build/*
  111. %dir %{_includedir}/apr-%{aprver}
  112. %{_includedir}/apr-%{aprver}/*.h
  113. %changelog
  114. * Sat Oct 1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.5-1
  115. - new upstream release
  116. * Wed Sep 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.2-1
  117. - new upstream release
  118. - built with rpm-4.8.1
  119. - removed static libraries from devel package
  120. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.10-1
  121. - rebuilt with new toolchain
  122. * Thu Dec 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
  123. - new upstream release
  124. * Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.8-1
  125. - new upstream release with security fix (CVE-2009-2412)
  126. * Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.5-1
  127. - new upstream release
  128. * Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.3-1vl5
  129. - new upstream release
  130. - updated Patch5
  131. * Wed Jun 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
  132. - new upstream release
  133. - removed Patch1 and 6
  134. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
  135. - removed *.la files from devel package
  136. * Sat Apr 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
  137. - new upstream release
  138. - added Patch2 and 6 from Fedora
  139. * Mon Jun 19 2006 Joe Orton <jorton@redhat.com> 1.2.7-9
  140. - add fix for use of %%pI with psprintf
  141. * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
  142. - use RTLD_DEEPBIND in apr_dso_open by default
  143. * Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
  144. - new upstream release
  145. * Thu Jul 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
  146. - new upstream release
  147. * Mon May 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl3
  148. - remove Requires: gcc = %%(gcc -dumpversion)
  149. * Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
  150. - rebuilt with new toolchain
  151. * Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
  152. - new upstream release
  153. * Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
  154. - initial build for Vine Linux based on FC package
  155. * Tue May 23 2006 Joe Orton <jorton@redhat.com> 1.2.7-7
  156. - fix another multilib conflict (#192659)
  157. * Tue May 16 2006 Joe Orton <jorton@redhat.com> 1.2.7-6
  158. - BR e2fsprogs-devel for libuuid
  159. * Mon May 8 2006 Joe Orton <jorton@redhat.com> 1.2.7-4
  160. - use multilib parallel-installation wrapper hack for apr.h
  161. * Tue May 2 2006 Joe Orton <jorton@redhat.com> 1.2.7-3
  162. - fix installbuilddir in apr-1-config
  163. * Tue May 2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
  164. - update to 1.2.7
  165. - use pkg-config in apr-1-config to make it libdir-agnostic
  166. * Thu Apr 6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
  167. - update to 1.2.6
  168. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.2
  169. - bump again for double-long bug on ppc(64)
  170. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.1
  171. - rebuilt for new gcc4.1 snapshot and glibc changes
  172. * Wed Jan 4 2006 Joe Orton <jorton@redhat.com> 1.2.2-7
  173. - fix namespace pollution (r354824, r355464)
  174. * Wed Jan 4 2006 Joe Orton <jorton@redhat.com> 1.2.2-6
  175. - fix build with recent glibc (#176911)
  176. * Tue Jan 3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-5.2
  177. - rebuilt again
  178. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  179. - rebuilt
  180. * Fri Dec 9 2005 Joe Orton <jorton@redhat.com> 1.2.2-5
  181. - rebuild for new gcc
  182. * Thu Dec 8 2005 Joe Orton <jorton@redhat.com> 1.2.2-4
  183. - add apr_file_seek() fixes from upstream (r326593, r326597)
  184. * Wed Dec 7 2005 Joe Orton <jorton@redhat.com> 1.2.2-3
  185. - apr-1-config: strip more exports (#175124)
  186. * Tue Dec 6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
  187. - avoid linking against -lrt
  188. - don't print -L${libdir} in --libs output
  189. - don't export -lcrypt/-luuid in .la file
  190. * Fri Dec 2 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
  191. - update to 1.2.2
  192. * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
  193. - use RTLD_DEEPBIND in apr_dso_open by default
  194. * Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
  195. - update to 0.9.7
  196. * Fri Sep 30 2005 Florian La Roche <laroche@redhat.com>
  197. - rebuild for new gcc
  198. * Thu Sep 15 2005 Joe Orton <jorton@redhat.com> 0.9.6-6
  199. - don't override CFLAGS at build time
  200. - allow setting TCP_NODELAY and TCP_CORK concurrently
  201. - use _exit() not exit() in child if exec*() fails (upstream #30913)
  202. * Fri Sep 9 2005 Joe Orton <jorton@redhat.com> 0.9.6-5
  203. - add from 0.9.x branch:
  204. * fix for apr_{uid,gid}_* error handling (r239592)
  205. * fix for apr_file_ write flushing (r267192)
  206. - add backport for use of readdir64_r (r265032, r265681, r265684)
  207. * Mon Jul 11 2005 Florian La Roche <laroche@redhat.com>
  208. - rebuild
  209. * Tue May 17 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
  210. - fix apr_procattr_child_*_set error handling
  211. * Tue Mar 1 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
  212. - have apr-devel depend on specific version of gcc
  213. - add NOTICE to docdir
  214. * Wed Feb 9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
  215. - update to 0.9.6
  216. * Wed Feb 2 2005 Joe Orton <jorton@redhat.com> 0.9.5-4
  217. - don't disable sendfile on s390 (IBM LTC, #146891)
  218. * Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-3
  219. - really fix apr-config --srcdir
  220. * Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-2
  221. - fix apr-config --srcdir again
  222. * Sun Nov 21 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
  223. - update to 0.9.5
  224. * Mon Sep 27 2004 Joe Orton <jorton@redhat.com> 0.9.4-24
  225. - rebuild
  226. * Wed Sep 1 2004 Joe Orton <jorton@redhat.com> 0.9.4-23
  227. - have -devel require apr of same V-R
  228. * Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.9.4-22
  229. - backport fixes from HEAD:
  230. * correct implementation of nested mutexes
  231. * support for POSIX semaphores on LP64 platforms
  232. * Thu Jul 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-21
  233. - rebuild for another attempt at using sem_open
  234. * Tue Jul 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-20
  235. - move sticky/suid bits outside APR_OS_DEFAULT bitmask (Greg Hudson)
  236. * Thu Jul 1 2004 Joe Orton <jorton@redhat.com> 0.9.4-19
  237. - rebuild
  238. * Wed Jun 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-18
  239. - rebuild now /dev/shm is mounted
  240. * Thu Jun 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
  241. - add fix for cleanup structure reuse (part of upstream #23567)
  242. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  243. - rebuilt
  244. * Thu Jun 10 2004 Joe Orton <jorton@redhat.com> 0.9.4-15
  245. - add support for setuid/setgid/sticky bits (Andr辿 Malo)
  246. - add apr_threadattr_{guardsize,stacksize}_set() (latter by Jeff Trawick)
  247. * Mon Jun 7 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
  248. - enable posixsem and process-shared pthread mutex support, but
  249. ensure that sysvsem remains the default mechanism
  250. * Mon May 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
  251. - entirely remove 2Gb file size limit from apr_file_copy();
  252. fixes "svnadmin hotcopy" on repos with >2Gb strings table
  253. - work around getnameinfo bugs with v4-mapped addresses
  254. - fix apr_time_exp_get() for dates in 2038 (Philip Martin)
  255. * Thu May 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
  256. - use APR_LARGEFILE in apr_file_{copy,append}
  257. * Wed Mar 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
  258. - add APR_LARGEFILE flag
  259. * Mon Mar 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
  260. - fix configure check for mmap of /dev/zero
  261. - just put -D_GNU_SOURCE in CPPFLAGS not _{BSD,SVID,XOPEN}_SOURCE
  262. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-9.1
  263. - rebuilt
  264. * Thu Feb 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
  265. - undocument apr_dir_read() ordering constraint and fix tests
  266. * Sun Feb 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-8
  267. - rebuilt without -Wall -Werror
  268. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-7
  269. - rebuilt
  270. * Tue Feb 3 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
  271. - define apr_off_t as int/long/... to prevent it changing
  272. with _FILE_OFFSET_BITS on 32-bit platforms
  273. * Mon Jan 12 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
  274. - add apr_temp_dir_get fixes from HEAD
  275. * Thu Jan 8 2004 Joe Orton <jorton@redhat.com> 0.9.4-4
  276. - ensure that libapr is linked against libpthread
  277. - don't link libapr against -lnsl
  278. * Thu Nov 13 2003 Joe Orton <jorton@redhat.com> 0.9.4-3
  279. - -devel package no longer requires libtool
  280. * Fri Oct 3 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
  281. - disable tests on x86_64 (#97611)
  282. * Fri Oct 3 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
  283. - update to 0.9.4, enable tests
  284. - ensure that libresolv is not used
  285. * Sun Sep 7 2003 Joe Orton <jorton@redhat.com> 0.9.3-14
  286. - use /dev/urandom (#103049)
  287. * Thu Jul 24 2003 Joe Orton <jorton@redhat.com> 0.9.3-13
  288. - add back CC=gcc, CXX=g++
  289. * Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-12
  290. - rebuild
  291. * Mon Jul 14 2003 Joe Orton <jorton@redhat.com> 0.9.3-11
  292. - work round useless autoconf 2.57 AC_DECL_SYS_SIGLIST
  293. * Thu Jul 10 2003 Joe Orton <jorton@redhat.com> 0.9.3-10
  294. - support --cc and --cpp arguments in apr-config
  295. * Thu Jul 3 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
  296. - force libtool to use CC=gcc, CXX=g++
  297. * Thu Jul 3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
  298. - fix libtool location in apr_rules.mk
  299. * Mon Jun 30 2003 Joe Orton <jorton@redhat.com> 0.9.3-7
  300. - use AI_ADDRCONFIG in getaddrinfo() support (#73350)
  301. - include a working libtool script rather than relying on
  302. /usr/bin/libtool (#97695)
  303. * Wed Jun 18 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
  304. - don't use /usr/bin/libtool
  305. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  306. - rebuilt
  307. * Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
  308. - add fix for psprintf memory corruption (CAN-2003-0245)
  309. - remove executable bit from apr_poll.h
  310. * Thu May 1 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
  311. - link libapr against libpthread
  312. - make apr-devel conflict with old subversion-devel
  313. - fix License
  314. * Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
  315. - run ldconfig in post/postun
  316. * Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
  317. - patch test suite to not care if IPv6 is disabled
  318. * Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
  319. - initial build