mariadb-vl.spec 29 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872
  1. %bcond_with source
  2. %define mysqld_user mysql
  3. %define mysqld_group mysql
  4. %define mysqldatadir /var/lib/mysql
  5. # Working around perl dependency problem
  6. %global __perl_requires %{SOURCE998}
  7. %global __perllib_requires %{SOURCE998}
  8. %define _unpackaged_files_terminate_build 1
  9. %define mariadb_base_version 10.0
  10. %define mariadb_version 10.0.15
  11. %define mroonga_version 4.06
  12. %define client_version 18
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. Packager: tomop
  16. Name: mariadb
  17. Summary: MariaDB: a very fast and robust SQL database server
  18. Version: %{mariadb_version}
  19. Release: 1%{_dist_release}
  20. Group: Applications/Databases
  21. License: GPL2
  22. URL: http://www.mariadb.org/
  23. Source: mariadb-%{version}.tar.gz
  24. # Don't depend on lib::mtr*
  25. Source998: perl-requires.sh
  26. Source1000: macros.mariadb.in
  27. Patch0: mysql-5.5.15-jp-all.patch
  28. Patch100: mysql-srv_buf_size.patch
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  30. BuildRequires: bison, cmake, gcc-c++, groff
  31. BuildRequires: libaio-devel, libboost-devel, libevent-devel, libxml2-devel
  32. BuildRequires: ncurses-devel, perl, openssl-devel, readline-devel
  33. BuildRequires: zlib-devel
  34. BuildRequires: mecab-devel
  35. Requires: fileutils sh-utils
  36. Provides: msqlormysql MySQL mysql
  37. Obsoletes: mysql MySQL5
  38. # From the manual
  39. %description
  40. MariaDB: a very fast and robust SQL database server
  41. It is GPL v2 licensed, which means you can use the it free of charge under the
  42. conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
  43. MariaDB documentation can be found at http://kb.askmonty.org/
  44. MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
  45. %package server
  46. Version: %{mariadb_version}
  47. Release: %{release}
  48. Summary: MariaDB: a very fast and robust SQL database server
  49. Group: Applications/Databases
  50. Requires: fileutils sh-utils net-tools mariadb-common
  51. Requires(post): mariadb-common
  52. Provides: mysql-server mysql MySQL MySQL-server mariadbserver-%{mariadb_base_version}
  53. Obsoletes: MySQL mysql mysql-server
  54. Obsoletes: MySQL-server < 5.6.0
  55. %description server
  56. MariaDB: a very fast and robust SQL database server
  57. It is GPL v2 licensed, which means you can use the it free of charge under the
  58. conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
  59. MariaDB documentation can be found at http://kb.askmonty.org/
  60. MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
  61. %package mroonga
  62. ##Version: %{mroonga_version}
  63. Version: %{mariadb_version}
  64. Summary: A fast fulltext searchable storage engine for MariaDB.
  65. Group: Applications/Databases
  66. Requires(pre): mariadb-server = %{mariadb_version}-%{release}
  67. Requires: mariadb-server = %{mariadb_version}-%{release}
  68. Obsoletes: mariadb-mroonga-doc < 4.07
  69. %description mroonga
  70. Mroonga is a fast fulltext searchable storage plugin for MariaDB.
  71. It is based on groonga that is a fast fulltext search engine and
  72. column store. Groonga is good at real-time update.
  73. %package client
  74. Version: %{mariadb_version}
  75. Summary: MariaDB - Client
  76. Group: Applications/Databases
  77. Obsoletes: mysql-client MySQL-client < 5.6.0
  78. Provides: mysql-client MySQL-client mariadbclient-%{mariadb_base_version}
  79. %description client
  80. This package contains the standard MariaDB clients and administration tools.
  81. %package devel
  82. Version: %{mariadb_version}
  83. Summary: MariaDB - Development libraries and headers
  84. Group: Development/Libraries
  85. Requires: %{name}-static, openssl-devel, zlib-devel
  86. Conflicts: MySQL-devel < 5.6.0
  87. Conflicts: libmysqlclient-devel
  88. %description devel
  89. This package contains the development libraries and headers to develop
  90. MariaDB server components (e.g. plugins or embedded applications).
  91. %package static
  92. Version: %{mariadb_version}
  93. Summary: MariaDB - static libraries
  94. Group: Development/Libraries
  95. Requires: %{name}-devel
  96. %description static
  97. This package provides static libraries of MariaDB.
  98. %if %{with source}
  99. %package source
  100. Version: %{mariadb_version}
  101. Summary: MariaDB - Source
  102. Group: Development/Libraries
  103. Requires: mariadb-devel = %{version}-%{release}
  104. Obsoletes: MySQL-source < 5.6.0
  105. AutoReqProv: no
  106. %description source
  107. This package contains the sources files of MariaDB.
  108. %endif
  109. %package test
  110. Version: %{mariadb_version}
  111. Requires: %{name}-client = %{version}-%{release} perl-DBI perl
  112. Summary: MariaDB - Test suite
  113. Group: Applications/Databases
  114. Obsoletes: mysql-bench MySQL5-bench MySQL-bench MySQL-test < 5.6.0
  115. Provides: perl(mtr_misc.pl)
  116. %description test
  117. This package contains the MariaDB regression test suite.
  118. %package embedded
  119. Version: %{mariadb_version}
  120. Summary: MariaDB as an embeddable library
  121. Group: System Environment/Libraries
  122. Obsoletes: mysql-embedded MySQL-embedded
  123. Provides: mysql-embedded MySQL-embedded
  124. %description embedded
  125. This package contains a version of the MariaDB server that can be embedded
  126. into a client application instead of running as a separate process.
  127. %prep
  128. %setup -q
  129. #%patch0 -p1 -b .jp
  130. %patch100 -p1 -b .srv_buf_size
  131. %build
  132. # Be strict about variables, bail at earliest opportunity, etc.
  133. set -eu
  134. # Optional package files
  135. touch optional-files-devel
  136. export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
  137. export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
  138. # Build full release
  139. mkdir release
  140. (
  141. cd release
  142. cmake ../ \
  143. -DINSTALL_LAYOUT=RPM \
  144. -DBUILD_CONFIG=mysql_release \
  145. -DCMAKE_BUILD_TYPE=Release \
  146. -DINSTALL_UNIX_ADDRDIR="/var/lib/mysql/mysql.sock" \
  147. -DMANUFACTURER="Vine Linux" \
  148. -DCOMPILATION_COMMENT="Vine Linux MariaDB RPM" \
  149. -DWITH_PIC="ON" \
  150. -DWITH_EMBEDDED_SERVER="ON" \
  151. -DWITH_ZLIB="system" \
  152. -DWITH_LIBEVENT="system" \
  153. -DWITH_LOCALES="yes" \
  154. -DWITH_UNIT_TESTS="no" \
  155. -DWITH_CONNECT_STORAGE_ENGINE="ON" \
  156. -DWITH_SEQUENCE_STORAGE_ENGINE="ON" \
  157. -DWITH_XTRADB_STORAGE_ENGINE="ON" \
  158. -DWITHOUT_TOKUDB=1 \
  159. -DWITH_JEMALLOC="no" \
  160. -DGRN_WITH_MECAB="yes"
  161. # -DWITH_PCRE="system"
  162. echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
  163. make %{?_smp_mflags} VERBOSE=1
  164. )
  165. %install
  166. rm -rf %{buildroot}
  167. install -d %{buildroot}%{mysqldatadir}/mysql
  168. install -d %{buildroot}%{_infodir}
  169. # Install all binaries
  170. (
  171. cd release
  172. make DESTDIR=%{buildroot} install
  173. )
  174. install -m 0644 Docs/mysql.info %{buildroot}%{_infodir}
  175. rm -rf ./doc
  176. mv -f %{buildroot}%{_docdir} ./
  177. %if %{with source}
  178. mkdir -p %{buildroot}%{_datadir}/%{name}-source
  179. pushd %{buildroot}%{_datadir}/%{name}-source
  180. tar zxf %{SOURCE0}
  181. find %{buildroot}%{_datadir}/%{name}-source -type f -exec chmod ugo-x {} \;
  182. popd
  183. %endif
  184. install -d %{buildroot}%{_sysconfdir}/rpm
  185. sed -e 's/@BASEVERSION@/%{mariadb_base_version}/' -e 's/@VERSION@/%{version}/' -e 's/@RELEASE@/%{release}/' < %{SOURCE1000} > %{buildroot}%{_sysconfdir}/rpm/macros.mariadb
  186. rm -f %{buildroot}%{_mandir}/man1/mysql_fix_privilege_tables.1*
  187. rm -f %{buildroot}%{_mandir}/man8/mysqlmanager.8*
  188. rm -f %{buildroot}%{_sysconfdir}/my.cnf
  189. rm -f %{buildroot}%{_sysconfdir}/my.cnf.d/client.cnf
  190. rm -f %{buildroot}%{_libdir}/libmysqlclient*.so*
  191. rm -f %{buildroot}%{_libdir}/mysql/plugin/daemon_example.ini
  192. # force linking statically.
  193. perl -pi -e 's,-lmysqlclient_r,%{_libdir}/libmysqlclient_r.a,' %{buildroot}%{_bindir}/mysql_config
  194. perl -pi -e 's,-lmysqlclient,%{_libdir}/libmysqlclient.a,' %{buildroot}%{_bindir}/mysql_config
  195. ##############################################################################
  196. %pre server
  197. # Create a MySQL user and group. Do not report any problems if it already
  198. # exists.
  199. datadir=/var/lib/mysql
  200. groupadd -r mysql 2> /dev/null || true
  201. useradd -M -r -d $datadir -s /bin/bash -c "MySQL server" -g mysql mysql 2> /dev/null || true
  202. # The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
  203. usermod -g mysql mysql 2> /dev/null || true
  204. %post server
  205. # Make MySQL start/shutdown automatically when the machine does it.
  206. if [ $1 = 1 ] ; then
  207. if [ -x /sbin/chkconfig ] ; then
  208. /sbin/chkconfig --add mysql
  209. fi
  210. basedir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--basedir=//p'|tail -1`
  211. if [ -z "$basedir" ] ; then
  212. basedir=/usr
  213. fi
  214. datadir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--datadir=//p'|tail -1`
  215. if [ -z "$datadir" ] ; then
  216. datadir=/var/lib/mysql
  217. else
  218. # datadir may be relative to a basedir!
  219. if ! expr $datadir : / > /dev/null; then
  220. datadir=$basedir/$datadir
  221. fi
  222. fi
  223. # Change permissions so that the user that will run the MySQL daemon
  224. # owns all database files.
  225. chown -R mysql:mysql $datadir
  226. if [ ! -e $datadir/mysql ]; then
  227. # Create data directory
  228. mkdir -p $datadir/{mysql,test}
  229. # Initiate databases
  230. /usr/bin/mysql_install_db --rpm --user=mysql
  231. fi
  232. # Change permissions again to fix any new files.
  233. chown -R mysql:mysql $datadir
  234. # Fix permissions for the permission database so that only the user
  235. # can read them.
  236. chmod -R og-rw $datadir/mysql
  237. fi
  238. %preun server
  239. if [ $1 = 0 ] ; then
  240. # Stop MySQL before uninstalling it
  241. if [ -x /etc/init.d/mysql ] ; then
  242. /etc/init.d/mysql stop > /dev/null
  243. fi
  244. # Don't start it automatically anymore
  245. if [ -x /sbin/chkconfig ] ; then
  246. /sbin/chkconfig --del mysql
  247. fi
  248. fi
  249. %postun server
  250. if [ $1 -ge 1 ]; then
  251. if [ -x /etc/init.d/mysql ] ; then
  252. # only restart the server if it was alredy running
  253. /etc/init.d/mysql status > /dev/null 2>&1 && \
  254. /etc/init.d/mysql restart
  255. fi
  256. fi
  257. %pre mroonga
  258. if [ $1 -gt 1 ]; then
  259. /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql || cat <<EOF
  260. An error occured when to register plugin.
  261. Please run a command below:
  262. /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql
  263. EOF
  264. fi
  265. %post mroonga
  266. if [ $1 -eq 1 ] ; then
  267. /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
  268. An error occured when to register plugin.
  269. Please run a command below:
  270. /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
  271. EOF
  272. fi
  273. %postun mroonga
  274. if [ $1 -gt 0 ] ; then
  275. /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
  276. An error occured when to register plugin.
  277. Please run a command below:
  278. /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
  279. EOF
  280. fi
  281. # Clean up the BuildRoot
  282. %clean
  283. [ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
  284. %files server
  285. %defattr(-,root,root)
  286. %doc doc/*
  287. %doc release/support-files/my-*.cnf
  288. %doc %{_infodir}/mysql.info*
  289. %doc %{_mandir}/man1/aria_*.1*
  290. %doc %{_mandir}/man1/innochecksum.1*
  291. %doc %{_mandir}/man1/my_print_defaults.1*
  292. %doc %{_mandir}/man1/myisam_ftdump.1*
  293. %doc %{_mandir}/man1/myisamchk.1*
  294. %doc %{_mandir}/man1/myisamlog.1*
  295. %doc %{_mandir}/man1/myisampack.1*
  296. %doc %{_mandir}/man1/mysql_convert_table_format.1*
  297. %doc %{_mandir}/man1/mysql_fix_extensions.1*
  298. %doc %{_mandir}/man8/mysqld.8*
  299. %doc %{_mandir}/man1/mysqld_multi.1*
  300. %doc %{_mandir}/man1/mysqld_safe.1*
  301. %doc %{_mandir}/man1/mysqldumpslow.1*
  302. %doc %{_mandir}/man1/mysql_install_db.1*
  303. %doc %{_mandir}/man1/mysql_plugin.1*
  304. %doc %{_mandir}/man1/mysql_secure_installation.1*
  305. %doc %{_mandir}/man1/mysql_setpermission.1*
  306. %doc %{_mandir}/man1/mysql_upgrade.1*
  307. %doc %{_mandir}/man1/mysqlhotcopy.1*
  308. %doc %{_mandir}/man1/mysql.server.1*
  309. %doc %{_mandir}/man1/mysqltest.1*
  310. %doc %{_mandir}/man1/mysql_tzinfo_to_sql.1*
  311. %doc %{_mandir}/man1/mysql_zap.1*
  312. %doc %{_mandir}/man1/mysqlbug.1*
  313. %doc %{_mandir}/man1/perror.1*
  314. %doc %{_mandir}/man1/replace.1*
  315. %doc %{_mandir}/man1/resolve_stack_dump.1*
  316. %doc %{_mandir}/man1/resolveip.1*
  317. %{_bindir}/aria_*
  318. %{_bindir}/innochecksum
  319. %{_bindir}/my_print_defaults
  320. %{_bindir}/myisam_ftdump
  321. %{_bindir}/myisamchk
  322. %{_bindir}/myisamlog
  323. %{_bindir}/myisampack
  324. %{_bindir}/mysql_convert_table_format
  325. %{_bindir}/mysql_fix_extensions
  326. %{_bindir}/mysql_install_db
  327. %{_bindir}/mysql_plugin
  328. %{_bindir}/mysql_secure_installation
  329. %{_bindir}/mysql_setpermission
  330. %{_bindir}/mysql_tzinfo_to_sql
  331. %{_bindir}/mysql_upgrade
  332. %{_bindir}/mysql_zap
  333. %{_bindir}/mysqlbug
  334. %{_bindir}/mysqld_multi
  335. %{_bindir}/mysqld_safe
  336. %{_bindir}/mysqldumpslow
  337. %{_bindir}/mysqlhotcopy
  338. %{_bindir}/mysqltest
  339. %{_bindir}/perror
  340. %{_bindir}/replace
  341. %{_bindir}/resolve_stack_dump
  342. %{_bindir}/resolveip
  343. #%{_bindir}/tokuftdump
  344. %{_sbindir}/mysqld
  345. %exclude %{_libdir}/mysql/plugin/ha_mroonga.so
  346. %exclude %{_datadir}/mysql/mroonga
  347. %{_libdir}/mysql
  348. %config(noreplace) %{_sysconfdir}/my.cnf.d/server.cnf
  349. #%config(noreplace) %{_sysconfdir}/my.cnf.d/tokudb.cnf
  350. %config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
  351. %{_sysconfdir}/init.d/mysql
  352. %{_datadir}/mysql
  353. %attr(755, mysql, mysql) %dir %{mysqldatadir}
  354. %files mroonga
  355. %defattr(-, root, root)
  356. %{_libdir}/mysql/plugin/ha_mroonga.so
  357. %{_datadir}/mysql/mroonga
  358. %files client
  359. %defattr(-, root, root)
  360. %config(noreplace) %{_sysconfdir}/my.cnf.d/mysql-clients.cnf
  361. %{_bindir}/msql2mysql
  362. %{_bindir}/mysql
  363. %{_bindir}/mysql_find_rows
  364. %{_bindir}/mysql_waitpid
  365. %{_bindir}/mysqlaccess
  366. %{_bindir}/mysqladmin
  367. %{_bindir}/mysqlbinlog
  368. %{_bindir}/mysqlcheck
  369. %{_bindir}/mysqldump
  370. %{_bindir}/mysqlimport
  371. %{_bindir}/mysqlshow
  372. %{_bindir}/mysqlslap
  373. %{_bindir}/mytop
  374. %doc %{_mandir}/man1/msql2mysql.1*
  375. %doc %{_mandir}/man1/mysql.1*
  376. %doc %{_mandir}/man1/mysql_find_rows.1*
  377. %doc %{_mandir}/man1/mysql_waitpid.1*
  378. %doc %{_mandir}/man1/mysqlaccess.1*
  379. %doc %{_mandir}/man1/mysqladmin.1*
  380. %doc %{_mandir}/man1/mysqlbinlog.1*
  381. %doc %{_mandir}/man1/mysqlcheck.1*
  382. %doc %{_mandir}/man1/mysqldump.1*
  383. %doc %{_mandir}/man1/mysqlimport.1*
  384. %doc %{_mandir}/man1/mysqlshow.1*
  385. %doc %{_mandir}/man1/mysqlslap.1*
  386. %files devel -f optional-files-devel
  387. %defattr(-, root, root)
  388. %doc %{_mandir}/man1/mysql_config.1*
  389. %{_bindir}/mysql_config
  390. %{_includedir}/mysql
  391. %{_datadir}/aclocal/mysql.m4
  392. %{_libdir}/*.so
  393. %{_sysconfdir}/rpm/*
  394. %{_bindir}/mysql_embedded
  395. %files static
  396. %defattr(-,root,root)
  397. %{_libdir}/lib*.a
  398. %if %{with source}
  399. %files source
  400. %defattr(-, root, root)
  401. %{_datadir}/mariadb-source
  402. %endif
  403. %files test
  404. %defattr(-, root, root)
  405. %attr(-, root, root) %{_datadir}/mysql-test
  406. %{_bindir}/mysql_client_test
  407. %{_bindir}/mysql_client_test_embedded
  408. %{_bindir}/mysqltest_embedded
  409. %doc %{_mandir}/man1/mysql_client_test.1*
  410. %doc %{_mandir}/man1/mysql-stress-test.pl.1*
  411. %doc %{_mandir}/man1/mysql-test-run.pl.1*
  412. %doc %{_mandir}/man1/mysql_client_test_embedded.1*
  413. %doc %{_mandir}/man1/mysqltest_embedded.1*
  414. %files embedded
  415. %defattr(-,root,root)
  416. %{_libdir}/libmysqld.so.*
  417. %changelog
  418. * Wed Nov 26 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.15-1
  419. - new upstream release.
  420. - enabled bundled Mroonga.
  421. * Mon Sep 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.14-1
  422. - new upstream release.
  423. * Sat May 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.11-1
  424. - new upstream release.
  425. * Sun Apr 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-2
  426. - fixed Conflicts: and Obsoletes:.
  427. * Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-1
  428. - new upstream release.
  429. * Mon Mar 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.9-1
  430. - new upstream release.
  431. * Tue Feb 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.8-1
  432. - new upstream release.
  433. * Sat Dec 07 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-2
  434. - removed duplicated files.
  435. * Wed Dec 04 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-1
  436. - switched to MariaDB.
  437. * Wed Feb 20 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.30-1
  438. - new upstream release.
  439. * Fri Nov 16 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.28-1
  440. - new upstream release.
  441. * Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.27-1
  442. - new upstream release.
  443. - added a sub-package 'MySQL-source".
  444. - added some macros for rpm.
  445. * Thu Jun 21 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.25-1
  446. - new upstream release.
  447. * Thu May 10 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.24-1
  448. - new upstream release.
  449. * Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.23-1
  450. - new upstream release.
  451. - added "Vendor:" and "Distribution:" tag.
  452. * Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
  453. - new upstream release.
  454. - removed NDB cluster support.
  455. * Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
  456. - Added "BR: zlib-devel" to MySQL-devel.
  457. * Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
  458. - Added "BR: openssl-devel" to MySQL-devel.
  459. * Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
  460. - new upstream release.
  461. * Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
  462. - new upstream release.
  463. - updated jp-patch.
  464. - added ssl support.
  465. * Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
  466. - new upstream release.
  467. - replaced '%%__find_requires' to '%%__perl_requires'.
  468. - updated jp-patch.
  469. * Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
  470. - added mysql-5.1.44-lib64.patch (on x86_64)
  471. - added -fPIC (on x86_64)
  472. * Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
  473. - made embedded package again
  474. * Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
  475. - new upstream release.
  476. - updated jp-patch.
  477. * Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
  478. - VineSeed: rebuilt with new toolchain.
  479. * Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
  480. - new upstream release.
  481. - fixed CVE-2009-4484.
  482. * Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
  483. - new upstream release.
  484. * Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
  485. - added net-tools to 'Requires'.
  486. - added groff to 'BuildRequires'.
  487. - renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
  488. * Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
  489. - new upstream release.
  490. * Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
  491. - new upstream release.
  492. * Sun Jul 5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
  493. - new upstream release.
  494. - dropped %%Patch100 (fixed in upstream).
  495. * Sat Jun 6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
  496. - new upstream release.
  497. - add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
  498. * Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
  499. - new upstream release.
  500. - rename 'MySQL-bench' to 'MySQL-test'.
  501. - update Patch0.
  502. - change default charset to 'utf8'.
  503. * Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
  504. - new upstream release.
  505. - update Patch0.
  506. - add "--with-client-charset=ujis".
  507. - sync %%files to official RPM.
  508. - remove MySQL-Max.
  509. * Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
  510. - for VineSeed
  511. * Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
  512. - move shared library from /usr/lib/ to /usr/lib/mysql/
  513. - add /etc/ld.so.conf.d/*.conf
  514. - fix broken libmysqlcient*.la files (or should we remove them permanently?)
  515. * Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
  516. - rebuild <BTS:VineLinux:534>
  517. * Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
  518. - added -fPIC
  519. * Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
  520. - fixed dependency. <BTS:338>
  521. * Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
  522. - add %%Patch1. <BTS:320>
  523. * Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
  524. - new upstream release.
  525. * Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
  526. - new upstream release.
  527. * Sat Jun 3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
  528. - new upstream release.
  529. * Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
  530. - release++.
  531. * Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
  532. - new upstream release.
  533. - for VineSeed.
  534. * Wed Feb 8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
  535. - new upstream release.
  536. - replace Patch0 for MySQL-4.1.16.
  537. * Thu Oct 6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
  538. - new upstream release.
  539. - add Patch0.
  540. * Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
  541. - new upstream version
  542. -- mysql-4.0.25
  543. * Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
  544. - new upstream version
  545. -- mysql-4.0.23
  546. * Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
  547. - new upstream version
  548. -- mysql-4.0.22
  549. * Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
  550. - new upstream version
  551. -- mysql-4.0.21
  552. * Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
  553. - new upstream version
  554. -- mysql-4.0.20
  555. * Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
  556. - modify CFLAGS, CXXFLAGS and configure options for alpha
  557. * Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
  558. - Upgraded to MySQL-4
  559. - added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
  560. - merged to MySQL Official packages
  561. -- renamed package "MySQL" to "MySQL-server"
  562. -- when using gcc, _always_ use CXX=gcc
  563. -- replaced Copyright with License field (Copyright is obsolete)
  564. -- added myisam_ftdump to the Server package
  565. -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
  566. -- fixed file permissions (BUG 1672)
  567. -- removed dependency on MySQL-client from the MySQL-devel subpackage
  568. -- as it is not really required. (BUG 1610)
  569. -- Fixed BUG 1162 (removed macro names from the changelog)
  570. -- Really fixed BUG 998 (disable the checking for installed but
  571. -- unpackaged files)
  572. -- Fixed BUG 959 (libmysqld not being compiled properly)
  573. -- Fixed BUG 998 (RPM build errors): added missing files to the
  574. -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
  575. -- mysql_fix_privilege_tables.1), removed "-n" from install section.
  576. -- removed the GIF Icon (file was not included in the sources anyway)
  577. -- removed unused variable shared_lib_version
  578. -- do not run automake before building the standard binary
  579. -- (should not be necessary)
  580. -- add server suffix '-standard' to standard binary (to be in line
  581. -- with the binary tarball distributions)
  582. -- allow overriding CC and CXX (required when building
  583. -- with other compilers)
  584. * Mon Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
  585. - added BuildRequires: automake16
  586. * Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
  587. - add '-fPIC -DPIC' to CFLAGS on alpha
  588. - little fix of spec file
  589. * Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
  590. - enable MySQL-shared subpackage for alpha
  591. - delete 'BuildPrereq: kernel24-headers' for alpha
  592. - fix shared %files (exclude sparc)
  593. * Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
  594. - new upstream version
  595. * Sun Mar 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
  596. - fixed devel %files (dropped *.la files)
  597. * Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
  598. - new upstream version
  599. - fixed document permission
  600. * Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
  601. - new upstream version
  602. * Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
  603. - dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
  604. -- don't work
  605. * Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
  606. - new upstream version
  607. - diseble-assembler in configure on sparc,sparc64,alpha
  608. * Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
  609. - new upstream version
  610. - moved some man files to main package
  611. - added enable-local-infile in configure
  612. - changed --with-extra-charsets=all in configure
  613. * Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
  614. - fixed changelog
  615. * Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
  616. - updated to mysql-3.23.51
  617. * Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
  618. - rebuild on zlib-1.1.4(security fix.)
  619. * Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
  620. - updated to mysql-2.23.49
  621. * Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
  622. - add 'BuildPrereq: kernel24-headers' on alpha
  623. - remove shared library and max on alpha
  624. * Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
  625. - updated to mysql-3.23.48
  626. * Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
  627. - updated to mysql-3.23.47
  628. * Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
  629. - updated to mysql-3.23.46
  630. * Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
  631. - updated to mysql-3.23.45
  632. * Mon Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
  633. - updated to mysql-3.23.44
  634. * Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
  635. - updated to mysql-3.23.43
  636. - removed shared library and max on sparc
  637. * Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
  638. - updated to mysql-3.23.42
  639. - changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
  640. * Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
  641. - updated to mysql-3.23.41
  642. * Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
  643. - updated to mysql-3.23.40
  644. * Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
  645. - updated to mysql-3.23.39
  646. * Fri Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
  647. - added configure --with-charset=ujis
  648. * Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
  649. - used some rpmmacro
  650. * Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
  651. - updated to MySQL-3.23.38
  652. * Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
  653. - removed Bench pakages
  654. * Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
  655. - removed pt_BR locale
  656. - build on Vine Linux
  657. - partially used rpmmacros
  658. - added %clean tag
  659. * Fri Aug 18 2000 Tim Smith <tim@mysql.com>
  660. - Added separate libmysql_r directory; now both a threaded
  661. and non-threaded library is shipped.
  662. * Tue Sep 28 1999 David Axmark <davida@mysql.com>
  663. - Added the support-files/my-example.cnf to the docs directory.
  664. - Removed devel dependency on base since it is about client
  665. development.
  666. * Wed Sep 8 1999 David Axmark <davida@mysql.com>
  667. - Cleaned up some for 3.23.
  668. * Thu Jul 1 1999 David Axmark <davida@mysql.com>
  669. - Added support for shared libraries in a separate sub
  670. package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
  671. - The --enable-assembler switch is now automatically disables on
  672. platforms there assembler code is unavailable. This should allow
  673. building this RPM on non i386 systems.
  674. * Mon Feb 22 1999 David Axmark <david@detron.se>
  675. - Removed unportable cc switches from the spec file. The defaults can
  676. now be overridden with environment variables. This feature is used
  677. to compile the official RPM with optimal (but compiler version
  678. specific) switches.
  679. - Removed the repetitive description parts for the sub rpms. Maybe add
  680. again if RPM gets a multiline macro capability.
  681. - Added support for a pt_BR translation. Translation contributed by
  682. Jorge Godoy <jorge@bestway.com.br>.
  683. * Wed Nov 4 1998 David Axmark <david@detron.se>
  684. - A lot of changes in all the rpm and install scripts. This may even
  685. be a working RPM :-)
  686. * Sun Aug 16 1998 David Axmark <david@detron.se>
  687. - A developers changelog for MySQL is available in the source RPM. And
  688. there is a history of major user visible changed in the Reference
  689. Manual. Only RPM specific changes will be documented here.