cups-filters-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481
  1. # we build CUPS also with relro
  2. %global _hardened_build 1
  3. %define _unpackaged_files_terminate_build 1
  4. Summary: OpenPrinting CUPS filters and backends
  5. Name: cups-filters
  6. Version: 1.18.0
  7. Release: 3%{?_dist_release}
  8. # For a breakdown of the licensing, see COPYING file
  9. # GPLv2: filters: commandto*, imagetoraster, pdftops, rasterto*,
  10. # imagetopdf, pstopdf, texttopdf
  11. # backends: parallel, serial
  12. # GPLv2+: filters: gstopxl, textonly, texttops, imagetops
  13. # GPLv3: filters: bannertopdf
  14. # GPLv3+: filters: urftopdf
  15. # LGPLv2+: utils: cups-browsed
  16. # MIT: filters: gstoraster, pdftoijs, pdftoopvp, pdftopdf, pdftoraster
  17. License: GPLv2 and GPLv2+ and GPLv3 and GPLv3+ and LGPLv2+ and MIT
  18. Group: System Environment/Base
  19. Url: http://www.linuxfoundation.org/collaborate/workgroups/openprinting/cups-filters
  20. Source0: http://www.openprinting.org/download/cups-filters/cups-filters-%{version}.tar.xz
  21. Requires: cups
  22. Requires: cups-filters-libs%{?_isa} = %{version}-%{release}
  23. # Obsolete cups-php (bug #971741)
  24. Obsoletes: cups-php < 1:1.6.0-1
  25. # Don't Provide it because we don't build the php module
  26. #Provides: cups-php = 1:1.6.0-1
  27. BuildRequires: cups-devel
  28. # pdftopdf
  29. BuildRequires: qpdf-devel
  30. # pdftops
  31. BuildRequires: poppler-utils
  32. # pdftoijs, pdftoopvp, pdftoraster, gstoraster
  33. BuildRequires: poppler-devel
  34. BuildRequires: libjpeg-devel
  35. BuildRequires: libpng-devel
  36. BuildRequires: libtiff-devel
  37. BuildRequires: zlib-devel
  38. BuildRequires: pkgconfig dbus-devel
  39. # libijs
  40. BuildRequires: ghostscript-devel
  41. BuildRequires: freetype2-devel
  42. BuildRequires: fontconfig-devel
  43. BuildRequires: lcms2-devel
  44. # cups-browsed
  45. BuildRequires: avahi-devel avahi-glib-devel
  46. # Make sure we get postscriptdriver tags.
  47. BuildRequires: python-cups
  48. # Testing font for test scripts.
  49. BuildRequires: TrueType-dejavu
  50. # autogen.sh
  51. BuildRequires: autoconf
  52. BuildRequires: automake
  53. BuildRequires: libtool
  54. Requires: poppler-utils
  55. # pstopdf
  56. Requires: bc grep sed
  57. # cups-browsed
  58. #Requires(post): systemd
  59. #Requires(preun): systemd
  60. #Requires(postun): systemd
  61. # Ghostscript CUPS filters live here since Ghostscript 9.08.
  62. Provides: ghostscript-cups = 9.08
  63. Obsoletes: ghostscript-cups < 9.08
  64. Vendor: Project Vine
  65. Distribution: Vine Linux
  66. Packager: tomop
  67. %package libs
  68. Summary: OpenPrinting CUPS filters and backends - cupsfilters and fontembed libraries
  69. Group: System Environment/Libraries
  70. # LGPLv2: libcupsfilters
  71. # MIT: libfontembed
  72. License: LGPLv2 and MIT
  73. %package devel
  74. Summary: OpenPrinting CUPS filters and backends - development environment
  75. Group: Development/Libraries
  76. License: LGPLv2 and MIT
  77. Requires: cups-filters-libs%{?_isa} = %{version}-%{release}
  78. %description
  79. Contains backends, filters, and other software that was
  80. once part of the core CUPS distribution but is no longer maintained by
  81. Apple Inc. In addition it contains additional filters developed
  82. independently of Apple, especially filters for the PDF-centric printing
  83. workflow introduced by OpenPrinting.
  84. %description libs
  85. This package provides cupsfilters and fontembed libraries.
  86. %description devel
  87. This is the development package for OpenPrinting CUPS filters and backends.
  88. %prep
  89. %setup -q
  90. %build
  91. # work-around Rpath
  92. ./autogen.sh
  93. # --with-pdftops=hybrid - use Poppler's pdftops instead of Ghostscript for
  94. # Brother, Minolta, and Konica Minolta to work around
  95. # bugs in the printer's PS interpreters
  96. # --with-rcdir=no - don't install SysV init script
  97. export IJS_CFLAGS="-I/usr/include/ijs"
  98. export IJS_LIBS="-lijs"
  99. %configure --disable-static \
  100. --disable-silent-rules \
  101. --disable-mutool \
  102. --with-pdftops=hybrid \
  103. --enable-dbus \
  104. --with-rcdir=%{_sysconfdir} \
  105. --with-test-font-path=/usr/share/fonts/TrueType-dejavu/DejaVuSans.ttf
  106. make %{?_smp_mflags}
  107. %install
  108. make install DESTDIR=%{buildroot}
  109. # https://fedoraproject.org/wiki/Packaging_tricks#With_.25doc
  110. mkdir __doc
  111. mv %{buildroot}%{_datadir}/doc/cups-filters/* __doc
  112. rm -rf %{buildroot}%{_datadir}/doc/cups-filters
  113. # Don't ship libtool la files.
  114. rm -f %{buildroot}%{_libdir}/lib*.la
  115. # Not sure what is this good for.
  116. rm -f %{buildroot}%{_bindir}/ttfread
  117. # systemd unit file
  118. #mkdir -p %{buildroot}%{_unitdir}
  119. #install -p -m 644 utils/cups-browsed.service %{buildroot}%{_unitdir}
  120. # SysV initscripts
  121. rm -rf %{buildroot}%{_sysconfdir}/rc{0,2,3,5}.d
  122. rm -rf %{buildroot}%{_sysconfdir}/rc.d
  123. mkdir -p %{buildroot}%{_sysconfdir}/rc.d
  124. mv -f %{buildroot}%{_sysconfdir}/init.d %{buildroot}%{_sysconfdir}/rc.d/
  125. for f in %{buildroot}%{_cups_serverbin}/filter/*; do
  126. if [ -f $f ]; then
  127. chmod 755 $f
  128. fi
  129. done
  130. %check
  131. make check
  132. %post
  133. #%systemd_post cups-browsed.service
  134. # Initial installation
  135. if [ $1 -eq 1 ] ; then
  136. IN=%{_sysconfdir}/cups/cupsd.conf
  137. OUT=%{_sysconfdir}/cups/cups-browsed.conf
  138. keyword=BrowsePoll
  139. # We can remove this after few releases, it's just for the introduction of cups-browsed.
  140. if [ -f "$OUT" ]; then
  141. echo -e "\n# NOTE: This file is not part of CUPS. You need to start & enable cups-browsed service." >> "$OUT"
  142. fi
  143. # move BrowsePoll from cupsd.conf to cups-browsed.conf
  144. if [ -f "$IN" ] && grep -iq ^$keyword "$IN"; then
  145. if ! grep -iq ^$keyword "$OUT"; then
  146. (cat >> "$OUT" <<EOF
  147. # Settings automatically moved from cupsd.conf by RPM package:
  148. EOF
  149. ) || :
  150. (grep -i ^$keyword "$IN" >> "$OUT") || :
  151. #systemctl enable cups-browsed.service >/dev/null 2>&1 || :
  152. fi
  153. sed -i -e "s,^$keyword,#$keyword directive moved to cups-browsed.conf\n#$keyword,i" "$IN" || :
  154. fi
  155. fi
  156. %preun
  157. #%systemd_preun cups-browsed.service
  158. %postun
  159. #%systemd_postun_with_restart cups-browsed.service
  160. %post libs
  161. /sbin/ldconfig
  162. %postun libs
  163. /sbin/ldconfig
  164. %files
  165. %doc __doc/README __doc/AUTHORS __doc/NEWS
  166. %config(noreplace) %{_sysconfdir}/cups/cups-browsed.conf
  167. %{_bindir}/driverless
  168. %{_bindir}/foomatic-rip
  169. %attr(-,root,root) %{_cups_serverbin}/filter/*
  170. %exclude %{_cups_serverbin}/filter/pdftoraster
  171. %attr(0755,root,root) %{_cups_serverbin}/backend/beh
  172. %attr(0755,root,root) %{_cups_serverbin}/backend/cups-brf
  173. %attr(0755,root,root) %{_cups_serverbin}/backend/driverless
  174. %attr(0755,root,root) %{_cups_serverbin}/backend/implicitclass
  175. %attr(0755,root,root) %{_cups_serverbin}/backend/parallel
  176. # Serial backend needs to run as root (bug #212577#c4).
  177. %attr(0700,root,root) %{_cups_serverbin}/backend/serial
  178. %attr(0755,root,root) %{_cups_serverbin}/driver/driverless
  179. %{_datadir}/cups/banners
  180. %{_datadir}/cups/braille
  181. %{_datadir}/cups/charsets
  182. %{_datadir}/cups/data/*
  183. # this needs to be in the main package because of cupsfilters.drv
  184. %{_datadir}/cups/drv/*
  185. %{_datadir}/cups/mime/*
  186. %{_datadir}/ppd/*
  187. %{_datadir}/cups/ppdc/*
  188. %{_sbindir}/cups-browsed
  189. #%{_unitdir}/cups-browsed.service
  190. %{_initdir}/cups-browsed
  191. %{_mandir}/man1/driverless.1.gz
  192. %{_mandir}/man1/foomatic-rip.1.gz
  193. %{_mandir}/man8/cups-browsed.8.gz
  194. %{_mandir}/man5/cups-browsed.conf.5.gz
  195. %files libs
  196. %doc __doc/COPYING fontembed/README
  197. %{_libdir}/libcupsfilters.so.*
  198. %{_libdir}/libfontembed.so.*
  199. %files devel
  200. %{_includedir}/cupsfilters
  201. %{_includedir}/fontembed
  202. %{_datadir}/cups/ppdc/escp.h
  203. %{_libdir}/pkgconfig/libcupsfilters.pc
  204. %{_libdir}/pkgconfig/libfontembed.pc
  205. %{_libdir}/libcupsfilters.so
  206. %{_libdir}/libfontembed.so
  207. %changelog
  208. * Tue Sep 04 2018 Toshiaki Ara <ara_t@384.jp> 1.18.0-3
  209. - rebuild with qpdf-8.1.0
  210. * Tue Jan 30 2018 Toshiaki Ara <ara_t@384.jp> 1.18.0-2
  211. - rebuild with qpdf-7.0.1
  212. * Wed Jan 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.18.0-1
  213. - new upstream release.
  214. * Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.0-1
  215. - new upstream release.
  216. * Tue May 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.3-2
  217. - rebuilt with poppler-0.43.0.
  218. * Tue May 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.3-1
  219. - new upstream release.
  220. * Mon May 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.76-3
  221. - rebuild with poppler-0.43.0
  222. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.76-2
  223. - rebuild with poppler-0.37.0
  224. * Sun Oct 4 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.76-1
  225. - new upstream release.
  226. * Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.54-2
  227. - rebuild with poppler-0.26.2
  228. * Sun Jun 8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.54-1
  229. - new upstream release.
  230. * Fri May 16 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.53-1
  231. - update to 1.0.53
  232. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.43-1
  233. - new upstream release.
  234. - initial build for Vine Linux.
  235. * Tue Nov 19 2013 Tim Waugh <twaugh@redhat.com> - 1.0.41-4
  236. - Adjust filter costs so application/vnd.adobe-read-postscript input
  237. doesn't go via pstotiff (bug #1008166).
  238. * Thu Nov 14 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.41-3
  239. - Fix memory leaks in cups-browsed (bug #1027317).
  240. * Wed Nov 6 2013 Tim Waugh <twaugh@redhat.com> - 1.0.41-2
  241. - Include dbus so that colord support works (bug #1026928).
  242. * Wed Oct 30 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.41-1
  243. - 1.0.41 - PPD-less printing support
  244. * Mon Oct 21 2013 Tim Waugh <twaugh@redhat.com> - 1.0.40-4
  245. - Fix socket leaks in the BrowsePoll code (bug #1021512).
  246. * Wed Oct 16 2013 Tim Waugh <twaugh@redhat.com> - 1.0.40-3
  247. - Ship the gstoraster MIME conversion rule now we provide that filter
  248. (bug #1019261).
  249. * Fri Oct 11 2013 Tim Waugh <twaugh@redhat.com> - 1.0.40-2
  250. - Fix PDF landscape printing (bug #768811).
  251. * Fri Oct 11 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.40-1
  252. - 1.0.40
  253. - Use new "hybrid" pdftops renderer.
  254. * Thu Oct 03 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.39-1
  255. - 1.0.39
  256. - Removed obsolete patches "pdf-landscape" and "browsepoll-notifications"
  257. * Tue Oct 1 2013 Tim Waugh <twaugh@redhat.com> - 1.0.38-4
  258. - Use IPP notifications for BrowsePoll when possible (bug #975241).
  259. * Tue Oct 1 2013 Tim Waugh <twaugh@redhat.com> - 1.0.38-3
  260. - Fixes for some printf-type format mismatches (bug #1014093).
  261. * Tue Sep 17 2013 Tim Waugh <twaugh@redhat.com> - 1.0.38-2
  262. - Fix landscape printing for PDFs (bug #768811).
  263. * Wed Sep 04 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.38-1
  264. - 1.0.38
  265. * Thu Aug 29 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.37-1
  266. - 1.0.37.
  267. * Tue Aug 27 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.36-5
  268. - Added build dependency - font required for running tests
  269. * Tue Aug 27 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.36-4
  270. - Added checking phase (make check)
  271. * Wed Aug 21 2013 Tim Waugh <twaugh@redhat.com> - 1.0.36-3
  272. - Upstream patch to re-work filter costs (bug #998977). No longer need
  273. text filter costs patch as paps gets used by default now if
  274. installed.
  275. * Mon Aug 19 2013 Marek Kasik <mkasik@redhat.com> - 1.0.36-2
  276. - Rebuild (poppler-0.24.0)
  277. * Tue Aug 13 2013 Tim Waugh <twaugh@redhat.com> - 1.0.36-1
  278. - 1.0.36.
  279. * Tue Aug 13 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-7
  280. - Upstream patch to move in filters from ghostscript.
  281. * Tue Jul 30 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-6
  282. - Set cost for text filters to 200 so that the paps filter gets
  283. preference for the time being (bug #988909).
  284. * Wed Jul 24 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-5
  285. - Handle page-label when printing n-up as well.
  286. * Tue Jul 23 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-4
  287. - Added support for page-label (bug #987515).
  288. * Thu Jul 11 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.35-3
  289. - Rebuild (qpdf-5.0.0)
  290. * Mon Jul 01 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.35-2
  291. - add cups-browsed(8) and cups-browsed.conf(5)
  292. - don't reverse lookup IP address in URI (#975822)
  293. * Wed Jun 26 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.35-1
  294. - 1.0.35
  295. * Mon Jun 24 2013 Marek Kasik <mkasik@redhat.com> - 1.0.34-9
  296. - Rebuild (poppler-0.22.5)
  297. * Wed Jun 19 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-8
  298. - fix the note we add in cups-browsed.conf
  299. * Wed Jun 12 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-7
  300. - Obsolete cups-php (#971741)
  301. * Wed Jun 05 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-6
  302. - one more cups-browsed leak fixed (#959682)
  303. * Wed Jun 05 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-5
  304. - perl is actually not required by pstopdf, because the calling is in dead code
  305. * Mon Jun 03 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-4
  306. - fix resource leaks and other problems found by Coverity & Valgrind (#959682)
  307. * Wed May 15 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-3
  308. - ship ppdc/pcl.h because of cupsfilters.drv
  309. * Tue May 07 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-2
  310. - pstopdf requires bc (#960315)
  311. * Thu Apr 11 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-1
  312. - 1.0.34
  313. * Fri Apr 05 2013 Fridolin Pokorny <fpokorny@redhat.com> - 1.0.33-1
  314. - 1.0.33
  315. - removed cups-filters-1.0.32-null-info.patch, accepted by upstream
  316. * Thu Apr 04 2013 Fridolin Pokorny <fpokorny@redhat.com> - 1.0.32-2
  317. - fixed segfault when info is NULL
  318. * Thu Apr 04 2013 Fridolin Pokorny <fpokorny@redhat.com> - 1.0.32-1
  319. - 1.0.32
  320. * Fri Mar 29 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.31-3
  321. - add note to cups-browsed.conf
  322. * Thu Mar 28 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.31-2
  323. - check cupsd.conf existence prior to grepping it (#928816)
  324. * Fri Mar 22 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.31-1
  325. - 1.0.31
  326. * Tue Mar 19 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-4
  327. - revert previous change
  328. * Wed Mar 13 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-3
  329. - don't ship banners for now (#919489)
  330. * Tue Mar 12 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-2
  331. - move BrowsePoll from cupsd.conf to cups-browsed.conf in %%post
  332. * Fri Mar 08 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-1
  333. - 1.0.30: CUPS browsing and broadcasting in cups-browsed
  334. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.29-4
  335. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  336. * Sat Jan 19 2013 Rex Dieter <rdieter@fedoraproject.org> 1.0.29-3
  337. - backport upstream buildfix for poppler-0.22.x
  338. * Fri Jan 18 2013 Adam Tkac <atkac redhat com> - 1.0.29-2
  339. - rebuild due to "jpeg8-ABI" feature drop
  340. * Thu Jan 03 2013 Jiri Popelka <jpopelka@redhat.com> 1.0.29-1
  341. - 1.0.29
  342. * Wed Jan 02 2013 Jiri Popelka <jpopelka@redhat.com> 1.0.28-1
  343. - 1.0.28: cups-browsed daemon and service
  344. * Thu Nov 29 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.25-1
  345. - 1.0.25
  346. * Fri Sep 07 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.24-1
  347. - 1.0.24
  348. * Wed Aug 22 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.23-1
  349. - 1.0.23: old pdftopdf removed
  350. * Tue Aug 21 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.22-1
  351. - 1.0.22: new pdftopdf (uses qpdf instead of poppler)
  352. * Wed Aug 08 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-4
  353. - rebuild
  354. * Thu Aug 02 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-3
  355. - commented multiple licensing breakdown (#832130)
  356. - verbose build output
  357. * Thu Aug 02 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-2
  358. - BuildRequires: poppler-cpp-devel (to build against poppler-0.20)
  359. * Mon Jul 23 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-1
  360. - 1.0.20
  361. * Tue Jul 17 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.19-1
  362. - 1.0.19
  363. * Wed May 30 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.18-1
  364. - initial spec file